EGIS.Controls Namespace

[image]

.NET Framework Class Library
EGIS.Controls Namespace
Send Feedback

Classes

 | Class | Description
Public class | SFMap | SFMap (ShapeFile Map) is a .NET ShapeFile Control which displays shapefiles in a .NET Windows Form application
Public class | SFMap..::..TooltipEventArgs | EventArgs class containing data for the TooltipDisplayed event
Public class | ShapeFileListControl | User control containing a list of ShapeFiles

Delegates

 | Delegate | Description
Public delegate | ProgressLoadStatusHandler |

Enumerations

 | Enumeration | Description
Public enumeration | PanSelectMode |
Send feedback on this topic to Microsoft.


PanSelectMode Enumeration

[image]

.NET Framework Class Library
PanSelectMode Enumeration
See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Enumeration PanSelectMode
C#
public enum PanSelectMode
Visual C++
public enum class PanSelectMode
JavaScript
EGIS.Controls.PanSelectMode = function();
EGIS.Controls.PanSelectMode.createEnum('EGIS.Controls.PanSelectMode', false);

Members

Member name | Description
None |
Pan |
SelectRectangle |
SelectCircle |

See Also

EGIS.Controls Namespace


ProgressLoadStatusHandler Delegate

[image]

.NET Framework Class Library
ProgressLoadStatusHandler Delegate
See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Delegate Sub ProgressLoadStatusHandler ( _
    totalLayers As Integer, _
    numberLayersLoaded As Integer _
)
C#
public delegate void ProgressLoadStatusHandler(
    int totalLayers,
    int numberLayersLoaded
)
Visual C++
public delegate void ProgressLoadStatusHandler(
    int totalLayers,
    int numberLayersLoaded
)
JavaScript
function(totalLayers, numberLayersLoaded);

Parameters

totalLayers
Type: System..::..Int32
numberLayersLoaded
Type: System..::..Int32

See Also

EGIS.Controls Namespace


SFMap Class

[image]

.NET Framework Class Library
SFMap Class
Members See Also Send Feedback

SFMap (ShapeFile Map) is a .NET ShapeFile Control which displays shapefiles in a .NET Windows Form application

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Class SFMap _
    Inherits UserControl
C#
public class SFMap : UserControl
Visual C++
public ref class SFMap : public UserControl
JavaScript
EGIS.Controls.SFMap = function();

Type.createClass(
    'EGIS.Controls.SFMap',
    UserControl);

Remarks

This is the main control in the EGIS.Controls namespace

The SFMap control is a .NET ShapeFile Control which provides methods to add or remove ShapeFile layers to/from a map, zoom, pan and locate shapes on the map.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
EGIS.Controls..::..SFMap

See Also

SFMap Members
EGIS.Controls Namespace


SFMap Members

[image] [image]

.NET Framework Class Library
SFMap Members
SFMap Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The SFMap type exposes the following members.

Constructors

 | Name | Description
Public method | SFMap | SFMap contructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AddShapeFile | Adds a new ShapeFile layer to the map
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearShapeFiles | Removes all ShapeFile layers from the map
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindShapeFileBypath | Finds and returns the ShapeFile which was loaded from the given path
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetBitmap | Utility method that creates and returns a new Bitmap Image of the current map displayed in the SFMap Control
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetShapeIndexAtPixelCoord | Returns the shape index for a given shapefile located at a point (in pixel/mouse coordinates)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GisPointToPixelCoord(PointD) | Converts a GIS position to mouse position
Public method | GisPointToPixelCoord(Double, Double) | Converts a GIS position to mouse position
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexOfShapeFileByPath | Finds and returns the index of the ShapeFile which was loaded from the given path
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | (Overrides Control..::..IsInputKey(Keys).)
 | LoadOptimalRenderSettings |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MousePosToGisPoint(Point) | Converts a MousePoint (in pixel coords) to a map coordinate point
Public method | MousePosToGisPoint(Int32, Int32) | Converts a MousePoint's x and y location to a map coordinate point
Public method | MoveShapeFileDown | Moves the spcified ShapeFile "down" in the ShapeFile layers
Public method | MoveShapeFileUp | Moves the spcified ShapeFile "up" in the ShapeFile layers
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Handles the DoubleClick event. Derived classes overriding this method should call base.OnDoubleClick to ensure the SFMap control handles the event correctly (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Handles the MouseDown event. Derived classes overriding this method should call base.OnMouseDown to ensure the SFMap control handles the event correctly (Overrides UserControl..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Handles the MouseLeave event. Derived classes overriding this method should call base.OnMouseLeave to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Handles the MouseMove event. Derived classes overriding this method should call base.OnMouseMove to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Handles the MouseUp event. Derived classes overriding this method should call base.OnMouseUp to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Handles the MouseWheel event. Derived classes overriding this method should call base.OnMouseWheel to ensure the SFMap control handles the event correctly (Overrides ScrollableControl..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Overrides UserControl..::..OnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedRecordChanged |
Protected method | OnShapeFilesChanged | Fires the ShapeFilesChanged event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnTooltipDisplayed | Fires the TooltipDisplayed event
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Protected method | OnZoomLevelChanged | Fires the ZoomLevelChanged event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PixelCoordToGisPoint(Point) | Converts pixel coordinates to map coordinates
Public method | PixelCoordToGisPoint(Int32, Int32) | Converts pixel coordinates to map coordinates
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReadXml(XmlElement) |
Public method | ReadXml(XmlElement, ProgressLoadStatusHandler) |
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Refresh(Boolean) | Causes the map to redraw all of its contents immediately
Public method | RemoveShapeFile | Removes the specifed ShapeFile from the SFMap control
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomAndCentre | Convenience method to set the ZoomLevel and CentrePoint in one method
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | WriteXml | Writes an xml representation of the current project loaded in the SFMap control
Public method | ZoomToFullExtent | Centres and scales the map to fit the entire map in the SFControl

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CentrePoint | Obsolete. Gets or sets the centre point of the map in mapping coordinates (as used by the shapefiles)
Public property | CentrePoint2D | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Item[([( Int32])]) | Gets the ShapeFile at the spcified index
Public property | Item[([( String])]) | Gets the ShapeFile with the specified file path
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MapBackColor | Gets or sets the color on the map background
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanSelectMode |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProjectedExtent | Gets the rectangular extent of the entire map in projected coordinates
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderQuality | Gets or sets the RenderQuality to use when rendering the map
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShapeFileCount | Gets the number of ShapeFile layers in the SFMap Control
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMercatorProjection | Gets or sets whether to render the map using the MercatorProjection
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Public property | VisibleExtent | Gets the rectangular extent of the current visible area of the map being displayed in the SFMap control
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the current ZoomLevel of the SFMap

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedRecordsChanged | event fired when selected records of a shapefile change
Public event | ShapeFilesChanged | Event indicating that the SFMap ShapeFile Layers has changed (ShapeFile added or removed)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | TooltipDisplayed | Event fired when a tooltip is displayed for a shapefile with the RenderSettings.UseTooltip property set to true
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomLevelChanged | Event indicating that the ZoomLevel of the map has changed

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

SFMap Class
EGIS.Controls Namespace


SFMap Constructor

[image]

.NET Framework Class Library
SFMap Constructor
SFMap Class See Also Send Feedback

SFMap contructor

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public SFMap()
Visual C++
public:
SFMap()
JavaScript
EGIS.Controls.SFMap = function();

See Also

SFMap Class
EGIS.Controls Namespace


SFMap Methods

[image] [image]

.NET Framework Class Library
SFMap Methods
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AddShapeFile | Adds a new ShapeFile layer to the map
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearShapeFiles | Removes all ShapeFile layers from the map
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindShapeFileBypath | Finds and returns the ShapeFile which was loaded from the given path
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetBitmap | Utility method that creates and returns a new Bitmap Image of the current map displayed in the SFMap Control
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetShapeIndexAtPixelCoord | Returns the shape index for a given shapefile located at a point (in pixel/mouse coordinates)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GisPointToPixelCoord(PointD) | Converts a GIS position to mouse position
Public method | GisPointToPixelCoord(Double, Double) | Converts a GIS position to mouse position
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexOfShapeFileByPath | Finds and returns the index of the ShapeFile which was loaded from the given path
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | (Overrides Control..::..IsInputKey(Keys).)
 | LoadOptimalRenderSettings |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MousePosToGisPoint(Point) | Converts a MousePoint (in pixel coords) to a map coordinate point
Public method | MousePosToGisPoint(Int32, Int32) | Converts a MousePoint's x and y location to a map coordinate point
Public method | MoveShapeFileDown | Moves the spcified ShapeFile "down" in the ShapeFile layers
Public method | MoveShapeFileUp | Moves the spcified ShapeFile "up" in the ShapeFile layers
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Handles the DoubleClick event. Derived classes overriding this method should call base.OnDoubleClick to ensure the SFMap control handles the event correctly (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Handles the MouseDown event. Derived classes overriding this method should call base.OnMouseDown to ensure the SFMap control handles the event correctly (Overrides UserControl..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Handles the MouseLeave event. Derived classes overriding this method should call base.OnMouseLeave to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Handles the MouseMove event. Derived classes overriding this method should call base.OnMouseMove to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Handles the MouseUp event. Derived classes overriding this method should call base.OnMouseUp to ensure the SFMap control handles the event correctly (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Handles the MouseWheel event. Derived classes overriding this method should call base.OnMouseWheel to ensure the SFMap control handles the event correctly (Overrides ScrollableControl..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Overrides UserControl..::..OnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedRecordChanged |
Protected method | OnShapeFilesChanged | Fires the ShapeFilesChanged event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnTooltipDisplayed | Fires the TooltipDisplayed event
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Protected method | OnZoomLevelChanged | Fires the ZoomLevelChanged event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PixelCoordToGisPoint(Point) | Converts pixel coordinates to map coordinates
Public method | PixelCoordToGisPoint(Int32, Int32) | Converts pixel coordinates to map coordinates
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReadXml(XmlElement) |
Public method | ReadXml(XmlElement, ProgressLoadStatusHandler) |
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Refresh(Boolean) | Causes the map to redraw all of its contents immediately
Public method | RemoveShapeFile | Removes the specifed ShapeFile from the SFMap control
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomAndCentre | Convenience method to set the ZoomLevel and CentrePoint in one method
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Public method | WriteXml | Writes an xml representation of the current project loaded in the SFMap control
Public method | ZoomToFullExtent | Centres and scales the map to fit the entire map in the SFControl

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

SFMap Class
EGIS.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
SFMap..::..AccessibilityNotifyClients Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


AddShapeFile Method

[image]

.NET Framework Class Library
SFMap..::..AddShapeFile Method
SFMap Class See Also Send Feedback

Adds a new ShapeFile layer to the map

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function AddShapeFile ( _
    path As String, _
    name As String, _
    labelFieldName As String _
) As ShapeFile
C#
public ShapeFile AddShapeFile(
    string path,
    string name,
    string labelFieldName
)
Visual C++
public:
ShapeFile^ AddShapeFile(
    String^ path,
    String^ name,
    String^ labelFieldName
)
JavaScript
function addShapeFile(path, name, labelFieldName);

Parameters

path
Type: System..::..String
The file path to the ShapeFile
name
Type: System..::..String
The "display" name of the ShapeFile.
labelFieldName
Type: System..::..String
The name of the field in the ShapeFiles's DBF file to use when rendering the shape labels

Return Value

Returns the created ShapeFile which was added to the SFMap

Remarks

After the shapefile is added to the map, the map will auto fit the entire ShapeFile in the control by adjusting the current ZomLevel and CentrePoint accordingly.

See Also

SFMap Class
EGIS.Controls Namespace


BeginInvoke Method

[image] [image]

.NET Framework Class Library
SFMap..::..BeginInvoke Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


ClearShapeFiles Method

[image]

.NET Framework Class Library
SFMap..::..ClearShapeFiles Method
SFMap Class See Also Send Feedback

Removes all ShapeFile layers from the map

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub ClearShapeFiles
C#
public void ClearShapeFiles()
Visual C++
public:
void ClearShapeFiles()
JavaScript
function clearShapeFiles();

See Also

SFMap Class
EGIS.Controls Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
SFMap..::..Dispose Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
SFMap..::..Dispose Method (Boolean)
SFMap Class See Also Send Feedback

Clean up any resources being used.

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SFMap Class
Dispose Overload
EGIS.Controls Namespace


FindShapeFileBypath Method

[image]

.NET Framework Class Library
SFMap..::..FindShapeFileBypath Method
SFMap Class See Also Send Feedback

Finds and returns the ShapeFile which was loaded from the given path

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function FindShapeFileBypath ( _
    path As String _
) As ShapeFile
C#
public ShapeFile FindShapeFileBypath(
    string path
)
Visual C++
public:
ShapeFile^ FindShapeFileBypath(
    String^ path
)
JavaScript
function findShapeFileBypath(path);

Parameters

path
Type: System..::..String

Return Value

The found ShapeFile or null if the ShapeFile could not be found

See Also

SFMap Class
EGIS.Controls Namespace


GetBitmap Method

[image]

.NET Framework Class Library
SFMap..::..GetBitmap Method
SFMap Class See Also Send Feedback

Utility method that creates and returns a new Bitmap Image of the current map displayed in the SFMap Control

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function GetBitmap As Bitmap
C#
public Bitmap GetBitmap()
Visual C++
public:
Bitmap^ GetBitmap()
JavaScript
function getBitmap();

Return Value

Remarks

The returned image should be disposed when you have finshed using the Bitmap

See Also

SFMap Class
EGIS.Controls Namespace


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
SFMap..::..GetChildAtPoint Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


GetShapeIndexAtPixelCoord Method

[image]

.NET Framework Class Library
SFMap..::..GetShapeIndexAtPixelCoord Method
SFMap Class See Also Send Feedback

Returns the shape index for a given shapefile located at a point (in pixel/mouse coordinates)

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function GetShapeIndexAtPixelCoord ( _
    shapeIndex As Integer, _
    pt As Point, _
    pixelDelta As Integer _
) As Integer
C#
public int GetShapeIndexAtPixelCoord(
    int shapeIndex,
    Point pt,
    int pixelDelta
)
Visual C++
public:
int GetShapeIndexAtPixelCoord(
    int shapeIndex,
    Point pt,
    int pixelDelta
)
JavaScript
function getShapeIndexAtPixelCoord(shapeIndex, pt, pixelDelta);

Parameters

shapeIndex
Type: System..::..Int32
The zero based index of the shapefile layer
pt
Type: System.Drawing..::..Point
The pixel point
pixelDelta
Type: System..::..Int32
The pixel delta value added to pt. I.E return shape under pt +/- delta pixels. A suitable value for delta is 5 to 8 pixels

Return Value

The zero based shape index, or -1 if no shape is located at pt

See Also

SFMap Class
EGIS.Controls Namespace


GisPointToPixelCoord Method

[image] [image]

.NET Framework Class Library
SFMap..::..GisPointToPixelCoord Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GisPointToPixelCoord(PointD) | Converts a GIS position to mouse position
Public method | GisPointToPixelCoord(Double, Double) | Converts a GIS position to mouse position

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


GisPointToPixelCoord Method (PointD)

[image]

.NET Framework Class Library
SFMap..::..GisPointToPixelCoord Method (PointD)
SFMap Class See Also Send Feedback

Converts a GIS position to mouse position

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function GisPointToPixelCoord ( _
    pt As PointD _
) As Point
C#
public Point GisPointToPixelCoord(
    PointD pt
)
Visual C++
public:
Point GisPointToPixelCoord(
    PointD pt
)
JavaScript
function gisPointToPixelCoord(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Return Value

See Also

SFMap Class
GisPointToPixelCoord Overload
EGIS.Controls Namespace


GisPointToPixelCoord Method (Double, Double)

[image]

.NET Framework Class Library
SFMap..::..GisPointToPixelCoord Method (Double, Double)
SFMap Class See Also Send Feedback

Converts a GIS position to mouse position

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function GisPointToPixelCoord ( _
    x As Double, _
    y As Double _
) As Point
C#
public Point GisPointToPixelCoord(
    double x,
    double y
)
Visual C++
public:
Point GisPointToPixelCoord(
    double x,
    double y
)
JavaScript
function gisPointToPixelCoord(x, y);

Parameters

x
Type: System..::..Double
x-coord of the GIS point
y
Type: System..::..Double
y-coord of the GIS point

Return Value

See Also

SFMap Class
GisPointToPixelCoord Overload
EGIS.Controls Namespace


IndexOfShapeFileByPath Method

[image]

.NET Framework Class Library
SFMap..::..IndexOfShapeFileByPath Method
SFMap Class See Also Send Feedback

Finds and returns the index of the ShapeFile which was loaded from the given path

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function IndexOfShapeFileByPath ( _
    path As String _
) As Integer
C#
public int IndexOfShapeFileByPath(
    string path
)
Visual C++
public:
int IndexOfShapeFileByPath(
    String^ path
)
JavaScript
function indexOfShapeFileByPath(path);

Parameters

path
Type: System..::..String

Return Value

The found zero based ShapeFile index or -1 if the ShapeFile could not be found

See Also

SFMap Class
EGIS.Controls Namespace


Invalidate Method

[image] [image]

.NET Framework Class Library
SFMap..::..Invalidate Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Invoke Method

[image] [image]

.NET Framework Class Library
SFMap..::..Invoke Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


IsInputKey Method

[image]

.NET Framework Class Library
SFMap..::..IsInputKey Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Function IsInputKey ( _
    keyData As Keys _
) As Boolean
C#
protected override bool IsInputKey(
    Keys keyData
)
Visual C++
protected:
virtual bool IsInputKey(
    Keys keyData
) override
JavaScript
function isInputKey(keyData);

Parameters

keyData
Type: System.Windows.Forms..::..Keys

See Also

SFMap Class
EGIS.Controls Namespace


LoadOptimalRenderSettings Method

[image]

.NET Framework Class Library
SFMap..::..LoadOptimalRenderSettings Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Shared Sub LoadOptimalRenderSettings ( _
    sf As ShapeFile _
)
C#
protected static void LoadOptimalRenderSettings(
    ShapeFile sf
)
Visual C++
protected:
static void LoadOptimalRenderSettings(
    ShapeFile^ sf
)
JavaScript
EGIS.Controls.SFMap.loadOptimalRenderSettings = function(sf);

Parameters

sf
Type: EGIS.ShapeFileLib..::..ShapeFile

See Also

SFMap Class
EGIS.Controls Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
SFMap..::..MemberwiseClone Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


MousePosToGisPoint Method

[image] [image]

.NET Framework Class Library
SFMap..::..MousePosToGisPoint Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MousePosToGisPoint(Point) | Converts a MousePoint (in pixel coords) to a map coordinate point
Public method | MousePosToGisPoint(Int32, Int32) | Converts a MousePoint's x and y location to a map coordinate point

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


MousePosToGisPoint Method (Point)

[image]

.NET Framework Class Library
SFMap..::..MousePosToGisPoint Method (Point)
SFMap Class See Also Send Feedback

Converts a MousePoint (in pixel coords) to a map coordinate point

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function MousePosToGisPoint ( _
    pt As Point _
) As PointD
C#
public PointD MousePosToGisPoint(
    Point pt
)
Visual C++
public:
PointD MousePosToGisPoint(
    Point pt
)
JavaScript
function mousePosToGisPoint(pt);

Parameters

pt
Type: System.Drawing..::..Point

Return Value

Remarks

This method is being deprecated - use PixelCoordToGisPoint PixelCoordToGisPoint(Int32, Int32)

See Also

SFMap Class
MousePosToGisPoint Overload
EGIS.Controls Namespace


MousePosToGisPoint Method (Int32, Int32)

[image]

.NET Framework Class Library
SFMap..::..MousePosToGisPoint Method (Int32, Int32)
SFMap Class See Also Send Feedback

Converts a MousePoint's x and y location to a map coordinate point

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function MousePosToGisPoint ( _
    mouseX As Integer, _
    mouseY As Integer _
) As PointD
C#
public PointD MousePosToGisPoint(
    int mouseX,
    int mouseY
)
Visual C++
public:
PointD MousePosToGisPoint(
    int mouseX,
    int mouseY
)
JavaScript
function mousePosToGisPoint(mouseX, mouseY);

Parameters

mouseX
Type: System..::..Int32
mouseY
Type: System..::..Int32

Return Value

Remarks

This method is being deprecated - use PixelCoordToGisPoint PixelCoordToGisPoint(Int32, Int32)

See Also

SFMap Class
MousePosToGisPoint Overload
EGIS.Controls Namespace


MoveShapeFileDown Method

[image]

.NET Framework Class Library
SFMap..::..MoveShapeFileDown Method
SFMap Class See Also Send Feedback

Moves the spcified ShapeFile "down" in the ShapeFile layers

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub MoveShapeFileDown ( _
    shapeFile As ShapeFile _
)
C#
public void MoveShapeFileDown(
    ShapeFile shapeFile
)
Visual C++
public:
void MoveShapeFileDown(
    ShapeFile^ shapeFile
)
JavaScript
function moveShapeFileDown(shapeFile);

Parameters

shapeFile
Type: EGIS.ShapeFileLib..::..ShapeFile

Remarks

When ShapeFiles are added to the map the order that they are added determines the order that they will be rendered. This means that the first ShapeFile layer that is rendered may potentially be covered or patially covered by subsequent shapefiles. By calling the MoveShapeFileUp and MoveShapeFileDown methods you can control the order that the ShapeFile layers will be rendered.

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..MoveShapeFileUp(ShapeFile)


MoveShapeFileUp Method

[image]

.NET Framework Class Library
SFMap..::..MoveShapeFileUp Method
SFMap Class See Also Send Feedback

Moves the spcified ShapeFile "up" in the ShapeFile layers

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub MoveShapeFileUp ( _
    shapeFile As ShapeFile _
)
C#
public void MoveShapeFileUp(
    ShapeFile shapeFile
)
Visual C++
public:
void MoveShapeFileUp(
    ShapeFile^ shapeFile
)
JavaScript
function moveShapeFileUp(shapeFile);

Parameters

shapeFile
Type: EGIS.ShapeFileLib..::..ShapeFile

Remarks

When ShapeFiles are added to the map the order that they are added determines the order that they will be rendered. This means that the first ShapeFile layer that is rendered may potentially be covered or patially covered by subsequent shapefiles. By calling the MoveShapeFileUp and MoveShapeFileDown methods you can control the order that the ShapeFile layers will be rendered.

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..MoveShapeFileDown(ShapeFile)


OnDoubleClick Method

[image]

.NET Framework Class Library
SFMap..::..OnDoubleClick Method
SFMap Class See Also Send Feedback

Handles the DoubleClick event. Derived classes overriding this method should call base.OnDoubleClick to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
C#
protected override void OnDoubleClick(
    EventArgs e
)
Visual C++
protected:
virtual void OnDoubleClick(
    EventArgs^ e
) override
JavaScript
function onDoubleClick(e);

Parameters

e
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnKeyDown Method

[image]

.NET Framework Class Library
SFMap..::..OnKeyDown Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override
JavaScript
function onKeyDown(e);

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnKeyUp Method

[image]

.NET Framework Class Library
SFMap..::..OnKeyUp Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override
JavaScript
function onKeyUp(e);

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnMouseDown Method

[image]

.NET Framework Class Library
SFMap..::..OnMouseDown Method
SFMap Class See Also Send Feedback

Handles the MouseDown event. Derived classes overriding this method should call base.OnMouseDown to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
JavaScript
function onMouseDown(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnMouseLeave Method

[image]

.NET Framework Class Library
SFMap..::..OnMouseLeave Method
SFMap Class See Also Send Feedback

Handles the MouseLeave event. Derived classes overriding this method should call base.OnMouseLeave to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override
JavaScript
function onMouseLeave(e);

Parameters

e
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnMouseMove Method

[image]

.NET Framework Class Library
SFMap..::..OnMouseMove Method
SFMap Class See Also Send Feedback

Handles the MouseMove event. Derived classes overriding this method should call base.OnMouseMove to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
JavaScript
function onMouseMove(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnMouseUp Method

[image]

.NET Framework Class Library
SFMap..::..OnMouseUp Method
SFMap Class See Also Send Feedback

Handles the MouseUp event. Derived classes overriding this method should call base.OnMouseUp to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
JavaScript
function onMouseUp(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnMouseWheel Method

[image]

.NET Framework Class Library
SFMap..::..OnMouseWheel Method
SFMap Class See Also Send Feedback

Handles the MouseWheel event. Derived classes overriding this method should call base.OnMouseWheel to ensure the SFMap control handles the event correctly

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
JavaScript
function onMouseWheel(e);

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnPaint Method

[image]

.NET Framework Class Library
SFMap..::..OnPaint Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
JavaScript
function onPaint(e);

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnResize Method

[image]

.NET Framework Class Library
SFMap..::..OnResize Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
C#
protected override void OnResize(
    EventArgs e
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override
JavaScript
function onResize(e);

Parameters

e
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnSelectedRecordChanged Method

[image]

.NET Framework Class Library
SFMap..::..OnSelectedRecordChanged Method
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnSelectedRecordChanged ( _
    args As EventArgs _
)
C#
protected void OnSelectedRecordChanged(
    EventArgs args
)
Visual C++
protected:
void OnSelectedRecordChanged(
    EventArgs^ args
)
JavaScript
function onSelectedRecordChanged(args);

Parameters

args
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Controls Namespace


OnShapeFilesChanged Method

[image]

.NET Framework Class Library
SFMap..::..OnShapeFilesChanged Method
SFMap Class See Also Send Feedback

Fires the ShapeFilesChanged event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnShapeFilesChanged
C#
protected void OnShapeFilesChanged()
Visual C++
protected:
void OnShapeFilesChanged()
JavaScript
function onShapeFilesChanged();

See Also

SFMap Class
EGIS.Controls Namespace


OnTooltipDisplayed Method

[image]

.NET Framework Class Library
SFMap..::..OnTooltipDisplayed Method
SFMap Class See Also Send Feedback

Fires the TooltipDisplayed event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnTooltipDisplayed ( _
    shapeIndex As Integer, _
    recordIndex As Integer, _
    mousePt As Point, _
    gisPt As PointD _
)
C#
protected void OnTooltipDisplayed(
    int shapeIndex,
    int recordIndex,
    Point mousePt,
    PointD gisPt
)
Visual C++
protected:
void OnTooltipDisplayed(
    int shapeIndex,
    int recordIndex,
    Point mousePt,
    PointD gisPt
)
JavaScript
function onTooltipDisplayed(shapeIndex, recordIndex, mousePt, gisPt);

Parameters

shapeIndex
Type: System..::..Int32
recordIndex
Type: System..::..Int32
mousePt
Type: System.Drawing..::..Point
gisPt
Type: EGIS.ShapeFileLib..::..PointD

See Also

SFMap Class
EGIS.Controls Namespace


OnZoomLevelChanged Method

[image]

.NET Framework Class Library
SFMap..::..OnZoomLevelChanged Method
SFMap Class See Also Send Feedback

Fires the ZoomLevelChanged event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnZoomLevelChanged
C#
protected void OnZoomLevelChanged()
Visual C++
protected:
void OnZoomLevelChanged()
JavaScript
function onZoomLevelChanged();

See Also

SFMap Class
EGIS.Controls Namespace


PerformLayout Method

[image] [image]

.NET Framework Class Library
SFMap..::..PerformLayout Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


PixelCoordToGisPoint Method

[image] [image]

.NET Framework Class Library
SFMap..::..PixelCoordToGisPoint Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PixelCoordToGisPoint(Point) | Converts pixel coordinates to map coordinates
Public method | PixelCoordToGisPoint(Int32, Int32) | Converts pixel coordinates to map coordinates

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


PixelCoordToGisPoint Method (Point)

[image]

.NET Framework Class Library
SFMap..::..PixelCoordToGisPoint Method (Point)
SFMap Class See Also Send Feedback

Converts pixel coordinates to map coordinates

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function PixelCoordToGisPoint ( _
    pt As Point _
) As PointD
C#
public PointD PixelCoordToGisPoint(
    Point pt
)
Visual C++
public:
PointD PixelCoordToGisPoint(
    Point pt
)
JavaScript
function pixelCoordToGisPoint(pt);

Parameters

pt
Type: System.Drawing..::..Point
the x,y pixel coords

Return Value

See Also

SFMap Class
PixelCoordToGisPoint Overload
EGIS.Controls Namespace


PixelCoordToGisPoint Method (Int32, Int32)

[image]

.NET Framework Class Library
SFMap..::..PixelCoordToGisPoint Method (Int32, Int32)
SFMap Class See Also Send Feedback

Converts pixel coordinates to map coordinates

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Function PixelCoordToGisPoint ( _
    pixX As Integer, _
    pixY As Integer _
) As PointD
C#
public PointD PixelCoordToGisPoint(
    int pixX,
    int pixY
)
Visual C++
public:
PointD PixelCoordToGisPoint(
    int pixX,
    int pixY
)
JavaScript
function pixelCoordToGisPoint(pixX, pixY);

Parameters

pixX
Type: System..::..Int32
pixel x value
pixY
Type: System..::..Int32
pixel y value

Return Value

See Also

SFMap Class
PixelCoordToGisPoint Overload
EGIS.Controls Namespace


ReadXml Method

[image] [image]

.NET Framework Class Library
SFMap..::..ReadXml Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadXml(XmlElement) |
Public method | ReadXml(XmlElement, ProgressLoadStatusHandler) |

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


ReadXml Method (XmlElement)

[image]

.NET Framework Class Library
SFMap..::..ReadXml Method (XmlElement)
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub ReadXml ( _
    projectElement As XmlElement _
)
C#
public void ReadXml(
    XmlElement projectElement
)
Visual C++
public:
void ReadXml(
    XmlElement^ projectElement
)
JavaScript
function readXml(projectElement);

Parameters

projectElement
Type: System.Xml..::..XmlElement

See Also

SFMap Class
ReadXml Overload
EGIS.Controls Namespace


ReadXml Method (XmlElement, ProgressLoadStatusHandler)

[image]

.NET Framework Class Library
SFMap..::..ReadXml Method (XmlElement, ProgressLoadStatusHandler)
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub ReadXml ( _
    projectElement As XmlElement, _
    loadingDelegate As ProgressLoadStatusHandler _
)
C#
public void ReadXml(
    XmlElement projectElement,
    ProgressLoadStatusHandler loadingDelegate
)
Visual C++
public:
void ReadXml(
    XmlElement^ projectElement,
    ProgressLoadStatusHandler^ loadingDelegate
)
JavaScript
function readXml(projectElement, loadingDelegate);

Parameters

projectElement
Type: System.Xml..::..XmlElement
loadingDelegate
Type: EGIS.Controls..::..ProgressLoadStatusHandler

See Also

SFMap Class
ReadXml Overload
EGIS.Controls Namespace


Refresh Method

[image] [image]

.NET Framework Class Library
SFMap..::..Refresh Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Refresh(Boolean) | Causes the map to redraw all of its contents immediately

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Refresh Method (Boolean)

[image]

.NET Framework Class Library
SFMap..::..Refresh Method (Boolean)
SFMap Class See Also Send Feedback

Causes the map to redraw all of its contents immediately

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub Refresh ( _
    fullRefresh As Boolean _
)
C#
public void Refresh(
    bool fullRefresh
)
Visual C++
public:
void Refresh(
    bool fullRefresh
)
JavaScript
function refresh(fullRefresh);

Parameters

fullRefresh
Type: System..::..Boolean
Flag to indicate whether to redraw al layers or just re-draw the internal buffer

Remarks

Internally the SFMap control uses an offsceen buffer to draw the contents of the map to, which provides efficient painting when the control is redrawn due to an OS call (i.e. another window is moved accross the SFMap control). Caling this method with fullRefresh set to true will cause the internal buffer to be re-drawn. You should call this method if a ShapeFile's RenderSettings are changed to ensure the layer is redrawn.

See Also

SFMap Class
Refresh Overload
EGIS.Controls Namespace


RemoveShapeFile Method

[image]

.NET Framework Class Library
SFMap..::..RemoveShapeFile Method
SFMap Class See Also Send Feedback

Removes the specifed ShapeFile from the SFMap control

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub RemoveShapeFile ( _
    shapeFile As ShapeFile _
)
C#
public void RemoveShapeFile(
    ShapeFile shapeFile
)
Visual C++
public:
void RemoveShapeFile(
    ShapeFile^ shapeFile
)
JavaScript
function removeShapeFile(shapeFile);

Parameters

shapeFile
Type: EGIS.ShapeFileLib..::..ShapeFile

See Also

SFMap Class
EGIS.Controls Namespace


ResumeLayout Method

[image] [image]

.NET Framework Class Library
SFMap..::..ResumeLayout Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
SFMap..::..RtlTranslateAlignment Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Scale Method

[image] [image]

.NET Framework Class Library
SFMap..::..Scale Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Select Method

[image] [image]

.NET Framework Class Library
SFMap..::..Select Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


SetBounds Method

[image] [image]

.NET Framework Class Library
SFMap..::..SetBounds Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


SetZoomAndCentre Method

[image]

.NET Framework Class Library
SFMap..::..SetZoomAndCentre Method
SFMap Class See Also Send Feedback

Convenience method to set the ZoomLevel and CentrePoint in one method

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub SetZoomAndCentre ( _
    zoom As Double, _
    centre As PointD _
)
C#
public void SetZoomAndCentre(
    double zoom,
    PointD centre
)
Visual C++
public:
void SetZoomAndCentre(
    double zoom,
    PointD centre
)
JavaScript
function setZoomAndCentre(zoom, centre);

Parameters

zoom
Type: System..::..Double
The desired ZoomLevel
centre
Type: EGIS.ShapeFileLib..::..PointD
The desired CentrePoint

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..ZoomLevel
SFMap..::..CentrePoint


UpdateBounds Method

[image] [image]

.NET Framework Class Library
SFMap..::..UpdateBounds Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Validate Method

[image] [image]

.NET Framework Class Library
SFMap..::..Validate Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


ValidateChildren Method

[image] [image]

.NET Framework Class Library
SFMap..::..ValidateChildren Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


WriteXml Method

[image]

.NET Framework Class Library
SFMap..::..WriteXml Method
SFMap Class See Also Send Feedback

Writes an xml representation of the current project loaded in the SFMap control

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
C#
public void WriteXml(
    XmlWriter writer
)
Visual C++
public:
void WriteXml(
    XmlWriter^ writer
)
JavaScript
function writeXml(writer);

Parameters

writer
Type: System.Xml..::..XmlWriter

See Also

SFMap Class
EGIS.Controls Namespace


ZoomToFullExtent Method

[image]

.NET Framework Class Library
SFMap..::..ZoomToFullExtent Method
SFMap Class See Also Send Feedback

Centres and scales the map to fit the entire map in the SFControl

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub ZoomToFullExtent
C#
public void ZoomToFullExtent()
Visual C++
public:
void ZoomToFullExtent()
JavaScript
function zoomToFullExtent();

Remarks

Call this method to apply a "zoom 100%"

See Also

SFMap Class
EGIS.Controls Namespace


SFMap Properties

[image] [image]

.NET Framework Class Library
SFMap Properties
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CentrePoint | Obsolete. Gets or sets the centre point of the map in mapping coordinates (as used by the shapefiles)
Public property | CentrePoint2D | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Item[([( Int32])]) | Gets the ShapeFile at the spcified index
Public property | Item[([( String])]) | Gets the ShapeFile with the specified file path
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MapBackColor | Gets or sets the color on the map background
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanSelectMode |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProjectedExtent | Gets the rectangular extent of the entire map in projected coordinates
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderQuality | Gets or sets the RenderQuality to use when rendering the map
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShapeFileCount | Gets the number of ShapeFile layers in the SFMap Control
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMercatorProjection | Gets or sets whether to render the map using the MercatorProjection
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Public property | VisibleExtent | Gets the rectangular extent of the current visible area of the map being displayed in the SFMap control
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the current ZoomLevel of the SFMap

See Also

SFMap Class
EGIS.Controls Namespace


CentrePoint Property

[image]

.NET Framework Class Library
SFMap..::..CentrePoint Property
SFMap Class See Also Send Feedback

Gets or sets the centre point of the map in mapping coordinates (as used by the shapefiles)

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
<ObsoleteAttribute("Superceded by CentrePoint2D to use double-precision floating-point coordinates")> _
Public Property CentrePoint As PointF
    Get
    Set
C#
[ObsoleteAttribute("Superceded by CentrePoint2D to use double-precision floating-point coordinates")]
public PointF CentrePoint { get; set; }
Visual C++
[ObsoleteAttribute(L"Superceded by CentrePoint2D to use double-precision floating-point coordinates")]
public:
property PointF CentrePoint {
    PointF get ();
    void set (PointF value);
}
JavaScript
function get_centrePoint();
function set_centrePoint(value);

Remarks

Changing the CentrePoint can be used to center the map on a new location without changing the map scale

The ZoomLevel, CentrePoint and ClientSize of the SFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CentrePoint and scaled according to the ZoomLevel.

This property should no longer be used. Use CentrePoint2D instead, which uses double-precision floating-point coordinates

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..ZoomLevel


CentrePoint2D Property

[image]

.NET Framework Class Library
SFMap..::..CentrePoint2D Property
SFMap Class See Also Send Feedback

Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property CentrePoint2D As PointD
    Get
    Set
C#
public PointD CentrePoint2D { get; set; }
Visual C++
public:
property PointD CentrePoint2D {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_centrePoint2D();
function set_centrePoint2D(value);

Remarks

This method replaces the obsolete CentrePoint property

Changing the CenterPoint2D can be used to center the map on a new location without changing the map scale

The ZoomLevel, CentrePoint and ClientSize of the SFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CentrePoint and scaled according to the ZoomLevel.

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..ZoomLevel


Extent Property

[image]

.NET Framework Class Library
SFMap..::..Extent Property
SFMap Class See Also Send Feedback

Gets the rectangular extent of the entire map

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property Extent As RectangleD
    Get
C#
public RectangleD Extent { get; }
Visual C++
public:
property RectangleD Extent {
    RectangleD get ();
}
JavaScript
function get_extent();

Remarks

Extent is the rectangular extent of the ENTIRE map, regardless of the current ZoomLevel or CentrePoint. To get the extent of the current visible area of the map call VisibleExtent

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..VisibleExtent


Item Property

[image] [image]

.NET Framework Class Library
SFMap..::..Item Property
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the ShapeFile at the spcified index
Public property | Item[([( String])]) | Gets the ShapeFile with the specified file path

See Also

SFMap Class
SFMap Members
EGIS.Controls Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
SFMap..::..Item Property (Int32)
SFMap Class See Also Send Feedback

Gets the ShapeFile at the spcified index

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ShapeFile
    Get
C#
public ShapeFile this[
    int index
] { get; }
Visual C++
public:
property ShapeFile^ default[int index] {
    ShapeFile^ get (int index);
}
JavaScript
function get_item(index);

Parameters

index
Type: System..::..Int32

Return Value

See Also

SFMap Class
Item Overload
EGIS.Controls Namespace


Item Property (String)

[image]

.NET Framework Class Library
SFMap..::..Item Property (String)
SFMap Class See Also Send Feedback

Gets the ShapeFile with the specified file path

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Default Property Item ( _
    shapeFilePath As String _
) As ShapeFile
    Get
C#
public ShapeFile this[
    string shapeFilePath
] { get; }
Visual C++
public:
property ShapeFile^ default[String^ shapeFilePath] {
    ShapeFile^ get (String^ shapeFilePath);
}
JavaScript
function get_item(shapeFilePath);

Parameters

shapeFilePath
Type: System..::..String

Return Value

See Also

SFMap Class
Item Overload
EGIS.Controls Namespace


MapBackColor Property

[image]

.NET Framework Class Library
SFMap..::..MapBackColor Property
SFMap Class See Also Send Feedback

Gets or sets the color on the map background

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property MapBackColor As Color
    Get
    Set
C#
public Color MapBackColor { get; set; }
Visual C++
public:
property Color MapBackColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_mapBackColor();
function set_mapBackColor(value);

See Also

SFMap Class
EGIS.Controls Namespace


PanSelectMode Property

[image]

.NET Framework Class Library
SFMap..::..PanSelectMode Property
SFMap Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property PanSelectMode As PanSelectMode
    Get
    Set
C#
public PanSelectMode PanSelectMode { get; set; }
Visual C++
public:
property PanSelectMode PanSelectMode {
    PanSelectMode get ();
    void set (PanSelectMode value);
}
JavaScript
function get_panSelectMode();
function set_panSelectMode(value);

See Also

SFMap Class
EGIS.Controls Namespace


ProjectedExtent Property

[image]

.NET Framework Class Library
SFMap..::..ProjectedExtent Property
SFMap Class See Also Send Feedback

Gets the rectangular extent of the entire map in projected coordinates

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ProjectedExtent As RectangleD
    Get
C#
public RectangleD ProjectedExtent { get; }
Visual C++
public:
property RectangleD ProjectedExtent {
    RectangleD get ();
}
JavaScript
function get_projectedExtent();

Remarks

ProjectedExtent is the rectangular extent of the ENTIRE map, regardless of the current ZoomLevel or CentrePoint. If MapProjectionType is ProjectionType.none the returned RectangleD is the same as Extent

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..VisibleExtent


RenderQuality Property

[image]

.NET Framework Class Library
SFMap..::..RenderQuality Property
SFMap Class See Also Send Feedback

Gets or sets the RenderQuality to use when rendering the map

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property RenderQuality As RenderQuality
    Get
    Set
C#
public RenderQuality RenderQuality { get; set; }
Visual C++
public:
property RenderQuality RenderQuality {
    RenderQuality get ();
    void set (RenderQuality value);
}
JavaScript
function get_renderQuality();
function set_renderQuality(value);

Remarks

Changing the RenderQuality to RenderQuality.Auto will let the SFMap change the RenderQuality dynamically depending on the size of the ShapeFiles and as the ZoomLevel changes. This is the default RenderQuality setting and in most cases you will not need to change this setting.

Changing the RenderQuality to RenderQuality.High will render the map using high quality GDI+ Graphics, but the rendering speed will be slowed down somewhat.

Changing the RenderQuality to RenderQuality.Low will render maps much faster, but at the expense of lower quality graphics. For very large ShapeFiles when drawing the entire ShapeFile choosing this option may render the maps considerably faster.

See Also

SFMap Class
EGIS.Controls Namespace
EGIS.ShapeFileLib..::..RenderQuality


ShapeFileCount Property

[image]

.NET Framework Class Library
SFMap..::..ShapeFileCount Property
SFMap Class See Also Send Feedback

Gets the number of ShapeFile layers in the SFMap Control

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ShapeFileCount As Integer
    Get
C#
public int ShapeFileCount { get; }
Visual C++
public:
property int ShapeFileCount {
    int get ();
}
JavaScript
function get_shapeFileCount();

See Also

SFMap Class
EGIS.Controls Namespace


UseMercatorProjection Property

[image]

.NET Framework Class Library
SFMap..::..UseMercatorProjection Property
SFMap Class See Also Send Feedback

Gets or sets whether to render the map using the MercatorProjection

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property UseMercatorProjection As Boolean
    Get
    Set
C#
public bool UseMercatorProjection { get; set; }
Visual C++
public:
property bool UseMercatorProjection {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useMercatorProjection();
function set_useMercatorProjection(value);

See Also

SFMap Class
EGIS.Controls Namespace


VisibleExtent Property

[image]

.NET Framework Class Library
SFMap..::..VisibleExtent Property
SFMap Class See Also Send Feedback

Gets the rectangular extent of the current visible area of the map being displayed in the SFMap control

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property VisibleExtent As RectangleF
    Get
C#
public RectangleF VisibleExtent { get; }
Visual C++
public:
property RectangleF VisibleExtent {
    RectangleF get ();
}
JavaScript
function get_visibleExtent();

Remarks

VisibleExtent is the current visible area of the map, as determind by the current ZoomLevel, CentrePoint and ClientSize of the SFMap control. To get the extent of the ENTIRE map call Extent

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..Extent


ZoomLevel Property

[image]

.NET Framework Class Library
SFMap..::..ZoomLevel Property
SFMap Class See Also Send Feedback

Gets or sets the current ZoomLevel of the SFMap

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property ZoomLevel As Double
    Get
    Set
C#
public double ZoomLevel { get; set; }
Visual C++
public:
property double ZoomLevel {
    double get ();
    void set (double value);
}
JavaScript
function get_zoomLevel();
function set_zoomLevel(value);

Remarks

Changing the ZoomLevel will zoom into or out of the map. Increasing the ZoomLevel will zoom into the map, while decreasing the ZoomLevel will zoom out of the map

The ZoomLevel, CentrePoint and ClientSize of the SFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CentrePoint and scaled according to the ZoomLevel.

Exceptions

Exception | Condition
System..::..ArgumentException | if ZoomLevel less than or equal to zero

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..CentrePoint


SFMap Events

[image] [image]

.NET Framework Class Library
SFMap Events
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedRecordsChanged | event fired when selected records of a shapefile change
Public event | ShapeFilesChanged | Event indicating that the SFMap ShapeFile Layers has changed (ShapeFile added or removed)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | TooltipDisplayed | Event fired when a tooltip is displayed for a shapefile with the RenderSettings.UseTooltip property set to true
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomLevelChanged | Event indicating that the ZoomLevel of the map has changed

See Also

SFMap Class
EGIS.Controls Namespace


SelectedRecordsChanged Event

[image]

.NET Framework Class Library
SFMap..::..SelectedRecordsChanged Event
SFMap Class See Also Send Feedback

event fired when selected records of a shapefile change

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event SelectedRecordsChanged As EventHandler(Of EventArgs)
C#
public event EventHandler<EventArgs> SelectedRecordsChanged
Visual C++
public:
 event EventHandler<EventArgs^>^ SelectedRecordsChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
JavaScript
function add_selectedRecordsChanged(value);
function remove_selectedRecordsChanged(value);

Remarks

To obtain the selected records iterate over each shapefile and call the SelectedRecordIndices method

See Also

SFMap Class
EGIS.Controls Namespace


ShapeFilesChanged Event

[image]

.NET Framework Class Library
SFMap..::..ShapeFilesChanged Event
SFMap Class See Also Send Feedback

Event indicating that the SFMap ShapeFile Layers has changed (ShapeFile added or removed)

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event ShapeFilesChanged As EventHandler(Of EventArgs)
C#
public event EventHandler<EventArgs> ShapeFilesChanged
Visual C++
public:
 event EventHandler<EventArgs^>^ ShapeFilesChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
JavaScript
function add_shapeFilesChanged(value);
function remove_shapeFilesChanged(value);

See Also

SFMap Class
EGIS.Controls Namespace


TooltipDisplayed Event

[image]

.NET Framework Class Library
SFMap..::..TooltipDisplayed Event
SFMap Class See Also Send Feedback

Event fired when a tooltip is displayed for a shapefile with the RenderSettings.UseTooltip property set to true

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event TooltipDisplayed As EventHandler(Of SFMap..::..TooltipEventArgs)
C#
public event EventHandler<SFMap..::..TooltipEventArgs> TooltipDisplayed
Visual C++
public:
 event EventHandler<SFMap..::..TooltipEventArgs^>^ TooltipDisplayed {
    void add (EventHandler<SFMap..::..TooltipEventArgs^>^ value);
    void remove (EventHandler<SFMap..::..TooltipEventArgs^>^ value);
}
JavaScript
function add_tooltipDisplayed(value);
function remove_tooltipDisplayed(value);

Remarks

The event is also fired when the tooltip is hidden. In this case the TooltipEventArgs ShapeFileIndex and RecordIndex will return -1 This allows receivers to be notified when the mouse is no longer over a shape

See Also

SFMap Class
EGIS.Controls Namespace
SFMap..::..GetShapeIndexAtPixelCoord(Int32, Point, Int32)


ZoomLevelChanged Event

[image]

.NET Framework Class Library
SFMap..::..ZoomLevelChanged Event
SFMap Class See Also Send Feedback

Event indicating that the ZoomLevel of the map has changed

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event ZoomLevelChanged As EventHandler(Of EventArgs)
C#
public event EventHandler<EventArgs> ZoomLevelChanged
Visual C++
public:
 event EventHandler<EventArgs^>^ ZoomLevelChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
JavaScript
function add_zoomLevelChanged(value);
function remove_zoomLevelChanged(value);

See Also

SFMap Class
EGIS.Controls Namespace


SFMap.TooltipEventArgs Class

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs Class
SFMap Class Members See Also Send Feedback

EventArgs class containing data for the TooltipDisplayed event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Class TooltipEventArgs _
    Inherits EventArgs
C#
public class TooltipEventArgs : EventArgs
Visual C++
public ref class TooltipEventArgs : public EventArgs
JavaScript
EGIS.Controls.TooltipEventArgs = function();

Type.createClass(
    'EGIS.Controls.TooltipEventArgs',
    EventArgs);

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
EGIS.Controls..::..SFMap..::..TooltipEventArgs

See Also

SFMap..::..TooltipEventArgs Members
EGIS.Controls Namespace


SFMap.TooltipEventArgs Members

[image] [image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs Members
SFMap..::..TooltipEventArgs Class Constructors Methods Properties See Also Send Feedback

SFMap (ShapeFile Map) is a .NET ShapeFile Control which displays shapefiles in a .NET Windows Form application

The SFMap..::..TooltipEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SFMap..::..TooltipEventArgs |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GISLocation |
Public property | MousePosition |
Public property | RecordIndex | Gets / Sets the zero based index of the shapefile record.
Public property | ShapeFileIndex | Gets / Sets the zero based index of the shapefile.

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


SFMap.TooltipEventArgs Constructor

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs Constructor
SFMap..::..TooltipEventArgs Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    shapeIndex As Integer, _
    recordIndex As Integer, _
    mousePt As Point, _
    gisPoint As PointD _
)
C#
public TooltipEventArgs(
    int shapeIndex,
    int recordIndex,
    Point mousePt,
    PointD gisPoint
)
Visual C++
public:
TooltipEventArgs(
    int shapeIndex,
    int recordIndex,
    Point mousePt,
    PointD gisPoint
)
JavaScript
EGIS.Controls.TooltipEventArgs = function(shapeIndex, recordIndex, mousePt, gisPoint);

Parameters

shapeIndex
Type: System..::..Int32
recordIndex
Type: System..::..Int32
mousePt
Type: System.Drawing..::..Point
gisPoint
Type: EGIS.ShapeFileLib..::..PointD

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


SFMap.TooltipEventArgs Methods

[image] [image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs Methods
SFMap..::..TooltipEventArgs Class See Also Send Feedback

The SFMap..::..TooltipEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


SFMap.TooltipEventArgs Properties

[image] [image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs Properties
SFMap..::..TooltipEventArgs Class See Also Send Feedback

The SFMap..::..TooltipEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GISLocation |
Public property | MousePosition |
Public property | RecordIndex | Gets / Sets the zero based index of the shapefile record.
Public property | ShapeFileIndex | Gets / Sets the zero based index of the shapefile.

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


GISLocation Property

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs..::..GISLocation Property
SFMap..::..TooltipEventArgs Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property GISLocation As PointD
    Get
    Set
C#
public PointD GISLocation { get; set; }
Visual C++
public:
property PointD GISLocation {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_gisLocation();
function set_gisLocation(value);

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


MousePosition Property

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs..::..MousePosition Property
SFMap..::..TooltipEventArgs Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property MousePosition As Point
    Get
    Set
C#
public Point MousePosition { get; set; }
Visual C++
public:
property Point MousePosition {
    Point get ();
    void set (Point value);
}
JavaScript
function get_mousePosition();
function set_mousePosition(value);

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


RecordIndex Property

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs..::..RecordIndex Property
SFMap..::..TooltipEventArgs Class See Also Send Feedback

Gets / Sets the zero based index of the shapefile record.

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property RecordIndex As Integer
    Get
    Set
C#
public int RecordIndex { get; set; }
Visual C++
public:
property int RecordIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_recordIndex();
function set_recordIndex(value);

Remarks

The returned value will be between zero and the number of records in the Shapefile displaying the tooltip
If no tooltip is displayed RecordIndex returns -1

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


ShapeFileIndex Property

[image]

.NET Framework Class Library
SFMap..::..TooltipEventArgs..::..ShapeFileIndex Property
SFMap..::..TooltipEventArgs Class See Also Send Feedback

Gets / Sets the zero based index of the shapefile.

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property ShapeFileIndex As Integer
    Get
    Set
C#
public int ShapeFileIndex { get; set; }
Visual C++
public:
property int ShapeFileIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_shapeFileIndex();
function set_shapeFileIndex(value);

Remarks

The returned value will be between zero and the number of Shapefiles in the SFMap displaying the tooltip
If no tooltip is displayed ShapeFileIndex returns -1

See Also

SFMap..::..TooltipEventArgs Class
EGIS.Controls Namespace


ShapeFileListControl Class

[image]

.NET Framework Class Library
ShapeFileListControl Class
Members See Also Send Feedback

User control containing a list of ShapeFiles

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Class ShapeFileListControl _
    Inherits UserControl
C#
public class ShapeFileListControl : UserControl
Visual C++
public ref class ShapeFileListControl : public UserControl
JavaScript
EGIS.Controls.ShapeFileListControl = function();

Type.createClass(
    'EGIS.Controls.ShapeFileListControl',
    UserControl);

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
EGIS.Controls..::..ShapeFileListControl

See Also

ShapeFileListControl Members
EGIS.Controls Namespace


ShapeFileListControl Members

[image] [image]

.NET Framework Class Library
ShapeFileListControl Members
ShapeFileListControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The ShapeFileListControl type exposes the following members.

Constructors

 | Name | Description
Public method | ShapeFileListControl |

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAddLayerClicked | Called when AddLayer button is clicked. Fires the AddLayerClicked event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedShapeFileChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetMap | called when the Map property is set
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Map | Reference to the SFMap that the ShapeFileListControl layers is associated with
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedShapeFile | Returns the currently selected ShapeFile in the controls list of shapefiles
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AddLayerClicked | Event fired when the add layer button is clicked
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedShapeFileChanged | Selected ShapeFile Changed event
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


ShapeFileListControl Constructor

[image]

.NET Framework Class Library
ShapeFileListControl Constructor
ShapeFileListControl Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public ShapeFileListControl()
Visual C++
public:
ShapeFileListControl()
JavaScript
EGIS.Controls.ShapeFileListControl = function();

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


ShapeFileListControl Methods

[image] [image]

.NET Framework Class Library
ShapeFileListControl Methods
ShapeFileListControl Class See Also Send Feedback

The ShapeFileListControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAddLayerClicked | Called when AddLayer button is clicked. Fires the AddLayerClicked event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedShapeFileChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetMap | called when the Map property is set
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IContainerControl..::..ActivateControl | (Inherited from ContainerControl.)
Explicit interface implemetation | IDropTarget..::..OnDragDrop | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragEnter | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragLeave | (Inherited from Control.)
Explicit interface implemetation | IDropTarget..::..OnDragOver | (Inherited from Control.)

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..AccessibilityNotifyClients Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


BeginInvoke Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..BeginInvoke Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Dispose Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
ShapeFileListControl..::..Dispose Method (Boolean)
ShapeFileListControl Class See Also Send Feedback

Clean up any resources being used.

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ShapeFileListControl Class
Dispose Overload
EGIS.Controls Namespace


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..GetChildAtPoint Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Invalidate Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Invalidate Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Invoke Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Invoke Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..MemberwiseClone Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


OnAddLayerClicked Method

[image]

.NET Framework Class Library
ShapeFileListControl..::..OnAddLayerClicked Method
ShapeFileListControl Class See Also Send Feedback

Called when AddLayer button is clicked. Fires the AddLayerClicked event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnAddLayerClicked
C#
protected void OnAddLayerClicked()
Visual C++
protected:
void OnAddLayerClicked()
JavaScript
function onAddLayerClicked();

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


OnSelectedShapeFileChanged Method

[image]

.NET Framework Class Library
ShapeFileListControl..::..OnSelectedShapeFileChanged Method
ShapeFileListControl Class See Also Send Feedback

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Sub OnSelectedShapeFileChanged
C#
protected void OnSelectedShapeFileChanged()
Visual C++
protected:
void OnSelectedShapeFileChanged()
JavaScript
function onSelectedShapeFileChanged();

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


PerformLayout Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..PerformLayout Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


ResumeLayout Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..ResumeLayout Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..RtlTranslateAlignment Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Scale Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Scale Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Select Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Select Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


SetBounds Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..SetBounds Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


SetMap Method

[image]

.NET Framework Class Library
ShapeFileListControl..::..SetMap Method
ShapeFileListControl Class See Also Send Feedback

called when the Map property is set

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub SetMap ( _
    map As SFMap _
)
C#
protected virtual void SetMap(
    SFMap map
)
Visual C++
protected:
virtual void SetMap(
    SFMap^ map
)
JavaScript
function setMap(map);

Parameters

map
Type: EGIS.Controls..::..SFMap

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


UpdateBounds Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..UpdateBounds Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


Validate Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..Validate Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


ValidateChildren Method

[image] [image]

.NET Framework Class Library
ShapeFileListControl..::..ValidateChildren Method
ShapeFileListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ShapeFileListControl Class
ShapeFileListControl Members
EGIS.Controls Namespace


ShapeFileListControl Properties

[image] [image]

.NET Framework Class Library
ShapeFileListControl Properties
ShapeFileListControl Class See Also Send Feedback

The ShapeFileListControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Map | Reference to the SFMap that the ShapeFileListControl layers is associated with
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedShapeFile | Returns the currently selected ShapeFile in the controls list of shapefiles
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


Map Property

[image]

.NET Framework Class Library
ShapeFileListControl..::..Map Property
ShapeFileListControl Class See Also Send Feedback

Reference to the SFMap that the ShapeFileListControl layers is associated with

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Property Map As SFMap
    Get
    Set
C#
public SFMap Map { get; set; }
Visual C++
public:
property SFMap^ Map {
    SFMap^ get ();
    void set (SFMap^ value);
}
JavaScript
function get_map();
function set_map(value);

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


SelectedShapeFile Property

[image]

.NET Framework Class Library
ShapeFileListControl..::..SelectedShapeFile Property
ShapeFileListControl Class See Also Send Feedback

Returns the currently selected ShapeFile in the controls list of shapefiles

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property SelectedShapeFile As ShapeFile
    Get
C#
public ShapeFile SelectedShapeFile { get; }
Visual C++
public:
property ShapeFile^ SelectedShapeFile {
    ShapeFile^ get ();
}
JavaScript
function get_selectedShapeFile();

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


ShapeFileListControl Events

[image] [image]

.NET Framework Class Library
ShapeFileListControl Events
ShapeFileListControl Class See Also Send Feedback

The ShapeFileListControl type exposes the following members.

Events

 | Name | Description
Public event | AddLayerClicked | Event fired when the add layer button is clicked
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedShapeFileChanged | Selected ShapeFile Changed event
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


AddLayerClicked Event

[image]

.NET Framework Class Library
ShapeFileListControl..::..AddLayerClicked Event
ShapeFileListControl Class See Also Send Feedback

Event fired when the add layer button is clicked

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event AddLayerClicked As EventHandler
C#
public event EventHandler AddLayerClicked
Visual C++
public:
 event EventHandler^ AddLayerClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
JavaScript
function add_addLayerClicked(value);
function remove_addLayerClicked(value);

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


SelectedShapeFileChanged Event

[image]

.NET Framework Class Library
ShapeFileListControl..::..SelectedShapeFileChanged Event
ShapeFileListControl Class See Also Send Feedback

Selected ShapeFile Changed event

Namespace: EGIS.Controls
Assembly: EGIS.Controls (in EGIS.Controls.dll)

Syntax

Visual Basic
Public Event SelectedShapeFileChanged As EventHandler(Of EventArgs)
C#
public event EventHandler<EventArgs> SelectedShapeFileChanged
Visual C++
public:
 event EventHandler<EventArgs^>^ SelectedShapeFileChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
JavaScript
function add_selectedShapeFileChanged(value);
function remove_selectedShapeFileChanged(value);

See Also

ShapeFileListControl Class
EGIS.Controls Namespace


EGIS.ShapeFileLib Namespace

[image]

.NET Framework Class Library
EGIS.ShapeFileLib Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConversionFunctions | Utility class containing static methods to calculate the distance between points and convert projections
Public class | CustomRenderSettingsUtil | Utility factory class which creates ICustomRenderSettings objects
Public class | DbfReader | A DBF Reader class, providing direct access to record data within a DBF file, with low memory useage.
Public class | DbfWriter | a DBF File Writer class
Public class | Ellipsoid | Simple class that encapsulates the parameters defining an Ellipsoid
Public class | GeometryAlgorithms | Collection of 2D Geometry algorithms
Public class | LatLongProjection |
Public class | MapProjectionCreator |
Public class | MercatorProjection |
Public class | RenderSettings | Encapsulates settings used when rendering a ShapeFile
Public class | ShapeFile | .NET ShapeFile class used to load, render and query data in an ESRI Shape File. The ShapeFile class is the main class of the EGIS.ShapeFileLib namespace
Public class | ShapeFileEnumerator | ShapeFile enumerator used to enumerate the raw data of each shape in a shapeFile. The ShapeFileEnumerator provides a fast, low memory, forward only means of iterating over all of the records in a shapefile.
Public class | ShapeFileWriter | .NET ShapeFile Writer utility class which provides the ability to create or edit shapefiles from .NET applications.
Public class | SizeDConverter | Converts SizeD objects from one type to another.
Public class | TileUtil | Utility class with methods to convert Lat Long locations to Tile Coordinates

Structures

 | Structure | Description
Public structure | DbfFieldDesc | Describes a single field in a DBF file, including the name of the field, the DbfFieldType and the length of the field
Public structure | DbfFileHeader | Struct representing the contents of the main header of a DBF file. The main header stores version number, modification date, the number of fields in each record and a description of each field in a record. For a more detailed description of the main header of a DBF file refer to the DBF File Format techincal description
Public structure | LatLongCoordinate | struct used to store a Lat Long Coordinate. Used in ConversionFunctions
Public structure | PointD | Represents an ordered pair of double-precision floating-point x- and y-coordinates that defines a point in a two-dimensional plane.
Public structure | PolylineDistanceInfo | Encapsulates point from polyline distance information
Public structure | RectangleD | Stores a set of four double-precision floating-point numbers that represent the location and size of a rectangle.
Public structure | SizeD | Stores an ordered pair of double-precision floating-point numbers, typically the width and height of a rectangle.
Public structure | UtmCoordinate | struct used to store a UTM Coordinat. Used in ConversionFunctions

Interfaces

 | Interface | Description
Public interface | ICustomRenderSettings | The ICustomRenderSettings allows applying custom render settings to a shapefile layer
Public interface | IMapProjection |

Enumerations

 | Enumeration | Description
Public enumeration | DbfFieldType | Specifies the type of a field in a DBF file
Public enumeration | LineSegmentSide |
Public enumeration | LineType | Enumeration defining a LineType when rendering PolyLine ShapeFiles
Public enumeration | ProjectionType |
Public enumeration | RenderQuality | Enumeration to indicate render quality.
Public enumeration | ShapeFileEnumerator..::..IntersectionType | Defines how shapes will be evaluated when moving to the next record when enumerating through a shapefile. Intersects (the default) evaluates shapes that intersect with the Extent of the ShapeFileEnumerator. Contains evaluates shapes that fit entirely within the Extent of the ShapeFileEnumerator.
Public enumeration | ShapeType | Enumeration representing a ShapeType. Currently supported shape types are Point, PolyLine, Polygon and PolyLineM


ConversionFunctions Class

[image]

.NET Framework Class Library
ConversionFunctions Class
Members See Also Send Feedback

Utility class containing static methods to calculate the distance between points and convert projections

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class ConversionFunctions
C#
public sealed class ConversionFunctions
Visual C++
public ref class ConversionFunctions sealed
JavaScript
EGIS.ShapeFileLib.ConversionFunctions = function();

Type.createClass(
    'EGIS.ShapeFileLib.ConversionFunctions');

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..ConversionFunctions

See Also

ConversionFunctions Members
EGIS.ShapeFileLib Namespace


ConversionFunctions Members

[image] [image]

.NET Framework Class Library
ConversionFunctions Members
ConversionFunctions Class Methods Fields See Also Send Feedback

The ConversionFunctions type exposes the following members.

Methods

 | Name | Description
 | DistanceBetweenLatLongPoints(Int32, LatLongCoordinate, LatLongCoordinate) | returns the distance in meters between 2 lat/long double-precision points
 | DistanceBetweenLatLongPoints(Int32, Double, Double, Double, Double) | returns the distance in meters between 2 lat/long double-precision points
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDistance |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLongitude |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LLToUtm(Int32, Double, Double) |
 | LLToUtm(Double, Double, Double, Double, Double) |
 | LLToUtm2 |
 | LocationFromRangeBearing |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PseudoAmgToLL |
 | ToLL(PointF, Double, Double, Double, Double, Double, Ellipsoid) |
 | ToLL(PointF, Double, Double, Double, Double, Double, Double, Double) |
 | ToLL2 |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UtmToLL(Int32, UtmCoordinate) |
 | UtmToLL(Int32, Double, Double, Int32, Char) |

Fields

Name | Description
EllipseCollection |
RefEllipse |
Wgs66RefEllipsoid |

See Also

ConversionFunctions Class


ConversionFunctions Fields

[image] [image]

.NET Framework Class Library
ConversionFunctions Fields
ConversionFunctions Class See Also Send Feedback

The ConversionFunctions type exposes the following members.

Fields

Name | Description
EllipseCollection |
RefEllipse |
Wgs66RefEllipsoid |

See Also

ConversionFunctions Class


EllipseCollection Field

[image]

.NET Framework Class Library
ConversionFunctions..::..EllipseCollection Field
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared ReadOnly EllipseCollection As Ellipsoid()
C#
public static readonly Ellipsoid[] EllipseCollection
Visual C++
public:
static initonly array<Ellipsoid^>^ EllipseCollection
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.ellipseCollection

See Also

ConversionFunctions Class


RefEllipse Field

[image]

.NET Framework Class Library
ConversionFunctions..::..RefEllipse Field
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared RefEllipse As Integer
C#
public static int RefEllipse
Visual C++
public:
static int RefEllipse
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.refEllipse

See Also

ConversionFunctions Class


Wgs66RefEllipsoid Field

[image]

.NET Framework Class Library
ConversionFunctions..::..Wgs66RefEllipsoid Field
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Const Wgs66RefEllipsoid As Integer
C#
public const int Wgs66RefEllipsoid
Visual C++
public:
literal int Wgs66RefEllipsoid
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.wgs66RefEllipsoid

See Also

ConversionFunctions Class


ConversionFunctions Methods

[image] [image]

.NET Framework Class Library
ConversionFunctions Methods
ConversionFunctions Class See Also Send Feedback

The ConversionFunctions type exposes the following members.

Methods

 | Name | Description
 | DistanceBetweenLatLongPoints(Int32, LatLongCoordinate, LatLongCoordinate) | returns the distance in meters between 2 lat/long double-precision points
 | DistanceBetweenLatLongPoints(Int32, Double, Double, Double, Double) | returns the distance in meters between 2 lat/long double-precision points
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDistance |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLongitude |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LLToUtm(Int32, Double, Double) |
 | LLToUtm(Double, Double, Double, Double, Double) |
 | LLToUtm2 |
 | LocationFromRangeBearing |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PseudoAmgToLL |
 | ToLL(PointF, Double, Double, Double, Double, Double, Ellipsoid) |
 | ToLL(PointF, Double, Double, Double, Double, Double, Double, Double) |
 | ToLL2 |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UtmToLL(Int32, UtmCoordinate) |
 | UtmToLL(Int32, Double, Double, Int32, Char) |

See Also

ConversionFunctions Class


DistanceBetweenLatLongPoints Method

[image] [image]

.NET Framework Class Library
ConversionFunctions..::..DistanceBetweenLatLongPoints Method
ConversionFunctions Class See Also Send Feedback

Overload List

Name | Description
DistanceBetweenLatLongPoints(Int32, LatLongCoordinate, LatLongCoordinate) | returns the distance in meters between 2 lat/long double-precision points
DistanceBetweenLatLongPoints(Int32, Double, Double, Double, Double) | returns the distance in meters between 2 lat/long double-precision points

See Also

ConversionFunctions Class
ConversionFunctions Members


DistanceBetweenLatLongPoints Method (Int32, LatLongCoordinate, LatLongCoordinate)

[image]

.NET Framework Class Library
ConversionFunctions..::..DistanceBetweenLatLongPoints Method (Int32, LatLongCoordinate, LatLongCoordinate)
ConversionFunctions Class See Also Send Feedback

returns the distance in meters between 2 lat/long double-precision points

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function DistanceBetweenLatLongPoints ( _
    referenceEllipsoid As Integer, _
    origin As LatLongCoordinate, _
    destination As LatLongCoordinate _
) As Double
C#
public static double DistanceBetweenLatLongPoints(
    int referenceEllipsoid,
    LatLongCoordinate origin,
    LatLongCoordinate destination
)
Visual C++
public:
static double DistanceBetweenLatLongPoints(
    int referenceEllipsoid,
    LatLongCoordinate origin,
    LatLongCoordinate destination
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.distanceBetweenLatLongPoints = function(referenceEllipsoid, origin, destination);

Parameters

referenceEllipsoid
Type: System..::..Int32
origin
Type: EGIS.ShapeFileLib..::..LatLongCoordinate
destination
Type: EGIS.ShapeFileLib..::..LatLongCoordinate

Return Value

See Also

ConversionFunctions Class
DistanceBetweenLatLongPoints Overload


DistanceBetweenLatLongPoints Method (Int32, Double, Double, Double, Double)

[image]

.NET Framework Class Library
ConversionFunctions..::..DistanceBetweenLatLongPoints Method (Int32, Double, Double, Double, Double)
ConversionFunctions Class See Also Send Feedback

returns the distance in meters between 2 lat/long double-precision points

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function DistanceBetweenLatLongPoints ( _
    referenceEllipsoid As Integer, _
    latOrigin As Double, _
    longOrigin As Double, _
    latDestination As Double, _
    longDestination As Double _
) As Double
C#
public static double DistanceBetweenLatLongPoints(
    int referenceEllipsoid,
    double latOrigin,
    double longOrigin,
    double latDestination,
    double longDestination
)
Visual C++
public:
static double DistanceBetweenLatLongPoints(
    int referenceEllipsoid,
    double latOrigin,
    double longOrigin,
    double latDestination,
    double longDestination
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.distanceBetweenLatLongPoints = function(referenceEllipsoid, latOrigin, longOrigin, latDestination, longDestination);

Parameters

referenceEllipsoid
Type: System..::..Int32
latOrigin
Type: System..::..Double
longOrigin
Type: System..::..Double
latDestination
Type: System..::..Double
longDestination
Type: System..::..Double

Return Value

See Also

ConversionFunctions Class
DistanceBetweenLatLongPoints Overload


GetDistance Method

[image]

.NET Framework Class Library
ConversionFunctions..::..GetDistance Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function GetDistance ( _
    currentPosition As UtmCoordinate, _
    currentDestination As UtmCoordinate _
) As Double
C#
public static double GetDistance(
    UtmCoordinate currentPosition,
    UtmCoordinate currentDestination
)
Visual C++
public:
static double GetDistance(
    UtmCoordinate currentPosition,
    UtmCoordinate currentDestination
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.getDistance = function(currentPosition, currentDestination);

Parameters

currentPosition
Type: EGIS.ShapeFileLib..::..UtmCoordinate
currentDestination
Type: EGIS.ShapeFileLib..::..UtmCoordinate

See Also

ConversionFunctions Class


GetLongitude Method

[image]

.NET Framework Class Library
ConversionFunctions..::..GetLongitude Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function GetLongitude ( _
    longitudeToken As String, _
    direction As String _
) As Double
C#
public static double GetLongitude(
    string longitudeToken,
    string direction
)
Visual C++
public:
static double GetLongitude(
    String^ longitudeToken,
    String^ direction
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.getLongitude = function(longitudeToken, direction);

Parameters

longitudeToken
Type: System..::..String
direction
Type: System..::..String

See Also

ConversionFunctions Class


LLToUtm Method

[image] [image]

.NET Framework Class Library
ConversionFunctions..::..LLToUtm Method
ConversionFunctions Class See Also Send Feedback

Overload List

Name | Description
LLToUtm(Int32, Double, Double) |
LLToUtm(Double, Double, Double, Double, Double) |

See Also

ConversionFunctions Class
ConversionFunctions Members


LLToUtm Method (Int32, Double, Double)

[image]

.NET Framework Class Library
ConversionFunctions..::..LLToUtm Method (Int32, Double, Double)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLToUtm ( _
    referenceEllipsoid As Integer, _
    latitude As Double, _
    longitude As Double _
) As UtmCoordinate
C#
public static UtmCoordinate LLToUtm(
    int referenceEllipsoid,
    double latitude,
    double longitude
)
Visual C++
public:
static UtmCoordinate LLToUtm(
    int referenceEllipsoid,
    double latitude,
    double longitude
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.llToUtm = function(referenceEllipsoid, latitude, longitude);

Parameters

referenceEllipsoid
Type: System..::..Int32
latitude
Type: System..::..Double
longitude
Type: System..::..Double

See Also

ConversionFunctions Class
LLToUtm Overload


LLToUtm Method (Double, Double, Double, Double, Double)

[image]

.NET Framework Class Library
ConversionFunctions..::..LLToUtm Method (Double, Double, Double, Double, Double)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLToUtm ( _
    latitude As Double, _
    longitude As Double, _
    eqRadius As Double, _
    eccSquared As Double, _
    scaleFactor As Double _
) As PointF
C#
public static PointF LLToUtm(
    double latitude,
    double longitude,
    double eqRadius,
    double eccSquared,
    double scaleFactor
)
Visual C++
public:
static PointF LLToUtm(
    double latitude,
    double longitude,
    double eqRadius,
    double eccSquared,
    double scaleFactor
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.llToUtm = function(latitude, longitude, eqRadius, eccSquared, scaleFactor);

Parameters

latitude
Type: System..::..Double
longitude
Type: System..::..Double
eqRadius
Type: System..::..Double
eccSquared
Type: System..::..Double
scaleFactor
Type: System..::..Double

See Also

ConversionFunctions Class
LLToUtm Overload


LLToUtm2 Method

[image]

.NET Framework Class Library
ConversionFunctions..::..LLToUtm2 Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLToUtm2 ( _
    latitude As Double, _
    longitude As Double, _
    eqRadius As Double, _
    inverseFlattening As Double, _
    scaleFactor As Double _
) As PointF
C#
public static PointF LLToUtm2(
    double latitude,
    double longitude,
    double eqRadius,
    double inverseFlattening,
    double scaleFactor
)
Visual C++
public:
static PointF LLToUtm2(
    double latitude,
    double longitude,
    double eqRadius,
    double inverseFlattening,
    double scaleFactor
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.llToUtm2 = function(latitude, longitude, eqRadius, inverseFlattening, scaleFactor);

Parameters

latitude
Type: System..::..Double
longitude
Type: System..::..Double
eqRadius
Type: System..::..Double
inverseFlattening
Type: System..::..Double
scaleFactor
Type: System..::..Double

See Also

ConversionFunctions Class


LocationFromRangeBearing Method

[image]

.NET Framework Class Library
ConversionFunctions..::..LocationFromRangeBearing Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LocationFromRangeBearing ( _
    currentLocation As UtmCoordinate, _
    range As Double, _
    bearing As Double _
) As UtmCoordinate
C#
public static UtmCoordinate LocationFromRangeBearing(
    UtmCoordinate currentLocation,
    double range,
    double bearing
)
Visual C++
public:
static UtmCoordinate LocationFromRangeBearing(
    UtmCoordinate currentLocation,
    double range,
    double bearing
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.locationFromRangeBearing = function(currentLocation, range, bearing);

Parameters

currentLocation
Type: EGIS.ShapeFileLib..::..UtmCoordinate
range
Type: System..::..Double
bearing
Type: System..::..Double

See Also

ConversionFunctions Class


PseudoAmgToLL Method

[image]

.NET Framework Class Library
ConversionFunctions..::..PseudoAmgToLL Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PseudoAmgToLL ( _
    amgPoint As PointF _
) As PointF
C#
public static PointF PseudoAmgToLL(
    PointF amgPoint
)
Visual C++
public:
static PointF PseudoAmgToLL(
    PointF amgPoint
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.pseudoAmgToLL = function(amgPoint);

Parameters

amgPoint
Type: System.Drawing..::..PointF

See Also

ConversionFunctions Class


ToLL Method

[image] [image]

.NET Framework Class Library
ConversionFunctions..::..ToLL Method
ConversionFunctions Class See Also Send Feedback

Overload List

Name | Description
ToLL(PointF, Double, Double, Double, Double, Double, Ellipsoid) |
ToLL(PointF, Double, Double, Double, Double, Double, Double, Double) |

See Also

ConversionFunctions Class
ConversionFunctions Members


ToLL Method (PointF, Double, Double, Double, Double, Double, Ellipsoid)

[image]

.NET Framework Class Library
ConversionFunctions..::..ToLL Method (PointF, Double, Double, Double, Double, Double, Ellipsoid)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ToLL ( _
    inPoint As PointF, _
    centralMeridian As Double, _
    latOrigin As Double, _
    falseEasting As Double, _
    falseNorthing As Double, _
    scaleFactor As Double, _
    ellipsoid As Ellipsoid _
) As PointF
C#
public static PointF ToLL(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    Ellipsoid ellipsoid
)
Visual C++
public:
static PointF ToLL(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    Ellipsoid^ ellipsoid
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.toLL = function(inPoint, centralMeridian, latOrigin, falseEasting, falseNorthing, scaleFactor, ellipsoid);

Parameters

inPoint
Type: System.Drawing..::..PointF
centralMeridian
Type: System..::..Double
latOrigin
Type: System..::..Double
falseEasting
Type: System..::..Double
falseNorthing
Type: System..::..Double
scaleFactor
Type: System..::..Double
ellipsoid
Type: EGIS.ShapeFileLib..::..Ellipsoid

See Also

ConversionFunctions Class
ToLL Overload


ToLL Method (PointF, Double, Double, Double, Double, Double, Double, Double)

[image]

.NET Framework Class Library
ConversionFunctions..::..ToLL Method (PointF, Double, Double, Double, Double, Double, Double, Double)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ToLL ( _
    inPoint As PointF, _
    centralMeridian As Double, _
    latOrigin As Double, _
    falseEasting As Double, _
    falseNorthing As Double, _
    scaleFactor As Double, _
    equatorialRadius As Double, _
    eccSquared As Double _
) As PointF
C#
public static PointF ToLL(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    double equatorialRadius,
    double eccSquared
)
Visual C++
public:
static PointF ToLL(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    double equatorialRadius,
    double eccSquared
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.toLL = function(inPoint, centralMeridian, latOrigin, falseEasting, falseNorthing, scaleFactor, equatorialRadius, eccSquared);

Parameters

inPoint
Type: System.Drawing..::..PointF
centralMeridian
Type: System..::..Double
latOrigin
Type: System..::..Double
falseEasting
Type: System..::..Double
falseNorthing
Type: System..::..Double
scaleFactor
Type: System..::..Double
equatorialRadius
Type: System..::..Double
eccSquared
Type: System..::..Double

See Also

ConversionFunctions Class
ToLL Overload


ToLL2 Method

[image]

.NET Framework Class Library
ConversionFunctions..::..ToLL2 Method
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ToLL2 ( _
    inPoint As PointF, _
    centralMeridian As Double, _
    latOrigin As Double, _
    falseEasting As Double, _
    falseNorthing As Double, _
    scaleFactor As Double, _
    equatorialRadius As Double, _
    inverseFlattening As Double _
) As PointF
C#
public static PointF ToLL2(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    double equatorialRadius,
    double inverseFlattening
)
Visual C++
public:
static PointF ToLL2(
    PointF inPoint,
    double centralMeridian,
    double latOrigin,
    double falseEasting,
    double falseNorthing,
    double scaleFactor,
    double equatorialRadius,
    double inverseFlattening
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.toLL2 = function(inPoint, centralMeridian, latOrigin, falseEasting, falseNorthing, scaleFactor, equatorialRadius, inverseFlattening);

Parameters

inPoint
Type: System.Drawing..::..PointF
centralMeridian
Type: System..::..Double
latOrigin
Type: System..::..Double
falseEasting
Type: System..::..Double
falseNorthing
Type: System..::..Double
scaleFactor
Type: System..::..Double
equatorialRadius
Type: System..::..Double
inverseFlattening
Type: System..::..Double

See Also

ConversionFunctions Class


UtmToLL Method

[image] [image]

.NET Framework Class Library
ConversionFunctions..::..UtmToLL Method
ConversionFunctions Class See Also Send Feedback

Overload List

Name | Description
UtmToLL(Int32, UtmCoordinate) |
UtmToLL(Int32, Double, Double, Int32, Char) |

See Also

ConversionFunctions Class
ConversionFunctions Members


UtmToLL Method (Int32, UtmCoordinate)

[image]

.NET Framework Class Library
ConversionFunctions..::..UtmToLL Method (Int32, UtmCoordinate)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function UtmToLL ( _
    referenceEllipsoid As Integer, _
    position As UtmCoordinate _
) As LatLongCoordinate
C#
public static LatLongCoordinate UtmToLL(
    int referenceEllipsoid,
    UtmCoordinate position
)
Visual C++
public:
static LatLongCoordinate UtmToLL(
    int referenceEllipsoid,
    UtmCoordinate position
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.utmToLL = function(referenceEllipsoid, position);

Parameters

referenceEllipsoid
Type: System..::..Int32
position
Type: EGIS.ShapeFileLib..::..UtmCoordinate

See Also

ConversionFunctions Class
UtmToLL Overload


UtmToLL Method (Int32, Double, Double, Int32, Char)

[image]

.NET Framework Class Library
ConversionFunctions..::..UtmToLL Method (Int32, Double, Double, Int32, Char)
ConversionFunctions Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function UtmToLL ( _
    referenceEllipsoid As Integer, _
    utmNorthing As Double, _
    utmEasting As Double, _
    zone As Integer, _
    zoneIdentifier As Char _
) As LatLongCoordinate
C#
public static LatLongCoordinate UtmToLL(
    int referenceEllipsoid,
    double utmNorthing,
    double utmEasting,
    int zone,
    char zoneIdentifier
)
Visual C++
public:
static LatLongCoordinate UtmToLL(
    int referenceEllipsoid,
    double utmNorthing,
    double utmEasting,
    int zone,
    wchar_t zoneIdentifier
)
JavaScript
EGIS.ShapeFileLib.ConversionFunctions.utmToLL = function(referenceEllipsoid, utmNorthing, utmEasting, zone, zoneIdentifier);

Parameters

referenceEllipsoid
Type: System..::..Int32
utmNorthing
Type: System..::..Double
utmEasting
Type: System..::..Double
zone
Type: System..::..Int32
zoneIdentifier
Type: System..::..Char

See Also

ConversionFunctions Class
UtmToLL Overload


CustomRenderSettingsUtil Class

[image]

.NET Framework Class Library
CustomRenderSettingsUtil Class
Members See Also Send Feedback

Utility factory class which creates ICustomRenderSettings objects

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class CustomRenderSettingsUtil
C#
public class CustomRenderSettingsUtil
Visual C++
public ref class CustomRenderSettingsUtil
JavaScript
EGIS.ShapeFileLib.CustomRenderSettingsUtil = function();

Type.createClass(
    'EGIS.ShapeFileLib.CustomRenderSettingsUtil');

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..CustomRenderSettingsUtil

See Also

CustomRenderSettingsUtil Members


CustomRenderSettingsUtil Members

[image] [image]

.NET Framework Class Library
CustomRenderSettingsUtil Members
CustomRenderSettingsUtil Class Methods See Also Send Feedback

The CustomRenderSettingsUtil type exposes the following members.

Methods

 | Name | Description
 | CreateQuantileCustomRenderSettings | Creates an ICustomRenderSettings object which renders shape colors using quantiles
 | CreateRandomColorCustomRenderSettings | Creates an ICustomRenderSettings object which renders shapes with a random color
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomRenderSettingsUtil Class


CustomRenderSettingsUtil Methods

[image] [image]

.NET Framework Class Library
CustomRenderSettingsUtil Methods
CustomRenderSettingsUtil Class See Also Send Feedback

The CustomRenderSettingsUtil type exposes the following members.

Methods

 | Name | Description
 | CreateQuantileCustomRenderSettings | Creates an ICustomRenderSettings object which renders shape colors using quantiles
 | CreateRandomColorCustomRenderSettings | Creates an ICustomRenderSettings object which renders shapes with a random color
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomRenderSettingsUtil Class


CreateQuantileCustomRenderSettings Method

[image]

.NET Framework Class Library
CustomRenderSettingsUtil..::..CreateQuantileCustomRenderSettings Method
CustomRenderSettingsUtil Class See Also Send Feedback

Creates an ICustomRenderSettings object which renders shape colors using quantiles

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function CreateQuantileCustomRenderSettings ( _
    renderSettings As RenderSettings, _
    quantileColors As Color(), _
    shapeFieldName As String _
) As ICustomRenderSettings
C#
public static ICustomRenderSettings CreateQuantileCustomRenderSettings(
    RenderSettings renderSettings,
    Color[] quantileColors,
    string shapeFieldName
)
Visual C++
public:
static ICustomRenderSettings^ CreateQuantileCustomRenderSettings(
    RenderSettings^ renderSettings,
    array<Color>^ quantileColors,
    String^ shapeFieldName
)
JavaScript
EGIS.ShapeFileLib.CustomRenderSettingsUtil.createQuantileCustomRenderSettings = function(renderSettings, quantileColors, shapeFieldName);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
quantileColors
Type: array< System.Drawing..::..Color >[]()[][]
The colors used for each quantile. If 5 colors are used then 5 quantiles will be setup
shapeFieldName
Type: System..::..String
The field name to use for the quantiles

Return Value

Remarks

QuantileCustomRenderSettings are used to render individual shape colors in a shapefile layer according to a specified range of values. For example, the color of the rendered shape could be green if field1 is between 0 and 100, yellow if field 1 is between 100 and 200, or red if it is greater than 200.

See Also

CustomRenderSettingsUtil Class


CreateRandomColorCustomRenderSettings Method

[image]

.NET Framework Class Library
CustomRenderSettingsUtil..::..CreateRandomColorCustomRenderSettings Method
CustomRenderSettingsUtil Class See Also Send Feedback

Creates an ICustomRenderSettings object which renders shapes with a random color

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function CreateRandomColorCustomRenderSettings ( _
    renderSettings As RenderSettings, _
    seed As Integer _
) As ICustomRenderSettings
C#
public static ICustomRenderSettings CreateRandomColorCustomRenderSettings(
    RenderSettings renderSettings,
    int seed
)
Visual C++
public:
static ICustomRenderSettings^ CreateRandomColorCustomRenderSettings(
    RenderSettings^ renderSettings,
    int seed
)
JavaScript
EGIS.ShapeFileLib.CustomRenderSettingsUtil.createRandomColorCustomRenderSettings = function(renderSettings, seed);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
The shapefile's RenderSettings object
seed
Type: System..::..Int32
Random seed used to create the colors. By supplying a seed the same colors will be used when rendering the shapefile in successive drawing operations

Return Value

See Also

CustomRenderSettingsUtil Class


DbfFieldDesc Structure

[image]

.NET Framework Class Library
DbfFieldDesc Structure
Members See Also Send Feedback

Describes a single field in a DBF file, including the name of the field, the DbfFieldType and the length of the field

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Structure DbfFieldDesc
C#
public struct DbfFieldDesc
Visual C++
public value class DbfFieldDesc
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

DbfFieldDesc Members


DbfFieldDesc Members

[image] [image]

.NET Framework Class Library
DbfFieldDesc Members
DbfFieldDesc Structure Constructors Methods Properties See Also Send Feedback

The DbfFieldDesc type exposes the following members.

Constructors

 | Name | Description
Public method | DbfFieldDesc | Creates a DBFFieldDesc struct by reading from raw byte data. The contents of the raw byte data are as they would appear in the header of a DBF file

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the DbfFieldDesc (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | DecimalCount | Gets/Sets the decimal count for numeric data types.
Public property | FieldLength | The length of the field. Note that in a DBF file each record is a constant length (even if a record is an empty string)
Public property | FieldName | The name of the field. The maximum length of a field name is 10 characters
Public property | FieldType | The field type
Public property | RecordOffset | RecordOffset = the offset of the field in a record. For Field 0, RecordOffset = 0, For Field 1, RecordOffset = Length of Field 0, For Field N, RecordOffset = Length of Field0 to FieldN-1

See Also

DbfFieldDesc Structure


DbfFieldDesc Constructor

[image]

.NET Framework Class Library
DbfFieldDesc Constructor
DbfFieldDesc Structure See Also Send Feedback

Creates a DBFFieldDesc struct by reading from raw byte data. The contents of the raw byte data are as they would appear in the header of a DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    data As Byte(), _
    dataOffset As Integer, _
    recordOffset As Integer _
)
C#
public DbfFieldDesc(
    byte[] data,
    int dataOffset,
    int recordOffset
)
Visual C++
public:
DbfFieldDesc(
    array<unsigned char>^ data,
    int dataOffset,
    int recordOffset
)
JavaScript
EGIS.ShapeFileLib.DbfFieldDesc = function(data, dataOffset, recordOffset);

Parameters

data
Type: array< System..::..Byte >[]()[][]
a byte array containing the raw header data
dataOffset
Type: System..::..Int32
the zero based offset in the raw data from where to start reading
recordOffset
Type: System..::..Int32
the zero based offset of the Field within a record

See Also

DbfFieldDesc Structure


DbfFieldDesc Methods

[image] [image]

.NET Framework Class Library
DbfFieldDesc Methods
DbfFieldDesc Structure See Also Send Feedback

The DbfFieldDesc type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the DbfFieldDesc (Overrides ValueType..::..ToString()()()().)

See Also

DbfFieldDesc Structure


ToString Method

[image]

.NET Framework Class Library
DbfFieldDesc..::..ToString Method
DbfFieldDesc Structure See Also Send Feedback

Returns a string representation of the DbfFieldDesc

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

See Also

DbfFieldDesc Structure


DbfFieldDesc Properties

[image] [image]

.NET Framework Class Library
DbfFieldDesc Properties
DbfFieldDesc Structure See Also Send Feedback

The DbfFieldDesc type exposes the following members.

Properties

 | Name | Description
Public property | DecimalCount | Gets/Sets the decimal count for numeric data types.
Public property | FieldLength | The length of the field. Note that in a DBF file each record is a constant length (even if a record is an empty string)
Public property | FieldName | The name of the field. The maximum length of a field name is 10 characters
Public property | FieldType | The field type
Public property | RecordOffset | RecordOffset = the offset of the field in a record. For Field 0, RecordOffset = 0, For Field 1, RecordOffset = Length of Field 0, For Field N, RecordOffset = Length of Field0 to FieldN-1

See Also

DbfFieldDesc Structure


DecimalCount Property

[image]

.NET Framework Class Library
DbfFieldDesc..::..DecimalCount Property
DbfFieldDesc Structure See Also Send Feedback

Gets/Sets the decimal count for numeric data types.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property DecimalCount As Integer
    Get
    Set
C#
public int DecimalCount { get; set; }
Visual C++
public:
property int DecimalCount {
    int get ();
    void set (int value);
}
JavaScript
function get_decimalCount();
function set_decimalCount(value);

Remarks

DecimalCount must be >=0 and <16

See Also

DbfFieldDesc Structure


FieldLength Property

[image]

.NET Framework Class Library
DbfFieldDesc..::..FieldLength Property
DbfFieldDesc Structure See Also Send Feedback

The length of the field. Note that in a DBF file each record is a constant length (even if a record is an empty string)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FieldLength As Integer
    Get
    Set
C#
public int FieldLength { get; set; }
Visual C++
public:
property int FieldLength {
    int get ();
    void set (int value);
}
JavaScript
function get_fieldLength();
function set_fieldLength(value);

See Also

DbfFieldDesc Structure


FieldName Property

[image]

.NET Framework Class Library
DbfFieldDesc..::..FieldName Property
DbfFieldDesc Structure See Also Send Feedback

The name of the field. The maximum length of a field name is 10 characters

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FieldName As String
    Get
    Set
C#
public string FieldName { get; set; }
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fieldName();
function set_fieldName(value);

See Also

DbfFieldDesc Structure


FieldType Property

[image]

.NET Framework Class Library
DbfFieldDesc..::..FieldType Property
DbfFieldDesc Structure See Also Send Feedback

The field type

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FieldType As DbfFieldType
    Get
    Set
C#
public DbfFieldType FieldType { get; set; }
Visual C++
public:
property DbfFieldType FieldType {
    DbfFieldType get ();
    void set (DbfFieldType value);
}
JavaScript
function get_fieldType();
function set_fieldType(value);

See Also

DbfFieldDesc Structure


RecordOffset Property

[image]

.NET Framework Class Library
DbfFieldDesc..::..RecordOffset Property
DbfFieldDesc Structure See Also Send Feedback

RecordOffset = the offset of the field in a record. For Field 0, RecordOffset = 0, For Field 1, RecordOffset = Length of Field 0, For Field N, RecordOffset = Length of Field0 to FieldN-1

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property RecordOffset As Integer
    Get
    Set
C#
public int RecordOffset { get; set; }
Visual C++
public:
property int RecordOffset {
    int get ();
    void set (int value);
}
JavaScript
function get_recordOffset();
function set_recordOffset(value);

See Also

DbfFieldDesc Structure


DbfFieldType Enumeration

[image]

.NET Framework Class Library
DbfFieldType Enumeration
See Also Send Feedback

Specifies the type of a field in a DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration DbfFieldType
C#
public enum DbfFieldType
Visual C++
public enum class DbfFieldType
JavaScript
EGIS.ShapeFileLib.DbfFieldType = function();
EGIS.ShapeFileLib.DbfFieldType.createEnum('EGIS.ShapeFileLib.DbfFieldType', false);

Members

Member name | Description
Character |
Number |
Logical |
Date |
FloatingPoint |
Binary |
General |
None |

See Also


DbfFileHeader Structure

[image]

.NET Framework Class Library
DbfFileHeader Structure
Members See Also Send Feedback

Struct representing the contents of the main header of a DBF file. The main header stores version number, modification date, the number of fields in each record and a description of each field in a record. For a more detailed description of the main header of a DBF file refer to the DBF File Format techincal description

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Structure DbfFileHeader
C#
public struct DbfFileHeader
Visual C++
public value class DbfFileHeader
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

DbfFileHeader Members


DbfFileHeader Members

[image] [image]

.NET Framework Class Library
DbfFileHeader Members
DbfFileHeader Structure Methods Properties See Also Send Feedback

The DbfFileHeader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldDescriptions | Method to return an array of DbfFieldDesc structs, describing each field in a record
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream) | Reads the header contents from a stream
Public method | Read(array<Byte>[]()[][], Int32) | Reads the header contents from raw byte data
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Day |
Public property | FieldCount | The number of fields in each record
Public property | HeaderLength | The length of the main header
Public property | LDID | The DBF Language Driver Id
Public property | Month |
Public property | RecordCount | the number of records contained in the DBF file
Public property | RecordLength | The length of each record (in bytes) in the DBF file. Note that each record will have the same length.
Public property | VersionNumber | The DBF version number
Public property | Year |

See Also

DbfFileHeader Structure


DbfFileHeader Methods

[image] [image]

.NET Framework Class Library
DbfFileHeader Methods
DbfFileHeader Structure See Also Send Feedback

The DbfFileHeader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldDescriptions | Method to return an array of DbfFieldDesc structs, describing each field in a record
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream) | Reads the header contents from a stream
Public method | Read(array<Byte>[]()[][], Int32) | Reads the header contents from raw byte data
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

DbfFileHeader Structure


GetFieldDescriptions Method

[image]

.NET Framework Class Library
DbfFileHeader..::..GetFieldDescriptions Method
DbfFileHeader Structure See Also Send Feedback

Method to return an array of DbfFieldDesc structs, describing each field in a record

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetFieldDescriptions As DbfFieldDesc()
C#
public DbfFieldDesc[] GetFieldDescriptions()
Visual C++
public:
array<DbfFieldDesc>^ GetFieldDescriptions()
JavaScript
function getFieldDescriptions();

Return Value

See Also

DbfFileHeader Structure


Read Method

[image] [image]

.NET Framework Class Library
DbfFileHeader..::..Read Method
DbfFileHeader Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(Stream) | Reads the header contents from a stream
Public method | Read(array<Byte>[]()[][], Int32) | Reads the header contents from raw byte data

See Also

DbfFileHeader Structure
DbfFileHeader Members


Read Method (Stream)

[image]

.NET Framework Class Library
DbfFileHeader..::..Read Method (Stream)
DbfFileHeader Structure See Also Send Feedback

Reads the header contents from a stream

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Read ( _
    stream As Stream _
)
C#
public void Read(
    Stream stream
)
Visual C++
public:
void Read(
    Stream^ stream
)
JavaScript
function read(stream);

Parameters

stream
Type: System.IO..::..Stream

See Also

DbfFileHeader Structure
Read Overload


Read Method (Byte[], Int32)

[image]

.NET Framework Class Library
DbfFileHeader..::..Read Method (array<Byte>[]()[][], Int32)
DbfFileHeader Structure See Also Send Feedback

Reads the header contents from raw byte data

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Read ( _
    data As Byte(), _
    dataOffset As Integer _
)
C#
public void Read(
    byte[] data,
    int dataOffset
)
Visual C++
public:
void Read(
    array<unsigned char>^ data,
    int dataOffset
)
JavaScript
function read(data, dataOffset);

Parameters

data
Type: array< System..::..Byte >[]()[][]
byte array containing the header data
dataOffset
Type: System..::..Int32
offset in the data byte array containing the first byte of the header

See Also

DbfFileHeader Structure
Read Overload


ToString Method

[image]

.NET Framework Class Library
DbfFileHeader..::..ToString Method
DbfFileHeader Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

See Also

DbfFileHeader Structure


DbfFileHeader Properties

[image] [image]

.NET Framework Class Library
DbfFileHeader Properties
DbfFileHeader Structure See Also Send Feedback

The DbfFileHeader type exposes the following members.

Properties

 | Name | Description
Public property | Day |
Public property | FieldCount | The number of fields in each record
Public property | HeaderLength | The length of the main header
Public property | LDID | The DBF Language Driver Id
Public property | Month |
Public property | RecordCount | the number of records contained in the DBF file
Public property | RecordLength | The length of each record (in bytes) in the DBF file. Note that each record will have the same length.
Public property | VersionNumber | The DBF version number
Public property | Year |

See Also

DbfFileHeader Structure


Day Property

[image]

.NET Framework Class Library
DbfFileHeader..::..Day Property
DbfFileHeader Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Day As Byte
    Get
C#
public byte Day { get; }
Visual C++
public:
property unsigned char Day {
    unsigned char get ();
}
JavaScript
function get_day();

See Also

DbfFileHeader Structure


FieldCount Property

[image]

.NET Framework Class Library
DbfFileHeader..::..FieldCount Property
DbfFileHeader Structure See Also Send Feedback

The number of fields in each record

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property FieldCount As Integer
    Get
C#
public int FieldCount { get; }
Visual C++
public:
property int FieldCount {
    int get ();
}
JavaScript
function get_fieldCount();

See Also

DbfFileHeader Structure


HeaderLength Property

[image]

.NET Framework Class Library
DbfFileHeader..::..HeaderLength Property
DbfFileHeader Structure See Also Send Feedback

The length of the main header

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property HeaderLength As Short
    Get
C#
public short HeaderLength { get; }
Visual C++
public:
property short HeaderLength {
    short get ();
}
JavaScript
function get_headerLength();

See Also

DbfFileHeader Structure


LDID Property

[image]

.NET Framework Class Library
DbfFileHeader..::..LDID Property
DbfFileHeader Structure See Also Send Feedback

The DBF Language Driver Id

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property LDID As Integer
    Get
C#
public int LDID { get; }
Visual C++
public:
property int LDID {
    int get ();
}
JavaScript
function get_LDID();

Remarks

See http://downloads.esri.com/support/documentation/pad_/ArcPad_RefGuide_1105.pdf

See Also

DbfFileHeader Structure


Month Property

[image]

.NET Framework Class Library
DbfFileHeader..::..Month Property
DbfFileHeader Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Month As Byte
    Get
C#
public byte Month { get; }
Visual C++
public:
property unsigned char Month {
    unsigned char get ();
}
JavaScript
function get_month();

See Also

DbfFileHeader Structure


RecordCount Property

[image]

.NET Framework Class Library
DbfFileHeader..::..RecordCount Property
DbfFileHeader Structure See Also Send Feedback

the number of records contained in the DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordCount As Integer
    Get
C#
public int RecordCount { get; }
Visual C++
public:
property int RecordCount {
    int get ();
}
JavaScript
function get_recordCount();

See Also

DbfFileHeader Structure


RecordLength Property

[image]

.NET Framework Class Library
DbfFileHeader..::..RecordLength Property
DbfFileHeader Structure See Also Send Feedback

The length of each record (in bytes) in the DBF file. Note that each record will have the same length.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordLength As Short
    Get
C#
public short RecordLength { get; }
Visual C++
public:
property short RecordLength {
    short get ();
}
JavaScript
function get_recordLength();

See Also

DbfFileHeader Structure


VersionNumber Property

[image]

.NET Framework Class Library
DbfFileHeader..::..VersionNumber Property
DbfFileHeader Structure See Also Send Feedback

The DBF version number

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property VersionNumber As Byte
    Get
C#
public byte VersionNumber { get; }
Visual C++
public:
property unsigned char VersionNumber {
    unsigned char get ();
}
JavaScript
function get_versionNumber();

See Also

DbfFileHeader Structure


Year Property

[image]

.NET Framework Class Library
DbfFileHeader..::..Year Property
DbfFileHeader Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Year As Byte
    Get
C#
public byte Year { get; }
Visual C++
public:
property unsigned char Year {
    unsigned char get ();
}
JavaScript
function get_year();

See Also

DbfFileHeader Structure


DbfReader Class

[image]

.NET Framework Class Library
DbfReader Class
Members See Also Send Feedback

A DBF Reader class, providing direct access to record data within a DBF file, with low memory useage.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class DbfReader _
    Implements IDisposable
C#
public sealed class DbfReader : IDisposable
Visual C++
public ref class DbfReader sealed : IDisposable
JavaScript
EGIS.ShapeFileLib.DbfReader = function();

Type.createClass(
    'EGIS.ShapeFileLib.DbfReader',
    null,
    IDisposable);

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..DbfReader

See Also

DbfReader Members


DbfReader Members

[image] [image]

.NET Framework Class Library
DbfReader Members
DbfReader Class Constructors Methods Properties See Also Send Feedback

The DbfReader type exposes the following members.

Constructors

 | Name | Description
Public method | DbfReader | DbfReader constructor

Methods

 | Name | Description
Public method | Close | Closes the DbfReader. This method will close internal resources and should be called when you have finshed using the DbfReader. After this method has been called any attempt to read a field or record data from the DbfReader will throw an Exception
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistinctRecords | Gets an array of strings representing the distinct record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces
Public method | GetField | returns a string representing the field[fieldIndex] of the Record[recordNumber] in the dbf file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative, fieldIndex >= FieldCount or negative,
Public method | GetFieldNames | Utility method to return the names of the fields in the DBF file Internally extracts the field names from the DBFRecordHeader
Public method | GetFields | Gets an array of strings representing the fields of Record[recordNumber] in the DBF file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecords | Gets an array of strings representing all of the record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Obsolete.
Public method | IndexOfFieldName | returns the field index of fieldName. If a field with name fieldName does not exist the method will return -1
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DbfRecordHeader | Returns the DbfFileHeader representing the contents of the DBF file's main header
Public property | StringEncoding | Get/Sets the Encoding used to read string fields

See Also

DbfReader Class


DbfReader Constructor

[image]

.NET Framework Class Library
DbfReader Constructor
DbfReader Class See Also Send Feedback

DbfReader constructor

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    filePath As String _
)
C#
public DbfReader(
    string filePath
)
Visual C++
public:
DbfReader(
    String^ filePath
)
JavaScript
EGIS.ShapeFileLib.DbfReader = function(filePath);

Parameters

filePath
Type: System..::..String
The path to the DBF file. If the file extension contained in fileName is not included then ".dbf" will be appended to the file path before it is opened

See Also

DbfReader Class


DbfReader Methods

[image] [image]

.NET Framework Class Library
DbfReader Methods
DbfReader Class See Also Send Feedback

The DbfReader type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the DbfReader. This method will close internal resources and should be called when you have finshed using the DbfReader. After this method has been called any attempt to read a field or record data from the DbfReader will throw an Exception
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistinctRecords | Gets an array of strings representing the distinct record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces
Public method | GetField | returns a string representing the field[fieldIndex] of the Record[recordNumber] in the dbf file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative, fieldIndex >= FieldCount or negative,
Public method | GetFieldNames | Utility method to return the names of the fields in the DBF file Internally extracts the field names from the DBFRecordHeader
Public method | GetFields | Gets an array of strings representing the fields of Record[recordNumber] in the DBF file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecords | Gets an array of strings representing all of the record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Obsolete.
Public method | IndexOfFieldName | returns the field index of fieldName. If a field with name fieldName does not exist the method will return -1
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DbfReader Class


Close Method

[image]

.NET Framework Class Library
DbfReader..::..Close Method
DbfReader Class See Also Send Feedback

Closes the DbfReader. This method will close internal resources and should be called when you have finshed using the DbfReader. After this method has been called any attempt to read a field or record data from the DbfReader will throw an Exception

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

See Also

DbfReader Class


Dispose Method

[image]

.NET Framework Class Library
DbfReader..::..Dispose Method
DbfReader Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

DbfReader Class


GetDistinctRecords Method

[image]

.NET Framework Class Library
DbfReader..::..GetDistinctRecords Method
DbfReader Class See Also Send Feedback

Gets an array of strings representing the distinct record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetDistinctRecords ( _
    fieldIndex As Integer _
) As String()
C#
public string[] GetDistinctRecords(
    int fieldIndex
)
Visual C++
public:
array<String^>^ GetDistinctRecords(
    int fieldIndex
)
JavaScript
function getDistinctRecords(fieldIndex);

Parameters

fieldIndex
Type: System..::..Int32
Zero based index of the field in the DBF file

Return Value

See Also

DbfReader Class


GetField Method

[image]

.NET Framework Class Library
DbfReader..::..GetField Method
DbfReader Class See Also Send Feedback

returns a string representing the field[fieldIndex] of the Record[recordNumber] in the dbf file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative, fieldIndex >= FieldCount or negative,

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetField ( _
    recordNumber As Integer, _
    fieldIndex As Integer _
) As String
C#
public string GetField(
    int recordNumber,
    int fieldIndex
)
Visual C++
public:
String^ GetField(
    int recordNumber,
    int fieldIndex
)
JavaScript
function getField(recordNumber, fieldIndex);

Parameters

recordNumber
Type: System..::..Int32
Zero based record number in the dbf file
fieldIndex
Type: System..::..Int32
Zero based field index in a record

Return Value

the string contents of the required field. Note that the returned string is not trimmed so that if a field length is longer than the stored string then the string is padded with spaces. I.E if a field of length 10 is storing "abc" then the returned string will be padded with 7 space characters

See Also

DbfReader Class


GetFieldNames Method

[image]

.NET Framework Class Library
DbfReader..::..GetFieldNames Method
DbfReader Class See Also Send Feedback

Utility method to return the names of the fields in the DBF file Internally extracts the field names from the DBFRecordHeader

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetFieldNames As String()
C#
public string[] GetFieldNames()
Visual C++
public:
array<String^>^ GetFieldNames()
JavaScript
function getFieldNames();

Return Value

See Also

DbfReader Class


GetFields Method

[image]

.NET Framework Class Library
DbfReader..::..GetFields Method
DbfReader Class See Also Send Feedback

Gets an array of strings representing the fields of Record[recordNumber] in the DBF file Throws ArgumentException if recordNumber ">=" NumberOfRecords or negative

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetFields ( _
    recordNumber As Integer _
) As String()
C#
public string[] GetFields(
    int recordNumber
)
Visual C++
public:
array<String^>^ GetFields(
    int recordNumber
)
JavaScript
function getFields(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
Zero based record number in the dbfFile

Return Value

See Also

DbfReader Class


GetRecords Method

[image]

.NET Framework Class Library
DbfReader..::..GetRecords Method
DbfReader Class See Also Send Feedback

Gets an array of strings representing all of the record contents for a specified field. Each string in the returned array is trimmed to remove trailing spaces

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetRecords ( _
    fieldIndex As Integer _
) As String()
C#
public string[] GetRecords(
    int fieldIndex
)
Visual C++
public:
array<String^>^ GetRecords(
    int fieldIndex
)
JavaScript
function getRecords(fieldIndex);

Parameters

fieldIndex
Type: System..::..Int32
Zero based index of the field in the DBF file

Return Value

See Also

DbfReader Class


IndexOf Method

[image]

.NET Framework Class Library
DbfReader..::..IndexOf Method
DbfReader Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<ObsoleteAttribute("this method may be removed in future versions")> _
Public Function IndexOf ( _
    value As String, _
    fieldIndex As Integer, _
    ignoreCase As Boolean _
) As Integer
C#
[ObsoleteAttribute("this method may be removed in future versions")]
public int IndexOf(
    string value,
    int fieldIndex,
    bool ignoreCase
)
Visual C++
[ObsoleteAttribute(L"this method may be removed in future versions")]
public:
int IndexOf(
    String^ value,
    int fieldIndex,
    bool ignoreCase
)
JavaScript
function indexOf(value, fieldIndex, ignoreCase);

Parameters

value
Type: System..::..String
fieldIndex
Type: System..::..Int32
ignoreCase
Type: System..::..Boolean

See Also

DbfReader Class


IndexOfFieldName Method

[image]

.NET Framework Class Library
DbfReader..::..IndexOfFieldName Method
DbfReader Class See Also Send Feedback

returns the field index of fieldName. If a field with name fieldName does not exist the method will return -1

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function IndexOfFieldName ( _
    fieldName As String _
) As Integer
C#
public int IndexOfFieldName(
    string fieldName
)
Visual C++
public:
int IndexOfFieldName(
    String^ fieldName
)
JavaScript
function indexOfFieldName(fieldName);

Parameters

fieldName
Type: System..::..String

Return Value

See Also

DbfReader Class


DbfReader Properties

[image] [image]

.NET Framework Class Library
DbfReader Properties
DbfReader Class See Also Send Feedback

The DbfReader type exposes the following members.

Properties

 | Name | Description
Public property | DbfRecordHeader | Returns the DbfFileHeader representing the contents of the DBF file's main header
Public property | StringEncoding | Get/Sets the Encoding used to read string fields

See Also

DbfReader Class


DbfRecordHeader Property

[image]

.NET Framework Class Library
DbfReader..::..DbfRecordHeader Property
DbfReader Class See Also Send Feedback

Returns the DbfFileHeader representing the contents of the DBF file's main header

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property DbfRecordHeader As DbfFileHeader
    Get
C#
public DbfFileHeader DbfRecordHeader { get; }
Visual C++
public:
property DbfFileHeader DbfRecordHeader {
    DbfFileHeader get ();
}
JavaScript
function get_dbfRecordHeader();

See Also

DbfReader Class


StringEncoding Property

[image]

.NET Framework Class Library
DbfReader..::..StringEncoding Property
DbfReader Class See Also Send Feedback

Get/Sets the Encoding used to read string fields

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property StringEncoding As Encoding
    Get
    Set
C#
public Encoding StringEncoding { get; set; }
Visual C++
public:
property Encoding^ StringEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
JavaScript
function get_stringEncoding();
function set_stringEncoding(value);

See Also

DbfReader Class


DbfWriter Class

[image]

.NET Framework Class Library
DbfWriter Class
Members See Also Send Feedback

a DBF File Writer class

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class DbfWriter _
    Implements IDisposable
C#
public sealed class DbfWriter : IDisposable
Visual C++
public ref class DbfWriter sealed : IDisposable
JavaScript
EGIS.ShapeFileLib.DbfWriter = function();

Type.createClass(
    'EGIS.ShapeFileLib.DbfWriter',
    null,
    IDisposable);

Remarks

The DbfWriter class can be used to create or edit a DBF file

The class is used by the ShapeFileWriter class to create new shapefiles. The class can also be used in conjunction with a DbfReader to edit a DBF file by filtering required records or adding/removing new columns

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..DbfWriter

See Also

DbfWriter Members
EGIS.ShapeFileLib Namespace
EGIS.ShapeFileLib..::..DbfReader
EGIS.ShapeFileLib..::..ShapeFileWriter


DbfWriter Members

[image] [image]

.NET Framework Class Library
DbfWriter Members
DbfWriter Class Constructors Methods See Also Send Feedback

The DbfWriter type exposes the following members.

Constructors

 | Name | Description
Public method | DbfWriter | Creates a new DbfWriter

Methods

 | Name | Description
Public method | Close | Closes the DBF file and the underlying stream used to write the DBF file
Public method | Dispose | Releases all resources used by the DbfWriter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Adds a new reocrd to the DBF file

See Also

DbfWriter Class


DbfWriter Constructor

[image]

.NET Framework Class Library
DbfWriter Constructor
DbfWriter Class See Also Send Feedback

Creates a new DbfWriter

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    filePath As String, _
    dataFields As DbfFieldDesc() _
)
C#
public DbfWriter(
    string filePath,
    DbfFieldDesc[] dataFields
)
Visual C++
public:
DbfWriter(
    String^ filePath,
    array<DbfFieldDesc>^ dataFields
)
JavaScript
EGIS.ShapeFileLib.DbfWriter = function(filePath, dataFields);

Parameters

filePath
Type: System..::..String
The path to the new DBF file to be created. If filePath does not include the ".dbf" extension it will be added
dataFields
Type: array< EGIS.ShapeFileLib..::..DbfFieldDesc >[]()[][]
A DbfFieldDesc aray describing the field of the DBF file

See Also

DbfWriter Class


DbfWriter Methods

[image] [image]

.NET Framework Class Library
DbfWriter Methods
DbfWriter Class See Also Send Feedback

The DbfWriter type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the DBF file and the underlying stream used to write the DBF file
Public method | Dispose | Releases all resources used by the DbfWriter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Adds a new reocrd to the DBF file

See Also

DbfWriter Class


Close Method

[image]

.NET Framework Class Library
DbfWriter..::..Close Method
DbfWriter Class See Also Send Feedback

Closes the DBF file and the underlying stream used to write the DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

Remarks

The Close method must be called after all records have been added. This method will update the number of records in the file's main header and outputs the end of file marker to the end of the file.

Failure to call this method will result in an invalid DBF file being generated

See Also

DbfWriter Class


Dispose Method

[image]

.NET Framework Class Library
DbfWriter..::..Dispose Method
DbfWriter Class See Also Send Feedback

Releases all resources used by the DbfWriter

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

DbfWriter Class


WriteRecord Method

[image]

.NET Framework Class Library
DbfWriter..::..WriteRecord Method
DbfWriter Class See Also Send Feedback

Adds a new reocrd to the DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub WriteRecord ( _
    fieldData As String() _
)
C#
public void WriteRecord(
    string[] fieldData
)
Visual C++
public:
void WriteRecord(
    array<String^>^ fieldData
)
JavaScript
function writeRecord(fieldData);

Parameters

fieldData
Type: array< System..::..String >[]()[][]
strign array containing the data for each field in the record

See Also

DbfWriter Class


Ellipsoid Class

[image]

.NET Framework Class Library
Ellipsoid Class
Members See Also Send Feedback

Simple class that encapsulates the parameters defining an Ellipsoid

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class Ellipsoid
C#
public class Ellipsoid
Visual C++
public ref class Ellipsoid
JavaScript
EGIS.ShapeFileLib.Ellipsoid = function();

Type.createClass(
    'EGIS.ShapeFileLib.Ellipsoid');

Remarks

Note that in most SPHEROID parameters of the WKT format contained in a ".prj" projection file, the flattening is expressed as 1/f. For example, in SPHEROID["GRS_1980",6378137.0,298.257222101] 1/f = 298.257222101. 6378137.0 is the EquatorialRadius

See remarks on EccentricitySquared for explanation on how to convert "f" to "E^2"

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..Ellipsoid

See Also

Ellipsoid Members
EGIS.ShapeFileLib Namespace
Ellipsoid..::..EccentricitySquared
Ellipsoid..::..EquatorialRadius


Ellipsoid Members

[image] [image]

.NET Framework Class Library
Ellipsoid Members
Ellipsoid Class Constructors Methods Properties See Also Send Feedback

The Ellipsoid type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipsoid |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | EccentricitySquared | Eccentricity of the Ellipsoid squared
Public property | EllipsoidName | The well known name of the Ellipsoid
Public property | EquatorialRadius | The equatorial radius (semi-major axis) of the ellipsoid
Public property | Id | unique Id of the Ellipsoid
Public property | InverseFlattening |

See Also

Ellipsoid Class


Ellipsoid Constructor

[image]

.NET Framework Class Library
Ellipsoid Constructor
Ellipsoid Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    id As Integer, _
    name As String, _
    radius As Double, _
    ecc As Double _
)
C#
public Ellipsoid(
    int id,
    string name,
    double radius,
    double ecc
)
Visual C++
public:
Ellipsoid(
    int id,
    String^ name,
    double radius,
    double ecc
)
JavaScript
EGIS.ShapeFileLib.Ellipsoid = function(id, name, radius, ecc);

Parameters

id
Type: System..::..Int32
name
Type: System..::..String
radius
Type: System..::..Double
ecc
Type: System..::..Double

See Also

Ellipsoid Class


Ellipsoid Methods

[image] [image]

.NET Framework Class Library
Ellipsoid Methods
Ellipsoid Class See Also Send Feedback

The Ellipsoid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Ellipsoid Class


ToString Method

[image]

.NET Framework Class Library
Ellipsoid..::..ToString Method
Ellipsoid Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

Ellipsoid Class


Ellipsoid Properties

[image] [image]

.NET Framework Class Library
Ellipsoid Properties
Ellipsoid Class See Also Send Feedback

The Ellipsoid type exposes the following members.

Properties

 | Name | Description
Public property | EccentricitySquared | Eccentricity of the Ellipsoid squared
Public property | EllipsoidName | The well known name of the Ellipsoid
Public property | EquatorialRadius | The equatorial radius (semi-major axis) of the ellipsoid
Public property | Id | unique Id of the Ellipsoid
Public property | InverseFlattening |

See Also

Ellipsoid Class


EccentricitySquared Property

[image]

.NET Framework Class Library
Ellipsoid..::..EccentricitySquared Property
Ellipsoid Class See Also Send Feedback

Eccentricity of the Ellipsoid squared

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property EccentricitySquared As Double
    Get
    Set
C#
public double EccentricitySquared { get; set; }
Visual C++
public:
property double EccentricitySquared {
    double get ();
    void set (double value);
}
JavaScript
function get_eccentricitySquared();
function set_eccentricitySquared(value);

Remarks

E^2 is related to the flattening of the Ellipsoid as follows:

E^2 = 1 - (1-f)^2

Note that in most SPHEROID parameters of the WKT format the flattening is expressed as 1/f. For example, in SPHEROID["GRS_1980",6378137.0,298.257222101] 1/f = 298.257222101

See Also

Ellipsoid Class


EllipsoidName Property

[image]

.NET Framework Class Library
Ellipsoid..::..EllipsoidName Property
Ellipsoid Class See Also Send Feedback

The well known name of the Ellipsoid

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property EllipsoidName As String
    Get
    Set
C#
public string EllipsoidName { get; set; }
Visual C++
public:
property String^ EllipsoidName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ellipsoidName();
function set_ellipsoidName(value);

See Also

Ellipsoid Class


EquatorialRadius Property

[image]

.NET Framework Class Library
Ellipsoid..::..EquatorialRadius Property
Ellipsoid Class See Also Send Feedback

The equatorial radius (semi-major axis) of the ellipsoid

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property EquatorialRadius As Double
    Get
    Set
C#
public double EquatorialRadius { get; set; }
Visual C++
public:
property double EquatorialRadius {
    double get ();
    void set (double value);
}
JavaScript
function get_equatorialRadius();
function set_equatorialRadius(value);

See Also

Ellipsoid Class


Id Property

[image]

.NET Framework Class Library
Ellipsoid..::..Id Property
Ellipsoid Class See Also Send Feedback

unique Id of the Ellipsoid

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Id As Integer
    Get
    Set
C#
public int Id { get; set; }
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}
JavaScript
function get_id();
function set_id(value);

See Also

Ellipsoid Class


InverseFlattening Property

[image]

.NET Framework Class Library
Ellipsoid..::..InverseFlattening Property
Ellipsoid Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property InverseFlattening As Double
    Get
C#
public double InverseFlattening { get; }
Visual C++
public:
property double InverseFlattening {
    double get ();
}
JavaScript
function get_inverseFlattening();

See Also

Ellipsoid Class


GeometryAlgorithms Class

[image]

.NET Framework Class Library
GeometryAlgorithms Class
Members See Also Send Feedback

Collection of 2D Geometry algorithms

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class GeometryAlgorithms
C#
public class GeometryAlgorithms
Visual C++
public ref class GeometryAlgorithms
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms = function();

Type.createClass(
    'EGIS.ShapeFileLib.GeometryAlgorithms');

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..GeometryAlgorithms

See Also

GeometryAlgorithms Members


GeometryAlgorithms Members

[image] [image]

.NET Framework Class Library
GeometryAlgorithms Members
GeometryAlgorithms Class Methods See Also Send Feedback

The GeometryAlgorithms type exposes the following members.

Methods

 | Name | Description
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD) |
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |
 | Cross |
 | Distance |
 | DistanceToPolygon(array<PointD>[]()[][], PointD, Boolean) |
 | DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD) |
 | DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD, Boolean) |
 | Dot |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPolygonHole |
 | LineSegPointDist(PointD%, PointD%, PointD%) |
 | LineSegPointDist(PointD%, PointD%, PointD%, Double%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerpindicularVectorCCW |
 | PerpindicularVectorCW |
 | PointInPolygon(array<PointD>[]()[][], Double, Double) |
 | PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double) |
 | PointInPolygon(array<PointD>[]()[][], Double, Double, Boolean, Boolean%) | Tests whether point is inside a polygon
 | PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double, Boolean, Boolean%) |
 | PointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
 | PointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, Double) |
 | PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
 | PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double, Boolean) |
 | PolylineCircleIntersects |
 | RectangleCircleIntersects(RectangleF%, PointD%, Double) |
 | RectangleCircleIntersects(RectangleD%, PointD%, Double) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryAlgorithms Class


GeometryAlgorithms Methods

[image] [image]

.NET Framework Class Library
GeometryAlgorithms Methods
GeometryAlgorithms Class See Also Send Feedback

The GeometryAlgorithms type exposes the following members.

Methods

 | Name | Description
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD) |
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
 | ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |
 | ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |
 | Cross |
 | Distance |
 | DistanceToPolygon(array<PointD>[]()[][], PointD, Boolean) |
 | DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD) |
 | DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD, Boolean) |
 | Dot |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPolygonHole |
 | LineSegPointDist(PointD%, PointD%, PointD%) |
 | LineSegPointDist(PointD%, PointD%, PointD%, Double%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerpindicularVectorCCW |
 | PerpindicularVectorCW |
 | PointInPolygon(array<PointD>[]()[][], Double, Double) |
 | PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double) |
 | PointInPolygon(array<PointD>[]()[][], Double, Double, Boolean, Boolean%) | Tests whether point is inside a polygon
 | PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double, Boolean, Boolean%) |
 | PointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
 | PointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, Double) |
 | PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
 | PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double, Boolean) |
 | PolylineCircleIntersects |
 | RectangleCircleIntersects(RectangleF%, PointD%, Double) |
 | RectangleCircleIntersects(RectangleD%, PointD%, Double) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryAlgorithms Class


ClosestPointOnPolyline Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD) |
ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD) |
ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%) |
ClosestPointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |
ClosestPointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


ClosestPointOnPolyline Method (Byte[], Int32, Int32, PointD)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<Byte>[]()[][], Int32, Int32, PointD)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ClosestPointOnPolyline ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD _
) As Double
C#
public static double ClosestPointOnPolyline(
    byte[] data,
    int offset,
    int numPoints,
    PointD pt
)
Visual C++
public:
static double ClosestPointOnPolyline(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD pt
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(data, offset, numPoints, pt);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


ClosestPointOnPolyline Method (PointD[], Int32, Int32, PointD)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<PointD>[]()[][], Int32, Int32, PointD)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ClosestPointOnPolyline ( _
    points As PointD(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD _
) As Double
C#
public static double ClosestPointOnPolyline(
    PointD[] points,
    int offset,
    int numPoints,
    PointD pt
)
Visual C++
public:
static double ClosestPointOnPolyline(
    array<PointD>^ points,
    int offset,
    int numPoints,
    PointD pt
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(points, offset, numPoints, pt);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


ClosestPointOnPolyline Method (Byte[], Int32, Int32, PointD, PolylineDistanceInfo)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<Byte>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ClosestPointOnPolyline ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    <OutAttribute> ByRef polylineDistanceInfo As PolylineDistanceInfo _
) As Double
C#
public static double ClosestPointOnPolyline(
    byte[] data,
    int offset,
    int numPoints,
    PointD pt,
    out PolylineDistanceInfo polylineDistanceInfo
)
Visual C++
public:
static double ClosestPointOnPolyline(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD pt,
    [OutAttribute] PolylineDistanceInfo% polylineDistanceInfo
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(data, offset, numPoints, pt, polylineDistanceInfo);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
polylineDistanceInfo
Type: EGIS.ShapeFileLib..::..PolylineDistanceInfo %

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


ClosestPointOnPolyline Method (PointD[], Int32, Int32, PointD, PolylineDistanceInfo)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<PointD>[]()[][], Int32, Int32, PointD, PolylineDistanceInfo%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ClosestPointOnPolyline ( _
    points As PointD(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    <OutAttribute> ByRef polylineDistanceInfo As PolylineDistanceInfo _
) As Double
C#
public static double ClosestPointOnPolyline(
    PointD[] points,
    int offset,
    int numPoints,
    PointD pt,
    out PolylineDistanceInfo polylineDistanceInfo
)
Visual C++
public:
static double ClosestPointOnPolyline(
    array<PointD>^ points,
    int offset,
    int numPoints,
    PointD pt,
    [OutAttribute] PolylineDistanceInfo% polylineDistanceInfo
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(points, offset, numPoints, pt, polylineDistanceInfo);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
polylineDistanceInfo
Type: EGIS.ShapeFileLib..::..PolylineDistanceInfo %

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


ClosestPointOnPolyline Method (Byte[], Int32, Int32, PointD, PointD, Double, Int32, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<Byte>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Sub ClosestPointOnPolyline ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    <OutAttribute> ByRef closestPoint As PointD, _
    <OutAttribute> ByRef distance As Double, _
    <OutAttribute> ByRef segmentIndex As Integer, _
    <OutAttribute> ByRef tVal As Double _
)
C#
public static void ClosestPointOnPolyline(
    byte[] data,
    int offset,
    int numPoints,
    PointD pt,
    out PointD closestPoint,
    out double distance,
    out int segmentIndex,
    out double tVal
)
Visual C++
public:
static void ClosestPointOnPolyline(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD pt,
    [OutAttribute] PointD% closestPoint,
    [OutAttribute] double% distance,
    [OutAttribute] int% segmentIndex,
    [OutAttribute] double% tVal
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(data, offset, numPoints, pt, closestPoint, distance, segmentIndex, tVal);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
closestPoint
Type: EGIS.ShapeFileLib..::..PointD %
distance
Type: System..::..Double %
segmentIndex
Type: System..::..Int32 %
tVal
Type: System..::..Double %

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


ClosestPointOnPolyline Method (PointD[], Int32, Int32, PointD, PointD, Double, Int32, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..ClosestPointOnPolyline Method (array<PointD>[]()[][], Int32, Int32, PointD, PointD%, Double%, Int32%, Double%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Sub ClosestPointOnPolyline ( _
    points As PointD(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    <OutAttribute> ByRef closestPoint As PointD, _
    <OutAttribute> ByRef distance As Double, _
    <OutAttribute> ByRef segmentIndex As Integer, _
    <OutAttribute> ByRef tVal As Double _
)
C#
public static void ClosestPointOnPolyline(
    PointD[] points,
    int offset,
    int numPoints,
    PointD pt,
    out PointD closestPoint,
    out double distance,
    out int segmentIndex,
    out double tVal
)
Visual C++
public:
static void ClosestPointOnPolyline(
    array<PointD>^ points,
    int offset,
    int numPoints,
    PointD pt,
    [OutAttribute] PointD% closestPoint,
    [OutAttribute] double% distance,
    [OutAttribute] int% segmentIndex,
    [OutAttribute] double% tVal
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.closestPointOnPolyline = function(points, offset, numPoints, pt, closestPoint, distance, segmentIndex, tVal);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
closestPoint
Type: EGIS.ShapeFileLib..::..PointD %
distance
Type: System..::..Double %
segmentIndex
Type: System..::..Int32 %
tVal
Type: System..::..Double %

See Also

GeometryAlgorithms Class
ClosestPointOnPolyline Overload


Cross Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..Cross Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Cross ( _
    ByRef a As PointD, _
    ByRef b As PointD, _
    ByRef c As PointD _
) As Double
C#
public static double Cross(
    ref PointD a,
    ref PointD b,
    ref PointD c
)
Visual C++
public:
static double Cross(
    PointD% a,
    PointD% b,
    PointD% c
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.cross = function(a, b, c);

Parameters

a
Type: EGIS.ShapeFileLib..::..PointD %
b
Type: EGIS.ShapeFileLib..::..PointD %
c
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class


Distance Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..Distance Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Distance ( _
    ByRef a As PointD, _
    ByRef b As PointD _
) As Double
C#
public static double Distance(
    ref PointD a,
    ref PointD b
)
Visual C++
public:
static double Distance(
    PointD% a,
    PointD% b
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.distance = function(a, b);

Parameters

a
Type: EGIS.ShapeFileLib..::..PointD %
b
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class


DistanceToPolygon Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..DistanceToPolygon Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
DistanceToPolygon(array<PointD>[]()[][], PointD, Boolean) |
DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD) |
DistanceToPolygon(array<Byte>[]()[][], Int32, Int32, PointD, Boolean) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


DistanceToPolygon Method (PointD[], PointD, Boolean)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..DistanceToPolygon Method (array<PointD>[]()[][], PointD, Boolean)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function DistanceToPolygon ( _
    points As PointD(), _
    point As PointD, _
    ignoreHoles As Boolean _
) As Double
C#
public static double DistanceToPolygon(
    PointD[] points,
    PointD point,
    bool ignoreHoles
)
Visual C++
public:
static double DistanceToPolygon(
    array<PointD>^ points,
    PointD point,
    bool ignoreHoles
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.distanceToPolygon = function(points, point, ignoreHoles);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
point
Type: EGIS.ShapeFileLib..::..PointD
ignoreHoles
Type: System..::..Boolean

See Also

GeometryAlgorithms Class
DistanceToPolygon Overload


DistanceToPolygon Method (Byte[], Int32, Int32, PointD)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..DistanceToPolygon Method (array<Byte>[]()[][], Int32, Int32, PointD)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function DistanceToPolygon ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    point As PointD _
) As Double
C#
public static double DistanceToPolygon(
    byte[] data,
    int offset,
    int numPoints,
    PointD point
)
Visual C++
public:
static double DistanceToPolygon(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD point
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.distanceToPolygon = function(data, offset, numPoints, point);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
point
Type: EGIS.ShapeFileLib..::..PointD

See Also

GeometryAlgorithms Class
DistanceToPolygon Overload


DistanceToPolygon Method (Byte[], Int32, Int32, PointD, Boolean)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..DistanceToPolygon Method (array<Byte>[]()[][], Int32, Int32, PointD, Boolean)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function DistanceToPolygon ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    point As PointD, _
    ignoreHoles As Boolean _
) As Double
C#
public static double DistanceToPolygon(
    byte[] data,
    int offset,
    int numPoints,
    PointD point,
    bool ignoreHoles
)
Visual C++
public:
static double DistanceToPolygon(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD point,
    bool ignoreHoles
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.distanceToPolygon = function(data, offset, numPoints, point, ignoreHoles);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
point
Type: EGIS.ShapeFileLib..::..PointD
ignoreHoles
Type: System..::..Boolean

See Also

GeometryAlgorithms Class
DistanceToPolygon Overload


Dot Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..Dot Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Dot ( _
    ByRef a As PointD, _
    ByRef b As PointD, _
    ByRef c As PointD _
) As Double
C#
public static double Dot(
    ref PointD a,
    ref PointD b,
    ref PointD c
)
Visual C++
public:
static double Dot(
    PointD% a,
    PointD% b,
    PointD% c
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.dot = function(a, b, c);

Parameters

a
Type: EGIS.ShapeFileLib..::..PointD %
b
Type: EGIS.ShapeFileLib..::..PointD %
c
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class


IsPolygonHole Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..IsPolygonHole Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function IsPolygonHole ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer _
) As Boolean
C#
public static bool IsPolygonHole(
    byte[] data,
    int offset,
    int numPoints
)
Visual C++
public:
static bool IsPolygonHole(
    array<unsigned char>^ data,
    int offset,
    int numPoints
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.isPolygonHole = function(data, offset, numPoints);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32

See Also

GeometryAlgorithms Class


LineSegPointDist Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..LineSegPointDist Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
LineSegPointDist(PointD%, PointD%, PointD%) |
LineSegPointDist(PointD%, PointD%, PointD%, Double%, PointD%) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


LineSegPointDist Method (PointD, PointD, PointD)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..LineSegPointDist Method (PointD%, PointD%, PointD%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LineSegPointDist ( _
    ByRef a As PointD, _
    ByRef b As PointD, _
    ByRef c As PointD _
) As Double
C#
public static double LineSegPointDist(
    ref PointD a,
    ref PointD b,
    ref PointD c
)
Visual C++
public:
static double LineSegPointDist(
    PointD% a,
    PointD% b,
    PointD% c
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.lineSegPointDist = function(a, b, c);

Parameters

a
Type: EGIS.ShapeFileLib..::..PointD %
b
Type: EGIS.ShapeFileLib..::..PointD %
c
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class
LineSegPointDist Overload


LineSegPointDist Method (PointD, PointD, PointD, Double, PointD)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..LineSegPointDist Method (PointD%, PointD%, PointD%, Double%, PointD%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LineSegPointDist ( _
    ByRef a As PointD, _
    ByRef b As PointD, _
    ByRef c As PointD, _
    <OutAttribute> ByRef tVal As Double, _
    <OutAttribute> ByRef pointOnSegment As PointD _
) As Double
C#
public static double LineSegPointDist(
    ref PointD a,
    ref PointD b,
    ref PointD c,
    out double tVal,
    out PointD pointOnSegment
)
Visual C++
public:
static double LineSegPointDist(
    PointD% a,
    PointD% b,
    PointD% c,
    [OutAttribute] double% tVal,
    [OutAttribute] PointD% pointOnSegment
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.lineSegPointDist = function(a, b, c, tVal, pointOnSegment);

Parameters

a
Type: EGIS.ShapeFileLib..::..PointD %
b
Type: EGIS.ShapeFileLib..::..PointD %
c
Type: EGIS.ShapeFileLib..::..PointD %
tVal
Type: System..::..Double %
pointOnSegment
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class
LineSegPointDist Overload


PerpindicularVectorCCW Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PerpindicularVectorCCW Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PerpindicularVectorCCW ( _
    ByRef v As PointD _
) As PointD
C#
public static PointD PerpindicularVectorCCW(
    ref PointD v
)
Visual C++
public:
static PointD PerpindicularVectorCCW(
    PointD% v
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.perpindicularVectorCCW = function(v);

Parameters

v
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class


PerpindicularVectorCW Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PerpindicularVectorCW Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PerpindicularVectorCW ( _
    ByRef v As PointD _
) As PointD
C#
public static PointD PerpindicularVectorCW(
    ref PointD v
)
Visual C++
public:
static PointD PerpindicularVectorCW(
    PointD% v
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.perpindicularVectorCW = function(v);

Parameters

v
Type: EGIS.ShapeFileLib..::..PointD %

See Also

GeometryAlgorithms Class


PointInPolygon Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..PointInPolygon Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
PointInPolygon(array<PointD>[]()[][], Double, Double) |
PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double) |
PointInPolygon(array<PointD>[]()[][], Double, Double, Boolean, Boolean%) | Tests whether point is inside a polygon
PointInPolygon(array<Byte>[]()[][], Int32, Int32, Double, Double, Boolean, Boolean%) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


PointInPolygon Method (PointD[], Double, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointInPolygon Method (array<PointD>[]()[][], Double, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointInPolygon ( _
    points As PointD(), _
    x As Double, _
    y As Double _
) As Boolean
C#
public static bool PointInPolygon(
    PointD[] points,
    double x,
    double y
)
Visual C++
public:
static bool PointInPolygon(
    array<PointD>^ points,
    double x,
    double y
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointInPolygon = function(points, x, y);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
x
Type: System..::..Double
y
Type: System..::..Double

See Also

GeometryAlgorithms Class
PointInPolygon Overload


PointInPolygon Method (Byte[], Int32, Int32, Double, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointInPolygon Method (array<Byte>[]()[][], Int32, Int32, Double, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointInPolygon ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    x As Double, _
    y As Double _
) As Boolean
C#
public static bool PointInPolygon(
    byte[] data,
    int offset,
    int numPoints,
    double x,
    double y
)
Visual C++
public:
static bool PointInPolygon(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    double x,
    double y
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointInPolygon = function(data, offset, numPoints, x, y);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
x
Type: System..::..Double
y
Type: System..::..Double

See Also

GeometryAlgorithms Class
PointInPolygon Overload


PointInPolygon Method (PointD[], Double, Double, Boolean, Boolean)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointInPolygon Method (array<PointD>[]()[][], Double, Double, Boolean, Boolean%)
GeometryAlgorithms Class See Also Send Feedback

Tests whether point is inside a polygon

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointInPolygon ( _
    points As PointD(), _
    x As Double, _
    y As Double, _
    ignoreHoles As Boolean, _
    ByRef isHole As Boolean _
) As Boolean
C#
public static bool PointInPolygon(
    PointD[] points,
    double x,
    double y,
    bool ignoreHoles,
    ref bool isHole
)
Visual C++
public:
static bool PointInPolygon(
    array<PointD>^ points,
    double x,
    double y,
    bool ignoreHoles,
    bool% isHole
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointInPolygon = function(points, x, y, ignoreHoles, isHole);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
x
Type: System..::..Double
y
Type: System..::..Double
ignoreHoles
Type: System..::..Boolean
isHole
Type: System..::..Boolean %

Return Value

See Also

GeometryAlgorithms Class
PointInPolygon Overload


PointInPolygon Method (Byte[], Int32, Int32, Double, Double, Boolean, Boolean)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointInPolygon Method (array<Byte>[]()[][], Int32, Int32, Double, Double, Boolean, Boolean%)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointInPolygon ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    x As Double, _
    y As Double, _
    ignoreHoles As Boolean, _
    ByRef isHole As Boolean _
) As Boolean
C#
public static bool PointInPolygon(
    byte[] data,
    int offset,
    int numPoints,
    double x,
    double y,
    bool ignoreHoles,
    ref bool isHole
)
Visual C++
public:
static bool PointInPolygon(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    double x,
    double y,
    bool ignoreHoles,
    bool% isHole
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointInPolygon = function(data, offset, numPoints, x, y, ignoreHoles, isHole);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
x
Type: System..::..Double
y
Type: System..::..Double
ignoreHoles
Type: System..::..Boolean
isHole
Type: System..::..Boolean %

See Also

GeometryAlgorithms Class
PointInPolygon Overload


PointOnPolyline Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..PointOnPolyline Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
PointOnPolyline(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
PointOnPolyline(array<PointD>[]()[][], Int32, Int32, PointD, Double) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


PointOnPolyline Method (Byte[], Int32, Int32, PointD, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointOnPolyline Method (array<Byte>[]()[][], Int32, Int32, PointD, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointOnPolyline ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    minDist As Double _
) As Boolean
C#
public static bool PointOnPolyline(
    byte[] data,
    int offset,
    int numPoints,
    PointD pt,
    double minDist
)
Visual C++
public:
static bool PointOnPolyline(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD pt,
    double minDist
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointOnPolyline = function(data, offset, numPoints, pt, minDist);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
minDist
Type: System..::..Double

See Also

GeometryAlgorithms Class
PointOnPolyline Overload


PointOnPolyline Method (PointD[], Int32, Int32, PointD, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PointOnPolyline Method (array<PointD>[]()[][], Int32, Int32, PointD, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PointOnPolyline ( _
    points As PointD(), _
    offset As Integer, _
    numPoints As Integer, _
    pt As PointD, _
    minDist As Double _
) As Boolean
C#
public static bool PointOnPolyline(
    PointD[] points,
    int offset,
    int numPoints,
    PointD pt,
    double minDist
)
Visual C++
public:
static bool PointOnPolyline(
    array<PointD>^ points,
    int offset,
    int numPoints,
    PointD pt,
    double minDist
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.pointOnPolyline = function(points, offset, numPoints, pt, minDist);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
pt
Type: EGIS.ShapeFileLib..::..PointD
minDist
Type: System..::..Double

See Also

GeometryAlgorithms Class
PointOnPolyline Overload


PolygonCircleIntersects Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..PolygonCircleIntersects Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double) |
PolygonCircleIntersects(array<Byte>[]()[][], Int32, Int32, PointD, Double, Boolean) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


PolygonCircleIntersects Method (Byte[], Int32, Int32, PointD, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PolygonCircleIntersects Method (array<Byte>[]()[][], Int32, Int32, PointD, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PolygonCircleIntersects ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    centre As PointD, _
    radius As Double _
) As Boolean
C#
public static bool PolygonCircleIntersects(
    byte[] data,
    int offset,
    int numPoints,
    PointD centre,
    double radius
)
Visual C++
public:
static bool PolygonCircleIntersects(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD centre,
    double radius
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.polygonCircleIntersects = function(data, offset, numPoints, centre, radius);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double

See Also

GeometryAlgorithms Class
PolygonCircleIntersects Overload


PolygonCircleIntersects Method (Byte[], Int32, Int32, PointD, Double, Boolean)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PolygonCircleIntersects Method (array<Byte>[]()[][], Int32, Int32, PointD, Double, Boolean)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PolygonCircleIntersects ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    centre As PointD, _
    radius As Double, _
    ignoreHoles As Boolean _
) As Boolean
C#
public static bool PolygonCircleIntersects(
    byte[] data,
    int offset,
    int numPoints,
    PointD centre,
    double radius,
    bool ignoreHoles
)
Visual C++
public:
static bool PolygonCircleIntersects(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD centre,
    double radius,
    bool ignoreHoles
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.polygonCircleIntersects = function(data, offset, numPoints, centre, radius, ignoreHoles);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double
ignoreHoles
Type: System..::..Boolean

Return Value

Remarks

Not tested

See Also

GeometryAlgorithms Class
PolygonCircleIntersects Overload


PolylineCircleIntersects Method

[image]

.NET Framework Class Library
GeometryAlgorithms..::..PolylineCircleIntersects Method
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PolylineCircleIntersects ( _
    data As Byte(), _
    offset As Integer, _
    numPoints As Integer, _
    centre As PointD, _
    radius As Double _
) As Boolean
C#
public static bool PolylineCircleIntersects(
    byte[] data,
    int offset,
    int numPoints,
    PointD centre,
    double radius
)
Visual C++
public:
static bool PolylineCircleIntersects(
    array<unsigned char>^ data,
    int offset,
    int numPoints,
    PointD centre,
    double radius
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.polylineCircleIntersects = function(data, offset, numPoints, centre, radius);

Parameters

data
Type: array< System..::..Byte >[]()[][]
offset
Type: System..::..Int32
numPoints
Type: System..::..Int32
centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double

Return Value

Remarks

Not tested

See Also

GeometryAlgorithms Class


RectangleCircleIntersects Method

[image] [image]

.NET Framework Class Library
GeometryAlgorithms..::..RectangleCircleIntersects Method
GeometryAlgorithms Class See Also Send Feedback

Overload List

Name | Description
RectangleCircleIntersects(RectangleF%, PointD%, Double) |
RectangleCircleIntersects(RectangleD%, PointD%, Double) |

See Also

GeometryAlgorithms Class
GeometryAlgorithms Members


RectangleCircleIntersects Method (RectangleF, PointD, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..RectangleCircleIntersects Method (RectangleF%, PointD%, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function RectangleCircleIntersects ( _
    ByRef r As RectangleF, _
    ByRef centre As PointD, _
    radius As Double _
) As Boolean
C#
public static bool RectangleCircleIntersects(
    ref RectangleF r,
    ref PointD centre,
    double radius
)
Visual C++
public:
static bool RectangleCircleIntersects(
    RectangleF% r,
    PointD% centre,
    double radius
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.rectangleCircleIntersects = function(r, centre, radius);

Parameters

r
Type: System.Drawing..::..RectangleF %
centre
Type: EGIS.ShapeFileLib..::..PointD %
radius
Type: System..::..Double

See Also

GeometryAlgorithms Class
RectangleCircleIntersects Overload


RectangleCircleIntersects Method (RectangleD, PointD, Double)

[image]

.NET Framework Class Library
GeometryAlgorithms..::..RectangleCircleIntersects Method (RectangleD%, PointD%, Double)
GeometryAlgorithms Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function RectangleCircleIntersects ( _
    ByRef r As RectangleD, _
    ByRef centre As PointD, _
    radius As Double _
) As Boolean
C#
public static bool RectangleCircleIntersects(
    ref RectangleD r,
    ref PointD centre,
    double radius
)
Visual C++
public:
static bool RectangleCircleIntersects(
    RectangleD% r,
    PointD% centre,
    double radius
)
JavaScript
EGIS.ShapeFileLib.GeometryAlgorithms.rectangleCircleIntersects = function(r, centre, radius);

Parameters

r
Type: EGIS.ShapeFileLib..::..RectangleD %
centre
Type: EGIS.ShapeFileLib..::..PointD %
radius
Type: System..::..Double

Return Value

Remarks

This method is untested

See Also

GeometryAlgorithms Class
RectangleCircleIntersects Overload


ICustomRenderSettings Interface

[image]

.NET Framework Class Library
ICustomRenderSettings Interface
Members See Also Send Feedback

The ICustomRenderSettings allows applying custom render settings to a shapefile layer

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Interface ICustomRenderSettings
C#
public interface ICustomRenderSettings
Visual C++
public interface class ICustomRenderSettings
JavaScript
EGIS.ShapeFileLib.ICustomRenderSettings = function();
EGIS.ShapeFileLib.ICustomRenderSettings.createInterface('EGIS.ShapeFileLib.ICustomRenderSettings');

Remarks

By setting an ICustomRenderSettings object on a shapefile's RenderSettings, you can gain full control over whether indivdual shapes should be rendered and the color to use when rendering the shapes. The ICustomRenderSettings interface also supplies methods to customize any tooltips used by the shapefile layer.

See Also

ICustomRenderSettings Members
EGIS.ShapeFileLib..::..RenderSettings


ICustomRenderSettings Members

[image] [image]

.NET Framework Class Library
ICustomRenderSettings Members
ICustomRenderSettings Interface Methods Properties See Also Send Feedback

The ICustomRenderSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetRecordFillColor | Returns the FillColor to use when rendering the specified shape
Public method | GetRecordFontColor | Returns the Font Color to use when labelling the specified shape
Public method | GetRecordImageSymbol | returns the custom image symbol for the specified symbol.
Public method | GetRecordOutlineColor | Returns the OutlineColor to use when rendering the specified shape
Public method | GetRecordToolTip | returns the custom tooltip string for the specified shape
Public method | RenderShape | Returns whether to render the specified shape

Properties

 | Name | Description
Public property | UseCustomImageSymbols | returns whether custom Image Symbols should be used for shapes. Applys to Point type shapefiles only
Public property | UseCustomTooltips | returns whether to use custom tooltips

See Also

ICustomRenderSettings Interface


ICustomRenderSettings Methods

[image] [image]

.NET Framework Class Library
ICustomRenderSettings Methods
ICustomRenderSettings Interface See Also Send Feedback

The ICustomRenderSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetRecordFillColor | Returns the FillColor to use when rendering the specified shape
Public method | GetRecordFontColor | Returns the Font Color to use when labelling the specified shape
Public method | GetRecordImageSymbol | returns the custom image symbol for the specified symbol.
Public method | GetRecordOutlineColor | Returns the OutlineColor to use when rendering the specified shape
Public method | GetRecordToolTip | returns the custom tooltip string for the specified shape
Public method | RenderShape | Returns whether to render the specified shape

See Also

ICustomRenderSettings Interface


GetRecordFillColor Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..GetRecordFillColor Method
ICustomRenderSettings Interface See Also Send Feedback

Returns the FillColor to use when rendering the specified shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function GetRecordFillColor ( _
    recordNumber As Integer _
) As Color
C#
Color GetRecordFillColor(
    int recordNumber
)
Visual C++
Color GetRecordFillColor(
    int recordNumber
)
JavaScript
function getRecordFillColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

See Also

ICustomRenderSettings Interface


GetRecordFontColor Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..GetRecordFontColor Method
ICustomRenderSettings Interface See Also Send Feedback

Returns the Font Color to use when labelling the specified shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function GetRecordFontColor ( _
    recordNumber As Integer _
) As Color
C#
Color GetRecordFontColor(
    int recordNumber
)
Visual C++
Color GetRecordFontColor(
    int recordNumber
)
JavaScript
function getRecordFontColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

See Also

ICustomRenderSettings Interface


GetRecordImageSymbol Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..GetRecordImageSymbol Method
ICustomRenderSettings Interface See Also Send Feedback

returns the custom image symbol for the specified symbol.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function GetRecordImageSymbol ( _
    recordNumber As Integer _
) As Image
C#
Image GetRecordImageSymbol(
    int recordNumber
)
Visual C++
Image^ GetRecordImageSymbol(
    int recordNumber
)
JavaScript
function getRecordImageSymbol(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

Remarks

Implementing classes must ensure that a valid image is returned when this method is called. If a null Image is returned then an error will occur when the shapefile is rendered

See Also

ICustomRenderSettings Interface


GetRecordOutlineColor Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..GetRecordOutlineColor Method
ICustomRenderSettings Interface See Also Send Feedback

Returns the OutlineColor to use when rendering the specified shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function GetRecordOutlineColor ( _
    recordNumber As Integer _
) As Color
C#
Color GetRecordOutlineColor(
    int recordNumber
)
Visual C++
Color GetRecordOutlineColor(
    int recordNumber
)
JavaScript
function getRecordOutlineColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

See Also

ICustomRenderSettings Interface


GetRecordToolTip Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..GetRecordToolTip Method
ICustomRenderSettings Interface See Also Send Feedback

returns the custom tooltip string for the specified shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function GetRecordToolTip ( _
    recordNumber As Integer _
) As String
C#
string GetRecordToolTip(
    int recordNumber
)
Visual C++
String^ GetRecordToolTip(
    int recordNumber
)
JavaScript
function getRecordToolTip(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

See Also

ICustomRenderSettings Interface


RenderShape Method

[image]

.NET Framework Class Library
ICustomRenderSettings..::..RenderShape Method
ICustomRenderSettings Interface See Also Send Feedback

Returns whether to render the specified shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function RenderShape ( _
    recordNumber As Integer _
) As Boolean
C#
bool RenderShape(
    int recordNumber
)
Visual C++
bool RenderShape(
    int recordNumber
)
JavaScript
function renderShape(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero-based record number of the shape

Return Value

See Also

ICustomRenderSettings Interface


ICustomRenderSettings Properties

[image] [image]

.NET Framework Class Library
ICustomRenderSettings Properties
ICustomRenderSettings Interface See Also Send Feedback

The ICustomRenderSettings type exposes the following members.

Properties

 | Name | Description
Public property | UseCustomImageSymbols | returns whether custom Image Symbols should be used for shapes. Applys to Point type shapefiles only
Public property | UseCustomTooltips | returns whether to use custom tooltips

See Also

ICustomRenderSettings Interface


UseCustomImageSymbols Property

[image]

.NET Framework Class Library
ICustomRenderSettings..::..UseCustomImageSymbols Property
ICustomRenderSettings Interface See Also Send Feedback

returns whether custom Image Symbols should be used for shapes. Applys to Point type shapefiles only

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
ReadOnly Property UseCustomImageSymbols As Boolean
    Get
C#
bool UseCustomImageSymbols { get; }
Visual C++
property bool UseCustomImageSymbols {
    bool get ();
}
JavaScript
function get_useCustomImageSymbols();

See Also

ICustomRenderSettings Interface


UseCustomTooltips Property

[image]

.NET Framework Class Library
ICustomRenderSettings..::..UseCustomTooltips Property
ICustomRenderSettings Interface See Also Send Feedback

returns whether to use custom tooltips

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
ReadOnly Property UseCustomTooltips As Boolean
    Get
C#
bool UseCustomTooltips { get; }
Visual C++
property bool UseCustomTooltips {
    bool get ();
}
JavaScript
function get_useCustomTooltips();

See Also

ICustomRenderSettings Interface


IMapProjection Interface

[image]

.NET Framework Class Library
IMapProjection Interface
Members See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Interface IMapProjection
C#
public interface IMapProjection
Visual C++
public interface class IMapProjection
JavaScript
EGIS.ShapeFileLib.IMapProjection = function();
EGIS.ShapeFileLib.IMapProjection.createInterface('EGIS.ShapeFileLib.IMapProjection');

See Also

IMapProjection Members


IMapProjection Members

[image] [image]

.NET Framework Class Library
IMapProjection Members
IMapProjection Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |

See Also

IMapProjection Interface


IMapProjection Methods

[image] [image]

.NET Framework Class Library
IMapProjection Methods
IMapProjection Interface See Also Send Feedback

Methods

 | Name | Description
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |

See Also

IMapProjection Interface


LatLongtoProjection Method

[image] [image]

.NET Framework Class Library
IMapProjection..::..LatLongtoProjection Method
IMapProjection Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |

See Also

IMapProjection Interface
IMapProjection Members


LatLongtoProjection Method (PointD)

[image]

.NET Framework Class Library
IMapProjection..::..LatLongtoProjection Method (PointD)
IMapProjection Interface See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function LatLongtoProjection ( _
    pt As PointD _
) As PointD
C#
PointD LatLongtoProjection(
    PointD pt
)
Visual C++
PointD LatLongtoProjection(
    PointD pt
)
JavaScript
function latLongtoProjection(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

See Also

IMapProjection Interface
LatLongtoProjection Overload


LatLongtoProjection Method (PointD, PointD)

[image]

.NET Framework Class Library
IMapProjection..::..LatLongtoProjection Method (PointD%, PointD%)
IMapProjection Interface See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Sub LatLongtoProjection ( _
    ByRef ptLL As PointD, _
    ByRef ptProj As PointD _
)
C#
void LatLongtoProjection(
    ref PointD ptLL,
    ref PointD ptProj
)
Visual C++
void LatLongtoProjection(
    PointD% ptLL,
    PointD% ptProj
)
JavaScript
function latLongtoProjection(ptLL, ptProj);

Parameters

ptLL
Type: EGIS.ShapeFileLib..::..PointD %
ptProj
Type: EGIS.ShapeFileLib..::..PointD %

See Also

IMapProjection Interface
LatLongtoProjection Overload


ProjectionToLatLong Method

[image] [image]

.NET Framework Class Library
IMapProjection..::..ProjectionToLatLong Method
IMapProjection Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |

See Also

IMapProjection Interface
IMapProjection Members


ProjectionToLatLong Method (PointD)

[image]

.NET Framework Class Library
IMapProjection..::..ProjectionToLatLong Method (PointD)
IMapProjection Interface See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Function ProjectionToLatLong ( _
    pt As PointD _
) As PointD
C#
PointD ProjectionToLatLong(
    PointD pt
)
Visual C++
PointD ProjectionToLatLong(
    PointD pt
)
JavaScript
function projectionToLatLong(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

See Also

IMapProjection Interface
ProjectionToLatLong Overload


ProjectionToLatLong Method (PointD, PointD)

[image]

.NET Framework Class Library
IMapProjection..::..ProjectionToLatLong Method (PointD%, PointD%)
IMapProjection Interface See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Sub ProjectionToLatLong ( _
    ByRef ptProj As PointD, _
    ByRef ptLL As PointD _
)
C#
void ProjectionToLatLong(
    ref PointD ptProj,
    ref PointD ptLL
)
Visual C++
void ProjectionToLatLong(
    PointD% ptProj,
    PointD% ptLL
)
JavaScript
function projectionToLatLong(ptProj, ptLL);

Parameters

ptProj
Type: EGIS.ShapeFileLib..::..PointD %
ptLL
Type: EGIS.ShapeFileLib..::..PointD %

See Also

IMapProjection Interface
ProjectionToLatLong Overload


LatLongCoordinate Structure

[image]

.NET Framework Class Library
LatLongCoordinate Structure
Members See Also Send Feedback

struct used to store a Lat Long Coordinate. Used in ConversionFunctions

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Structure LatLongCoordinate
C#
public struct LatLongCoordinate
Visual C++
public value class LatLongCoordinate
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

LatLongCoordinate Members
EGIS.ShapeFileLib..::..ConversionFunctions


LatLongCoordinate Members

[image] [image]

.NET Framework Class Library
LatLongCoordinate Members
LatLongCoordinate Structure Methods Properties See Also Send Feedback

The LatLongCoordinate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Latitude |
Public property | Longitude |

See Also

LatLongCoordinate Structure


LatLongCoordinate Methods

[image] [image]

.NET Framework Class Library
LatLongCoordinate Methods
LatLongCoordinate Structure See Also Send Feedback

The LatLongCoordinate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

LatLongCoordinate Structure


ToString Method

[image]

.NET Framework Class Library
LatLongCoordinate..::..ToString Method
LatLongCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

LatLongCoordinate Structure


LatLongCoordinate Properties

[image] [image]

.NET Framework Class Library
LatLongCoordinate Properties
LatLongCoordinate Structure See Also Send Feedback

The LatLongCoordinate type exposes the following members.

Properties

 | Name | Description
Public property | Latitude |
Public property | Longitude |

See Also

LatLongCoordinate Structure


Latitude Property

[image]

.NET Framework Class Library
LatLongCoordinate..::..Latitude Property
LatLongCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Latitude As Double
    Get
    Set
C#
public double Latitude { get; set; }
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}
JavaScript
function get_latitude();
function set_latitude(value);

See Also

LatLongCoordinate Structure


Longitude Property

[image]

.NET Framework Class Library
LatLongCoordinate..::..Longitude Property
LatLongCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Longitude As Double
    Get
    Set
C#
public double Longitude { get; set; }
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}
JavaScript
function get_longitude();
function set_longitude(value);

See Also

LatLongCoordinate Structure


LatLongProjection Class

[image]

.NET Framework Class Library
LatLongProjection Class
Members See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class LatLongProjection _
    Implements IMapProjection
C#
public class LatLongProjection : IMapProjection
Visual C++
public ref class LatLongProjection : IMapProjection
JavaScript
EGIS.ShapeFileLib.LatLongProjection = function();

Type.createClass(
    'EGIS.ShapeFileLib.LatLongProjection',
    null,
    EGIS.ShapeFileLib.IMapProjection);

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..LatLongProjection

See Also

LatLongProjection Members


LatLongProjection Members

[image] [image]

.NET Framework Class Library
LatLongProjection Members
LatLongProjection Class Constructors Methods See Also Send Feedback

The LatLongProjection type exposes the following members.

Constructors

 | Name | Description
Public method | LatLongProjection |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatLongProjection Class


LatLongProjection Constructor

[image]

.NET Framework Class Library
LatLongProjection Constructor
LatLongProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New
C#
public LatLongProjection()
Visual C++
public:
LatLongProjection()
JavaScript
EGIS.ShapeFileLib.LatLongProjection = function();

See Also

LatLongProjection Class


LatLongProjection Methods

[image] [image]

.NET Framework Class Library
LatLongProjection Methods
LatLongProjection Class See Also Send Feedback

The LatLongProjection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatLongProjection Class


LatLongtoProjection Method

[image] [image]

.NET Framework Class Library
LatLongProjection..::..LatLongtoProjection Method
LatLongProjection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |

See Also

LatLongProjection Class
LatLongProjection Members


LatLongtoProjection Method (PointD)

[image]

.NET Framework Class Library
LatLongProjection..::..LatLongtoProjection Method (PointD)
LatLongProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function LatLongtoProjection ( _
    pt As PointD _
) As PointD
C#
public PointD LatLongtoProjection(
    PointD pt
)
Visual C++
public:
virtual PointD LatLongtoProjection(
    PointD pt
) sealed
JavaScript
function latLongtoProjection(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Implements

IMapProjection..::..LatLongtoProjection(PointD)

See Also

LatLongProjection Class
LatLongtoProjection Overload


LatLongtoProjection Method (PointD, PointD)

[image]

.NET Framework Class Library
LatLongProjection..::..LatLongtoProjection Method (PointD%, PointD%)
LatLongProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub LatLongtoProjection ( _
    ByRef ptLL As PointD, _
    ByRef ptProj As PointD _
)
C#
public void LatLongtoProjection(
    ref PointD ptLL,
    ref PointD ptProj
)
Visual C++
public:
virtual void LatLongtoProjection(
    PointD% ptLL,
    PointD% ptProj
) sealed
JavaScript
function latLongtoProjection(ptLL, ptProj);

Parameters

ptLL
Type: EGIS.ShapeFileLib..::..PointD %
ptProj
Type: EGIS.ShapeFileLib..::..PointD %

Implements

IMapProjection..::..LatLongtoProjection(PointD%, PointD%)

See Also

LatLongProjection Class
LatLongtoProjection Overload


ProjectionToLatLong Method

[image] [image]

.NET Framework Class Library
LatLongProjection..::..ProjectionToLatLong Method
LatLongProjection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |

See Also

LatLongProjection Class
LatLongProjection Members


ProjectionToLatLong Method (PointD)

[image]

.NET Framework Class Library
LatLongProjection..::..ProjectionToLatLong Method (PointD)
LatLongProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function ProjectionToLatLong ( _
    pt As PointD _
) As PointD
C#
public PointD ProjectionToLatLong(
    PointD pt
)
Visual C++
public:
virtual PointD ProjectionToLatLong(
    PointD pt
) sealed
JavaScript
function projectionToLatLong(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Implements

IMapProjection..::..ProjectionToLatLong(PointD)

See Also

LatLongProjection Class
ProjectionToLatLong Overload


ProjectionToLatLong Method (PointD, PointD)

[image]

.NET Framework Class Library
LatLongProjection..::..ProjectionToLatLong Method (PointD%, PointD%)
LatLongProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub ProjectionToLatLong ( _
    ByRef ptProj As PointD, _
    ByRef ptLL As PointD _
)
C#
public void ProjectionToLatLong(
    ref PointD ptProj,
    ref PointD ptLL
)
Visual C++
public:
virtual void ProjectionToLatLong(
    PointD% ptProj,
    PointD% ptLL
) sealed
JavaScript
function projectionToLatLong(ptProj, ptLL);

Parameters

ptProj
Type: EGIS.ShapeFileLib..::..PointD %
ptLL
Type: EGIS.ShapeFileLib..::..PointD %

Implements

IMapProjection..::..ProjectionToLatLong(PointD%, PointD%)

See Also

LatLongProjection Class
ProjectionToLatLong Overload


LineSegmentSide Enumeration

[image]

.NET Framework Class Library
LineSegmentSide Enumeration
See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration LineSegmentSide
C#
public enum LineSegmentSide
Visual C++
public enum class LineSegmentSide
JavaScript
EGIS.ShapeFileLib.LineSegmentSide = function();
EGIS.ShapeFileLib.LineSegmentSide.createEnum('EGIS.ShapeFileLib.LineSegmentSide', false);

Members

Member name | Description
None |
OnSegment |
StartOfSegment |
LeftOfSegment |
RightOfSegment |
EndOfSegment |

See Also


LineType Enumeration

[image]

.NET Framework Class Library
LineType Enumeration
See Also Send Feedback

Enumeration defining a LineType when rendering PolyLine ShapeFiles

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration LineType
C#
public enum LineType
Visual C++
public enum class LineType
JavaScript
EGIS.ShapeFileLib.LineType = function();
EGIS.ShapeFileLib.LineType.createEnum('EGIS.ShapeFileLib.LineType', false);

Members

Member name | Description
Solid |
Outline |
Railway |

See Also


MapProjectionCreator Class

[image]

.NET Framework Class Library
MapProjectionCreator Class
Members See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class MapProjectionCreator
C#
public class MapProjectionCreator
Visual C++
public ref class MapProjectionCreator
JavaScript
EGIS.ShapeFileLib.MapProjectionCreator = function();

Type.createClass(
    'EGIS.ShapeFileLib.MapProjectionCreator');

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..MapProjectionCreator

See Also

MapProjectionCreator Members


MapProjectionCreator Members

[image] [image]

.NET Framework Class Library
MapProjectionCreator Members
MapProjectionCreator Class Constructors Methods See Also Send Feedback

The MapProjectionCreator type exposes the following members.

Constructors

 | Name | Description
Public method | MapProjectionCreator |

Methods

 | Name | Description
 | CreateMapProjection |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapProjectionCreator Class


MapProjectionCreator Constructor

[image]

.NET Framework Class Library
MapProjectionCreator Constructor
MapProjectionCreator Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New
C#
public MapProjectionCreator()
Visual C++
public:
MapProjectionCreator()
JavaScript
EGIS.ShapeFileLib.MapProjectionCreator = function();

See Also

MapProjectionCreator Class


MapProjectionCreator Methods

[image] [image]

.NET Framework Class Library
MapProjectionCreator Methods
MapProjectionCreator Class See Also Send Feedback

The MapProjectionCreator type exposes the following members.

Methods

 | Name | Description
 | CreateMapProjection |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapProjectionCreator Class


CreateMapProjection Method

[image]

.NET Framework Class Library
MapProjectionCreator..::..CreateMapProjection Method
MapProjectionCreator Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function CreateMapProjection ( _
    projectionType As ProjectionType _
) As IMapProjection
C#
public static IMapProjection CreateMapProjection(
    ProjectionType projectionType
)
Visual C++
public:
static IMapProjection^ CreateMapProjection(
    ProjectionType projectionType
)
JavaScript
EGIS.ShapeFileLib.MapProjectionCreator.createMapProjection = function(projectionType);

Parameters

projectionType
Type: EGIS.ShapeFileLib..::..ProjectionType

See Also

MapProjectionCreator Class


MercatorProjection Class

[image]

.NET Framework Class Library
MercatorProjection Class
Members See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class MercatorProjection _
    Implements IMapProjection
C#
public class MercatorProjection : IMapProjection
Visual C++
public ref class MercatorProjection : IMapProjection
JavaScript
EGIS.ShapeFileLib.MercatorProjection = function();

Type.createClass(
    'EGIS.ShapeFileLib.MercatorProjection',
    null,
    EGIS.ShapeFileLib.IMapProjection);

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..MercatorProjection

See Also

MercatorProjection Members


MercatorProjection Members

[image] [image]

.NET Framework Class Library
MercatorProjection Members
MercatorProjection Class Constructors Methods See Also Send Feedback

The MercatorProjection type exposes the following members.

Constructors

 | Name | Description
Public method | MercatorProjection |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MercatorProjection Class


MercatorProjection Constructor

[image]

.NET Framework Class Library
MercatorProjection Constructor
MercatorProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New
C#
public MercatorProjection()
Visual C++
public:
MercatorProjection()
JavaScript
EGIS.ShapeFileLib.MercatorProjection = function();

See Also

MercatorProjection Class


MercatorProjection Methods

[image] [image]

.NET Framework Class Library
MercatorProjection Methods
MercatorProjection Class See Also Send Feedback

The MercatorProjection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MercatorProjection Class


LatLongtoProjection Method

[image] [image]

.NET Framework Class Library
MercatorProjection..::..LatLongtoProjection Method
MercatorProjection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LatLongtoProjection(PointD) |
Public method | LatLongtoProjection(PointD%, PointD%) |

See Also

MercatorProjection Class
MercatorProjection Members


LatLongtoProjection Method (PointD)

[image]

.NET Framework Class Library
MercatorProjection..::..LatLongtoProjection Method (PointD)
MercatorProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function LatLongtoProjection ( _
    pt As PointD _
) As PointD
C#
public PointD LatLongtoProjection(
    PointD pt
)
Visual C++
public:
virtual PointD LatLongtoProjection(
    PointD pt
) sealed
JavaScript
function latLongtoProjection(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Implements

IMapProjection..::..LatLongtoProjection(PointD)

See Also

MercatorProjection Class
LatLongtoProjection Overload


LatLongtoProjection Method (PointD, PointD)

[image]

.NET Framework Class Library
MercatorProjection..::..LatLongtoProjection Method (PointD%, PointD%)
MercatorProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub LatLongtoProjection ( _
    ByRef ptLL As PointD, _
    ByRef ptProj As PointD _
)
C#
public void LatLongtoProjection(
    ref PointD ptLL,
    ref PointD ptProj
)
Visual C++
public:
virtual void LatLongtoProjection(
    PointD% ptLL,
    PointD% ptProj
) sealed
JavaScript
function latLongtoProjection(ptLL, ptProj);

Parameters

ptLL
Type: EGIS.ShapeFileLib..::..PointD %
ptProj
Type: EGIS.ShapeFileLib..::..PointD %

Implements

IMapProjection..::..LatLongtoProjection(PointD%, PointD%)

See Also

MercatorProjection Class
LatLongtoProjection Overload


ProjectionToLatLong Method

[image] [image]

.NET Framework Class Library
MercatorProjection..::..ProjectionToLatLong Method
MercatorProjection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProjectionToLatLong(PointD) |
Public method | ProjectionToLatLong(PointD%, PointD%) |

See Also

MercatorProjection Class
MercatorProjection Members


ProjectionToLatLong Method (PointD)

[image]

.NET Framework Class Library
MercatorProjection..::..ProjectionToLatLong Method (PointD)
MercatorProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function ProjectionToLatLong ( _
    pt As PointD _
) As PointD
C#
public PointD ProjectionToLatLong(
    PointD pt
)
Visual C++
public:
virtual PointD ProjectionToLatLong(
    PointD pt
) sealed
JavaScript
function projectionToLatLong(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Implements

IMapProjection..::..ProjectionToLatLong(PointD)

See Also

MercatorProjection Class
ProjectionToLatLong Overload


ProjectionToLatLong Method (PointD, PointD)

[image]

.NET Framework Class Library
MercatorProjection..::..ProjectionToLatLong Method (PointD%, PointD%)
MercatorProjection Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub ProjectionToLatLong ( _
    ByRef ptProj As PointD, _
    ByRef ptLL As PointD _
)
C#
public void ProjectionToLatLong(
    ref PointD ptProj,
    ref PointD ptLL
)
Visual C++
public:
virtual void ProjectionToLatLong(
    PointD% ptProj,
    PointD% ptLL
) sealed
JavaScript
function projectionToLatLong(ptProj, ptLL);

Parameters

ptProj
Type: EGIS.ShapeFileLib..::..PointD %
ptLL
Type: EGIS.ShapeFileLib..::..PointD %

Implements

IMapProjection..::..ProjectionToLatLong(PointD%, PointD%)

See Also

MercatorProjection Class
ProjectionToLatLong Overload


PointD Structure

[image]

.NET Framework Class Library
PointD Structure
Members See Also Send Feedback

Represents an ordered pair of double-precision floating-point x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<SerializableAttribute> _
<ComVisibleAttribute(True)> _
Public Structure PointD
C#
[SerializableAttribute]
[ComVisibleAttribute(true)]
public struct PointD
Visual C++
[SerializableAttribute]
[ComVisibleAttribute(true)]
public value class PointD
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

Remarks

This structure is essentially the same as the System.Drawing.PointD structure but uses double-precision floating point numbers, which are needed for accuracy in GIS applications

See Also

PointD Members


PointD Members

[image] [image]

.NET Framework Class Library
PointD Members
PointD Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The PointD type exposes the following members.

Constructors

 | Name | Description
Public method | PointD | Initializes a new instance of the PointD class with the specified coordinates.

Methods

 | Name | Description
 | Add(PointD, SizeD) | Translates a given PointD by a specified SizeD.
 | Add(PointD, Size) | Translates a given PointD by the specified Size.
 | Add(PointD, SizeF) | Translates a given PointD by a specified SizeF.
Public method | Equals | Specifies whether this PointD contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this PointD structure. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subtract(PointD, SizeD) | Translates a PointD by the negative of a specified size.
 | Subtract(PointD, Size) | Translates a PointD by the negative of a specified size.
 | Subtract(PointD, SizeF) | Translates a PointD by the negative of a specified size.
Public method | ToString | Converts this PointD to a human readable string. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Addition(PointD, SizeD) | Translates a PointD by a given Size.
Addition(PointD, Size) | Translates a PointD by a given Size.
Addition(PointD, SizeF) | Translates the PointD by the specified SizeF.
Equality | Compares two PointD structures. The result specifies whether the values of the X()()()() and Y()()()() properties of the two PointD structures are equal.
ImplicitWideningImplicitImplicitImplicit(PointF to PointD) | converts a PointF structure to a PointD structure
Inequality | Determines whether the coordinates of the specified points are not equal.
Subtraction(PointD, SizeD) | Translates a PointD by the negative of a given SizeD.
Subtraction(PointD, Size) | Translates a PointD by the negative of a given Size.
Subtraction(PointD, SizeF) | Translates a PointD by the negative of a specified SizeF.

Fields

Name | Description
Empty | Represents a new instance of the PointD class with member data left uninitialized.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this PointD is empty.
Public property | X | Gets or sets the x-coordinate of this PointD.
Public property | Y | Gets or sets the y-coordinate of this PointD.

See Also

PointD Structure


PointD Constructor

[image]

.NET Framework Class Library
PointD Constructor
PointD Structure See Also Send Feedback

Initializes a new instance of the PointD class with the specified coordinates.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double _
)
C#
public PointD(
    double x,
    double y
)
Visual C++
public:
PointD(
    double x,
    double y
)
JavaScript
EGIS.ShapeFileLib.PointD = function(x, y);

Parameters

x
Type: System..::..Double
The horizontal position of the point.
y
Type: System..::..Double
The vertical position of the point.

See Also

PointD Structure


PointD Fields

[image] [image]

.NET Framework Class Library
PointD Fields
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Fields

Name | Description
Empty | Represents a new instance of the PointD class with member data left uninitialized.

See Also

PointD Structure


Empty Field

[image]

.NET Framework Class Library
PointD..::..Empty Field
PointD Structure See Also Send Feedback

Represents a new instance of the PointD class with member data left uninitialized.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared ReadOnly Empty As PointD
C#
public static readonly PointD Empty
Visual C++
public:
static initonly PointD Empty
JavaScript
EGIS.ShapeFileLib.PointD.empty

See Also

PointD Structure


PointD Methods

[image] [image]

.NET Framework Class Library
PointD Methods
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Methods

 | Name | Description
 | Add(PointD, SizeD) | Translates a given PointD by a specified SizeD.
 | Add(PointD, Size) | Translates a given PointD by the specified Size.
 | Add(PointD, SizeF) | Translates a given PointD by a specified SizeF.
Public method | Equals | Specifies whether this PointD contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this PointD structure. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subtract(PointD, SizeD) | Translates a PointD by the negative of a specified size.
 | Subtract(PointD, Size) | Translates a PointD by the negative of a specified size.
 | Subtract(PointD, SizeF) | Translates a PointD by the negative of a specified size.
Public method | ToString | Converts this PointD to a human readable string. (Overrides ValueType..::..ToString()()()().)

See Also

PointD Structure


Add Method

[image] [image]

.NET Framework Class Library
PointD..::..Add Method
PointD Structure See Also Send Feedback

Overload List

Name | Description
Add(PointD, SizeD) | Translates a given PointD by a specified SizeD.
Add(PointD, Size) | Translates a given PointD by the specified Size.
Add(PointD, SizeF) | Translates a given PointD by a specified SizeF.

See Also

PointD Structure
PointD Members


Add Method (PointD, SizeD)

[image]

.NET Framework Class Library
PointD..::..Add Method (PointD, SizeD)
PointD Structure See Also Send Feedback

Translates a given PointD by a specified SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Add ( _
    pt As PointD, _
    sz As SizeD _
) As PointD
C#
public static PointD Add(
    PointD pt,
    SizeD sz
)
Visual C++
public:
static PointD Add(
    PointD pt,
    SizeD sz
)
JavaScript
EGIS.ShapeFileLib.PointD.add = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD that specifies the numbers to add to the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Add Overload


Add Method (PointD, Size)

[image]

.NET Framework Class Library
PointD..::..Add Method (PointD, Size)
PointD Structure See Also Send Feedback

Translates a given PointD by the specified Size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Add ( _
    pt As PointD, _
    sz As Size _
) As PointD
C#
public static PointD Add(
    PointD pt,
    Size sz
)
Visual C++
public:
static PointD Add(
    PointD pt,
    Size sz
)
JavaScript
EGIS.ShapeFileLib.PointD.add = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..Size
The Size that specifies the numbers to add to the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Add Overload


Add Method (PointD, SizeF)

[image]

.NET Framework Class Library
PointD..::..Add Method (PointD, SizeF)
PointD Structure See Also Send Feedback

Translates a given PointD by a specified SizeF.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Add ( _
    pt As PointD, _
    sz As SizeF _
) As PointD
C#
public static PointD Add(
    PointD pt,
    SizeF sz
)
Visual C++
public:
static PointD Add(
    PointD pt,
    SizeF sz
)
JavaScript
EGIS.ShapeFileLib.PointD.add = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..SizeF
The SizeF that specifies the numbers to add to the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Add Overload


Equals Method

[image]

.NET Framework Class Library
PointD..::..Equals Method
PointD Structure See Also Send Feedback

Specifies whether this PointD contains the same coordinates as the specified Object.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object
The Object to test.

Return Value

This method returns true if obj is a PointD and has the same coordinates as this Point.

See Also

PointD Structure


GetHashCode Method

[image]

.NET Framework Class Library
PointD..::..GetHashCode Method
PointD Structure See Also Send Feedback

Returns a hash code for this PointD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

Return Value

An integer value that specifies a hash value for this PointD structure.

See Also

PointD Structure


Subtract Method

[image] [image]

.NET Framework Class Library
PointD..::..Subtract Method
PointD Structure See Also Send Feedback

Overload List

Name | Description
Subtract(PointD, SizeD) | Translates a PointD by the negative of a specified size.
Subtract(PointD, Size) | Translates a PointD by the negative of a specified size.
Subtract(PointD, SizeF) | Translates a PointD by the negative of a specified size.

See Also

PointD Structure
PointD Members


Subtract Method (PointD, SizeD)

[image]

.NET Framework Class Library
PointD..::..Subtract Method (PointD, SizeD)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a specified size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Subtract ( _
    pt As PointD, _
    sz As SizeD _
) As PointD
C#
public static PointD Subtract(
    PointD pt,
    SizeD sz
)
Visual C++
public:
static PointD Subtract(
    PointD pt,
    SizeD sz
)
JavaScript
EGIS.ShapeFileLib.PointD.subtract = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD that specifies the numbers to subtract from the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Subtract Overload


Subtract Method (PointD, Size)

[image]

.NET Framework Class Library
PointD..::..Subtract Method (PointD, Size)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a specified size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Subtract ( _
    pt As PointD, _
    sz As Size _
) As PointD
C#
public static PointD Subtract(
    PointD pt,
    Size sz
)
Visual C++
public:
static PointD Subtract(
    PointD pt,
    Size sz
)
JavaScript
EGIS.ShapeFileLib.PointD.subtract = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..Size
The Size that specifies the numbers to subtract from the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Subtract Overload


Subtract Method (PointD, SizeF)

[image]

.NET Framework Class Library
PointD..::..Subtract Method (PointD, SizeF)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a specified size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Subtract ( _
    pt As PointD, _
    sz As SizeF _
) As PointD
C#
public static PointD Subtract(
    PointD pt,
    SizeF sz
)
Visual C++
public:
static PointD Subtract(
    PointD pt,
    SizeF sz
)
JavaScript
EGIS.ShapeFileLib.PointD.subtract = function(pt, sz);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..SizeF
The SizeF that specifies the numbers to subtract from the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Subtract Overload


ToString Method

[image]

.NET Framework Class Library
PointD..::..ToString Method
PointD Structure See Also Send Feedback

Converts this PointD to a human readable string.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

A string that represents this PointD.

See Also

PointD Structure


PointD Operators and Type Conversions

[image] [image]

.NET Framework Class Library
PointD Operators and Type Conversions
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Operators

Name | Description
Addition(PointD, SizeD) | Translates a PointD by a given Size.
Addition(PointD, Size) | Translates a PointD by a given Size.
Addition(PointD, SizeF) | Translates the PointD by the specified SizeF.
Equality | Compares two PointD structures. The result specifies whether the values of the X()()()() and Y()()()() properties of the two PointD structures are equal.
ImplicitWideningImplicitImplicitImplicit(PointF to PointD) | converts a PointF structure to a PointD structure
Inequality | Determines whether the coordinates of the specified points are not equal.
Subtraction(PointD, SizeD) | Translates a PointD by the negative of a given SizeD.
Subtraction(PointD, Size) | Translates a PointD by the negative of a given Size.
Subtraction(PointD, SizeF) | Translates a PointD by the negative of a specified SizeF.

See Also

PointD Structure


Addition Operator

[image] [image]

.NET Framework Class Library
PointD..::..Addition Operator
PointD Structure See Also Send Feedback

Overload List

Name | Description
Addition(PointD, SizeD) | Translates a PointD by a given Size.
Addition(PointD, Size) | Translates a PointD by a given Size.
Addition(PointD, SizeF) | Translates the PointD by the specified SizeF.

See Also

PointD Structure
PointD Members


Addition Operator (PointD, SizeD)

[image]

.NET Framework Class Library
PointD..::..Addition Operator (PointD, SizeD)
PointD Structure See Also Send Feedback

Translates a PointD by a given Size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator + ( _
    pt As PointD, _
    sz As SizeD _
) As PointD
C#
public static PointD operator +(
    PointD pt,
    SizeD sz
)
Visual C++
public:
static PointD operator +(
    PointD pt,
    SizeD sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: EGIS.ShapeFileLib..::..SizeD
A Size that specifies the pair of numbers to add to the coordinates of pt.

Return Value

Returns the translated PointD.

See Also

PointD Structure
Addition Overload


Addition Operator (PointD, Size)

[image]

.NET Framework Class Library
PointD..::..Addition Operator (PointD, Size)
PointD Structure See Also Send Feedback

Translates a PointD by a given Size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator + ( _
    pt As PointD, _
    sz As Size _
) As PointD
C#
public static PointD operator +(
    PointD pt,
    Size sz
)
Visual C++
public:
static PointD operator +(
    PointD pt,
    Size sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..Size
A Size that specifies the pair of numbers to add to the coordinates of pt.

Return Value

Returns the translated PointD.

See Also

PointD Structure
Addition Overload


Addition Operator (PointD, SizeF)

[image]

.NET Framework Class Library
PointD..::..Addition Operator (PointD, SizeF)
PointD Structure See Also Send Feedback

Translates the PointD by the specified SizeF.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator + ( _
    pt As PointD, _
    sz As SizeF _
) As PointD
C#
public static PointD operator +(
    PointD pt,
    SizeF sz
)
Visual C++
public:
static PointD operator +(
    PointD pt,
    SizeF sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..SizeF
The SizeF that specifies the numbers to add to the x- and y-coordinates of the PointD.

Return Value

The translated PointD.

See Also

PointD Structure
Addition Overload


Equality Operator

[image]

.NET Framework Class Library
PointD..::..Equality Operator
PointD Structure See Also Send Feedback

Compares two PointD structures. The result specifies whether the values of the X()()()() and Y()()()() properties of the two PointD structures are equal.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator = ( _
    left As PointD, _
    right As PointD _
) As Boolean
C#
public static bool operator ==(
    PointD left,
    PointD right
)
Visual C++
public:
static bool operator ==(
    PointD left,
    PointD right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: EGIS.ShapeFileLib..::..PointD
A PointD to compare.
right
Type: EGIS.ShapeFileLib..::..PointD
A PointD to compare.

Return Value

true if the X()()()() and Y()()()() values of the left and right PointD structures are equal; otherwise, false.

See Also

PointD Structure


Implicit Conversion (PointF to PointD)

[image]

.NET Framework Class Library
PointD ImplicitWideningImplicitImplicitImplicit Conversion (PointF to PointD)
PointD Structure See Also Send Feedback

converts a PointF structure to a PointD structure

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    p As PointF _
) As PointD
C#
public static implicit operator PointD (
    PointF p
)
Visual C++
static implicit operator PointD (
    PointF p
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

p
Type: System.Drawing..::..PointF

Return Value

See Also

PointD Structure


Inequality Operator

[image]

.NET Framework Class Library
PointD..::..Inequality Operator
PointD Structure See Also Send Feedback

Determines whether the coordinates of the specified points are not equal.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator <> ( _
    left As PointD, _
    right As PointD _
) As Boolean
C#
public static bool operator !=(
    PointD left,
    PointD right
)
Visual C++
public:
static bool operator !=(
    PointD left,
    PointD right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: EGIS.ShapeFileLib..::..PointD
A PointD to compare.
right
Type: EGIS.ShapeFileLib..::..PointD
A PointD to compare.

Return Value

true to indicate the X()()()() and Y()()()() values of left and right are not equal; otherwise, false.

See Also

PointD Structure


Subtraction Operator

[image] [image]

.NET Framework Class Library
PointD..::..Subtraction Operator
PointD Structure See Also Send Feedback

Overload List

Name | Description
Subtraction(PointD, SizeD) | Translates a PointD by the negative of a given SizeD.
Subtraction(PointD, Size) | Translates a PointD by the negative of a given Size.
Subtraction(PointD, SizeF) | Translates a PointD by the negative of a specified SizeF.

See Also

PointD Structure
PointD Members


Subtraction Operator (PointD, SizeD)

[image]

.NET Framework Class Library
PointD..::..Subtraction Operator (PointD, SizeD)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a given SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator - ( _
    pt As PointD, _
    sz As SizeD _
) As PointD
C#
public static PointD operator -(
    PointD pt,
    SizeD sz
)
Visual C++
public:
static PointD operator -(
    PointD pt,
    SizeD sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD that specifies the numbers to subtract from the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Subtraction Overload


Subtraction Operator (PointD, Size)

[image]

.NET Framework Class Library
PointD..::..Subtraction Operator (PointD, Size)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a given Size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator - ( _
    pt As PointD, _
    sz As Size _
) As PointD
C#
public static PointD operator -(
    PointD pt,
    Size sz
)
Visual C++
public:
static PointD operator -(
    PointD pt,
    Size sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
A PointD to compare.
sz
Type: System.Drawing..::..Size
A PointD to compare.

Return Value

The translated PointD.

See Also

PointD Structure
Subtraction Overload


Subtraction Operator (PointD, SizeF)

[image]

.NET Framework Class Library
PointD..::..Subtraction Operator (PointD, SizeF)
PointD Structure See Also Send Feedback

Translates a PointD by the negative of a specified SizeF.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator - ( _
    pt As PointD, _
    sz As SizeF _
) As PointD
C#
public static PointD operator -(
    PointD pt,
    SizeF sz
)
Visual C++
public:
static PointD operator -(
    PointD pt,
    SizeF sz
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to translate.
sz
Type: System.Drawing..::..SizeF
The SizeF that specifies the numbers to subtract from the coordinates of pt.

Return Value

The translated PointD.

See Also

PointD Structure
Subtraction Overload


PointD Properties

[image] [image]

.NET Framework Class Library
PointD Properties
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this PointD is empty.
Public property | X | Gets or sets the x-coordinate of this PointD.
Public property | Y | Gets or sets the y-coordinate of this PointD.

See Also

PointD Structure


IsEmpty Property

[image]

.NET Framework Class Library
PointD..::..IsEmpty Property
PointD Structure See Also Send Feedback

Gets a value indicating whether this PointD is empty.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
C#
public bool IsEmpty { get; }
Visual C++
public:
property bool IsEmpty {
    bool get ();
}
JavaScript
function get_isEmpty();

Return Value

true if both X()()()() and Y()()()() are 0; otherwise, false.

See Also

PointD Structure


X Property

[image]

.NET Framework Class Library
PointD..::..X Property
PointD Structure See Also Send Feedback

Gets or sets the x-coordinate of this PointD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property X As Double
    Get
    Set
C#
public double X { get; set; }
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}
JavaScript
function get_x();
function set_x(value);

Return Value

The x-coordinate of this PointD.

See Also

PointD Structure


Y Property

[image]

.NET Framework Class Library
PointD..::..Y Property
PointD Structure See Also Send Feedback

Gets or sets the y-coordinate of this PointD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Y As Double
    Get
    Set
C#
public double Y { get; set; }
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}
JavaScript
function get_y();
function set_y(value);

Return Value

The y-coordinate of this PointD.

See Also

PointD Structure


PolylineDistanceInfo Structure

[image]

.NET Framework Class Library
PolylineDistanceInfo Structure
Members See Also Send Feedback

Encapsulates point from polyline distance information

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Structure PolylineDistanceInfo
C#
public struct PolylineDistanceInfo
Visual C++
public value class PolylineDistanceInfo
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

PolylineDistanceInfo Members


PolylineDistanceInfo Members

[image] [image]

.NET Framework Class Library
PolylineDistanceInfo Members
PolylineDistanceInfo Structure Constructors Methods Fields Properties See Also Send Feedback

The PolylineDistanceInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PolylineDistanceInfo |

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Empty |

Properties

 | Name | Description
Public property | Distance | The distance from the given point to the polyline
Public property | LineSegmentSide |
Public property | PointIndex | The zero based point index at the start of the line segment in the poyline closest to the given point
Public property | PolylinePoint | The point on the poyline closest to the given point
Public property | TVal | A value between 0..1 indicating the location within the closest line segment

See Also

PolylineDistanceInfo Structure


PolylineDistanceInfo Constructor

[image]

.NET Framework Class Library
PolylineDistanceInfo Constructor
PolylineDistanceInfo Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    polylinePoint As PointD, _
    distance As Double, _
    tVal As Double, _
    pointIndex As Integer, _
    lineSegmentSide As LineSegmentSide _
)
C#
public PolylineDistanceInfo(
    PointD polylinePoint,
    double distance,
    double tVal,
    int pointIndex,
    LineSegmentSide lineSegmentSide
)
Visual C++
public:
PolylineDistanceInfo(
    PointD polylinePoint,
    double distance,
    double tVal,
    int pointIndex,
    LineSegmentSide lineSegmentSide
)
JavaScript
EGIS.ShapeFileLib.PolylineDistanceInfo = function(polylinePoint, distance, tVal, pointIndex, lineSegmentSide);

Parameters

polylinePoint
Type: EGIS.ShapeFileLib..::..PointD
distance
Type: System..::..Double
tVal
Type: System..::..Double
pointIndex
Type: System..::..Int32
lineSegmentSide
Type: EGIS.ShapeFileLib..::..LineSegmentSide

See Also

PolylineDistanceInfo Structure


PolylineDistanceInfo Fields

[image] [image]

.NET Framework Class Library
PolylineDistanceInfo Fields
PolylineDistanceInfo Structure See Also Send Feedback

The PolylineDistanceInfo type exposes the following members.

Fields

Name | Description
Empty |

See Also

PolylineDistanceInfo Structure


Empty Field

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..Empty Field
PolylineDistanceInfo Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Empty As PolylineDistanceInfo
C#
public static PolylineDistanceInfo Empty
Visual C++
public:
static PolylineDistanceInfo Empty
JavaScript
EGIS.ShapeFileLib.PolylineDistanceInfo.empty

See Also

PolylineDistanceInfo Structure


PolylineDistanceInfo Methods

[image] [image]

.NET Framework Class Library
PolylineDistanceInfo Methods
PolylineDistanceInfo Structure See Also Send Feedback

The PolylineDistanceInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

PolylineDistanceInfo Structure


PolylineDistanceInfo Properties

[image] [image]

.NET Framework Class Library
PolylineDistanceInfo Properties
PolylineDistanceInfo Structure See Also Send Feedback

The PolylineDistanceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Distance | The distance from the given point to the polyline
Public property | LineSegmentSide |
Public property | PointIndex | The zero based point index at the start of the line segment in the poyline closest to the given point
Public property | PolylinePoint | The point on the poyline closest to the given point
Public property | TVal | A value between 0..1 indicating the location within the closest line segment

See Also

PolylineDistanceInfo Structure


Distance Property

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..Distance Property
PolylineDistanceInfo Structure See Also Send Feedback

The distance from the given point to the polyline

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Distance As Double
    Get
    Set
C#
public double Distance { get; set; }
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}
JavaScript
function get_distance();
function set_distance(value);

See Also

PolylineDistanceInfo Structure


LineSegmentSide Property

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..LineSegmentSide Property
PolylineDistanceInfo Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property LineSegmentSide As LineSegmentSide
    Get
    Set
C#
public LineSegmentSide LineSegmentSide { get; set; }
Visual C++
public:
property LineSegmentSide LineSegmentSide {
    LineSegmentSide get ();
    void set (LineSegmentSide value);
}
JavaScript
function get_lineSegmentSide();
function set_lineSegmentSide(value);

See Also

PolylineDistanceInfo Structure


PointIndex Property

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..PointIndex Property
PolylineDistanceInfo Structure See Also Send Feedback

The zero based point index at the start of the line segment in the poyline closest to the given point

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property PointIndex As Integer
    Get
    Set
C#
public int PointIndex { get; set; }
Visual C++
public:
property int PointIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_pointIndex();
function set_pointIndex(value);

Remarks

A polyline of N points has (N-1) line segments. PointIndex will be between 0 to (N-2) inclusive.

See Also

PolylineDistanceInfo Structure


PolylinePoint Property

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..PolylinePoint Property
PolylineDistanceInfo Structure See Also Send Feedback

The point on the poyline closest to the given point

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property PolylinePoint As PointD
    Get
    Set
C#
public PointD PolylinePoint { get; set; }
Visual C++
public:
property PointD PolylinePoint {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_polylinePoint();
function set_polylinePoint(value);

See Also

PolylineDistanceInfo Structure


TVal Property

[image]

.NET Framework Class Library
PolylineDistanceInfo..::..TVal Property
PolylineDistanceInfo Structure See Also Send Feedback

A value between 0..1 indicating the location within the closest line segment

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property TVal As Double
    Get
    Set
C#
public double TVal { get; set; }
Visual C++
public:
property double TVal {
    double get ();
    void set (double value);
}
JavaScript
function get_tVal();
function set_tVal(value);

Remarks

A TVal of 0 indicates the position on the line segment closest the given point is at the start of the line segment
A TVal of 1 indicates the position on the line segment closest the given point is at the end of the line segment

The TVal property is useful when used with polylines containing measures. For example if Segmentindex is N then the dervied measure at the point on the polyline closest to a given point would be measure[N] + tVal x (measure[N+1] - measure[N])

See Also

PolylineDistanceInfo Structure


ProjectionType Enumeration

[image]

.NET Framework Class Library
ProjectionType Enumeration
See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration ProjectionType
C#
public enum ProjectionType
Visual C++
public enum class ProjectionType
JavaScript
EGIS.ShapeFileLib.ProjectionType = function();
EGIS.ShapeFileLib.ProjectionType.createEnum('EGIS.ShapeFileLib.ProjectionType', false);

Members

Member name | Description
None |
Mercator |

See Also


RectangleD Structure

[image]

.NET Framework Class Library
RectangleD Structure
Members See Also Send Feedback

Stores a set of four double-precision floating-point numbers that represent the location and size of a rectangle.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Structure RectangleD
C#
[SerializableAttribute]
public struct RectangleD
Visual C++
[SerializableAttribute]
public value class RectangleD
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

RectangleD Members


RectangleD Members

[image] [image]

.NET Framework Class Library
RectangleD Members
RectangleD Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The RectangleD type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleD(PointD, SizeD) | Initializes a new instance of the RectangleD class with the specified location and size.
Public method | RectangleD(Double, Double, Double, Double) | Initializes a new instance of the RectangleD class with the specified location and size.

Methods

 | Name | Description
Public method | Contains(PointD) | Determines if the specified point is contained within this RectangleD structure.
Public method | Contains(RectangleD) | Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.
Public method | Contains(Double, Double) | Determines if the specified point is contained within this RectangleD structure.
Public method | Equals | Tests whether obj is a RectangleD with the same location and size of this RectangleD. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromLTRB | Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.
Public method | GetHashCode | Gets the hash code for this RectangleD structure. For information about the use of hash codes, see Object.GetHashCode. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inflate(SizeD) | Inflates this RectangleD by the specified amount.
Public method | Inflate(Double, Double) | Inflates this RectangleD structure by the specified amount.
 | Inflate(RectangleD, Double, Double) | Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Public method | Intersect(RectangleD) | Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.
 | Intersect(RectangleD, RectangleD) | Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.
Public method | IntersectsWith | Determines if this rectangle intersects with rect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset(PointD) | Adjusts the location of this rectangle by the specified amount.
Public method | Offset(Double, Double) | Adjusts the location of this rectangle by the specified amount.
Public method | ToString | Converts the Location and Size of this RectangleD to a human-readable string. (Overrides ValueType..::..ToString()()()().)
 | Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

Operators

Name | Description
Equality | Tests whether two RectangleD structures have equal location and size.
ImplicitWideningImplicitImplicitImplicit(Rectangle to RectangleD) | Converts the specified Rectangle structure to a RectangleD structure.
ImplicitWideningImplicitImplicitImplicit(RectangleF to RectangleD) |
ImplicitWideningImplicitImplicitImplicit(RectangleD to RectangleF) |
Inequality | Tests whether two RectangleD structures differ in location or size.

Fields

Name | Description
Empty | Represents an instance of the RectangleD class with its members uninitialized.

Properties

 | Name | Description
Public property | Bottom | Gets the y-coordinate that is the sum of Y()()()() and Height()()()() of this RectangleD structure.
Public property | Height | Gets or sets the height of this RectangleD structure.
Public property | IsEmpty | Tests whether the Width()()()() or Height()()()() property of this RectangleD has a value of zero.
Public property | Left | Gets the x-coordinate of the left edge of this RectangleD structure.
Public property | Location | Gets or sets the coordinates of the upper-left corner of this RectangleD structure.
Public property | Right | Gets the x-coordinate that is the sum of X()()()() and Width()()()() of this RectangleD structure.
Public property | Size | Gets or sets the size of this RectangleD.
Public property | Top | Gets the y-coordinate of the top edge of this RectangleD structure.
Public property | Width | Gets or sets the width of this RectangleD structure.
Public property | X | Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.

See Also

RectangleD Structure


RectangleD Constructor

[image] [image]

.NET Framework Class Library
RectangleD Constructor
RectangleD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangleD(PointD, SizeD) | Initializes a new instance of the RectangleD class with the specified location and size.
Public method | RectangleD(Double, Double, Double, Double) | Initializes a new instance of the RectangleD class with the specified location and size.

See Also

RectangleD Structure
RectangleD Members


RectangleD Constructor (PointD, SizeD)

[image]

.NET Framework Class Library
RectangleD Constructor (PointD, SizeD)
RectangleD Structure See Also Send Feedback

Initializes a new instance of the RectangleD class with the specified location and size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    location As PointD, _
    size As SizeD _
)
C#
public RectangleD(
    PointD location,
    SizeD size
)
Visual C++
public:
RectangleD(
    PointD location,
    SizeD size
)
JavaScript
EGIS.ShapeFileLib.RectangleD = function(location, size);

Parameters

location
Type: EGIS.ShapeFileLib..::..PointD
A PointD that represents the upper-left corner of the rectangular region.
size
Type: EGIS.ShapeFileLib..::..SizeD
A SizeD that represents the width and height of the rectangular region.

See Also

RectangleD Structure
RectangleD Overload


RectangleD Constructor (Double, Double, Double, Double)

[image]

.NET Framework Class Library
RectangleD Constructor (Double, Double, Double, Double)
RectangleD Structure See Also Send Feedback

Initializes a new instance of the RectangleD class with the specified location and size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
C#
public RectangleD(
    double x,
    double y,
    double width,
    double height
)
Visual C++
public:
RectangleD(
    double x,
    double y,
    double width,
    double height
)
JavaScript
EGIS.ShapeFileLib.RectangleD = function(x, y, width, height);

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the rectangle.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the rectangle.
width
Type: System..::..Double
The width of the rectangle.
height
Type: System..::..Double
The height of the rectangle.

See Also

RectangleD Structure
RectangleD Overload


RectangleD Fields

[image] [image]

.NET Framework Class Library
RectangleD Fields
RectangleD Structure See Also Send Feedback

The RectangleD type exposes the following members.

Fields

Name | Description
Empty | Represents an instance of the RectangleD class with its members uninitialized.

See Also

RectangleD Structure


Empty Field

[image]

.NET Framework Class Library
RectangleD..::..Empty Field
RectangleD Structure See Also Send Feedback

Represents an instance of the RectangleD class with its members uninitialized.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared ReadOnly Empty As RectangleD
C#
public static readonly RectangleD Empty
Visual C++
public:
static initonly RectangleD Empty
JavaScript
EGIS.ShapeFileLib.RectangleD.empty

See Also

RectangleD Structure


RectangleD Methods

[image] [image]

.NET Framework Class Library
RectangleD Methods
RectangleD Structure See Also Send Feedback

The RectangleD type exposes the following members.

Methods

 | Name | Description
Public method | Contains(PointD) | Determines if the specified point is contained within this RectangleD structure.
Public method | Contains(RectangleD) | Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.
Public method | Contains(Double, Double) | Determines if the specified point is contained within this RectangleD structure.
Public method | Equals | Tests whether obj is a RectangleD with the same location and size of this RectangleD. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromLTRB | Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.
Public method | GetHashCode | Gets the hash code for this RectangleD structure. For information about the use of hash codes, see Object.GetHashCode. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inflate(SizeD) | Inflates this RectangleD by the specified amount.
Public method | Inflate(Double, Double) | Inflates this RectangleD structure by the specified amount.
 | Inflate(RectangleD, Double, Double) | Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Public method | Intersect(RectangleD) | Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.
 | Intersect(RectangleD, RectangleD) | Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.
Public method | IntersectsWith | Determines if this rectangle intersects with rect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset(PointD) | Adjusts the location of this rectangle by the specified amount.
Public method | Offset(Double, Double) | Adjusts the location of this rectangle by the specified amount.
Public method | ToString | Converts the Location and Size of this RectangleD to a human-readable string. (Overrides ValueType..::..ToString()()()().)
 | Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

See Also

RectangleD Structure


Contains Method

[image] [image]

.NET Framework Class Library
RectangleD..::..Contains Method
RectangleD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(PointD) | Determines if the specified point is contained within this RectangleD structure.
Public method | Contains(RectangleD) | Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.
Public method | Contains(Double, Double) | Determines if the specified point is contained within this RectangleD structure.

See Also

RectangleD Structure
RectangleD Members


Contains Method (PointD)

[image]

.NET Framework Class Library
RectangleD..::..Contains Method (PointD)
RectangleD Structure See Also Send Feedback

Determines if the specified point is contained within this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function Contains ( _
    pt As PointD _
) As Boolean
C#
public bool Contains(
    PointD pt
)
Visual C++
public:
bool Contains(
    PointD pt
)
JavaScript
function contains(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD to test.

Return Value

This method returns true if the point represented by the pt parameter is contained within this RectangleD structure; otherwise false.

See Also

RectangleD Structure
Contains Overload


Contains Method (RectangleD)

[image]

.NET Framework Class Library
RectangleD..::..Contains Method (RectangleD)
RectangleD Structure See Also Send Feedback

Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function Contains ( _
    rect As RectangleD _
) As Boolean
C#
public bool Contains(
    RectangleD rect
)
Visual C++
public:
bool Contains(
    RectangleD rect
)
JavaScript
function contains(rect);

Parameters

rect
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD to test.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within the rectangular region represented by this RectangleD; otherwise false.

See Also

RectangleD Structure
Contains Overload


Contains Method (Double, Double)

[image]

.NET Framework Class Library
RectangleD..::..Contains Method (Double, Double)
RectangleD Structure See Also Send Feedback

Determines if the specified point is contained within this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function Contains ( _
    x As Double, _
    y As Double _
) As Boolean
C#
public bool Contains(
    double x,
    double y
)
Visual C++
public:
bool Contains(
    double x,
    double y
)
JavaScript
function contains(x, y);

Parameters

x
Type: System..::..Double
The x-coordinate of the point to test.
y
Type: System..::..Double
The y-coordinate of the point to test.

Return Value

This method returns true if the point defined by x and y is contained within this RectangleD structure; otherwise false.

See Also

RectangleD Structure
Contains Overload


Equals Method

[image]

.NET Framework Class Library
RectangleD..::..Equals Method
RectangleD Structure See Also Send Feedback

Tests whether obj is a RectangleD with the same location and size of this RectangleD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object
The Object to test.

Return Value

This method returns true if obj is a RectangleD and its X, Y, Width, and Height properties are equal to the corresponding properties of this RectangleD; otherwise, false.

See Also

RectangleD Structure


FromLTRB Method

[image]

.NET Framework Class Library
RectangleD..::..FromLTRB Method
RectangleD Structure See Also Send Feedback

Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function FromLTRB ( _
    left As Double, _
    top As Double, _
    right As Double, _
    bottom As Double _
) As RectangleD
C#
public static RectangleD FromLTRB(
    double left,
    double top,
    double right,
    double bottom
)
Visual C++
public:
static RectangleD FromLTRB(
    double left,
    double top,
    double right,
    double bottom
)
JavaScript
EGIS.ShapeFileLib.RectangleD.fromLTRB = function(left, top, right, bottom);

Parameters

left
Type: System..::..Double
The x-coordinate of the upper-left corner of the rectangular region.
top
Type: System..::..Double
The y-coordinate of the upper-left corner of the rectangular region.
right
Type: System..::..Double
The x-coordinate of the lower-right corner of the rectangular region.
bottom
Type: System..::..Double
The y-coordinate of the lower-right corner of the rectangular region.

Return Value

The new RectangleD that this method creates.

See Also

RectangleD Structure


GetHashCode Method

[image]

.NET Framework Class Library
RectangleD..::..GetHashCode Method
RectangleD Structure See Also Send Feedback

Gets the hash code for this RectangleD structure. For information about the use of hash codes, see Object.GetHashCode.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

Return Value

The hash code for this RectangleD.

See Also

RectangleD Structure


Inflate Method

[image] [image]

.NET Framework Class Library
RectangleD..::..Inflate Method
RectangleD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Inflate(SizeD) | Inflates this RectangleD by the specified amount.
Public method | Inflate(Double, Double) | Inflates this RectangleD structure by the specified amount.
 | Inflate(RectangleD, Double, Double) | Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

See Also

RectangleD Structure
RectangleD Members


Inflate Method (SizeD)

[image]

.NET Framework Class Library
RectangleD..::..Inflate Method (SizeD)
RectangleD Structure See Also Send Feedback

Inflates this RectangleD by the specified amount.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Inflate ( _
    size As SizeD _
)
C#
public void Inflate(
    SizeD size
)
Visual C++
public:
void Inflate(
    SizeD size
)
JavaScript
function inflate(size);

Parameters

size
Type: EGIS.ShapeFileLib..::..SizeD
The amount to inflate this rectangle.

Return Value

This method does not return a value.

See Also

RectangleD Structure
Inflate Overload


Inflate Method (Double, Double)

[image]

.NET Framework Class Library
RectangleD..::..Inflate Method (Double, Double)
RectangleD Structure See Also Send Feedback

Inflates this RectangleD structure by the specified amount.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Inflate ( _
    x As Double, _
    y As Double _
)
C#
public void Inflate(
    double x,
    double y
)
Visual C++
public:
void Inflate(
    double x,
    double y
)
JavaScript
function inflate(x, y);

Parameters

x
Type: System..::..Double
The amount to inflate this RectangleD structure horizontally.
y
Type: System..::..Double
The amount to inflate this RectangleD structure vertically.

Return Value

This method does not return a value.

See Also

RectangleD Structure
Inflate Overload


Inflate Method (RectangleD, Double, Double)

[image]

.NET Framework Class Library
RectangleD..::..Inflate Method (RectangleD, Double, Double)
RectangleD Structure See Also Send Feedback

Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Inflate ( _
    rect As RectangleD, _
    x As Double, _
    y As Double _
) As RectangleD
C#
public static RectangleD Inflate(
    RectangleD rect,
    double x,
    double y
)
Visual C++
public:
static RectangleD Inflate(
    RectangleD rect,
    double x,
    double y
)
JavaScript
EGIS.ShapeFileLib.RectangleD.inflate = function(rect, x, y);

Parameters

rect
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD to be copied. This rectangle is not modified.
x
Type: System..::..Double
The amount to inflate the copy of the rectangle horizontally.
y
Type: System..::..Double
The amount to inflate the copy of the rectangle vertically.

Return Value

The inflated RectangleD.

See Also

RectangleD Structure
Inflate Overload


Intersect Method

[image] [image]

.NET Framework Class Library
RectangleD..::..Intersect Method
RectangleD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Intersect(RectangleD) | Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.
 | Intersect(RectangleD, RectangleD) | Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.

See Also

RectangleD Structure
RectangleD Members


Intersect Method (RectangleD)

[image]

.NET Framework Class Library
RectangleD..::..Intersect Method (RectangleD)
RectangleD Structure See Also Send Feedback

Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Intersect ( _
    rect As RectangleD _
)
C#
public void Intersect(
    RectangleD rect
)
Visual C++
public:
void Intersect(
    RectangleD rect
)
JavaScript
function intersect(rect);

Parameters

rect
Type: EGIS.ShapeFileLib..::..RectangleD
The rectangle to intersect.

Return Value

This method does not return a value.

See Also

RectangleD Structure
Intersect Overload


Intersect Method (RectangleD, RectangleD)

[image]

.NET Framework Class Library
RectangleD..::..Intersect Method (RectangleD, RectangleD)
RectangleD Structure See Also Send Feedback

Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Intersect ( _
    a As RectangleD, _
    b As RectangleD _
) As RectangleD
C#
public static RectangleD Intersect(
    RectangleD a,
    RectangleD b
)
Visual C++
public:
static RectangleD Intersect(
    RectangleD a,
    RectangleD b
)
JavaScript
EGIS.ShapeFileLib.RectangleD.intersect = function(a, b);

Parameters

a
Type: EGIS.ShapeFileLib..::..RectangleD
A rectangle to intersect.
b
Type: EGIS.ShapeFileLib..::..RectangleD
A rectangle to intersect.

Return Value

A third RectangleD structure the size of which represents the overlapped area of the two specified rectangles.

See Also

RectangleD Structure
Intersect Overload


IntersectsWith Method

[image]

.NET Framework Class Library
RectangleD..::..IntersectsWith Method
RectangleD Structure See Also Send Feedback

Determines if this rectangle intersects with rect.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function IntersectsWith ( _
    rect As RectangleD _
) As Boolean
C#
public bool IntersectsWith(
    RectangleD rect
)
Visual C++
public:
bool IntersectsWith(
    RectangleD rect
)
JavaScript
function intersectsWith(rect);

Parameters

rect
Type: EGIS.ShapeFileLib..::..RectangleD
The rectangle to test.

Return Value

This method returns true if there is any intersection.

See Also

RectangleD Structure


Offset Method

[image] [image]

.NET Framework Class Library
RectangleD..::..Offset Method
RectangleD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Offset(PointD) | Adjusts the location of this rectangle by the specified amount.
Public method | Offset(Double, Double) | Adjusts the location of this rectangle by the specified amount.

See Also

RectangleD Structure
RectangleD Members


Offset Method (PointD)

[image]

.NET Framework Class Library
RectangleD..::..Offset Method (PointD)
RectangleD Structure See Also Send Feedback

Adjusts the location of this rectangle by the specified amount.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Offset ( _
    pos As PointD _
)
C#
public void Offset(
    PointD pos
)
Visual C++
public:
void Offset(
    PointD pos
)
JavaScript
function offset(pos);

Parameters

pos
Type: EGIS.ShapeFileLib..::..PointD
The amount to offset the location.

Return Value

This method does not return a value.

See Also

RectangleD Structure
Offset Overload


Offset Method (Double, Double)

[image]

.NET Framework Class Library
RectangleD..::..Offset Method (Double, Double)
RectangleD Structure See Also Send Feedback

Adjusts the location of this rectangle by the specified amount.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Offset ( _
    x As Double, _
    y As Double _
)
C#
public void Offset(
    double x,
    double y
)
Visual C++
public:
void Offset(
    double x,
    double y
)
JavaScript
function offset(x, y);

Parameters

x
Type: System..::..Double
The amount to offset the location horizontally.
y
Type: System..::..Double
The amount to offset the location vertically.

Return Value

This method does not return a value.

See Also

RectangleD Structure
Offset Overload


ToString Method

[image]

.NET Framework Class Library
RectangleD..::..ToString Method
RectangleD Structure See Also Send Feedback

Converts the Location and Size of this RectangleD to a human-readable string.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

A string that contains the position, width, and height of this RectangleD structure¾for example, "{X=20, Y=20, Width=100, Height=50}".

See Also

RectangleD Structure


Union Method

[image]

.NET Framework Class Library
RectangleD..::..Union Method
RectangleD Structure See Also Send Feedback

Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Union ( _
    a As RectangleD, _
    b As RectangleD _
) As RectangleD
C#
public static RectangleD Union(
    RectangleD a,
    RectangleD b
)
Visual C++
public:
static RectangleD Union(
    RectangleD a,
    RectangleD b
)
JavaScript
EGIS.ShapeFileLib.RectangleD.union = function(a, b);

Parameters

a
Type: EGIS.ShapeFileLib..::..RectangleD
A rectangle to union.
b
Type: EGIS.ShapeFileLib..::..RectangleD
A rectangle to union.

Return Value

A third RectangleD structure that contains both of the two rectangles that form the union.

See Also

RectangleD Structure


RectangleD Operators and Type Conversions

[image] [image]

.NET Framework Class Library
RectangleD Operators and Type Conversions
RectangleD Structure See Also Send Feedback

The RectangleD type exposes the following members.

Operators

Name | Description
Equality | Tests whether two RectangleD structures have equal location and size.
ImplicitWideningImplicitImplicitImplicit(Rectangle to RectangleD) | Converts the specified Rectangle structure to a RectangleD structure.
ImplicitWideningImplicitImplicitImplicit(RectangleF to RectangleD) |
ImplicitWideningImplicitImplicitImplicit(RectangleD to RectangleF) |
Inequality | Tests whether two RectangleD structures differ in location or size.

See Also

RectangleD Structure


Equality Operator

[image]

.NET Framework Class Library
RectangleD..::..Equality Operator
RectangleD Structure See Also Send Feedback

Tests whether two RectangleD structures have equal location and size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator = ( _
    left As RectangleD, _
    right As RectangleD _
) As Boolean
C#
public static bool operator ==(
    RectangleD left,
    RectangleD right
)
Visual C++
public:
static bool operator ==(
    RectangleD left,
    RectangleD right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD structure that is to the left of the equality operator.
right
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD structure that is to the right of the equality operator.

Return Value

This operator returns true if the two specified RectangleD structures have equal X()()()(), Y()()()(), Width()()()(), and Height()()()() properties.

See Also

RectangleD Structure


Implicit Conversion Operators

[image] [image]

.NET Framework Class Library
RectangleD ImplicitWideningImplicitImplicitImplicit Conversion Operators
RectangleD Structure See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Rectangle to RectangleD) | Converts the specified Rectangle structure to a RectangleD structure.
ImplicitWideningImplicitImplicitImplicit(RectangleF to RectangleD) |
ImplicitWideningImplicitImplicitImplicit(RectangleD to RectangleF) |

See Also

RectangleD Structure
RectangleD Members


Implicit Conversion (Rectangle to RectangleD)

[image]

.NET Framework Class Library
RectangleD ImplicitWideningImplicitImplicitImplicit Conversion (Rectangle to RectangleD)
RectangleD Structure See Also Send Feedback

Converts the specified Rectangle structure to a RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    r As Rectangle _
) As RectangleD
C#
public static implicit operator RectangleD (
    Rectangle r
)
Visual C++
static implicit operator RectangleD (
    Rectangle r
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

r
Type: System.Drawing..::..Rectangle
The Rectangle structure to convert.

Return Value

The RectangleD structure that is converted from the specified Rectangle structure.

See Also

RectangleD Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (RectangleF to RectangleD)

[image]

.NET Framework Class Library
RectangleD ImplicitWideningImplicitImplicitImplicit Conversion (RectangleF to RectangleD)
RectangleD Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    r As RectangleF _
) As RectangleD
C#
public static implicit operator RectangleD (
    RectangleF r
)
Visual C++
static implicit operator RectangleD (
    RectangleF r
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

r
Type: System.Drawing..::..RectangleF

See Also

RectangleD Structure
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (RectangleD to RectangleF)

[image]

.NET Framework Class Library
RectangleD ImplicitWideningImplicitImplicitImplicit Conversion (RectangleD to RectangleF)
RectangleD Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    r As RectangleD _
) As RectangleF
C#
public static implicit operator RectangleF (
    RectangleD r
)
Visual C++
static implicit operator RectangleF (
    RectangleD r
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

r
Type: EGIS.ShapeFileLib..::..RectangleD

See Also

RectangleD Structure
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image]

.NET Framework Class Library
RectangleD..::..Inequality Operator
RectangleD Structure See Also Send Feedback

Tests whether two RectangleD structures differ in location or size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator <> ( _
    left As RectangleD, _
    right As RectangleD _
) As Boolean
C#
public static bool operator !=(
    RectangleD left,
    RectangleD right
)
Visual C++
public:
static bool operator !=(
    RectangleD left,
    RectangleD right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD structure that is to the left of the inequality operator.
right
Type: EGIS.ShapeFileLib..::..RectangleD
The RectangleD structure that is to the right of the inequality operator.

Return Value

This operator returns true if any of the X()()()() , Y()()()(), Width()()()(), or Height()()()() properties of the two Rectangle structures are unequal; otherwise false.

See Also

RectangleD Structure


RectangleD Properties

[image] [image]

.NET Framework Class Library
RectangleD Properties
RectangleD Structure See Also Send Feedback

The RectangleD type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Gets the y-coordinate that is the sum of Y()()()() and Height()()()() of this RectangleD structure.
Public property | Height | Gets or sets the height of this RectangleD structure.
Public property | IsEmpty | Tests whether the Width()()()() or Height()()()() property of this RectangleD has a value of zero.
Public property | Left | Gets the x-coordinate of the left edge of this RectangleD structure.
Public property | Location | Gets or sets the coordinates of the upper-left corner of this RectangleD structure.
Public property | Right | Gets the x-coordinate that is the sum of X()()()() and Width()()()() of this RectangleD structure.
Public property | Size | Gets or sets the size of this RectangleD.
Public property | Top | Gets the y-coordinate of the top edge of this RectangleD structure.
Public property | Width | Gets or sets the width of this RectangleD structure.
Public property | X | Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.

See Also

RectangleD Structure


Bottom Property

[image]

.NET Framework Class Library
RectangleD..::..Bottom Property
RectangleD Structure See Also Send Feedback

Gets the y-coordinate that is the sum of Y()()()() and Height()()()() of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Bottom As Double
    Get
C#
public double Bottom { get; }
Visual C++
public:
property double Bottom {
    double get ();
}
JavaScript
function get_bottom();

Return Value

The y-coordinate that is the sum of Y()()()() and Height()()()() of this RectangleD structure.

See Also

RectangleD Structure


Height Property

[image]

.NET Framework Class Library
RectangleD..::..Height Property
RectangleD Structure See Also Send Feedback

Gets or sets the height of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Height As Double
    Get
    Set
C#
public double Height { get; set; }
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}
JavaScript
function get_height();
function set_height(value);

Return Value

The height of this RectangleD structure.

See Also

RectangleD Structure


IsEmpty Property

[image]

.NET Framework Class Library
RectangleD..::..IsEmpty Property
RectangleD Structure See Also Send Feedback

Tests whether the Width()()()() or Height()()()() property of this RectangleD has a value of zero.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
C#
public bool IsEmpty { get; }
Visual C++
public:
property bool IsEmpty {
    bool get ();
}
JavaScript
function get_isEmpty();

Return Value

This property returns true if the Width()()()() or Height()()()() property of this RectangleD has a value of zero; otherwise, false.

See Also

RectangleD Structure


Left Property

[image]

.NET Framework Class Library
RectangleD..::..Left Property
RectangleD Structure See Also Send Feedback

Gets the x-coordinate of the left edge of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Left As Double
    Get
C#
public double Left { get; }
Visual C++
public:
property double Left {
    double get ();
}
JavaScript
function get_left();

Return Value

The x-coordinate of the left edge of this RectangleD structure.

See Also

RectangleD Structure


Location Property

[image]

.NET Framework Class Library
RectangleD..::..Location Property
RectangleD Structure See Also Send Feedback

Gets or sets the coordinates of the upper-left corner of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Location As PointD
    Get
    Set
C#
public PointD Location { get; set; }
Visual C++
public:
property PointD Location {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_location();
function set_location(value);

Return Value

A PointD that represents the upper-left corner of this RectangleD structure.

See Also

RectangleD Structure


Right Property

[image]

.NET Framework Class Library
RectangleD..::..Right Property
RectangleD Structure See Also Send Feedback

Gets the x-coordinate that is the sum of X()()()() and Width()()()() of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Right As Double
    Get
C#
public double Right { get; }
Visual C++
public:
property double Right {
    double get ();
}
JavaScript
function get_right();

Return Value

The x-coordinate that is the sum of X()()()() and Width()()()() of this RectangleD structure.

See Also

RectangleD Structure


Size Property

[image]

.NET Framework Class Library
RectangleD..::..Size Property
RectangleD Structure See Also Send Feedback

Gets or sets the size of this RectangleD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Size As SizeD
    Get
    Set
C#
public SizeD Size { get; set; }
Visual C++
public:
property SizeD Size {
    SizeD get ();
    void set (SizeD value);
}
JavaScript
function get_size();
function set_size(value);

Return Value

A SizeD that represents the width and height of this RectangleD structure.

See Also

RectangleD Structure


Top Property

[image]

.NET Framework Class Library
RectangleD..::..Top Property
RectangleD Structure See Also Send Feedback

Gets the y-coordinate of the top edge of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Top As Double
    Get
C#
public double Top { get; }
Visual C++
public:
property double Top {
    double get ();
}
JavaScript
function get_top();

Return Value

The y-coordinate of the top edge of this RectangleD structure.

See Also

RectangleD Structure


Width Property

[image]

.NET Framework Class Library
RectangleD..::..Width Property
RectangleD Structure See Also Send Feedback

Gets or sets the width of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Width As Double
    Get
    Set
C#
public double Width { get; set; }
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}
JavaScript
function get_width();
function set_width(value);

Return Value

The width of this RectangleD structure.

See Also

RectangleD Structure


X Property

[image]

.NET Framework Class Library
RectangleD..::..X Property
RectangleD Structure See Also Send Feedback

Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property X As Double
    Get
    Set
C#
public double X { get; set; }
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}
JavaScript
function get_x();
function set_x(value);

Return Value

The x-coordinate of the upper-left corner of this RectangleD structure.

See Also

RectangleD Structure


Y Property

[image]

.NET Framework Class Library
RectangleD..::..Y Property
RectangleD Structure See Also Send Feedback

Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Y As Double
    Get
    Set
C#
public double Y { get; set; }
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}
JavaScript
function get_y();
function set_y(value);

Return Value

The y-coordinate of the upper-left corner of this RectangleD structure.

See Also

RectangleD Structure


RenderQuality Enumeration

[image]

.NET Framework Class Library
RenderQuality Enumeration
See Also Send Feedback

Enumeration to indicate render quality.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration RenderQuality
C#
public enum RenderQuality
Visual C++
public enum class RenderQuality
JavaScript
EGIS.ShapeFileLib.RenderQuality = function();
EGIS.ShapeFileLib.RenderQuality.createEnum('EGIS.ShapeFileLib.RenderQuality', false);

Members

Member name | Description
Low |
High |
Auto |

See Also


RenderSettings Class

[image]

.NET Framework Class Library
RenderSettings Class
Members See Also Send Feedback

Encapsulates settings used when rendering a ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class RenderSettings _
    Implements IDisposable
C#
public class RenderSettings : IDisposable
Visual C++
public ref class RenderSettings : IDisposable
JavaScript
EGIS.ShapeFileLib.RenderSettings = function();

Type.createClass(
    'EGIS.ShapeFileLib.RenderSettings',
    null,
    IDisposable);

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..RenderSettings

See Also

RenderSettings Members


RenderSettings Members

[image] [image]

.NET Framework Class Library
RenderSettings Members
RenderSettings Class Constructors Methods Properties See Also Send Feedback

The RenderSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RenderSettings | Constructs a new RenderSettings object

Methods

 | Name | Description
Public method | Dispose()()()() | Dispose of the RenderSettings
Protected method | Dispose(Boolean) | Diposes of the RenderSettings. Derived classes that override this method should call base.Dispose(disposing)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetImageSymbol | Returns the symbol Image if PointImageSymbol has been set
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Reads the RenderSettings properties from an Xml representation
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteXml | Writes an XML representation of RenderSettings

Properties

 | Name | Description
Public property | CustomRenderSettings | Gets or sets a ICustomRenderSettings object that should be applied when rendering the shapefile
Public property | DbfReader | Gets the DbfReader of this RenderSettings ShapeFile
Public property | FieldIndex | Gets the zero based field column index of the specifed DBF FieldName
Public property | FieldName | Gets / Sets the name of the Field in the DBF file that will be used when labeling shapes
Public property | FillColor | Gets / Sets the Fill Color to use when rendering the interior of each shape
Public property | FillInterior | Gets / Sets whether to fill the interior of each shape (Polygon)
Public property | Font | Gets / Sets the Font to use when labelling shapes
Public property | FontColor | Gets / Sets the Font Color to use when rendering shape labels
Public property | IsSelectable | Gets / Sets whether the ShapeFile is selectable
Public property | LineDashStyle |
Public property | LineType | Gets / Sets the LineType to use when rending lines (PolyLine and PolyLineM only)
Public property | MaxPixelPenWidth | Gets / Sets the Maximum width of the pen in Pixels.
Public property | MaxZoomLevel | Gets / Sets the Max Zoom level before the layer is not rendered
Public property | MinPixelPenWidth | Gets / Sets the Minimum width of the pen in Pixels.
Public property | MinRenderLabelZoom | Gets / Sets the Minimum Zoom Level before labels will be rendered.
Public property | MinZoomLevel | Gets / Sets the Min Zoom level before the layer is rendered.
Public property | OutlineColor | Gets / Sets the color used to draw the outline of each shape.
Public property | PenWidthScale | Gets / Sets the width of the pen in ShapeFile coordinate units (PolyLines only).
Public property | PointImageSymbol | Gets/Sets the Image Symbol to use for Point records
Public property | PointSize | Gets/Sets the size (in pixels) to use when rendering each point in a Point ShapeFile
Public property | RenderDuplicateFields | Indicates whether or not to render duplicate field names on a polyline shape
Public property | SelectFillColor | Gets / Sets the Fill Color to use when rendering the interior of selected shapes
Public property | SelectOutlineColor | Gets / Sets the color used to draw the outline of selected shapes.
Public property | ShadowText | Gets / Sets whether to use a "Shadow" text effect when labelling shapes
Public property | StringEncoding | Gets/Sets the text encoding used when reading string attribbutes from the shapefile's DBF file
Public property | ToolTipFieldIndex | Gets the zero based field column index of the ToolTipFieldName
Public property | ToolTipFieldName | Gets / Sets the name of the Field in the DBF file that will be used for the ToolTip text
Public property | UseToolTip | Gets / Sets whether to use a ToolTip for the layer

See Also

RenderSettings Class


RenderSettings Constructor

[image]

.NET Framework Class Library
RenderSettings Constructor
RenderSettings Class See Also Send Feedback

Constructs a new RenderSettings object

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    shapeFilePath As String, _
    fieldName As String, _
    renderFont As Font _
)
C#
public RenderSettings(
    string shapeFilePath,
    string fieldName,
    Font renderFont
)
Visual C++
public:
RenderSettings(
    String^ shapeFilePath,
    String^ fieldName,
    Font^ renderFont
)
JavaScript
EGIS.ShapeFileLib.RenderSettings = function(shapeFilePath, fieldName, renderFont);

Parameters

shapeFilePath
Type: System..::..String
The path to the shape file without the .shp file extension
fieldName
Type: System..::..String
The name of the DBF field to use when labelling shapes
renderFont
Type: System.Drawing..::..Font
The Font to use when labelling shapes in the shape file

See Also

RenderSettings Class


RenderSettings Methods

[image] [image]

.NET Framework Class Library
RenderSettings Methods
RenderSettings Class See Also Send Feedback

The RenderSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | Dispose of the RenderSettings
Protected method | Dispose(Boolean) | Diposes of the RenderSettings. Derived classes that override this method should call base.Dispose(disposing)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetImageSymbol | Returns the symbol Image if PointImageSymbol has been set
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Reads the RenderSettings properties from an Xml representation
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteXml | Writes an XML representation of RenderSettings

See Also

RenderSettings Class


Dispose Method

[image] [image]

.NET Framework Class Library
RenderSettings..::..Dispose Method
RenderSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Dispose of the RenderSettings
Protected method | Dispose(Boolean) | Diposes of the RenderSettings. Derived classes that override this method should call base.Dispose(disposing)

See Also

RenderSettings Class
RenderSettings Members


Dispose Method

[image]

.NET Framework Class Library
RenderSettings..::..Dispose Method
RenderSettings Class See Also Send Feedback

Dispose of the RenderSettings

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

RenderSettings Class
Dispose Overload


Dispose Method (Boolean)

[image]

.NET Framework Class Library
RenderSettings..::..Dispose Method (Boolean)
RenderSettings Class See Also Send Feedback

Diposes of the RenderSettings. Derived classes that override this method should call base.Dispose(disposing)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::..Boolean

See Also

RenderSettings Class
Dispose Overload


Finalize Method

[image]

.NET Framework Class Library
RenderSettings..::..Finalize Method
RenderSettings Class See Also Send Feedback

Destructor

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override
JavaScript
function finalize();

See Also

RenderSettings Class


GetImageSymbol Method

[image]

.NET Framework Class Library
RenderSettings..::..GetImageSymbol Method
RenderSettings Class See Also Send Feedback

Returns the symbol Image if PointImageSymbol has been set

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetImageSymbol As Image
C#
public Image GetImageSymbol()
Visual C++
public:
Image^ GetImageSymbol()
JavaScript
function getImageSymbol();

Return Value

See Also

RenderSettings Class


ReadXml Method

[image]

.NET Framework Class Library
RenderSettings..::..ReadXml Method
RenderSettings Class See Also Send Feedback

Reads the RenderSettings properties from an Xml representation

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub ReadXml ( _
    element As XmlElement _
)
C#
public void ReadXml(
    XmlElement element
)
Visual C++
public:
void ReadXml(
    XmlElement^ element
)
JavaScript
function readXml(element);

Parameters

element
Type: System.Xml..::..XmlElement

See Also

RenderSettings Class


WriteXml Method

[image]

.NET Framework Class Library
RenderSettings..::..WriteXml Method
RenderSettings Class See Also Send Feedback

Writes an XML representation of RenderSettings

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
C#
public void WriteXml(
    XmlWriter writer
)
Visual C++
public:
void WriteXml(
    XmlWriter^ writer
)
JavaScript
function writeXml(writer);

Parameters

writer
Type: System.Xml..::..XmlWriter

See Also

RenderSettings Class


RenderSettings Properties

[image] [image]

.NET Framework Class Library
RenderSettings Properties
RenderSettings Class See Also Send Feedback

The RenderSettings type exposes the following members.

Properties

 | Name | Description
Public property | CustomRenderSettings | Gets or sets a ICustomRenderSettings object that should be applied when rendering the shapefile
Public property | DbfReader | Gets the DbfReader of this RenderSettings ShapeFile
Public property | FieldIndex | Gets the zero based field column index of the specifed DBF FieldName
Public property | FieldName | Gets / Sets the name of the Field in the DBF file that will be used when labeling shapes
Public property | FillColor | Gets / Sets the Fill Color to use when rendering the interior of each shape
Public property | FillInterior | Gets / Sets whether to fill the interior of each shape (Polygon)
Public property | Font | Gets / Sets the Font to use when labelling shapes
Public property | FontColor | Gets / Sets the Font Color to use when rendering shape labels
Public property | IsSelectable | Gets / Sets whether the ShapeFile is selectable
Public property | LineDashStyle |
Public property | LineType | Gets / Sets the LineType to use when rending lines (PolyLine and PolyLineM only)
Public property | MaxPixelPenWidth | Gets / Sets the Maximum width of the pen in Pixels.
Public property | MaxZoomLevel | Gets / Sets the Max Zoom level before the layer is not rendered
Public property | MinPixelPenWidth | Gets / Sets the Minimum width of the pen in Pixels.
Public property | MinRenderLabelZoom | Gets / Sets the Minimum Zoom Level before labels will be rendered.
Public property | MinZoomLevel | Gets / Sets the Min Zoom level before the layer is rendered.
Public property | OutlineColor | Gets / Sets the color used to draw the outline of each shape.
Public property | PenWidthScale | Gets / Sets the width of the pen in ShapeFile coordinate units (PolyLines only).
Public property | PointImageSymbol | Gets/Sets the Image Symbol to use for Point records
Public property | PointSize | Gets/Sets the size (in pixels) to use when rendering each point in a Point ShapeFile
Public property | RenderDuplicateFields | Indicates whether or not to render duplicate field names on a polyline shape
Public property | SelectFillColor | Gets / Sets the Fill Color to use when rendering the interior of selected shapes
Public property | SelectOutlineColor | Gets / Sets the color used to draw the outline of selected shapes.
Public property | ShadowText | Gets / Sets whether to use a "Shadow" text effect when labelling shapes
Public property | StringEncoding | Gets/Sets the text encoding used when reading string attribbutes from the shapefile's DBF file
Public property | ToolTipFieldIndex | Gets the zero based field column index of the ToolTipFieldName
Public property | ToolTipFieldName | Gets / Sets the name of the Field in the DBF file that will be used for the ToolTip text
Public property | UseToolTip | Gets / Sets whether to use a ToolTip for the layer

See Also

RenderSettings Class


CustomRenderSettings Property

[image]

.NET Framework Class Library
RenderSettings..::..CustomRenderSettings Property
RenderSettings Class See Also Send Feedback

Gets or sets a ICustomRenderSettings object that should be applied when rendering the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property CustomRenderSettings As ICustomRenderSettings
    Get
    Set
C#
public ICustomRenderSettings CustomRenderSettings { get; set; }
Visual C++
public:
property ICustomRenderSettings^ CustomRenderSettings {
    ICustomRenderSettings^ get ();
    void set (ICustomRenderSettings^ value);
}
JavaScript
function get_customRenderSettings();
function set_customRenderSettings(value);

See Also

RenderSettings Class
EGIS.ShapeFileLib..::..ICustomRenderSettings


DbfReader Property

[image]

.NET Framework Class Library
RenderSettings..::..DbfReader Property
RenderSettings Class See Also Send Feedback

Gets the DbfReader of this RenderSettings ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property DbfReader As DbfReader
    Get
C#
public DbfReader DbfReader { get; }
Visual C++
public:
property DbfReader^ DbfReader {
    DbfReader^ get ();
}
JavaScript
function get_dbfReader();

See Also

RenderSettings Class


FieldIndex Property

[image]

.NET Framework Class Library
RenderSettings..::..FieldIndex Property
RenderSettings Class See Also Send Feedback

Gets the zero based field column index of the specifed DBF FieldName

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property FieldIndex As Integer
    Get
C#
public int FieldIndex { get; }
Visual C++
public:
property int FieldIndex {
    int get ();
}
JavaScript
function get_fieldIndex();

Remarks

If no FieldName is set or FieldName is not in the DBF file Field index returns -1

See Also

RenderSettings Class
RenderSettings..::..FieldName


FieldName Property

[image]

.NET Framework Class Library
RenderSettings..::..FieldName Property
RenderSettings Class See Also Send Feedback

Gets / Sets the name of the Field in the DBF file that will be used when labeling shapes

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FieldName As String
    Get
    Set
C#
public string FieldName { get; set; }
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fieldName();
function set_fieldName(value);

See Also

RenderSettings Class


FillColor Property

[image]

.NET Framework Class Library
RenderSettings..::..FillColor Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Fill Color to use when rendering the interior of each shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FillColor As Color
    Get
    Set
C#
public Color FillColor { get; set; }
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_fillColor();
function set_fillColor(value);

See Also

RenderSettings Class


FillInterior Property

[image]

.NET Framework Class Library
RenderSettings..::..FillInterior Property
RenderSettings Class See Also Send Feedback

Gets / Sets whether to fill the interior of each shape (Polygon)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FillInterior As Boolean
    Get
    Set
C#
public bool FillInterior { get; set; }
Visual C++
public:
property bool FillInterior {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fillInterior();
function set_fillInterior(value);

See Also

RenderSettings Class


Font Property

[image]

.NET Framework Class Library
RenderSettings..::..Font Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Font to use when labelling shapes

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Font As Font
    Get
    Set
C#
public Font Font { get; set; }
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
JavaScript
function get_font();
function set_font(value);

See Also

RenderSettings Class


FontColor Property

[image]

.NET Framework Class Library
RenderSettings..::..FontColor Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Font Color to use when rendering shape labels

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property FontColor As Color
    Get
    Set
C#
public Color FontColor { get; set; }
Visual C++
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_fontColor();
function set_fontColor(value);

See Also

RenderSettings Class


IsSelectable Property

[image]

.NET Framework Class Library
RenderSettings..::..IsSelectable Property
RenderSettings Class See Also Send Feedback

Gets / Sets whether the ShapeFile is selectable

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property IsSelectable As Boolean
    Get
    Set
C#
public bool IsSelectable { get; set; }
Visual C++
public:
property bool IsSelectable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelectable();
function set_isSelectable(value);

See Also

RenderSettings Class


LineDashStyle Property

[image]

.NET Framework Class Library
RenderSettings..::..LineDashStyle Property
RenderSettings Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property LineDashStyle As DashStyle
    Get
    Set
C#
public DashStyle LineDashStyle { get; set; }
Visual C++
public:
property DashStyle LineDashStyle {
    DashStyle get ();
    void set (DashStyle value);
}
JavaScript
function get_lineDashStyle();
function set_lineDashStyle(value);

See Also

RenderSettings Class


LineType Property

[image]

.NET Framework Class Library
RenderSettings..::..LineType Property
RenderSettings Class See Also Send Feedback

Gets / Sets the LineType to use when rending lines (PolyLine and PolyLineM only)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property LineType As LineType
    Get
    Set
C#
public LineType LineType { get; set; }
Visual C++
public:
property LineType LineType {
    LineType get ();
    void set (LineType value);
}
JavaScript
function get_lineType();
function set_lineType(value);

See Also

RenderSettings Class


MaxPixelPenWidth Property

[image]

.NET Framework Class Library
RenderSettings..::..MaxPixelPenWidth Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Maximum width of the pen in Pixels.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property MaxPixelPenWidth As Integer
    Get
    Set
C#
public int MaxPixelPenWidth { get; set; }
Visual C++
public:
property int MaxPixelPenWidth {
    int get ();
    void set (int value);
}
JavaScript
function get_maxPixelPenWidth();
function set_maxPixelPenWidth(value);

Remarks

This settings is only used when rendering PolyLine or PolyLineM ShapeFiles

This property is ignored if its value is set to zero or less.

See Also

RenderSettings Class


MaxZoomLevel Property

[image]

.NET Framework Class Library
RenderSettings..::..MaxZoomLevel Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Max Zoom level before the layer is not rendered

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property MaxZoomLevel As Single
    Get
    Set
C#
public float MaxZoomLevel { get; set; }
Visual C++
public:
property float MaxZoomLevel {
    float get ();
    void set (float value);
}
JavaScript
function get_maxZoomLevel();
function set_maxZoomLevel(value);

Remarks

Use this property in conjunction with MinRenderZoomLevel to control whether a layer is rendered as a map is zoomed in and out

This property will be ignored if it is set to a number less than 0

See Also

RenderSettings Class
RenderSettings..::..MinZoomLevel


MinPixelPenWidth Property

[image]

.NET Framework Class Library
RenderSettings..::..MinPixelPenWidth Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Minimum width of the pen in Pixels.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property MinPixelPenWidth As Integer
    Get
    Set
C#
public int MinPixelPenWidth { get; set; }
Visual C++
public:
property int MinPixelPenWidth {
    int get ();
    void set (int value);
}
JavaScript
function get_minPixelPenWidth();
function set_minPixelPenWidth(value);

Remarks

This settings is only used when rendering PolyLine or PolyLineM ShapeFiles

This property is ignored if its value is set to zero or less.

See Also

RenderSettings Class


MinRenderLabelZoom Property

[image]

.NET Framework Class Library
RenderSettings..::..MinRenderLabelZoom Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Minimum Zoom Level before labels will be rendered.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property MinRenderLabelZoom As Single
    Get
    Set
C#
public float MinRenderLabelZoom { get; set; }
Visual C++
public:
property float MinRenderLabelZoom {
    float get ();
    void set (float value);
}
JavaScript
function get_minRenderLabelZoom();
function set_minRenderLabelZoom(value);

Remarks

If MinRenderLabelZoom is less than zero then this setting is ignored and shape labels will be rendered regardless of the zurent zoom level

See Also

RenderSettings Class


MinZoomLevel Property

[image]

.NET Framework Class Library
RenderSettings..::..MinZoomLevel Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Min Zoom level before the layer is rendered.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property MinZoomLevel As Single
    Get
    Set
C#
public float MinZoomLevel { get; set; }
Visual C++
public:
property float MinZoomLevel {
    float get ();
    void set (float value);
}
JavaScript
function get_minZoomLevel();
function set_minZoomLevel(value);

Remarks

Use this property in conjunction with MaxZoomLevel to control whether a layer is rendered as a map is zoomed in and out.

This property will be ignored if it is set to a number less than 0

See Also

RenderSettings Class
RenderSettings..::..MaxZoomLevel


OutlineColor Property

[image]

.NET Framework Class Library
RenderSettings..::..OutlineColor Property
RenderSettings Class See Also Send Feedback

Gets / Sets the color used to draw the outline of each shape.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property OutlineColor As Color
    Get
    Set
C#
public Color OutlineColor { get; set; }
Visual C++
public:
property Color OutlineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_outlineColor();
function set_outlineColor(value);

See Also

RenderSettings Class


PenWidthScale Property

[image]

.NET Framework Class Library
RenderSettings..::..PenWidthScale Property
RenderSettings Class See Also Send Feedback

Gets / Sets the width of the pen in ShapeFile coordinate units (PolyLines only).

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property PenWidthScale As Single
    Get
    Set
C#
public float PenWidthScale { get; set; }
Visual C++
public:
property float PenWidthScale {
    float get ();
    void set (float value);
}
JavaScript
function get_penWidthScale();
function set_penWidthScale(value);

Remarks

This settings is only used when rendering PolyLine or PolyLineM ShapeFiles

If a ShapeFile is using UTM coords this is the width of the lines in metres.

If a ShapeFile is using Lat Long coordinates this is the width of the line in decimal degrees

This property is set automatically when using the Desktop version of Easy GIS .NET, using a default value of 8m for UTM ShapeFiles. For ShapeFiles using Lat Long coordinates, the decimal degree equivalent of the 8m value is calculated based on teh ShapeFiles Extent

See Also

RenderSettings Class


PointImageSymbol Property

[image]

.NET Framework Class Library
RenderSettings..::..PointImageSymbol Property
RenderSettings Class See Also Send Feedback

Gets/Sets the Image Symbol to use for Point records

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property PointImageSymbol As String
    Get
    Set
C#
public string PointImageSymbol { get; set; }
Visual C++
public:
property String^ PointImageSymbol {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pointImageSymbol();
function set_pointImageSymbol(value);

See Also

RenderSettings Class


PointSize Property

[image]

.NET Framework Class Library
RenderSettings..::..PointSize Property
RenderSettings Class See Also Send Feedback

Gets/Sets the size (in pixels) to use when rendering each point in a Point ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property PointSize As Integer
    Get
    Set
C#
public int PointSize { get; set; }
Visual C++
public:
property int PointSize {
    int get ();
    void set (int value);
}
JavaScript
function get_pointSize();
function set_pointSize(value);

See Also

RenderSettings Class


RenderDuplicateFields Property

[image]

.NET Framework Class Library
RenderSettings..::..RenderDuplicateFields Property
RenderSettings Class See Also Send Feedback

Indicates whether or not to render duplicate field names on a polyline shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property RenderDuplicateFields As Boolean
    Get
    Set
C#
public bool RenderDuplicateFields { get; set; }
Visual C++
public:
property bool RenderDuplicateFields {
    bool get ();
    void set (bool value);
}
JavaScript
function get_renderDuplicateFields();
function set_renderDuplicateFields(value);

See Also

RenderSettings Class


SelectFillColor Property

[image]

.NET Framework Class Library
RenderSettings..::..SelectFillColor Property
RenderSettings Class See Also Send Feedback

Gets / Sets the Fill Color to use when rendering the interior of selected shapes

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property SelectFillColor As Color
    Get
    Set
C#
public Color SelectFillColor { get; set; }
Visual C++
public:
property Color SelectFillColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_selectFillColor();
function set_selectFillColor(value);

See Also

RenderSettings Class


SelectOutlineColor Property

[image]

.NET Framework Class Library
RenderSettings..::..SelectOutlineColor Property
RenderSettings Class See Also Send Feedback

Gets / Sets the color used to draw the outline of selected shapes.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property SelectOutlineColor As Color
    Get
    Set
C#
public Color SelectOutlineColor { get; set; }
Visual C++
public:
property Color SelectOutlineColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_selectOutlineColor();
function set_selectOutlineColor(value);

See Also

RenderSettings Class


ShadowText Property

[image]

.NET Framework Class Library
RenderSettings..::..ShadowText Property
RenderSettings Class See Also Send Feedback

Gets / Sets whether to use a "Shadow" text effect when labelling shapes

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property ShadowText As Boolean
    Get
    Set
C#
public bool ShadowText { get; set; }
Visual C++
public:
property bool ShadowText {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shadowText();
function set_shadowText(value);

See Also

RenderSettings Class


StringEncoding Property

[image]

.NET Framework Class Library
RenderSettings..::..StringEncoding Property
RenderSettings Class See Also Send Feedback

Gets/Sets the text encoding used when reading string attribbutes from the shapefile's DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property StringEncoding As Encoding
    Get
    Set
C#
public Encoding StringEncoding { get; set; }
Visual C++
public:
property Encoding^ StringEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
JavaScript
function get_stringEncoding();
function set_stringEncoding(value);

See Also

RenderSettings Class


ToolTipFieldIndex Property

[image]

.NET Framework Class Library
RenderSettings..::..ToolTipFieldIndex Property
RenderSettings Class See Also Send Feedback

Gets the zero based field column index of the ToolTipFieldName

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property ToolTipFieldIndex As Integer
    Get
C#
public int ToolTipFieldIndex { get; }
Visual C++
public:
property int ToolTipFieldIndex {
    int get ();
}
JavaScript
function get_toolTipFieldIndex();

Remarks

If no FieldName is set or FieldName is not in the DBF file Field index returns -1

See Also

RenderSettings Class
RenderSettings..::..ToolTipFieldName


ToolTipFieldName Property

[image]

.NET Framework Class Library
RenderSettings..::..ToolTipFieldName Property
RenderSettings Class See Also Send Feedback

Gets / Sets the name of the Field in the DBF file that will be used for the ToolTip text

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property ToolTipFieldName As String
    Get
    Set
C#
public string ToolTipFieldName { get; set; }
Visual C++
public:
property String^ ToolTipFieldName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_toolTipFieldName();
function set_toolTipFieldName(value);

See Also

RenderSettings Class


UseToolTip Property

[image]

.NET Framework Class Library
RenderSettings..::..UseToolTip Property
RenderSettings Class See Also Send Feedback

Gets / Sets whether to use a ToolTip for the layer

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property UseToolTip As Boolean
    Get
    Set
C#
public bool UseToolTip { get; set; }
Visual C++
public:
property bool UseToolTip {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useToolTip();
function set_useToolTip(value);

See Also

RenderSettings Class


ShapeFile Class

[image]

.NET Framework Class Library
ShapeFile Class
Members See Also Send Feedback

.NET ShapeFile class used to load, render and query data in an ESRI Shape File. The ShapeFile class is the main class of the EGIS.ShapeFileLib namespace

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class ShapeFile _
    Implements IDisposable
C#
public sealed class ShapeFile : IDisposable
Visual C++
public ref class ShapeFile sealed : IDisposable
JavaScript
EGIS.ShapeFileLib.ShapeFile = function();

Type.createClass(
    'EGIS.ShapeFileLib.ShapeFile',
    null,
    IDisposable);

Remarks

The class is designed to open very large shapefiles, providing a low memory implementation which will not load the contents of the shapefile in memory.

The class also provides an option to map the shapefile in memory using native file mapping, which will provide faster rendering speed

NOTE THAT MANY OF THE METHODS IN THIS CLASS ARE NOT THREAD SAFE (due to internal shared buffers). If multiple threads require access to ShapeFile objects then the static (Shared in VB) Sync object should be used to provide mutual access to the shapefiles

An ESRI Shape File consists of 3 files - the ShapeFile index file (.shx), the shape file (.shp) and a DBF file (.dbf). For a more detailed desription of the ShapeFile format consult the ESRI ShapeFile file specification.

Currently supported Shape Types are Point, PointZ, PolyLine, PolyLineM, Polygon and PolygonZ

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..ShapeFile

See Also

ShapeFile Members


ShapeFile Members

[image] [image]

.NET Framework Class Library
ShapeFile Members
ShapeFile Class Constructors Methods Properties See Also Send Feedback

The ShapeFile type exposes the following members.

Constructors

 | Name | Description
Public method | ShapeFile()()()() | Empty constructor.
Public method | ShapeFile(String) | Constructs a ShapeFile using a path to a .shp shape file

Methods

 | Name | Description
Public method | ClearSelectedRecords | Clears any selected shapefile records
Public method | Close | Closes the underlying stream of the ShapeFile and clears all of the internal data. After calling this method the ShapeFile can no longer be rendered
Public method | Dispose | Disposes of the ShapeFile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActualExtent | Returns the actual ShapeFile Extent in unprojected coordinates
Public method | GetAttributeFieldNames | Gets all of the Attribute Names contained in the shapefile's DBF file
Public method | GetAttributeFieldValues | Gets all of the Attribute values contained in the shapefile's DBF file
Public method | GetClosestShape(PointD, Double) |
Public method | GetClosestShape(PointD, Double, PolylineDistanceInfo%) |
Public method | GetClosestShape(PointD, Double, List<(Of <<'(Int32>)>>), PolylineDistanceInfo%) | returns the index of the closest shape in the given collection of records
Public method | GetClosestShape(PointD, Double, ReadOnlyCollection<(Of <<'(Int32>)>>), PolylineDistanceInfo%) |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecords | Gets all of the records at fieldIndex in the DBF file
Public method | GetShapeBounds | Gets the rectangular bounds of an individual shape in the ShapeFile
Public method | GetShapeBoundsD | Gets the rectangular bounds of an individual shape in the ShapeFile in double precision coordinates
Public method | GetShapeData(Int32) | Gets the raw shape data at given record index.
Public method | GetShapeData(Int32, array<Byte>[]()[][]) | Gets the raw shape data at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeDataD(Int32) | Gets the raw shape data in double precision format at given record index.
Public method | GetShapeDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeExtents | Gets the rectangular extent of each shape in the shapefile
Public method | GetShapeExtentsD | Gets the rectangular extent of each shape in the shapefile in double precision form
Public method | GetShapeFileEnumerator()()()() | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile
Public method | GetShapeFileEnumerator(RectangleD) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting with a given bounds
Public method | GetShapeFileEnumerator(RectangleF, ShapeFileEnumerator..::..IntersectionType) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting or contained within a given bounds
Public method | GetShapeIndexContainingPoint | returns the index of the shape containing Point pt
Public method | GetShapeIndiciesIntersectingCircle |
Public method | GetShapeIndiciesIntersectingRect |
Public method | GetShapeMDataD(Int32) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeMDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeZData(Int32) | Gets the raw shape Z(height) data at given record index.
Public method | GetShapeZData(Int32, array<Byte>[]()[][]) | Gets the raw shape Z(height) data at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeZDataD | Gets the raw shape Z(height) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRecordSelected | returns whether a shapefile record is currently selected
Public method | IsVisibleAtZoomLevel | Checks whether the ShapeFile will be visible if rendered at given zoom level, as determined by the ShapeFile RenderSettings
 | LatLongToProjection | Transforms a point using MercatorProjection
 | LLExtentToProjectedExtent |
 | LLToMercator(PointF) | Utillity method to translate a Lat/Long Point to its Mercator Projection representation.
 | LLToMercator(PointD) | Applys the Mercator projection to a lat long pt and returns the projected point
Public method | LoadFromFile | Loads a ShapeFile using a path to a .shp shape file
Public method | LoadFromFile2 | Loads a ShapeFile using a path to a .shp shape file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MercatorToLL | Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.
 | MercatorToLLF | Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.
 | ProjectionToLatLong | Returns a projected point to its Lat Long equivalent
Public method | ReadXml | Reads and and loads a ShapeFile from Xml representation of the ShapeFile (as output by WriteXml)
Public method | Render(Graphics, Size, PointD, Double, ProjectionType) | Renders the shapefile centered at given point and zoom
Public method | Render(Graphics, Size, PointF, Single, RenderSettings, ProjectionType) | Renders the shapefile centered at given point and zoom
Public method | SelectRecord | Selects or de-selects a shapefile record.
Public method | ShapeIntersectsRect |
Public method | ToString | overridden ToString method (Overrides Object..::..ToString()()()().)
Public method | WriteXml | Writes an Xml representation of the ShapeFile.

Properties

 | Name | Description
Public property | Extent | Gets the Rectangular extent of the shapefile
Public property | FilePath | Gets the path to the ShapeFile, not including the .shp file extension
Public property | IsSelectable | Indicates whether the ShapeFile is selectable.
 | MapFilesInMemory | Gets or Sets whether to map files in memory.
Public property | Name | The name of this ShapeFile.
Public property | RecordCount | Gets the number of records(shapes) in the ShapeFile
 | RenderQuality | Gets or Sets the RenderQuality to use when rendering shapefiles
Public property | RenderSettings | Gets or sets the RenderSettings used by the ShapeFile when Rendering
Public property | SelectedRecordIndices | Returns a collection of all the selected record indices
Public property | ShapeType | Gets the ShapeType of the ShapeFile
 | Sync | Gets an object that can be used to synchronize access to the ShapeFile

See Also

ShapeFile Class


ShapeFile Constructor

[image] [image]

.NET Framework Class Library
ShapeFile Constructor
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShapeFile()()()() | Empty constructor.
Public method | ShapeFile(String) | Constructs a ShapeFile using a path to a .shp shape file

See Also

ShapeFile Class
ShapeFile Members


ShapeFile Constructor

[image]

.NET Framework Class Library
ShapeFile Constructor
ShapeFile Class See Also Send Feedback

Empty constructor.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New
C#
public ShapeFile()
Visual C++
public:
ShapeFile()
JavaScript
EGIS.ShapeFileLib.ShapeFile = function();

Remarks

If a ShapeFile is constructed using the empty constructor then it should be followed by calling Load or ReadXml

See Also

ShapeFile Class
ShapeFile Overload


ShapeFile Constructor (String)

[image]

.NET Framework Class Library
ShapeFile Constructor (String)
ShapeFile Class See Also Send Feedback

Constructs a ShapeFile using a path to a .shp shape file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    shapeFilePath As String _
)
C#
public ShapeFile(
    string shapeFilePath
)
Visual C++
public:
ShapeFile(
    String^ shapeFilePath
)
JavaScript
EGIS.ShapeFileLib.ShapeFile = function(shapeFilePath);

Parameters

shapeFilePath
Type: System..::..String
The path to the ".shp" shape file

See Also

ShapeFile Class
ShapeFile Overload


ShapeFile Methods

[image] [image]

.NET Framework Class Library
ShapeFile Methods
ShapeFile Class See Also Send Feedback

The ShapeFile type exposes the following members.

Methods

 | Name | Description
Public method | ClearSelectedRecords | Clears any selected shapefile records
Public method | Close | Closes the underlying stream of the ShapeFile and clears all of the internal data. After calling this method the ShapeFile can no longer be rendered
Public method | Dispose | Disposes of the ShapeFile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActualExtent | Returns the actual ShapeFile Extent in unprojected coordinates
Public method | GetAttributeFieldNames | Gets all of the Attribute Names contained in the shapefile's DBF file
Public method | GetAttributeFieldValues | Gets all of the Attribute values contained in the shapefile's DBF file
Public method | GetClosestShape(PointD, Double) |
Public method | GetClosestShape(PointD, Double, PolylineDistanceInfo%) |
Public method | GetClosestShape(PointD, Double, List<(Of <<'(Int32>)>>), PolylineDistanceInfo%) | returns the index of the closest shape in the given collection of records
Public method | GetClosestShape(PointD, Double, ReadOnlyCollection<(Of <<'(Int32>)>>), PolylineDistanceInfo%) |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecords | Gets all of the records at fieldIndex in the DBF file
Public method | GetShapeBounds | Gets the rectangular bounds of an individual shape in the ShapeFile
Public method | GetShapeBoundsD | Gets the rectangular bounds of an individual shape in the ShapeFile in double precision coordinates
Public method | GetShapeData(Int32) | Gets the raw shape data at given record index.
Public method | GetShapeData(Int32, array<Byte>[]()[][]) | Gets the raw shape data at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeDataD(Int32) | Gets the raw shape data in double precision format at given record index.
Public method | GetShapeDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeExtents | Gets the rectangular extent of each shape in the shapefile
Public method | GetShapeExtentsD | Gets the rectangular extent of each shape in the shapefile in double precision form
Public method | GetShapeFileEnumerator()()()() | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile
Public method | GetShapeFileEnumerator(RectangleD) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting with a given bounds
Public method | GetShapeFileEnumerator(RectangleF, ShapeFileEnumerator..::..IntersectionType) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting or contained within a given bounds
Public method | GetShapeIndexContainingPoint | returns the index of the shape containing Point pt
Public method | GetShapeIndiciesIntersectingCircle |
Public method | GetShapeIndiciesIntersectingRect |
Public method | GetShapeMDataD(Int32) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeMDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeZData(Int32) | Gets the raw shape Z(height) data at given record index.
Public method | GetShapeZData(Int32, array<Byte>[]()[][]) | Gets the raw shape Z(height) data at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeZDataD | Gets the raw shape Z(height) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRecordSelected | returns whether a shapefile record is currently selected
Public method | IsVisibleAtZoomLevel | Checks whether the ShapeFile will be visible if rendered at given zoom level, as determined by the ShapeFile RenderSettings
 | LatLongToProjection | Transforms a point using MercatorProjection
 | LLExtentToProjectedExtent |
 | LLToMercator(PointF) | Utillity method to translate a Lat/Long Point to its Mercator Projection representation.
 | LLToMercator(PointD) | Applys the Mercator projection to a lat long pt and returns the projected point
Public method | LoadFromFile | Loads a ShapeFile using a path to a .shp shape file
Public method | LoadFromFile2 | Loads a ShapeFile using a path to a .shp shape file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MercatorToLL | Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.
 | MercatorToLLF | Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.
 | ProjectionToLatLong | Returns a projected point to its Lat Long equivalent
Public method | ReadXml | Reads and and loads a ShapeFile from Xml representation of the ShapeFile (as output by WriteXml)
Public method | Render(Graphics, Size, PointD, Double, ProjectionType) | Renders the shapefile centered at given point and zoom
Public method | Render(Graphics, Size, PointF, Single, RenderSettings, ProjectionType) | Renders the shapefile centered at given point and zoom
Public method | SelectRecord | Selects or de-selects a shapefile record.
Public method | ShapeIntersectsRect |
Public method | ToString | overridden ToString method (Overrides Object..::..ToString()()()().)
Public method | WriteXml | Writes an Xml representation of the ShapeFile.

See Also

ShapeFile Class


ClearSelectedRecords Method

[image]

.NET Framework Class Library
ShapeFile..::..ClearSelectedRecords Method
ShapeFile Class See Also Send Feedback

Clears any selected shapefile records

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub ClearSelectedRecords
C#
public void ClearSelectedRecords()
Visual C++
public:
void ClearSelectedRecords()
JavaScript
function clearSelectedRecords();

See Also

ShapeFile Class


Close Method

[image]

.NET Framework Class Library
ShapeFile..::..Close Method
ShapeFile Class See Also Send Feedback

Closes the underlying stream of the ShapeFile and clears all of the internal data. After calling this method the ShapeFile can no longer be rendered

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

See Also

ShapeFile Class


Dispose Method

[image]

.NET Framework Class Library
ShapeFile..::..Dispose Method
ShapeFile Class See Also Send Feedback

Disposes of the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

ShapeFile Class


GetActualExtent Method

[image]

.NET Framework Class Library
ShapeFile..::..GetActualExtent Method
ShapeFile Class See Also Send Feedback

Returns the actual ShapeFile Extent in unprojected coordinates

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetActualExtent As RectangleF
C#
public RectangleF GetActualExtent()
Visual C++
public:
RectangleF GetActualExtent()
JavaScript
function getActualExtent();

Return Value

Remarks

The returned rectanlge is the extent contained in the shapefile's header

See Also

ShapeFile Class


GetAttributeFieldNames Method

[image]

.NET Framework Class Library
ShapeFile..::..GetAttributeFieldNames Method
ShapeFile Class See Also Send Feedback

Gets all of the Attribute Names contained in the shapefile's DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetAttributeFieldNames As String()
C#
public string[] GetAttributeFieldNames()
Visual C++
public:
array<String^>^ GetAttributeFieldNames()
JavaScript
function getAttributeFieldNames();

Return Value

See Also

ShapeFile Class


GetAttributeFieldValues Method

[image]

.NET Framework Class Library
ShapeFile..::..GetAttributeFieldValues Method
ShapeFile Class See Also Send Feedback

Gets all of the Attribute values contained in the shapefile's DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetAttributeFieldValues ( _
    recordNumber As Integer _
) As String()
C#
public string[] GetAttributeFieldValues(
    int recordNumber
)
Visual C++
public:
array<String^>^ GetAttributeFieldValues(
    int recordNumber
)
JavaScript
function getAttributeFieldValues(recordNumber);

Parameters

recordNumber
Type: System..::..Int32
zero based index of the required record/shape

Return Value

See Also

ShapeFile Class


GetClosestShape Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetClosestShape Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetClosestShape(PointD, Double) |
Public method | GetClosestShape(PointD, Double, PolylineDistanceInfo%) |
Public method | GetClosestShape(PointD, Double, List<(Of <<'(Int32>)>>), PolylineDistanceInfo%) | returns the index of the closest shape in the given collection of records
Public method | GetClosestShape(PointD, Double, ReadOnlyCollection<(Of <<'(Int32>)>>), PolylineDistanceInfo%) |

See Also

ShapeFile Class
ShapeFile Members


GetClosestShape Method (PointD, Double)

[image]

.NET Framework Class Library
ShapeFile..::..GetClosestShape Method (PointD, Double)
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetClosestShape ( _
    centre As PointD, _
    radius As Double _
) As Integer
C#
public int GetClosestShape(
    PointD centre,
    double radius
)
Visual C++
public:
int GetClosestShape(
    PointD centre,
    double radius
)
JavaScript
function getClosestShape(centre, radius);

Parameters

centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double

See Also

ShapeFile Class
GetClosestShape Overload


GetClosestShape Method (PointD, Double, PolylineDistanceInfo)

[image]

.NET Framework Class Library
ShapeFile..::..GetClosestShape Method (PointD, Double, PolylineDistanceInfo%)
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetClosestShape ( _
    centre As PointD, _
    radius As Double, _
    <OutAttribute> ByRef polylineDistanceInfo As PolylineDistanceInfo _
) As Integer
C#
public int GetClosestShape(
    PointD centre,
    double radius,
    out PolylineDistanceInfo polylineDistanceInfo
)
Visual C++
public:
int GetClosestShape(
    PointD centre,
    double radius,
    [OutAttribute] PolylineDistanceInfo% polylineDistanceInfo
)
JavaScript
function getClosestShape(centre, radius, polylineDistanceInfo);

Parameters

centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double
polylineDistanceInfo
Type: EGIS.ShapeFileLib..::..PolylineDistanceInfo %

See Also

ShapeFile Class
GetClosestShape Overload


GetClosestShape Method (PointD, Double, List(Int32), PolylineDistanceInfo)

[image]

.NET Framework Class Library
ShapeFile..::..GetClosestShape Method (PointD, Double, List<(Of <(<'Int32>)>)>, PolylineDistanceInfo%)
ShapeFile Class See Also Send Feedback

returns the index of the closest shape in the given collection of records

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetClosestShape ( _
    centre As PointD, _
    radius As Double, _
    recordIndices As List(Of Integer), _
    <OutAttribute> ByRef polylineDistanceInfo As PolylineDistanceInfo _
) As Integer
C#
public int GetClosestShape(
    PointD centre,
    double radius,
    List<int> recordIndices,
    out PolylineDistanceInfo polylineDistanceInfo
)
Visual C++
public:
int GetClosestShape(
    PointD centre,
    double radius,
    List<int>^ recordIndices,
    [OutAttribute] PolylineDistanceInfo% polylineDistanceInfo
)
JavaScript
function getClosestShape(centre, radius, recordIndices, polylineDistanceInfo);

Parameters

centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double
recordIndices
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
polylineDistanceInfo
Type: EGIS.ShapeFileLib..::..PolylineDistanceInfo %

Return Value

See Also

ShapeFile Class
GetClosestShape Overload


GetClosestShape Method (PointD, Double, ReadOnlyCollection(Int32), PolylineDistanceInfo)

[image]

.NET Framework Class Library
ShapeFile..::..GetClosestShape Method (PointD, Double, ReadOnlyCollection<(Of <(<'Int32>)>)>, PolylineDistanceInfo%)
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetClosestShape ( _
    centre As PointD, _
    radius As Double, _
    recordIndices As ReadOnlyCollection(Of Integer), _
    <OutAttribute> ByRef polylineDistanceInfo As PolylineDistanceInfo _
) As Integer
C#
public int GetClosestShape(
    PointD centre,
    double radius,
    ReadOnlyCollection<int> recordIndices,
    out PolylineDistanceInfo polylineDistanceInfo
)
Visual C++
public:
int GetClosestShape(
    PointD centre,
    double radius,
    ReadOnlyCollection<int>^ recordIndices,
    [OutAttribute] PolylineDistanceInfo% polylineDistanceInfo
)
JavaScript
function getClosestShape(centre, radius, recordIndices, polylineDistanceInfo);

Parameters

centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double
recordIndices
Type: System.Collections.ObjectModel..::..ReadOnlyCollection <(Of <(<' Int32 >)>)>
polylineDistanceInfo
Type: EGIS.ShapeFileLib..::..PolylineDistanceInfo %

See Also

ShapeFile Class
GetClosestShape Overload


GetRecords Method

[image]

.NET Framework Class Library
ShapeFile..::..GetRecords Method
ShapeFile Class See Also Send Feedback

Gets all of the records at fieldIndex in the DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetRecords ( _
    fieldIndex As Integer _
) As String()
C#
public string[] GetRecords(
    int fieldIndex
)
Visual C++
public:
array<String^>^ GetRecords(
    int fieldIndex
)
JavaScript
function getRecords(fieldIndex);

Parameters

fieldIndex
Type: System..::..Int32
zero based index of the required field

Return Value

See Also

ShapeFile Class


GetShapeBounds Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeBounds Method
ShapeFile Class See Also Send Feedback

Gets the rectangular bounds of an individual shape in the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeBounds ( _
    recordIndex As Integer _
) As RectangleF
C#
public RectangleF GetShapeBounds(
    int recordIndex
)
Visual C++
public:
RectangleF GetShapeBounds(
    int recordIndex
)
JavaScript
function getShapeBounds(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
Zero based index of shape bounds to return

Return Value

See Also

ShapeFile Class


GetShapeBoundsD Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeBoundsD Method
ShapeFile Class See Also Send Feedback

Gets the rectangular bounds of an individual shape in the ShapeFile in double precision coordinates

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeBoundsD ( _
    recordIndex As Integer _
) As RectangleD
C#
public RectangleD GetShapeBoundsD(
    int recordIndex
)
Visual C++
public:
RectangleD GetShapeBoundsD(
    int recordIndex
)
JavaScript
function getShapeBoundsD(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
Zero based index of shape bounds to return

Return Value

See Also

ShapeFile Class


GetShapeData Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetShapeData Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShapeData(Int32) | Gets the raw shape data at given record index.
Public method | GetShapeData(Int32, array<Byte>[]()[][]) | Gets the raw shape data at given record index, using a supplied dataBuffer to read the data.

See Also

ShapeFile Class
ShapeFile Members


GetShapeData Method (Int32)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeData Method (Int32)
ShapeFile Class See Also Send Feedback

Gets the raw shape data at given record index.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeData ( _
    recordIndex As Integer _
) As ReadOnlyCollection(Of PointF())
C#
public ReadOnlyCollection<PointF[]> GetShapeData(
    int recordIndex
)
Visual C++
public:
ReadOnlyCollection<array<PointF>^>^ GetShapeData(
    int recordIndex
)
JavaScript
function getShapeData(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

See Also

ShapeFile Class
GetShapeData Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeData Method (Int32, Byte[])

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeData Method (Int32, array<Byte>[]()[][])
ShapeFile Class See Also Send Feedback

Gets the raw shape data at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeData ( _
    recordIndex As Integer, _
    dataBuffer As Byte() _
) As ReadOnlyCollection(Of PointF())
C#
public ReadOnlyCollection<PointF[]> GetShapeData(
    int recordIndex,
    byte[] dataBuffer
)
Visual C++
public:
ReadOnlyCollection<array<PointF>^>^ GetShapeData(
    int recordIndex,
    array<unsigned char>^ dataBuffer
)
JavaScript
function getShapeData(recordIndex, dataBuffer);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return
dataBuffer
Type: array< System..::..Byte >[]()[][]
A supplied data buffer to use when reading the raw shape data from the shapefile. The buffer must be large enough to read the raw shape data.

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

See Also

ShapeFile Class
GetShapeData Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeDataD Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetShapeDataD Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShapeDataD(Int32) | Gets the raw shape data in double precision format at given record index.
Public method | GetShapeDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape data in double precision format at given record index, using a supplied dataBuffer to read the data.

See Also

ShapeFile Class
ShapeFile Members


GetShapeDataD Method (Int32)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeDataD Method (Int32)
ShapeFile Class See Also Send Feedback

Gets the raw shape data in double precision format at given record index.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeDataD ( _
    recordIndex As Integer _
) As ReadOnlyCollection(Of PointD())
C#
public ReadOnlyCollection<PointD[]> GetShapeDataD(
    int recordIndex
)
Visual C++
public:
ReadOnlyCollection<array<PointD>^>^ GetShapeDataD(
    int recordIndex
)
JavaScript
function getShapeDataD(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

See Also

ShapeFile Class
GetShapeDataD Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeDataD Method (Int32, Byte[])

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeDataD Method (Int32, array<Byte>[]()[][])
ShapeFile Class See Also Send Feedback

Gets the raw shape data in double precision format at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeDataD ( _
    recordIndex As Integer, _
    dataBuffer As Byte() _
) As ReadOnlyCollection(Of PointD())
C#
public ReadOnlyCollection<PointD[]> GetShapeDataD(
    int recordIndex,
    byte[] dataBuffer
)
Visual C++
public:
ReadOnlyCollection<array<PointD>^>^ GetShapeDataD(
    int recordIndex,
    array<unsigned char>^ dataBuffer
)
JavaScript
function getShapeDataD(recordIndex, dataBuffer);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return
dataBuffer
Type: array< System..::..Byte >[]()[][]
A supplied data buffer to use when reading the raw shape data from the shapefile. The buffer must be large enough to read the raw shape data.

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

See Also

ShapeFile Class
GetShapeDataD Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeExtents Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeExtents Method
ShapeFile Class See Also Send Feedback

Gets the rectangular extent of each shape in the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeExtents As RectangleF()
C#
public RectangleF[] GetShapeExtents()
Visual C++
public:
array<RectangleF>^ GetShapeExtents()
JavaScript
function getShapeExtents();

Return Value

RectangleF[] representing the extent of each shape in the shapefile

See Also

ShapeFile Class


GetShapeExtentsD Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeExtentsD Method
ShapeFile Class See Also Send Feedback

Gets the rectangular extent of each shape in the shapefile in double precision form

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeExtentsD As RectangleD()
C#
public RectangleD[] GetShapeExtentsD()
Visual C++
public:
array<RectangleD>^ GetShapeExtentsD()
JavaScript
function getShapeExtentsD();

Return Value

RectangleD[] representing the extent of each shape in the shapefile

See Also

ShapeFile Class


GetShapeFileEnumerator Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetShapeFileEnumerator Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShapeFileEnumerator()()()() | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile
Public method | GetShapeFileEnumerator(RectangleD) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting with a given bounds
Public method | GetShapeFileEnumerator(RectangleF, ShapeFileEnumerator..::..IntersectionType) | Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting or contained within a given bounds

See Also

ShapeFile Class
ShapeFile Members


GetShapeFileEnumerator Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeFileEnumerator Method
ShapeFile Class See Also Send Feedback

Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeFileEnumerator As ShapeFileEnumerator
C#
public ShapeFileEnumerator GetShapeFileEnumerator()
Visual C++
public:
ShapeFileEnumerator^ GetShapeFileEnumerator()
JavaScript
function getShapeFileEnumerator();

Return Value

See Also

ShapeFile Class
GetShapeFileEnumerator Overload


GetShapeFileEnumerator Method (RectangleD)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeFileEnumerator Method (RectangleD)
ShapeFile Class See Also Send Feedback

Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting with a given bounds

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeFileEnumerator ( _
    extents As RectangleD _
) As ShapeFileEnumerator
C#
public ShapeFileEnumerator GetShapeFileEnumerator(
    RectangleD extents
)
Visual C++
public:
ShapeFileEnumerator^ GetShapeFileEnumerator(
    RectangleD extents
)
JavaScript
function getShapeFileEnumerator(extents);

Parameters

extents
Type: EGIS.ShapeFileLib..::..RectangleD
extents defines the area that returned shapes must intersect with.If this is RectangleF.Empty then no recrods will be returned

Return Value

See Also

ShapeFile Class
GetShapeFileEnumerator Overload


GetShapeFileEnumerator Method (RectangleF, ShapeFileEnumerator.IntersectionType)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeFileEnumerator Method (RectangleF, ShapeFileEnumerator..::..IntersectionType)
ShapeFile Class See Also Send Feedback

Gets a ShapeFileEnumerator, which can be used to enumerate over all of the records in the ShapeFile, intersecting or contained within a given bounds

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeFileEnumerator ( _
    extent As RectangleF, _
    intersectionType As ShapeFileEnumerator..::..IntersectionType _
) As ShapeFileEnumerator
C#
public ShapeFileEnumerator GetShapeFileEnumerator(
    RectangleF extent,
    ShapeFileEnumerator..::..IntersectionType intersectionType
)
Visual C++
public:
ShapeFileEnumerator^ GetShapeFileEnumerator(
    RectangleF extent,
    ShapeFileEnumerator..::..IntersectionType intersectionType
)
JavaScript
function getShapeFileEnumerator(extent, intersectionType);

Parameters

extent
Type: System.Drawing..::..RectangleF
Defines the area that returned shapes must intersect with or be contained by. If this is RectangleF.Empty then no recrods will be returned
intersectionType
Type: EGIS.ShapeFileLib..::..ShapeFileEnumerator..::..IntersectionType
Indicates whether shapes must intersect with or be contained by extent

Return Value

See Also

ShapeFile Class
GetShapeFileEnumerator Overload


GetShapeIndexContainingPoint Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeIndexContainingPoint Method
ShapeFile Class See Also Send Feedback

returns the index of the shape containing Point pt

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeIndexContainingPoint ( _
    pt As PointD, _
    minDistance As Double _
) As Integer
C#
public int GetShapeIndexContainingPoint(
    PointD pt,
    double minDistance
)
Visual C++
public:
int GetShapeIndexContainingPoint(
    PointD pt,
    double minDistance
)
JavaScript
function getShapeIndexContainingPoint(pt, minDistance);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The location of the point (in the shapefile's coordinates)
minDistance
Type: System..::..Double
the min distance (in ShapeFile coordinates) between pt and a shape when searching point or line shapes that will return a "hit".

Return Value

zero based index of the shape containing pt or -1 if no shape contains the point

Remarks

When searching in a Point ShapeFile a point will be defined as contining pt if the distance between the found point and pt is less than or equal to minDistance

When searching in a PolyLine ShapeFile a Line will be defined as containing the point if the distance between a line segment in the found shape and pt is less than or equal to minDistance

See Also

ShapeFile Class


GetShapeIndiciesIntersectingCircle Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeIndiciesIntersectingCircle Method
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub GetShapeIndiciesIntersectingCircle ( _
    indicies As List(Of Integer), _
    centre As PointD, _
    radius As Double _
)
C#
public void GetShapeIndiciesIntersectingCircle(
    List<int> indicies,
    PointD centre,
    double radius
)
Visual C++
public:
void GetShapeIndiciesIntersectingCircle(
    List<int>^ indicies,
    PointD centre,
    double radius
)
JavaScript
function getShapeIndiciesIntersectingCircle(indicies, centre, radius);

Parameters

indicies
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
centre
Type: EGIS.ShapeFileLib..::..PointD
radius
Type: System..::..Double

See Also

ShapeFile Class


GetShapeIndiciesIntersectingRect Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeIndiciesIntersectingRect Method
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub GetShapeIndiciesIntersectingRect ( _
    indicies As List(Of Integer), _
    rect As RectangleD _
)
C#
public void GetShapeIndiciesIntersectingRect(
    List<int> indicies,
    RectangleD rect
)
Visual C++
public:
void GetShapeIndiciesIntersectingRect(
    List<int>^ indicies,
    RectangleD rect
)
JavaScript
function getShapeIndiciesIntersectingRect(indicies, rect);

Parameters

indicies
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
rect
Type: EGIS.ShapeFileLib..::..RectangleD

See Also

ShapeFile Class


GetShapeMDataD Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetShapeMDataD Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShapeMDataD(Int32) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.
Public method | GetShapeMDataD(Int32, array<Byte>[]()[][]) | Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.

See Also

ShapeFile Class
ShapeFile Members


GetShapeMDataD Method (Int32)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeMDataD Method (Int32)
ShapeFile Class See Also Send Feedback

Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeMDataD ( _
    recordIndex As Integer _
) As ReadOnlyCollection(Of Double())
C#
public ReadOnlyCollection<double[]> GetShapeMDataD(
    int recordIndex
)
Visual C++
public:
ReadOnlyCollection<array<double>^>^ GetShapeMDataD(
    int recordIndex
)
JavaScript
function getShapeMDataD(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return

Return Value

See Also

ShapeFile Class
GetShapeMDataD Overload


GetShapeMDataD Method (Int32, Byte[])

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeMDataD Method (Int32, array<Byte>[]()[][])
ShapeFile Class See Also Send Feedback

Gets the raw shape M(Measures) data in double precision format at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeMDataD ( _
    recordIndex As Integer, _
    dataBuffer As Byte() _
) As ReadOnlyCollection(Of Double())
C#
public ReadOnlyCollection<double[]> GetShapeMDataD(
    int recordIndex,
    byte[] dataBuffer
)
Visual C++
public:
ReadOnlyCollection<array<double>^>^ GetShapeMDataD(
    int recordIndex,
    array<unsigned char>^ dataBuffer
)
JavaScript
function getShapeMDataD(recordIndex, dataBuffer);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return
dataBuffer
Type: array< System..::..Byte >[]()[][]
A supplied data buffer to use when reading the raw shape data from the shapefile. The buffer must be large enough to read the raw shape data.

Return Value

See Also

ShapeFile Class
GetShapeMDataD Overload


GetShapeZData Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..GetShapeZData Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShapeZData(Int32) | Gets the raw shape Z(height) data at given record index.
Public method | GetShapeZData(Int32, array<Byte>[]()[][]) | Gets the raw shape Z(height) data at given record index, using a supplied dataBuffer to read the data.

See Also

ShapeFile Class
ShapeFile Members


GetShapeZData Method (Int32)

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeZData Method (Int32)
ShapeFile Class See Also Send Feedback

Gets the raw shape Z(height) data at given record index.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeZData ( _
    recordIndex As Integer _
) As ReadOnlyCollection(Of Single())
C#
public ReadOnlyCollection<float[]> GetShapeZData(
    int recordIndex
)
Visual C++
public:
ReadOnlyCollection<array<float>^>^ GetShapeZData(
    int recordIndex
)
JavaScript
function getShapeZData(recordIndex);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

If the shapefile does not contain any Z values then this method will return null

See Also

ShapeFile Class
GetShapeZData Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeZData Method (Int32, Byte[])

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeZData Method (Int32, array<Byte>[]()[][])
ShapeFile Class See Also Send Feedback

Gets the raw shape Z(height) data at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeZData ( _
    recordIndex As Integer, _
    dataBuffer As Byte() _
) As ReadOnlyCollection(Of Single())
C#
public ReadOnlyCollection<float[]> GetShapeZData(
    int recordIndex,
    byte[] dataBuffer
)
Visual C++
public:
ReadOnlyCollection<array<float>^>^ GetShapeZData(
    int recordIndex,
    array<unsigned char>^ dataBuffer
)
JavaScript
function getShapeZData(recordIndex, dataBuffer);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return
dataBuffer
Type: array< System..::..Byte >[]()[][]
A supplied data buffer to use when reading the raw shape data from the shapefile. The buffer must be large enough to read the raw shape data.

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

If the shapefile does not contain any Z values then this method will return null

See Also

ShapeFile Class
GetShapeZData Overload
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


GetShapeZDataD Method

[image]

.NET Framework Class Library
ShapeFile..::..GetShapeZDataD Method
ShapeFile Class See Also Send Feedback

Gets the raw shape Z(height) data in double precision format at given record index, using a supplied dataBuffer to read the data.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetShapeZDataD ( _
    recordIndex As Integer, _
    dataBuffer As Byte() _
) As ReadOnlyCollection(Of Double())
C#
public ReadOnlyCollection<double[]> GetShapeZDataD(
    int recordIndex,
    byte[] dataBuffer
)
Visual C++
public:
ReadOnlyCollection<array<double>^>^ GetShapeZDataD(
    int recordIndex,
    array<unsigned char>^ dataBuffer
)
JavaScript
function getShapeZDataD(recordIndex, dataBuffer);

Parameters

recordIndex
Type: System..::..Int32
The zero based index of the shape data to return
dataBuffer
Type: array< System..::..Byte >[]()[][]
A supplied data buffer to use when reading the raw shape data from the shapefile. The buffer must be large enough to read the raw shape data.

Return Value

Remarks

If you are reading every record in a large shape file then the preferred method is to call GetShapeFileEnumerator

If the shapefile does not contain any Z values then this method will return null

See Also

ShapeFile Class
EGIS.ShapeFileLib Namespace
ShapeFile..::..GetShapeFileEnumerator()()()()


IsRecordSelected Method

[image]

.NET Framework Class Library
ShapeFile..::..IsRecordSelected Method
ShapeFile Class See Also Send Feedback

returns whether a shapefile record is currently selected

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function IsRecordSelected ( _
    index As Integer _
) As Boolean
C#
public bool IsRecordSelected(
    int index
)
Visual C++
public:
bool IsRecordSelected(
    int index
)
JavaScript
function isRecordSelected(index);

Parameters

index
Type: System..::..Int32
zero based index of the shapefile record to query

Return Value

See Also

ShapeFile Class


IsVisibleAtZoomLevel Method

[image]

.NET Framework Class Library
ShapeFile..::..IsVisibleAtZoomLevel Method
ShapeFile Class See Also Send Feedback

Checks whether the ShapeFile will be visible if rendered at given zoom level, as determined by the ShapeFile RenderSettings

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function IsVisibleAtZoomLevel ( _
    zoom As Single _
) As Boolean
C#
public bool IsVisibleAtZoomLevel(
    float zoom
)
Visual C++
public:
bool IsVisibleAtZoomLevel(
    float zoom
)
JavaScript
function isVisibleAtZoomLevel(zoom);

Parameters

zoom
Type: System..::..Single

Return Value

See Also

ShapeFile Class


LatLongToProjection Method

[image]

.NET Framework Class Library
ShapeFile..::..LatLongToProjection Method
ShapeFile Class See Also Send Feedback

Transforms a point using MercatorProjection

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LatLongToProjection ( _
    latLong As PointD _
) As PointD
C#
public static PointD LatLongToProjection(
    PointD latLong
)
Visual C++
public:
static PointD LatLongToProjection(
    PointD latLong
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.latLongToProjection = function(latLong);

Parameters

latLong
Type: EGIS.ShapeFileLib..::..PointD

Return Value

Remarks

If UseMercatorProjection is true then the returned point is transformed using MercatorProjection

If UseMercatorProjection is false then latLong will be returned (no transformation is performed)

See Also

ShapeFile Class


LLExtentToProjectedExtent Method

[image]

.NET Framework Class Library
ShapeFile..::..LLExtentToProjectedExtent Method
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLExtentToProjectedExtent ( _
    rectLL As RectangleD, _
    projectionType As ProjectionType _
) As RectangleD
C#
public static RectangleD LLExtentToProjectedExtent(
    RectangleD rectLL,
    ProjectionType projectionType
)
Visual C++
public:
static RectangleD LLExtentToProjectedExtent(
    RectangleD rectLL,
    ProjectionType projectionType
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.llExtentToProjectedExtent = function(rectLL, projectionType);

Parameters

rectLL
Type: EGIS.ShapeFileLib..::..RectangleD
projectionType
Type: EGIS.ShapeFileLib..::..ProjectionType

See Also

ShapeFile Class


LLToMercator Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..LLToMercator Method
ShapeFile Class See Also Send Feedback

Overload List

Name | Description
LLToMercator(PointF) | Utillity method to translate a Lat/Long Point to its Mercator Projection representation.
LLToMercator(PointD) | Applys the Mercator projection to a lat long pt and returns the projected point

See Also

ShapeFile Class
ShapeFile Members


LLToMercator Method (PointF)

[image]

.NET Framework Class Library
ShapeFile..::..LLToMercator Method (PointF)
ShapeFile Class See Also Send Feedback

Utillity method to translate a Lat/Long Point to its Mercator Projection representation.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLToMercator ( _
    pt As PointF _
) As PointF
C#
public static PointF LLToMercator(
    PointF pt
)
Visual C++
public:
static PointF LLToMercator(
    PointF pt
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.llToMercator = function(pt);

Parameters

pt
Type: System.Drawing..::..PointF

See Also

ShapeFile Class
LLToMercator Overload


LLToMercator Method (PointD)

[image]

.NET Framework Class Library
ShapeFile..::..LLToMercator Method (PointD)
ShapeFile Class See Also Send Feedback

Applys the Mercator projection to a lat long pt and returns the projected point

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function LLToMercator ( _
    pt As PointD _
) As PointD
C#
public static PointD LLToMercator(
    PointD pt
)
Visual C++
public:
static PointD LLToMercator(
    PointD pt
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.llToMercator = function(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

Return Value

See Also

ShapeFile Class
LLToMercator Overload


LoadFromFile Method

[image]

.NET Framework Class Library
ShapeFile..::..LoadFromFile Method
ShapeFile Class See Also Send Feedback

Loads a ShapeFile using a path to a .shp shape file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub LoadFromFile ( _
    shapeFilePath As String _
)
C#
public void LoadFromFile(
    string shapeFilePath
)
Visual C++
public:
void LoadFromFile(
    String^ shapeFilePath
)
JavaScript
function loadFromFile(shapeFilePath);

Parameters

shapeFilePath
Type: System..::..String
The path to the ".shp" shape file

See Also

ShapeFile Class


LoadFromFile2 Method

[image]

.NET Framework Class Library
ShapeFile..::..LoadFromFile2 Method
ShapeFile Class See Also Send Feedback

Loads a ShapeFile using a path to a .shp shape file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub LoadFromFile2 ( _
    shapeFilePath As String _
)
C#
public void LoadFromFile2(
    string shapeFilePath
)
Visual C++
public:
void LoadFromFile2(
    String^ shapeFilePath
)
JavaScript
function loadFromFile2(shapeFilePath);

Parameters

shapeFilePath
Type: System..::..String
The path to the ".shp" shape file

See Also

ShapeFile Class


MercatorToLL Method

[image]

.NET Framework Class Library
ShapeFile..::..MercatorToLL Method
ShapeFile Class See Also Send Feedback

Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function MercatorToLL ( _
    pt As PointD _
) As PointD
C#
public static PointD MercatorToLL(
    PointD pt
)
Visual C++
public:
static PointD MercatorToLL(
    PointD pt
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.mercatorToLL = function(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD

See Also

ShapeFile Class


MercatorToLLF Method

[image]

.NET Framework Class Library
ShapeFile..::..MercatorToLLF Method
ShapeFile Class See Also Send Feedback

Utillity method to translate a Point using a Mercator Projection t its Lat/Long representation.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function MercatorToLLF ( _
    pt As PointF _
) As PointF
C#
public static PointF MercatorToLLF(
    PointF pt
)
Visual C++
public:
static PointF MercatorToLLF(
    PointF pt
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.mercatorToLLF = function(pt);

Parameters

pt
Type: System.Drawing..::..PointF

See Also

ShapeFile Class


ProjectionToLatLong Method

[image]

.NET Framework Class Library
ShapeFile..::..ProjectionToLatLong Method
ShapeFile Class See Also Send Feedback

Returns a projected point to its Lat Long equivalent

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ProjectionToLatLong ( _
    projPoint As PointD _
) As PointD
C#
public static PointD ProjectionToLatLong(
    PointD projPoint
)
Visual C++
public:
static PointD ProjectionToLatLong(
    PointD projPoint
)
JavaScript
EGIS.ShapeFileLib.ShapeFile.projectionToLatLong = function(projPoint);

Parameters

projPoint
Type: EGIS.ShapeFileLib..::..PointD

Return Value

Remarks

If UseMercatorProjection is true then returned point will be transformed to Lat Long.

If UseMercatorProjection is false then projPoint is returned

See Also

ShapeFile Class


ReadXml Method

[image]

.NET Framework Class Library
ShapeFile..::..ReadXml Method
ShapeFile Class See Also Send Feedback

Reads and and loads a ShapeFile from Xml representation of the ShapeFile (as output by WriteXml)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub ReadXml ( _
    element As XmlElement _
)
C#
public void ReadXml(
    XmlElement element
)
Visual C++
public:
void ReadXml(
    XmlElement^ element
)
JavaScript
function readXml(element);

Parameters

element
Type: System.Xml..::..XmlElement

See Also

ShapeFile Class
EGIS.ShapeFileLib Namespace
ShapeFile..::..WriteXml(XmlWriter)


Render Method

[image] [image]

.NET Framework Class Library
ShapeFile..::..Render Method
ShapeFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Render(Graphics, Size, PointD, Double, ProjectionType) | Renders the shapefile centered at given point and zoom
Public method | Render(Graphics, Size, PointF, Single, RenderSettings, ProjectionType) | Renders the shapefile centered at given point and zoom

See Also

ShapeFile Class
ShapeFile Members


Render Method (Graphics, Size, PointD, Double, ProjectionType)

[image]

.NET Framework Class Library
ShapeFile..::..Render Method (Graphics, Size, PointD, Double, ProjectionType)
ShapeFile Class See Also Send Feedback

Renders the shapefile centered at given point and zoom

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Render ( _
    graphics As Graphics, _
    clientArea As Size, _
    centre As PointD, _
    zoom As Double, _
    projectionType As ProjectionType _
)
C#
public void Render(
    Graphics graphics,
    Size clientArea,
    PointD centre,
    double zoom,
    ProjectionType projectionType
)
Visual C++
public:
void Render(
    Graphics^ graphics,
    Size clientArea,
    PointD centre,
    double zoom,
    ProjectionType projectionType
)
JavaScript
function render(graphics, clientArea, centre, zoom, projectionType);

Parameters

graphics
Type: System.Drawing..::..Graphics
The Graphics device to render to
clientArea
Type: System.Drawing..::..Size
The client area in pixels to draw
centre
Type: EGIS.ShapeFileLib..::..PointD
The centre point in the ShapeFiles coordinates
zoom
Type: System..::..Double
The scaling to apply
projectionType
Type: EGIS.ShapeFileLib..::..ProjectionType
The Map Projection to use when rendering the shapefile

Remarks

If zoom is 1 and the width of the ShapeFile's extent is N units wide, then the ShapeFile wil be rendered N pixels wide. If zoom is 2 then shapefile will be rendered 2N pixels wide

See Also

ShapeFile Class
Render Overload


Render Method (Graphics, Size, PointF, Single, RenderSettings, ProjectionType)

[image]

.NET Framework Class Library
ShapeFile..::..Render Method (Graphics, Size, PointF, Single, RenderSettings, ProjectionType)
ShapeFile Class See Also Send Feedback

Renders the shapefile centered at given point and zoom

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Render ( _
    graphics As Graphics, _
    clientArea As Size, _
    centre As PointF, _
    zoom As Single, _
    renderSetings As RenderSettings, _
    projectionType As ProjectionType _
)
C#
public void Render(
    Graphics graphics,
    Size clientArea,
    PointF centre,
    float zoom,
    RenderSettings renderSetings,
    ProjectionType projectionType
)
Visual C++
public:
void Render(
    Graphics^ graphics,
    Size clientArea,
    PointF centre,
    float zoom,
    RenderSettings^ renderSetings,
    ProjectionType projectionType
)
JavaScript
function render(graphics, clientArea, centre, zoom, renderSetings, projectionType);

Parameters

graphics
Type: System.Drawing..::..Graphics
The Graphics device to render to
clientArea
Type: System.Drawing..::..Size
The client area in pixels to draw
centre
Type: System.Drawing..::..PointF
The centre point in the ShapeFiles coordinates
zoom
Type: System..::..Single
The scaling to apply
renderSetings
Type: EGIS.ShapeFileLib..::..RenderSettings
render settings to apply when rendering the shapefile
projectionType
Type: EGIS.ShapeFileLib..::..ProjectionType

Remarks

If zoom is 1 and the width of the ShapeFile's extent is N units wide, then the ShapeFile wil be rendered N pixels wide. If zoom is 2 then shapefile will be rendered 2N pixels wide

See Also

ShapeFile Class
Render Overload


SelectRecord Method

[image]

.NET Framework Class Library
ShapeFile..::..SelectRecord Method
ShapeFile Class See Also Send Feedback

Selects or de-selects a shapefile record.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub SelectRecord ( _
    index As Integer, _
    selected As Boolean _
)
C#
public void SelectRecord(
    int index,
    bool selected
)
Visual C++
public:
void SelectRecord(
    int index,
    bool selected
)
JavaScript
function selectRecord(index, selected);

Parameters

index
Type: System..::..Int32
zero based index of the record to select or de-select
selected
Type: System..::..Boolean

Remarks

Selected shapefiles will be rednered in the color specified by the RenderSettings SelectedFillColor and SelectedOutlineColor

See Also

ShapeFile Class


ShapeIntersectsRect Method

[image]

.NET Framework Class Library
ShapeFile..::..ShapeIntersectsRect Method
ShapeFile Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function ShapeIntersectsRect ( _
    shapeIndex As Integer, _
    ByRef rect As RectangleD _
) As Boolean
C#
public bool ShapeIntersectsRect(
    int shapeIndex,
    ref RectangleD rect
)
Visual C++
public:
bool ShapeIntersectsRect(
    int shapeIndex,
    RectangleD% rect
)
JavaScript
function shapeIntersectsRect(shapeIndex, rect);

Parameters

shapeIndex
Type: System..::..Int32
rect
Type: EGIS.ShapeFileLib..::..RectangleD %

See Also

ShapeFile Class


ToString Method

[image]

.NET Framework Class Library
ShapeFile..::..ToString Method
ShapeFile Class See Also Send Feedback

overridden ToString method

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

See Also

ShapeFile Class


WriteXml Method

[image]

.NET Framework Class Library
ShapeFile..::..WriteXml Method
ShapeFile Class See Also Send Feedback

Writes an Xml representation of the ShapeFile.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
C#
public void WriteXml(
    XmlWriter writer
)
Visual C++
public:
void WriteXml(
    XmlWriter^ writer
)
JavaScript
function writeXml(writer);

Parameters

writer
Type: System.Xml..::..XmlWriter

Remarks

Use ReadXml to load a ShapeFile from the Xml representation writen by this method

See Also

ShapeFile Class
EGIS.ShapeFileLib Namespace
ShapeFile..::..ReadXml(XmlElement)


ShapeFile Properties

[image] [image]

.NET Framework Class Library
ShapeFile Properties
ShapeFile Class See Also Send Feedback

The ShapeFile type exposes the following members.

Properties

 | Name | Description
Public property | Extent | Gets the Rectangular extent of the shapefile
Public property | FilePath | Gets the path to the ShapeFile, not including the .shp file extension
Public property | IsSelectable | Indicates whether the ShapeFile is selectable.
 | MapFilesInMemory | Gets or Sets whether to map files in memory.
Public property | Name | The name of this ShapeFile.
Public property | RecordCount | Gets the number of records(shapes) in the ShapeFile
 | RenderQuality | Gets or Sets the RenderQuality to use when rendering shapefiles
Public property | RenderSettings | Gets or sets the RenderSettings used by the ShapeFile when Rendering
Public property | SelectedRecordIndices | Returns a collection of all the selected record indices
Public property | ShapeType | Gets the ShapeType of the ShapeFile
 | Sync | Gets an object that can be used to synchronize access to the ShapeFile

See Also

ShapeFile Class


Extent Property

[image]

.NET Framework Class Library
ShapeFile..::..Extent Property
ShapeFile Class See Also Send Feedback

Gets the Rectangular extent of the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Extent As RectangleD
    Get
C#
public RectangleD Extent { get; }
Visual C++
public:
property RectangleD Extent {
    RectangleD get ();
}
JavaScript
function get_extent();

See Also

ShapeFile Class


FilePath Property

[image]

.NET Framework Class Library
ShapeFile..::..FilePath Property
ShapeFile Class See Also Send Feedback

Gets the path to the ShapeFile, not including the .shp file extension

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property FilePath As String
    Get
C#
public string FilePath { get; }
Visual C++
public:
property String^ FilePath {
    String^ get ();
}
JavaScript
function get_filePath();

See Also

ShapeFile Class


IsSelectable Property

[image]

.NET Framework Class Library
ShapeFile..::..IsSelectable Property
ShapeFile Class See Also Send Feedback

Indicates whether the ShapeFile is selectable.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property IsSelectable As Boolean
    Get
C#
public bool IsSelectable { get; }
Visual C++
public:
property bool IsSelectable {
    bool get ();
}
JavaScript
function get_isSelectable();

Remarks

For a ShapeFile to be selectable, the ShapeFile's RenderSettings must not be null and the RenderSettings must be selectable

See Also

ShapeFile Class


MapFilesInMemory Property

[image]

.NET Framework Class Library
ShapeFile..::..MapFilesInMemory Property
ShapeFile Class See Also Send Feedback

Gets or Sets whether to map files in memory.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Property MapFilesInMemory As Boolean
    Get
    Set
C#
public static bool MapFilesInMemory { get; set; }
Visual C++
public:
static property bool MapFilesInMemory {
    bool get ();
    void set (bool value);
}
JavaScript
EGIS.ShapeFileLib.ShapeFile.get_mapFilesInMemory = function();
EGIS.ShapeFileLib.ShapeFile.set_mapFilesInMemory = function(value);

Remarks

If MapFilesInMemory is set to true then shapefiles will be mapped in memory using native file mapping. When files are mapped in memory rendering performance will be improved; however they will use more memory.

See Also

ShapeFile Class


Name Property

[image]

.NET Framework Class Library
ShapeFile..::..Name Property
ShapeFile Class See Also Send Feedback

The name of this ShapeFile.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Name As String
    Get
    Set
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

This is common name used to identify a shapefile and is not the name of the file path of this shapefile

See Also

ShapeFile Class


RecordCount Property

[image]

.NET Framework Class Library
ShapeFile..::..RecordCount Property
ShapeFile Class See Also Send Feedback

Gets the number of records(shapes) in the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordCount As Integer
    Get
C#
public int RecordCount { get; }
Visual C++
public:
property int RecordCount {
    int get ();
}
JavaScript
function get_recordCount();

See Also

ShapeFile Class


RenderQuality Property

[image]

.NET Framework Class Library
ShapeFile..::..RenderQuality Property
ShapeFile Class See Also Send Feedback

Gets or Sets the RenderQuality to use when rendering shapefiles

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Property RenderQuality As RenderQuality
    Get
    Set
C#
public static RenderQuality RenderQuality { get; set; }
Visual C++
public:
static property RenderQuality RenderQuality {
    RenderQuality get ();
    void set (RenderQuality value);
}
JavaScript
EGIS.ShapeFileLib.ShapeFile.get_renderQuality = function();
EGIS.ShapeFileLib.ShapeFile.set_renderQuality = function(value);

See Also

ShapeFile Class


RenderSettings Property

[image]

.NET Framework Class Library
ShapeFile..::..RenderSettings Property
ShapeFile Class See Also Send Feedback

Gets or sets the RenderSettings used by the ShapeFile when Rendering

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property RenderSettings As RenderSettings
    Get
    Set
C#
public RenderSettings RenderSettings { get; set; }
Visual C++
public:
property RenderSettings^ RenderSettings {
    RenderSettings^ get ();
    void set (RenderSettings^ value);
}
JavaScript
function get_renderSettings();
function set_renderSettings(value);

See Also

ShapeFile Class


SelectedRecordIndices Property

[image]

.NET Framework Class Library
ShapeFile..::..SelectedRecordIndices Property
ShapeFile Class See Also Send Feedback

Returns a collection of all the selected record indices

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property SelectedRecordIndices As ReadOnlyCollection(Of Integer)
    Get
C#
public ReadOnlyCollection<int> SelectedRecordIndices { get; }
Visual C++
public:
property ReadOnlyCollection<int>^ SelectedRecordIndices {
    ReadOnlyCollection<int>^ get ();
}
JavaScript
function get_selectedRecordIndices();

See Also

ShapeFile Class


ShapeType Property

[image]

.NET Framework Class Library
ShapeFile..::..ShapeType Property
ShapeFile Class See Also Send Feedback

Gets the ShapeType of the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property ShapeType As ShapeType
    Get
C#
public ShapeType ShapeType { get; }
Visual C++
public:
property ShapeType ShapeType {
    ShapeType get ();
}
JavaScript
function get_shapeType();

See Also

ShapeFile Class


Sync Property

[image]

.NET Framework Class Library
ShapeFile..::..Sync Property
ShapeFile Class See Also Send Feedback

Gets an object that can be used to synchronize access to the ShapeFile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared ReadOnly Property Sync As Object
    Get
C#
public static Object Sync { get; }
Visual C++
public:
static property Object^ Sync {
    Object^ get ();
}
JavaScript
EGIS.ShapeFileLib.ShapeFile.get_sync = function();

Remarks

NOTE: Many of the methods in this class are not Thread Safe (due to internal shared buffers). If multiple threads require access to ShapeFile objects then the static (Shared in VB) Sync object should be used to provide mutual access to the shapefiles

See Also

ShapeFile Class


ShapeFileEnumerator Class

[image]

.NET Framework Class Library
ShapeFileEnumerator Class
Members See Also Send Feedback

ShapeFile enumerator used to enumerate the raw data of each shape in a shapeFile. The ShapeFileEnumerator provides a fast, low memory, forward only means of iterating over all of the records in a shapefile.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class ShapeFileEnumerator _
    Implements IEnumerator(Of ReadOnlyCollection(Of PointD())),  _
    IDisposable, IEnumerator
C#
public sealed class ShapeFileEnumerator : IEnumerator<ReadOnlyCollection<PointD[]>>,
    IDisposable, IEnumerator
Visual C++
public ref class ShapeFileEnumerator sealed : IEnumerator<ReadOnlyCollection<array<PointD>^>^>,
    IDisposable, IEnumerator
JavaScript
EGIS.ShapeFileLib.ShapeFileEnumerator = function();

Type.createClass(
    'EGIS.ShapeFileLib.ShapeFileEnumerator',
    null,
    IEnumerator`1,
    IDisposable,
    IEnumerator);

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..ShapeFileEnumerator

See Also

ShapeFileEnumerator Members


ShapeFileEnumerator Members

[image] [image]

.NET Framework Class Library
ShapeFileEnumerator Members
ShapeFileEnumerator Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ShapeFileEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentMValues | Gets the Measure data of the current shape. This method is currently not implemented
Public method | GetCurrentZValues | Gets the raw Z data of the current shape (3D shapefiles only)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next shape in the shape file. The next shape may not be the next shape in the shape file if the enumerator has a smaller Extent than the shape file's Extent.
Public method | Reset | Sets the enumerator to its initial position, which is before the first shape in the shapefile
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the raw PointD data of the current shape
Public property | CurrentShapeIndex | Gets the index (zero based) of the current shape.
Public property | Extent | Gets the Extent of the enumerator. In most cases this will be the extent of the shapefile, but this may be smaller than the shape file's exent if the enumerator has been created from a sub region of the shapefile's extent
Public property | TotalRecords | Convenience method which returns he total records contained in the shapefile. TotalRecords is the same as the shape File's RecordCount property

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IEnumerator..::..Current |

See Also

ShapeFileEnumerator Class


ShapeFileEnumerator Methods

[image] [image]

.NET Framework Class Library
ShapeFileEnumerator Methods
ShapeFileEnumerator Class See Also Send Feedback

The ShapeFileEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentMValues | Gets the Measure data of the current shape. This method is currently not implemented
Public method | GetCurrentZValues | Gets the raw Z data of the current shape (3D shapefiles only)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next shape in the shape file. The next shape may not be the next shape in the shape file if the enumerator has a smaller Extent than the shape file's Extent.
Public method | Reset | Sets the enumerator to its initial position, which is before the first shape in the shapefile
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeFileEnumerator Class


Dispose Method

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..Dispose Method
ShapeFileEnumerator Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

ShapeFileEnumerator Class


GetCurrentMValues Method

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..GetCurrentMValues Method
ShapeFileEnumerator Class See Also Send Feedback

Gets the Measure data of the current shape. This method is currently not implemented

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetCurrentMValues As ReadOnlyCollection(Of Double())
C#
public ReadOnlyCollection<double[]> GetCurrentMValues()
Visual C++
public:
ReadOnlyCollection<array<double>^>^ GetCurrentMValues()
JavaScript
function getCurrentMValues();

See Also

ShapeFileEnumerator Class


GetCurrentZValues Method

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..GetCurrentZValues Method
ShapeFileEnumerator Class See Also Send Feedback

Gets the raw Z data of the current shape (3D shapefiles only)

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function GetCurrentZValues As ReadOnlyCollection(Of Double())
C#
public ReadOnlyCollection<double[]> GetCurrentZValues()
Visual C++
public:
ReadOnlyCollection<array<double>^>^ GetCurrentZValues()
JavaScript
function getCurrentZValues();

See Also

ShapeFileEnumerator Class


MoveNext Method

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..MoveNext Method
ShapeFileEnumerator Class See Also Send Feedback

Advances the enumerator to the next shape in the shape file. The next shape may not be the next shape in the shape file if the enumerator has a smaller Extent than the shape file's Extent.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function MoveNext As Boolean
C#
public bool MoveNext()
Visual C++
public:
virtual bool MoveNext() sealed
JavaScript
function moveNext();

Return Value

Implements

IEnumerator..::..MoveNext()()()()

See Also

ShapeFileEnumerator Class


Reset Method

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..Reset Method
ShapeFileEnumerator Class See Also Send Feedback

Sets the enumerator to its initial position, which is before the first shape in the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Reset
C#
public void Reset()
Visual C++
public:
virtual void Reset() sealed
JavaScript
function reset();

Implements

IEnumerator..::..Reset()()()()

See Also

ShapeFileEnumerator Class


ShapeFileEnumerator Properties

[image] [image]

.NET Framework Class Library
ShapeFileEnumerator Properties
ShapeFileEnumerator Class See Also Send Feedback

The ShapeFileEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the raw PointD data of the current shape
Public property | CurrentShapeIndex | Gets the index (zero based) of the current shape.
Public property | Extent | Gets the Extent of the enumerator. In most cases this will be the extent of the shapefile, but this may be smaller than the shape file's exent if the enumerator has been created from a sub region of the shapefile's extent
Public property | TotalRecords | Convenience method which returns he total records contained in the shapefile. TotalRecords is the same as the shape File's RecordCount property

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IEnumerator..::..Current |

See Also

ShapeFileEnumerator Class


IEnumerator.Current Property

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..IEnumerator..::..Current Property
ShapeFileEnumerator Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
C#
Object IEnumerator.Current { get; }
Visual C++
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
JavaScript
JavaScript does not support explicit interface implementations.

Implements

IEnumerator..::..Current

See Also

ShapeFileEnumerator Class


Current Property

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..Current Property
ShapeFileEnumerator Class See Also Send Feedback

Gets the raw PointD data of the current shape

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Current As ReadOnlyCollection(Of PointD())
    Get
C#
public ReadOnlyCollection<PointD[]> Current { get; }
Visual C++
public:
virtual property ReadOnlyCollection<array<PointD>^>^ Current {
    ReadOnlyCollection<array<PointD>^>^ get () sealed;
}
JavaScript
function get_current();

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

ShapeFileEnumerator Class


CurrentShapeIndex Property

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..CurrentShapeIndex Property
ShapeFileEnumerator Class See Also Send Feedback

Gets the index (zero based) of the current shape.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property CurrentShapeIndex As Integer
    Get
C#
public int CurrentShapeIndex { get; }
Visual C++
public:
property int CurrentShapeIndex {
    int get ();
}
JavaScript
function get_currentShapeIndex();

See Also

ShapeFileEnumerator Class


Extent Property

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..Extent Property
ShapeFileEnumerator Class See Also Send Feedback

Gets the Extent of the enumerator. In most cases this will be the extent of the shapefile, but this may be smaller than the shape file's exent if the enumerator has been created from a sub region of the shapefile's extent

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property Extent As RectangleD
    Get
C#
public RectangleD Extent { get; }
Visual C++
public:
property RectangleD Extent {
    RectangleD get ();
}
JavaScript
function get_extent();

See Also

ShapeFileEnumerator Class


TotalRecords Property

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..TotalRecords Property
ShapeFileEnumerator Class See Also Send Feedback

Convenience method which returns he total records contained in the shapefile. TotalRecords is the same as the shape File's RecordCount property

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property TotalRecords As Integer
    Get
C#
public int TotalRecords { get; }
Visual C++
public:
property int TotalRecords {
    int get ();
}
JavaScript
function get_totalRecords();

See Also

ShapeFileEnumerator Class


ShapeFileEnumerator.IntersectionType Enumeration

[image]

.NET Framework Class Library
ShapeFileEnumerator..::..IntersectionType Enumeration
ShapeFileEnumerator Class See Also Send Feedback

Defines how shapes will be evaluated when moving to the next record when enumerating through a shapefile. Intersects (the default) evaluates shapes that intersect with the Extent of the ShapeFileEnumerator. Contains evaluates shapes that fit entirely within the Extent of the ShapeFileEnumerator.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration IntersectionType
C#
public enum IntersectionType
Visual C++
public enum class IntersectionType
JavaScript
EGIS.ShapeFileLib.IntersectionType = function();
EGIS.ShapeFileLib.IntersectionType.createEnum('EGIS.ShapeFileLib.IntersectionType', false);

Members

Member name | Description
Intersects |
Contains |

See Also


ShapeFileWriter Class

[image]

.NET Framework Class Library
ShapeFileWriter Class
Members Example See Also Send Feedback

.NET ShapeFile Writer utility class which provides the ability to create or edit shapefiles from .NET applications.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<ObfuscationAttribute(Exclude := True, ApplyToMembers := True)> _
Public MustInherit Class ShapeFileWriter _
    Implements IDisposable
C#
[ObfuscationAttribute(Exclude = true, ApplyToMembers = true)]
public abstract class ShapeFileWriter : IDisposable
Visual C++
[ObfuscationAttribute(Exclude = true, ApplyToMembers = true)]
public ref class ShapeFileWriter abstract : IDisposable
JavaScript
EGIS.ShapeFileLib.ShapeFileWriter = function();

Type.createClass(
    'EGIS.ShapeFileLib.ShapeFileWriter',
    null,
    IDisposable);

Remarks

ShapeFileWriter is an abstract class. To create an instance of ShapeFileWriter call the CreateWriter method or derive a new class by extending ShapeFileWriter

To use the ShapeFileWriter create a new instance by calling the CreateWriter method, passing in the shapefile path information, shape type and DBF field desricriptions. Progressively call the AddRecord method to add new records to the shapefile. Once all records have been added, close the shapefile by calling the Close method

Deriving classes must overload AddRecord.

IMPORTANT- When you have finished writing all records you must call Close.

All characters stored in DBF records use UTF-8 character encoding to support Unicode character sets

Examples

Example code to create a new shapefile using an existing shapefile and a ShapeFileWriter.
Copy image Copy Code
            public void CreateShapeFile()
            {
                ShapeFile sf = new ShapeFile("allroads.shp");
                DbfReader dbfReader = new DbfReader("allroads.dbf");

                //create a new ShapeFileWriter
                ShapeFileWriter sfw;
                sfw = ShapeFileWriter.CreateWriter(".", "highways", sf.ShapeType,
                    dbfReader.DbfRecordHeader.GetFieldDescriptions());
                try
                {
                    // Get a ShapeFileEnumerator from the shapefile
                    // and read each record
                    ShapeFileEnumerator sfEnum = sf.GetShapeFileEnumerator();
                    while (sfEnum.MoveNext())
                    {
                        // get the raw point data
                        PointD[] points = sfEnum.Current[0];
                        //get the DBF record
                        string[] fields = dbfReader.GetFields(sfEnum.CurrentShapeIndex);
                        //check whether to add the record to the new shapefile.
                        //(in this example, field zero contains the road type)
                        if(string.Compare(fields[0].Trim(), "highway", true) == 0)
                        {
                            sfw.AddRecord(points, points.Length, fields);
                        }
                    }
                }
                finally
                {
                    //close the shapefile, shapefilewriter and dbfreader
                    sfw.Close();
                    sf.Close();
                    dbfReader.Close();
                }
            }

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..ShapeFileWriter

See Also

ShapeFileWriter Members
EGIS.ShapeFileLib Namespace
ShapeFileWriter..::..AddRecord(array<Double>[]()[][], Int32, array<String>[]()[][])
ShapeFileWriter..::..Close()()()()


ShapeFileWriter Members

[image] [image]

.NET Framework Class Library
ShapeFileWriter Members
ShapeFileWriter Class Constructors Methods Properties See Also Send Feedback

The ShapeFileWriter type exposes the following members.

Constructors

 | Name | Description
Protected method | ShapeFileWriter | ShapeFileWriter Constructor

Methods

 | Name | Description
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<Double>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointF>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointD>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<Double>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointF>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointD>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | Close | Updates the headers inside the individual shapefile files and closes any used streams.
 | CreateWriter | Creates a ShapeFileWriter class
Public method | Dispose | Releases all resources used by the DbfWriter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenWriter |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WriteDbfRecord | Writes a record to the Shape Files's DBF file
Protected method | WriteFileHeaders | writes the shapefile's 3 file headers

Properties

 | Name | Description
Protected property | BaseDirectory | The base directory where the new shape file will be written
Protected property | DbfStream | The Stream used to write the shape files .dbf file
Protected property | FileName | The file name of the 3 shpaefile files, exluding their file extensions
Protected property | IndexStream | The Stream used to write the shape files index (.shx) file
Protected property | RecordCount | The number of records written in the shapefile
Protected property | ShapeBounds | The extent bounds of the shapefile being written
Protected property | ShapeStream | The Stream used to write the shape files .shp file
Protected property | ShapeType | The shape type of the shapefile

See Also

ShapeFileWriter Class


ShapeFileWriter Constructor

[image]

.NET Framework Class Library
ShapeFileWriter Constructor
ShapeFileWriter Class See Also Send Feedback

ShapeFileWriter Constructor

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Sub New ( _
    baseDir As String, _
    shapeFileName As String, _
    dataFields As DbfFieldDesc(), _
    append As Boolean _
)
C#
protected ShapeFileWriter(
    string baseDir,
    string shapeFileName,
    DbfFieldDesc[] dataFields,
    bool append
)
Visual C++
protected:
ShapeFileWriter(
    String^ baseDir,
    String^ shapeFileName,
    array<DbfFieldDesc>^ dataFields,
    bool append
)
JavaScript
EGIS.ShapeFileLib.ShapeFileWriter = function(baseDir, shapeFileName, dataFields, append);

Parameters

baseDir
Type: System..::..String
The base directory where the 3 shapefile files will be created
shapeFileName
Type: System..::..String
The name of the shapefile. The shapefile will be generated at baseDir + shapeFileName + ".shx|.shp|.dbf|.cpg
dataFields
Type: array< EGIS.ShapeFileLib..::..DbfFieldDesc >[]()[][]
DbfFieldDesc array describing the dbf fields of the shapefile
append
Type: System..::..Boolean

Remarks

Derived classes must call this constructor

See Also

ShapeFileWriter Class


ShapeFileWriter Methods

[image] [image]

.NET Framework Class Library
ShapeFileWriter Methods
ShapeFileWriter Class See Also Send Feedback

The ShapeFileWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<Double>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointF>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointD>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<Double>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointF>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointD>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | Close | Updates the headers inside the individual shapefile files and closes any used streams.
 | CreateWriter | Creates a ShapeFileWriter class
Public method | Dispose | Releases all resources used by the DbfWriter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenWriter |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WriteDbfRecord | Writes a record to the Shape Files's DBF file
Protected method | WriteFileHeaders | writes the shapefile's 3 file headers

See Also

ShapeFileWriter Class


AddRecord Method

[image] [image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method
ShapeFileWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<Double>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointF>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(ReadOnlyCollection<(Of <<'(array<PointD>[]()[][]>)>>), array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<Double>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointF>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile
Public method | AddRecord(array<PointD>[]()[][], Int32, array<String>[]()[][]) | abstract method used to add a new record to the shapefile

See Also

ShapeFileWriter Class
ShapeFileWriter Members


AddRecord Method (ReadOnlyCollection(Double[]), String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (ReadOnlyCollection<(Of <(<'array<Double>[]()[][]>)>)>, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public MustOverride Sub AddRecord ( _
    parts As ReadOnlyCollection(Of Double()), _
    fieldData As String() _
)
C#
public abstract void AddRecord(
    ReadOnlyCollection<double[]> parts,
    string[] fieldData
)
Visual C++
public:
virtual void AddRecord(
    ReadOnlyCollection<array<double>^>^ parts,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(parts, fieldData);

Parameters

parts
Type: System.Collections.ObjectModel..::..ReadOnlyCollection <(Of <(<'array< Double >[]()[][]>)>)>
collection of double arrays containing the individual points of each part in the shape record.
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Implementing subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


AddRecord Method (ReadOnlyCollection(PointF[]), String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (ReadOnlyCollection<(Of <(<'array<PointF>[]()[][]>)>)>, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public MustOverride Sub AddRecord ( _
    parts As ReadOnlyCollection(Of PointF()), _
    fieldData As String() _
)
C#
public abstract void AddRecord(
    ReadOnlyCollection<PointF[]> parts,
    string[] fieldData
)
Visual C++
public:
virtual void AddRecord(
    ReadOnlyCollection<array<PointF>^>^ parts,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(parts, fieldData);

Parameters

parts
Type: System.Collections.ObjectModel..::..ReadOnlyCollection <(Of <(<'array< PointF >[]()[][]>)>)>
collection of float arrays containing the individual points of each part in the shape record.
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Implementing subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


AddRecord Method (ReadOnlyCollection(PointD[]), String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (ReadOnlyCollection<(Of <(<'array<PointD>[]()[][]>)>)>, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<ObfuscationAttribute(Exclude := True)> _
Public MustOverride Sub AddRecord ( _
    parts As ReadOnlyCollection(Of PointD()), _
    fieldData As String() _
)
C#
[ObfuscationAttribute(Exclude = true)]
public abstract void AddRecord(
    ReadOnlyCollection<PointD[]> parts,
    string[] fieldData
)
Visual C++
[ObfuscationAttribute(Exclude = true)]
public:
virtual void AddRecord(
    ReadOnlyCollection<array<PointD>^>^ parts,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(parts, fieldData);

Parameters

parts
Type: System.Collections.ObjectModel..::..ReadOnlyCollection <(Of <(<'array< PointD >[]()[][]>)>)>
collection of PointD arrays containing the individual points of each part in the shape record.
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Implementing subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


AddRecord Method (Double[], Int32, String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (array<Double>[]()[][], Int32, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public MustOverride Sub AddRecord ( _
    points As Double(), _
    pointCount As Integer, _
    fieldData As String() _
)
C#
public abstract void AddRecord(
    double[] points,
    int pointCount,
    string[] fieldData
)
Visual C++
public:
virtual void AddRecord(
    array<double>^ points,
    int pointCount,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(points, pointCount, fieldData);

Parameters

points
Type: array< System..::..Double >[]()[][]
an array containing the individual points of the shape record, where the first element of the array is the x value of point 0, second element is y value of point 0 etc.
pointCount
Type: System..::..Int32
The number of points in the pts array (which may be less than points.length*2). Note that if all elements of points are used pointCount will equal pts.length/2
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Derived subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


AddRecord Method (PointF[], Int32, String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (array<PointF>[]()[][], Int32, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public MustOverride Sub AddRecord ( _
    points As PointF(), _
    pointCount As Integer, _
    fieldData As String() _
)
C#
public abstract void AddRecord(
    PointF[] points,
    int pointCount,
    string[] fieldData
)
Visual C++
public:
virtual void AddRecord(
    array<PointF>^ points,
    int pointCount,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(points, pointCount, fieldData);

Parameters

points
Type: array< System.Drawing..::..PointF >[]()[][]
an array containing the individual points of the shape record.
pointCount
Type: System..::..Int32
The number of points in the pts array (which may be less than points.length).
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Implementing subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


AddRecord Method (PointD[], Int32, String[])

[image]

.NET Framework Class Library
ShapeFileWriter..::..AddRecord Method (array<PointD>[]()[][], Int32, array<String>[]()[][])
ShapeFileWriter Class See Also Send Feedback

abstract method used to add a new record to the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public MustOverride Sub AddRecord ( _
    points As PointD(), _
    pointCount As Integer, _
    fieldData As String() _
)
C#
public abstract void AddRecord(
    PointD[] points,
    int pointCount,
    string[] fieldData
)
Visual C++
public:
virtual void AddRecord(
    array<PointD>^ points,
    int pointCount,
    array<String^>^ fieldData
) abstract
JavaScript
function addRecord(points, pointCount, fieldData);

Parameters

points
Type: array< EGIS.ShapeFileLib..::..PointD >[]()[][]
an array containing the individual points of the shape record.
pointCount
Type: System..::..Int32
The number of points in the pts array (which may be less than points.length).
fieldData
Type: array< System..::..String >[]()[][]
fieldData string values of the data associated with the shape record (which is stored in the dbf file)

Remarks

Implementing subclasses override this method to write the appropriate data depending on the ShapeType being used.

See Also

ShapeFileWriter Class
AddRecord Overload


Close Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..Close Method
ShapeFileWriter Class See Also Send Feedback

Updates the headers inside the individual shapefile files and closes any used streams.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

Remarks

This method MUST be called after all records have been added to the shapefile. Failure to call this method will result in a shapefile being generated with incorrect headers

See Also

ShapeFileWriter Class


CreateWriter Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..CreateWriter Method
ShapeFileWriter Class See Also Send Feedback

Creates a ShapeFileWriter class

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function CreateWriter ( _
    baseDir As String, _
    shapeFileName As String, _
    shapeFileType As ShapeType, _
    dataFields As DbfFieldDesc() _
) As ShapeFileWriter
C#
public static ShapeFileWriter CreateWriter(
    string baseDir,
    string shapeFileName,
    ShapeType shapeFileType,
    DbfFieldDesc[] dataFields
)
Visual C++
public:
static ShapeFileWriter^ CreateWriter(
    String^ baseDir,
    String^ shapeFileName,
    ShapeType shapeFileType,
    array<DbfFieldDesc>^ dataFields
)
JavaScript
EGIS.ShapeFileLib.ShapeFileWriter.createWriter = function(baseDir, shapeFileName, shapeFileType, dataFields);

Parameters

baseDir
Type: System..::..String
The path to the base directory where the shape file should be created
shapeFileName
Type: System..::..String
The name of the shapefile to create
shapeFileType
Type: EGIS.ShapeFileLib..::..ShapeType
The ShapeType of the shapefile
dataFields
Type: array< EGIS.ShapeFileLib..::..DbfFieldDesc >[]()[][]
array of DbfFieldDesc objects describing the fields to be created in the shape file's DBF file

Return Value

Remarks

To create a ShapeFileWriter to create a polygon shapefile pass in ShapeType.Polygon

To create a ShapeFileWriter to create a point shapefile pass in ShapeType.Point

To create a ShapeFileWriter to create a polyline shapefile pass in ShapeType.Polyline

See Also

ShapeFileWriter Class


Dispose Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..Dispose Method
ShapeFileWriter Class See Also Send Feedback

Releases all resources used by the DbfWriter

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::..Dispose()()()()

See Also

ShapeFileWriter Class


Finalize Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..Finalize Method
ShapeFileWriter Class See Also Send Feedback

Destructor

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override
JavaScript
function finalize();

See Also

ShapeFileWriter Class


OpenWriter Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..OpenWriter Method
ShapeFileWriter Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function OpenWriter ( _
    baseDir As String, _
    shapeFileName As String _
) As ShapeFileWriter
C#
public static ShapeFileWriter OpenWriter(
    string baseDir,
    string shapeFileName
)
Visual C++
public:
static ShapeFileWriter^ OpenWriter(
    String^ baseDir,
    String^ shapeFileName
)
JavaScript
EGIS.ShapeFileLib.ShapeFileWriter.openWriter = function(baseDir, shapeFileName);

Parameters

baseDir
Type: System..::..String
The path to the base directory where the shape file should be created
shapeFileName
Type: System..::..String
The name of the shapefile to create

Return Value

See Also

ShapeFileWriter Class


WriteDbfRecord Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..WriteDbfRecord Method
ShapeFileWriter Class See Also Send Feedback

Writes a record to the Shape Files's DBF file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Sub WriteDbfRecord ( _
    fieldData As String() _
)
C#
protected void WriteDbfRecord(
    string[] fieldData
)
Visual C++
protected:
void WriteDbfRecord(
    array<String^>^ fieldData
)
JavaScript
function writeDbfRecord(fieldData);

Parameters

fieldData
Type: array< System..::..String >[]()[][]
The data for each field in the record

See Also

ShapeFileWriter Class


WriteFileHeaders Method

[image]

.NET Framework Class Library
ShapeFileWriter..::..WriteFileHeaders Method
ShapeFileWriter Class See Also Send Feedback

writes the shapefile's 3 file headers

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Sub WriteFileHeaders
C#
protected void WriteFileHeaders()
Visual C++
protected:
void WriteFileHeaders()
JavaScript
function writeFileHeaders();

Remarks

Derived classes must call this method after setting the ShapeType when the ShapeFileWriter is created before the first record is written

See Also

ShapeFileWriter Class


ShapeFileWriter Properties

[image] [image]

.NET Framework Class Library
ShapeFileWriter Properties
ShapeFileWriter Class See Also Send Feedback

The ShapeFileWriter type exposes the following members.

Properties

 | Name | Description
Protected property | BaseDirectory | The base directory where the new shape file will be written
Protected property | DbfStream | The Stream used to write the shape files .dbf file
Protected property | FileName | The file name of the 3 shpaefile files, exluding their file extensions
Protected property | IndexStream | The Stream used to write the shape files index (.shx) file
Protected property | RecordCount | The number of records written in the shapefile
Protected property | ShapeBounds | The extent bounds of the shapefile being written
Protected property | ShapeStream | The Stream used to write the shape files .shp file
Protected property | ShapeType | The shape type of the shapefile

See Also

ShapeFileWriter Class


BaseDirectory Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..BaseDirectory Property
ShapeFileWriter Class See Also Send Feedback

The base directory where the new shape file will be written

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Property BaseDirectory As String
    Get
    Set
C#
protected string BaseDirectory { get; set; }
Visual C++
protected:
property String^ BaseDirectory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_baseDirectory();
function set_baseDirectory(value);

Remarks

The location of the 3 shapefiles will be written to BaseDirectory + FileName + .shp|.shx|.dbf

See Also

ShapeFileWriter Class
ShapeFileWriter..::..FileName


DbfStream Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..DbfStream Property
ShapeFileWriter Class See Also Send Feedback

The Stream used to write the shape files .dbf file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected ReadOnly Property DbfStream As FileStream
    Get
C#
protected FileStream DbfStream { get; }
Visual C++
protected:
property FileStream^ DbfStream {
    FileStream^ get ();
}
JavaScript
function get_dbfStream();

See Also

ShapeFileWriter Class


FileName Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..FileName Property
ShapeFileWriter Class See Also Send Feedback

The file name of the 3 shpaefile files, exluding their file extensions

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Property FileName As String
    Get
    Set
C#
protected string FileName { get; set; }
Visual C++
protected:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

See Also

ShapeFileWriter Class
ShapeFileWriter..::..BaseDirectory


IndexStream Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..IndexStream Property
ShapeFileWriter Class See Also Send Feedback

The Stream used to write the shape files index (.shx) file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected ReadOnly Property IndexStream As FileStream
    Get
C#
protected FileStream IndexStream { get; }
Visual C++
protected:
property FileStream^ IndexStream {
    FileStream^ get ();
}
JavaScript
function get_indexStream();

See Also

ShapeFileWriter Class


RecordCount Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..RecordCount Property
ShapeFileWriter Class See Also Send Feedback

The number of records written in the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Property RecordCount As Integer
    Get
    Set
C#
protected int RecordCount { get; set; }
Visual C++
protected:
property int RecordCount {
    int get ();
    void set (int value);
}
JavaScript
function get_recordCount();
function set_recordCount(value);

See Also

ShapeFileWriter Class


ShapeBounds Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..ShapeBounds Property
ShapeFileWriter Class See Also Send Feedback

The extent bounds of the shapefile being written

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Property ShapeBounds As RectangleD
    Get
    Set
C#
protected RectangleD ShapeBounds { get; set; }
Visual C++
protected:
property RectangleD ShapeBounds {
    RectangleD get ();
    void set (RectangleD value);
}
JavaScript
function get_shapeBounds();
function set_shapeBounds(value);

Remarks

Derived classes must update the ShapeBounds as each record is written, as thie shapefile's main header will be updated with the ShapeBounds when the Close method is called.

See Also

ShapeFileWriter Class


ShapeStream Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..ShapeStream Property
ShapeFileWriter Class See Also Send Feedback

The Stream used to write the shape files .shp file

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected ReadOnly Property ShapeStream As FileStream
    Get
C#
protected FileStream ShapeStream { get; }
Visual C++
protected:
property FileStream^ ShapeStream {
    FileStream^ get ();
}
JavaScript
function get_shapeStream();

See Also

ShapeFileWriter Class


ShapeType Property

[image]

.NET Framework Class Library
ShapeFileWriter..::..ShapeType Property
ShapeFileWriter Class See Also Send Feedback

The shape type of the shapefile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Protected Property ShapeType As ShapeType
    Get
    Set
C#
protected ShapeType ShapeType { get; set; }
Visual C++
protected:
property ShapeType ShapeType {
    ShapeType get ();
    void set (ShapeType value);
}
JavaScript
function get_shapeType();
function set_shapeType(value);

Remarks

Derived classes should set this when creating the ShapeFileWriter

See Also

ShapeFileWriter Class


ShapeType Enumeration

[image]

.NET Framework Class Library
ShapeType Enumeration
See Also Send Feedback

Enumeration representing a ShapeType. Currently supported shape types are Point, PolyLine, Polygon and PolyLineM

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Enumeration ShapeType
C#
public enum ShapeType
Visual C++
public enum class ShapeType
JavaScript
EGIS.ShapeFileLib.ShapeType = function();
EGIS.ShapeFileLib.ShapeType.createEnum('EGIS.ShapeFileLib.ShapeType', false);

Members

Member name | Description
NullShape |
Point |
PolyLine |
Polygon |
MultiPoint |
PointZ |
PolyLineZ |
PolygonZ |
MultiPointZ |
PointM |
PolyLineM |

See Also


SizeD Structure

[image]

.NET Framework Class Library
SizeD Structure
Members See Also Send Feedback

Stores an ordered pair of double-precision floating-point numbers, typically the width and height of a rectangle.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<SerializableAttribute> _
<ComVisibleAttribute(True)> _
<TypeConverterAttribute(GetType(SizeDConverter))> _
Public Structure SizeD
C#
[SerializableAttribute]
[ComVisibleAttribute(true)]
[TypeConverterAttribute(typeof(SizeDConverter))]
public struct SizeD
Visual C++
[SerializableAttribute]
[ComVisibleAttribute(true)]
[TypeConverterAttribute(typeof(SizeDConverter))]
public value class SizeD
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

Remarks

This structure is essentially the same as the System.Drawing.SizeF structure but uses double-precision floating point numbers, which are needed for accuracy in GIS applications

See Also

SizeD Members


SizeD Members

[image] [image]

.NET Framework Class Library
SizeD Members
SizeD Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The SizeD type exposes the following members.

Constructors

 | Name | Description
Public method | SizeD(PointD) | Initializes a new instance of the SizeD class from the specified PointD.
Public method | SizeD(SizeD) | Initializes a new instance of the SizeD class from the specified existing SizeD.
Public method | SizeD(Double, Double) | Initializes a new instance of the SizeD class from the specified dimensions.

Methods

 | Name | Description
 | Add | Adds the width and height of one SizeD structure to the width and height of another SizeD structure.
Public method | Equals | Tests to see whether the specified object is a SizeD with the same dimensions as this SizeD. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this Size structure. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subtract | Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.
Public method | ToPointD | Converts a SizeD to a PointD.
Public method | ToSize | Converts a SizeD to a Size.
Public method | ToString | Creates a human-readable string that represents this SizeD. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Addition | Adds the width and height of one SizeD structure to the width and height of another SizeD structure.
Equality | Tests whether two SizeD structures are equal.
ExplicitNarrowingExplicitExplicitExplicit(SizeD to PointD) | Converts the specified SizeD to a PointD.
Inequality | Tests whether two SizeD structures are different.
Subtraction | Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.

Fields

Name | Description
Empty | Initializes a new instance of the SizeD class.

Properties

 | Name | Description
Public property | Height | Gets or sets the vertical component of this SizeD.
Public property | IsEmpty | Gets a value indicating whether this SizeD has zero width and height.
Public property | Width | Gets or sets the horizontal component of this SizeD.

See Also

SizeD Structure


SizeD Constructor

[image] [image]

.NET Framework Class Library
SizeD Constructor
SizeD Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | SizeD(PointD) | Initializes a new instance of the SizeD class from the specified PointD.
Public method | SizeD(SizeD) | Initializes a new instance of the SizeD class from the specified existing SizeD.
Public method | SizeD(Double, Double) | Initializes a new instance of the SizeD class from the specified dimensions.

See Also

SizeD Structure
SizeD Members


SizeD Constructor (PointD)

[image]

.NET Framework Class Library
SizeD Constructor (PointD)
SizeD Structure See Also Send Feedback

Initializes a new instance of the SizeD class from the specified PointD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    pt As PointD _
)
C#
public SizeD(
    PointD pt
)
Visual C++
public:
SizeD(
    PointD pt
)
JavaScript
EGIS.ShapeFileLib.SizeD = function(pt);

Parameters

pt
Type: EGIS.ShapeFileLib..::..PointD
The PointD from which to initialize this SizeD.

See Also

SizeD Structure
SizeD Overload


SizeD Constructor (SizeD)

[image]

.NET Framework Class Library
SizeD Constructor (SizeD)
SizeD Structure See Also Send Feedback

Initializes a new instance of the SizeD class from the specified existing SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    size As SizeD _
)
C#
public SizeD(
    SizeD size
)
Visual C++
public:
SizeD(
    SizeD size
)
JavaScript
EGIS.ShapeFileLib.SizeD = function(size);

Parameters

size
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD from which to create the new SizeD.

See Also

SizeD Structure
SizeD Overload


SizeD Constructor (Double, Double)

[image]

.NET Framework Class Library
SizeD Constructor (Double, Double)
SizeD Structure See Also Send Feedback

Initializes a new instance of the SizeD class from the specified dimensions.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New ( _
    width As Double, _
    height As Double _
)
C#
public SizeD(
    double width,
    double height
)
Visual C++
public:
SizeD(
    double width,
    double height
)
JavaScript
EGIS.ShapeFileLib.SizeD = function(width, height);

Parameters

width
Type: System..::..Double
The width component of the new SizeD.
height
Type: System..::..Double
The height component of the new SizeD.

See Also

SizeD Structure
SizeD Overload


SizeD Fields

[image] [image]

.NET Framework Class Library
SizeD Fields
SizeD Structure See Also Send Feedback

The SizeD type exposes the following members.

Fields

Name | Description
Empty | Initializes a new instance of the SizeD class.

See Also

SizeD Structure


Empty Field

[image]

.NET Framework Class Library
SizeD..::..Empty Field
SizeD Structure See Also Send Feedback

Initializes a new instance of the SizeD class.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared ReadOnly Empty As SizeD
C#
public static readonly SizeD Empty
Visual C++
public:
static initonly SizeD Empty
JavaScript
EGIS.ShapeFileLib.SizeD.empty

See Also

SizeD Structure


SizeD Methods

[image] [image]

.NET Framework Class Library
SizeD Methods
SizeD Structure See Also Send Feedback

The SizeD type exposes the following members.

Methods

 | Name | Description
 | Add | Adds the width and height of one SizeD structure to the width and height of another SizeD structure.
Public method | Equals | Tests to see whether the specified object is a SizeD with the same dimensions as this SizeD. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this Size structure. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subtract | Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.
Public method | ToPointD | Converts a SizeD to a PointD.
Public method | ToSize | Converts a SizeD to a Size.
Public method | ToString | Creates a human-readable string that represents this SizeD. (Overrides ValueType..::..ToString()()()().)

See Also

SizeD Structure


Add Method

[image]

.NET Framework Class Library
SizeD..::..Add Method
SizeD Structure See Also Send Feedback

Adds the width and height of one SizeD structure to the width and height of another SizeD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Add ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As SizeD
C#
public static SizeD Add(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static SizeD Add(
    SizeD sz1,
    SizeD sz2
)
JavaScript
EGIS.ShapeFileLib.SizeD.add = function(sz1, sz2);

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The first SizeD to add.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The second SizeD to add.

Return Value

A SizeD structure that is the result of the addition operation.

See Also

SizeD Structure


Equals Method

[image]

.NET Framework Class Library
SizeD..::..Equals Method
SizeD Structure See Also Send Feedback

Tests to see whether the specified object is a SizeD with the same dimensions as this SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::..Object
The Object to test.

Return Value

This method returns true if obj is a SizeD and has the same width and height as this SizeD; otherwise, false.

See Also

SizeD Structure


GetHashCode Method

[image]

.NET Framework Class Library
SizeD..::..GetHashCode Method
SizeD Structure See Also Send Feedback

Returns a hash code for this Size structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

Return Value

An integer value that specifies a hash value for this Size structure.

See Also

SizeD Structure


Subtract Method

[image]

.NET Framework Class Library
SizeD..::..Subtract Method
SizeD Structure See Also Send Feedback

Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function Subtract ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As SizeD
C#
public static SizeD Subtract(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static SizeD Subtract(
    SizeD sz1,
    SizeD sz2
)
JavaScript
EGIS.ShapeFileLib.SizeD.subtract = function(sz1, sz2);

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the left side of the subtraction operator.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the right side of the subtraction operator.

Return Value

The SizeD that is a result of the subtraction operation.

See Also

SizeD Structure


ToPointD Method

[image]

.NET Framework Class Library
SizeD..::..ToPointD Method
SizeD Structure See Also Send Feedback

Converts a SizeD to a PointD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function ToPointD As PointD
C#
public PointD ToPointD()
Visual C++
public:
PointD ToPointD()
JavaScript
function toPointD();

Return Value

Returns a PointD structure.

See Also

SizeD Structure


ToSize Method

[image]

.NET Framework Class Library
SizeD..::..ToSize Method
SizeD Structure See Also Send Feedback

Converts a SizeD to a Size.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Function ToSize As Size
C#
public Size ToSize()
Visual C++
public:
Size ToSize()
JavaScript
function toSize();

Return Value

Returns a Size structure.

See Also

SizeD Structure


ToString Method

[image]

.NET Framework Class Library
SizeD..::..ToString Method
SizeD Structure See Also Send Feedback

Creates a human-readable string that represents this SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

A string that represents this SizeD.

See Also

SizeD Structure


SizeD Operators and Type Conversions

[image] [image]

.NET Framework Class Library
SizeD Operators and Type Conversions
SizeD Structure See Also Send Feedback

The SizeD type exposes the following members.

Operators

Name | Description
Addition | Adds the width and height of one SizeD structure to the width and height of another SizeD structure.
Equality | Tests whether two SizeD structures are equal.
ExplicitNarrowingExplicitExplicitExplicit(SizeD to PointD) | Converts the specified SizeD to a PointD.
Inequality | Tests whether two SizeD structures are different.
Subtraction | Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.

See Also

SizeD Structure


Addition Operator

[image]

.NET Framework Class Library
SizeD..::..Addition Operator
SizeD Structure See Also Send Feedback

Adds the width and height of one SizeD structure to the width and height of another SizeD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator + ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As SizeD
C#
public static SizeD operator +(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static SizeD operator +(
    SizeD sz1,
    SizeD sz2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The first SizeD to add.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The second SizeD to add.

Return Value

A Size structure that is the result of the addition operation.

See Also

SizeD Structure


Equality Operator

[image]

.NET Framework Class Library
SizeD..::..Equality Operator
SizeD Structure See Also Send Feedback

Tests whether two SizeD structures are equal.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator = ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As Boolean
C#
public static bool operator ==(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static bool operator ==(
    SizeD sz1,
    SizeD sz2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the left side of the equality operator.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the right of the equality operator.

Return Value

This operator returns true if sz1 and sz2 have equal width and height; otherwise, false.

See Also

SizeD Structure


Explicit Conversion (SizeD to PointD)

[image]

.NET Framework Class Library
SizeD ExplicitNarrowingExplicitExplicitExplicit Conversion (SizeD to PointD)
SizeD Structure See Also Send Feedback

Converts the specified SizeD to a PointD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Narrowing Operator CType ( _
    size As SizeD _
) As PointD
C#
public static explicit operator PointD (
    SizeD size
)
Visual C++
static explicit operator PointD (
    SizeD size
)
JavaScript
JavaScript does not support the declaration of new casting operators.

Parameters

size
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure to be converted

Return Value

The PointD structure to which this operator converts.

See Also

SizeD Structure


Inequality Operator

[image]

.NET Framework Class Library
SizeD..::..Inequality Operator
SizeD Structure See Also Send Feedback

Tests whether two SizeD structures are different.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator <> ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As Boolean
C#
public static bool operator !=(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static bool operator !=(
    SizeD sz1,
    SizeD sz2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the left of the inequality operator.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD structure on the right of the inequality operator.

Return Value

This operator returns true if sz1 and sz2 differ either in width or height; false if sz1 and sz2 are equal.

See Also

SizeD Structure


Subtraction Operator

[image]

.NET Framework Class Library
SizeD..::..Subtraction Operator
SizeD Structure See Also Send Feedback

Subtracts the width and height of one SizeD structure from the width and height of another SizeD structure.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Operator - ( _
    sz1 As SizeD, _
    sz2 As SizeD _
) As SizeD
C#
public static SizeD operator -(
    SizeD sz1,
    SizeD sz2
)
Visual C++
public:
static SizeD operator -(
    SizeD sz1,
    SizeD sz2
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

sz1
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD on the left side of the subtraction operator.
sz2
Type: EGIS.ShapeFileLib..::..SizeD
The SizeD on the right side of the subtraction operator.

Return Value

A SizeD that is the result of the subtraction operation.

See Also

SizeD Structure


SizeD Properties

[image] [image]

.NET Framework Class Library
SizeD Properties
SizeD Structure See Also Send Feedback

The SizeD type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets or sets the vertical component of this SizeD.
Public property | IsEmpty | Gets a value indicating whether this SizeD has zero width and height.
Public property | Width | Gets or sets the horizontal component of this SizeD.

See Also

SizeD Structure


Height Property

[image]

.NET Framework Class Library
SizeD..::..Height Property
SizeD Structure See Also Send Feedback

Gets or sets the vertical component of this SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Height As Double
    Get
    Set
C#
public double Height { get; set; }
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}
JavaScript
function get_height();
function set_height(value);

Return Value

The vertical component of this SizeD.

See Also

SizeD Structure


IsEmpty Property

[image]

.NET Framework Class Library
SizeD..::..IsEmpty Property
SizeD Structure See Also Send Feedback

Gets a value indicating whether this SizeD has zero width and height.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
C#
public bool IsEmpty { get; }
Visual C++
public:
property bool IsEmpty {
    bool get ();
}
JavaScript
function get_isEmpty();

Return Value

This property returns true when this SizeD has both a width and height of zero; otherwise, false.

See Also

SizeD Structure


Width Property

[image]

.NET Framework Class Library
SizeD..::..Width Property
SizeD Structure See Also Send Feedback

Gets or sets the horizontal component of this SizeD.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Width As Double
    Get
    Set
C#
public double Width { get; set; }
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}
JavaScript
function get_width();
function set_width(value);

Return Value

The horizontal component of this SizeD.

See Also

SizeD Structure


SizeDConverter Class

[image]

.NET Framework Class Library
SizeDConverter Class
Members See Also Send Feedback

Converts SizeD objects from one type to another.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Class SizeDConverter _
    Inherits TypeConverter
C#
public class SizeDConverter : TypeConverter
Visual C++
public ref class SizeDConverter : public TypeConverter
JavaScript
EGIS.ShapeFileLib.SizeDConverter = function();

Type.createClass(
    'EGIS.ShapeFileLib.SizeDConverter',
    TypeConverter);

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
EGIS.ShapeFileLib..::..SizeDConverter

See Also

SizeDConverter Members


SizeDConverter Members

[image] [image]

.NET Framework Class Library
SizeDConverter Members
SizeDConverter Class Constructors Methods See Also Send Feedback

The SizeDConverter type exposes the following members.

Constructors

 | Name | Description
Public method | SizeDConverter |

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns a value indicating whether the converter can convert from the type specified to the SizeD type, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns a value indicating whether the SizeDConverter can convert a SizeD to the specified type. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of a SizeD with the specified property values using the specified context. (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns a value indicating whether changing a value on this object requires a call to the CreateInstance(ITypeDescriptorContext, IDictionary) method to create a new value. (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Retrieves a set of properties for the SizeD type using the specified context and attributes. (Overrides TypeConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether the SizeD type supports properties. (Overrides TypeConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeDConverter Class


SizeDConverter Constructor

[image]

.NET Framework Class Library
SizeDConverter Constructor
SizeDConverter Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Sub New
C#
public SizeDConverter()
Visual C++
public:
SizeDConverter()
JavaScript
EGIS.ShapeFileLib.SizeDConverter = function();

See Also

SizeDConverter Class


SizeDConverter Methods

[image] [image]

.NET Framework Class Library
SizeDConverter Methods
SizeDConverter Class See Also Send Feedback

The SizeDConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns a value indicating whether the converter can convert from the type specified to the SizeD type, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns a value indicating whether the SizeDConverter can convert a SizeD to the specified type. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of a SizeD with the specified property values using the specified context. (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns a value indicating whether changing a value on this object requires a call to the CreateInstance(ITypeDescriptorContext, IDictionary) method to create a new value. (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Retrieves a set of properties for the SizeD type using the specified context and attributes. (Overrides TypeConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether the SizeD type supports properties. (Overrides TypeConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeDConverter Class


CanConvertFrom Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..CanConvertFrom Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns a value indicating whether the converter can convert from the type specified to the SizeD type, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

SizeDConverter Class
SizeDConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
SizeDConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
SizeDConverter Class See Also Send Feedback

Returns a value indicating whether the converter can convert from the type specified to the SizeD type, using the specified context.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
JavaScript
function canConvertFrom(context, sourceType);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext through which additional context can be supplied.
sourceType
Type: System..::..Type
A Type the represents the type you wish to convert from.

Return Value

true to indicate the conversion can be performed; otherwise, false.

See Also

SizeDConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..CanConvertTo Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns a value indicating whether the SizeDConverter can convert a SizeD to the specified type. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)

See Also

SizeDConverter Class
SizeDConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
SizeDConverter..::..CanConvertTo Method (ITypeDescriptorContext, Type)
SizeDConverter Class See Also Send Feedback

Returns a value indicating whether the SizeDConverter can convert a SizeD to the specified type.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override
JavaScript
function canConvertTo(context, destinationType);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext through which additional context can be supplied.
destinationType
Type: System..::..Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion otherwise, false.

See Also

SizeDConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertFrom Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

SizeDConverter Class
SizeDConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

.NET Framework Class Library
SizeDConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
SizeDConverter Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
JavaScript
function convertFrom(context, culture, value);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object

See Also

SizeDConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertFromInvariantString Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


ConvertFromString Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertFromString Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


ConvertTo Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertTo Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

SizeDConverter Class
SizeDConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

.NET Framework Class Library
SizeDConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
SizeDConverter Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
JavaScript
function convertTo(context, culture, value, destinationType);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

See Also

SizeDConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertToInvariantString Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


ConvertToString Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..ConvertToString Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


CreateInstance Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..CreateInstance Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of a SizeD with the specified property values using the specified context. (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)

See Also

SizeDConverter Class
SizeDConverter Members


CreateInstance Method (ITypeDescriptorContext, IDictionary)

[image]

.NET Framework Class Library
SizeDConverter..::..CreateInstance Method (ITypeDescriptorContext, IDictionary)
SizeDConverter Class See Also Send Feedback

Creates an instance of a SizeD with the specified property values using the specified context.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object
C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual C++
public:
virtual Object^ CreateInstance(
    ITypeDescriptorContext^ context,
    IDictionary^ propertyValues
) override
JavaScript
function createInstance(context, propertyValues);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext through which additional context can be supplied.
propertyValues
Type: System.Collections..::..IDictionary
An IDictionary containing property names and values.

Return Value

An Object representing the new SizeD, or null if the object cannot be created.

See Also

SizeDConverter Class
CreateInstance Overload


GetCreateInstanceSupported Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetCreateInstanceSupported Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns a value indicating whether changing a value on this object requires a call to the CreateInstance(ITypeDescriptorContext, IDictionary) method to create a new value. (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)

See Also

SizeDConverter Class
SizeDConverter Members


GetCreateInstanceSupported Method (ITypeDescriptorContext)

[image]

.NET Framework Class Library
SizeDConverter..::..GetCreateInstanceSupported Method (ITypeDescriptorContext)
SizeDConverter Class See Also Send Feedback

Returns a value indicating whether changing a value on this object requires a call to the CreateInstance(ITypeDescriptorContext, IDictionary) method to create a new value.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetCreateInstanceSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Visual C++
public:
virtual bool GetCreateInstanceSupported(
    ITypeDescriptorContext^ context
) override
JavaScript
function getCreateInstanceSupported(context);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context. This may be null.

Return Value

Always returns true.

See Also

SizeDConverter Class
GetCreateInstanceSupported Overload


GetProperties Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetProperties Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Retrieves a set of properties for the SizeD type using the specified context and attributes. (Overrides TypeConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)

See Also

SizeDConverter Class
SizeDConverter Members


GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

[image]

.NET Framework Class Library
SizeDConverter..::..GetProperties Method (ITypeDescriptorContext, Object, array<Attribute>[]()[][])
SizeDConverter Class See Also Send Feedback

Retrieves a set of properties for the SizeD type using the specified context and attributes.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection
C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties(
    ITypeDescriptorContext^ context,
    Object^ value,
    array<Attribute^>^ attributes
) override
JavaScript
function getProperties(context, value, attributes);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext through which additional context can be supplied.
value
Type: System..::..Object
The Object to return properties for.
attributes
Type: array< System..::..Attribute >[]()[][]
An array of Attribute objects that describe the properties.

Return Value

A PropertyDescriptorCollection containing the properties.

See Also

SizeDConverter Class
GetProperties Overload


GetPropertiesSupported Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetPropertiesSupported Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether the SizeD type supports properties. (Overrides TypeConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)

See Also

SizeDConverter Class
SizeDConverter Members


GetPropertiesSupported Method (ITypeDescriptorContext)

[image]

.NET Framework Class Library
SizeDConverter..::..GetPropertiesSupported Method (ITypeDescriptorContext)
SizeDConverter Class See Also Send Feedback

Returns whether the SizeD type supports properties.

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual C++
public:
virtual bool GetPropertiesSupported(
    ITypeDescriptorContext^ context
) override
JavaScript
function getPropertiesSupported(context);

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext through which additional context can be supplied.

Return Value

Always returns true.

See Also

SizeDConverter Class
GetPropertiesSupported Overload


GetStandardValues Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetStandardValues Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


GetStandardValuesExclusive Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetStandardValuesExclusive Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


GetStandardValuesSupported Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..GetStandardValuesSupported Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


IsValid Method

[image] [image]

.NET Framework Class Library
SizeDConverter..::..IsValid Method
SizeDConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

SizeDConverter Class
SizeDConverter Members


TileUtil Class

[image]

.NET Framework Class Library
TileUtil Class
Members See Also Send Feedback

Utility class with methods to convert Lat Long locations to Tile Coordinates

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public NotInheritable Class TileUtil
C#
public sealed class TileUtil
Visual C++
public ref class TileUtil sealed
JavaScript
EGIS.ShapeFileLib.TileUtil = function();

Type.createClass(
    'EGIS.ShapeFileLib.TileUtil');

Remarks

The TileUtil class is used by the EGIS.Web.Controls TiledSFMap to convert map tile image requests to actual Lat Long position and zoom level for rendering purposes

Note that in order to use Map tiles the [!:EGIS.ShapeFileLib.ShapeFile.UseMercatorProjection] property must be set to true

Tiles are organised in a manner similar to the approach used by google maps and bing maps. Each tiles dimension is 256x256 pixels. A tile request is made up of a zoom-level between 0 and 16(inclusive), tile x-ccord and a tile y-ccord. At zoom-level 0 the entire world (-180 lon -> +180 lon) is scaled to fit in 1 tile. At level 1 the world will fit in 2 tiles x 2 tiles, at level 2 the world will fit into 4 tiles x 4 tiles, .. etc.

Tiles are numbered from zero in the upper left corner to (NumTiles at zoom-level)-1 as below:

Copy image Copy Code
            (0,0) (1,0) (2,0) ..
            (0,1) (1,1) (2,1) ..
            (0,2) (1,2) (2,2) ..
            ..

Inheritance Hierarchy

System..::..Object
EGIS.ShapeFileLib..::..TileUtil

See Also

TileUtil Members
EGIS.ShapeFileLib Namespace
[!:EGIS.ShapeFileLib.ShapeFile.UseMercatorProjection]


TileUtil Members

[image] [image]

.NET Framework Class Library
TileUtil Members
TileUtil Class Methods See Also Send Feedback

The TileUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMercatorCenterPointFromTile | Returns the centre point (in Mercator Projection coordinates) of a given tile
 | GetTileFromGisLocation | Returns the tile number a given lat/long location lies in at a given zoom level
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LLToPixel |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PixelToLL |
 | PixelToMerc |
 | ScaleToZoomLevel | Converts a double-precision scaling to equivalent tile zoom-level
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ZoomLevelToScale | Converts a zoomLevel to its equivalent double-precision scaling

See Also

TileUtil Class


TileUtil Methods

[image] [image]

.NET Framework Class Library
TileUtil Methods
TileUtil Class See Also Send Feedback

The TileUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMercatorCenterPointFromTile | Returns the centre point (in Mercator Projection coordinates) of a given tile
 | GetTileFromGisLocation | Returns the tile number a given lat/long location lies in at a given zoom level
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LLToPixel |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PixelToLL |
 | PixelToMerc |
 | ScaleToZoomLevel | Converts a double-precision scaling to equivalent tile zoom-level
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ZoomLevelToScale | Converts a zoomLevel to its equivalent double-precision scaling

See Also

TileUtil Class


GetMercatorCenterPointFromTile Method

[image]

.NET Framework Class Library
TileUtil..::..GetMercatorCenterPointFromTile Method
TileUtil Class See Also Send Feedback

Returns the centre point (in Mercator Projection coordinates) of a given tile

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function GetMercatorCenterPointFromTile ( _
    tileX As Integer, _
    tileY As Integer, _
    zoomLevel As Integer _
) As PointD
C#
public static PointD GetMercatorCenterPointFromTile(
    int tileX,
    int tileY,
    int zoomLevel
)
Visual C++
public:
static PointD GetMercatorCenterPointFromTile(
    int tileX,
    int tileY,
    int zoomLevel
)
JavaScript
EGIS.ShapeFileLib.TileUtil.getMercatorCenterPointFromTile = function(tileX, tileY, zoomLevel);

Parameters

tileX
Type: System..::..Int32
zero based tile x-coord
tileY
Type: System..::..Int32
zero based tile y-ccord
zoomLevel
Type: System..::..Int32

Return Value

Exceptions

Exception | Condition
System..::..ArgumentException | If zoomLevel less than zero

See Also

TileUtil Class


GetTileFromGisLocation Method

[image]

.NET Framework Class Library
TileUtil..::..GetTileFromGisLocation Method
TileUtil Class See Also Send Feedback

Returns the tile number a given lat/long location lies in at a given zoom level

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function GetTileFromGisLocation ( _
    lon As Double, _
    lat As Double, _
    zoomLevel As Integer _
) As Point
C#
public static Point GetTileFromGisLocation(
    double lon,
    double lat,
    int zoomLevel
)
Visual C++
public:
static Point GetTileFromGisLocation(
    double lon,
    double lat,
    int zoomLevel
)
JavaScript
EGIS.ShapeFileLib.TileUtil.getTileFromGisLocation = function(lon, lat, zoomLevel);

Parameters

lon
Type: System..::..Double
lat
Type: System..::..Double
zoomLevel
Type: System..::..Int32

Return Value

a Point containing the tiles x,y coordinates

See Also

TileUtil Class


LLToPixel Method

[image]

.NET Framework Class Library
TileUtil..::..LLToPixel Method
TileUtil Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Sub LLToPixel ( _
    latLong As PointD, _
    zoomLevel As Integer, _
    <OutAttribute> ByRef x As Long, _
    <OutAttribute> ByRef y As Long _
)
C#
public static void LLToPixel(
    PointD latLong,
    int zoomLevel,
    out long x,
    out long y
)
Visual C++
public:
static void LLToPixel(
    PointD latLong,
    int zoomLevel,
    [OutAttribute] long long% x,
    [OutAttribute] long long% y
)
JavaScript
EGIS.ShapeFileLib.TileUtil.llToPixel = function(latLong, zoomLevel, x, y);

Parameters

latLong
Type: EGIS.ShapeFileLib..::..PointD
zoomLevel
Type: System..::..Int32
x
Type: System..::..Int64 %
y
Type: System..::..Int64 %

See Also

TileUtil Class


PixelToLL Method

[image]

.NET Framework Class Library
TileUtil..::..PixelToLL Method
TileUtil Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PixelToLL ( _
    pixX As Integer, _
    pixY As Integer, _
    zoomLevel As Integer _
) As PointD
C#
public static PointD PixelToLL(
    int pixX,
    int pixY,
    int zoomLevel
)
Visual C++
public:
static PointD PixelToLL(
    int pixX,
    int pixY,
    int zoomLevel
)
JavaScript
EGIS.ShapeFileLib.TileUtil.pixelToLL = function(pixX, pixY, zoomLevel);

Parameters

pixX
Type: System..::..Int32
pixY
Type: System..::..Int32
zoomLevel
Type: System..::..Int32

See Also

TileUtil Class


PixelToMerc Method

[image]

.NET Framework Class Library
TileUtil..::..PixelToMerc Method
TileUtil Class See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function PixelToMerc ( _
    pixX As Integer, _
    pixY As Integer, _
    zoomLevel As Integer _
) As PointD
C#
public static PointD PixelToMerc(
    int pixX,
    int pixY,
    int zoomLevel
)
Visual C++
public:
static PointD PixelToMerc(
    int pixX,
    int pixY,
    int zoomLevel
)
JavaScript
EGIS.ShapeFileLib.TileUtil.pixelToMerc = function(pixX, pixY, zoomLevel);

Parameters

pixX
Type: System..::..Int32
pixY
Type: System..::..Int32
zoomLevel
Type: System..::..Int32

See Also

TileUtil Class


ScaleToZoomLevel Method

[image]

.NET Framework Class Library
TileUtil..::..ScaleToZoomLevel Method
TileUtil Class See Also Send Feedback

Converts a double-precision scaling to equivalent tile zoom-level

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ScaleToZoomLevel ( _
    scale As Double _
) As Integer
C#
public static int ScaleToZoomLevel(
    double scale
)
Visual C++
public:
static int ScaleToZoomLevel(
    double scale
)
JavaScript
EGIS.ShapeFileLib.TileUtil.scaleToZoomLevel = function(scale);

Parameters

scale
Type: System..::..Double

Return Value

See Also

TileUtil Class


ZoomLevelToScale Method

[image]

.NET Framework Class Library
TileUtil..::..ZoomLevelToScale Method
TileUtil Class See Also Send Feedback

Converts a zoomLevel to its equivalent double-precision scaling

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Shared Function ZoomLevelToScale ( _
    zoomLevel As Integer _
) As Double
C#
public static double ZoomLevelToScale(
    int zoomLevel
)
Visual C++
public:
static double ZoomLevelToScale(
    int zoomLevel
)
JavaScript
EGIS.ShapeFileLib.TileUtil.zoomLevelToScale = function(zoomLevel);

Parameters

zoomLevel
Type: System..::..Int32

Return Value

Exceptions

Exception | Condition
System..::..ArgumentException | If zoomLevel less than zero

See Also

TileUtil Class


UtmCoordinate Structure

[image]

.NET Framework Class Library
UtmCoordinate Structure
Members See Also Send Feedback

struct used to store a UTM Coordinat. Used in ConversionFunctions

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
<SerializableAttribute> _
Public Structure UtmCoordinate
C#
[SerializableAttribute]
public struct UtmCoordinate
Visual C++
[SerializableAttribute]
public value class UtmCoordinate
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

UtmCoordinate Members
EGIS.ShapeFileLib..::..ConversionFunctions


UtmCoordinate Members

[image] [image]

.NET Framework Class Library
UtmCoordinate Members
UtmCoordinate Structure Methods Properties See Also Send Feedback

The UtmCoordinate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Easting |
Public property | Northing |
Public property | Zone |
Public property | ZoneIdentifier |

See Also

UtmCoordinate Structure


UtmCoordinate Methods

[image] [image]

.NET Framework Class Library
UtmCoordinate Methods
UtmCoordinate Structure See Also Send Feedback

The UtmCoordinate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

UtmCoordinate Structure


ToString Method

[image]

.NET Framework Class Library
UtmCoordinate..::..ToString Method
UtmCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

UtmCoordinate Structure


UtmCoordinate Properties

[image] [image]

.NET Framework Class Library
UtmCoordinate Properties
UtmCoordinate Structure See Also Send Feedback

The UtmCoordinate type exposes the following members.

Properties

 | Name | Description
Public property | Easting |
Public property | Northing |
Public property | Zone |
Public property | ZoneIdentifier |

See Also

UtmCoordinate Structure


Easting Property

[image]

.NET Framework Class Library
UtmCoordinate..::..Easting Property
UtmCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Easting As Double
    Get
    Set
C#
public double Easting { get; set; }
Visual C++
public:
property double Easting {
    double get ();
    void set (double value);
}
JavaScript
function get_easting();
function set_easting(value);

See Also

UtmCoordinate Structure


Northing Property

[image]

.NET Framework Class Library
UtmCoordinate..::..Northing Property
UtmCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Northing As Double
    Get
    Set
C#
public double Northing { get; set; }
Visual C++
public:
property double Northing {
    double get ();
    void set (double value);
}
JavaScript
function get_northing();
function set_northing(value);

See Also

UtmCoordinate Structure


Zone Property

[image]

.NET Framework Class Library
UtmCoordinate..::..Zone Property
UtmCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property Zone As Integer
    Get
    Set
C#
public int Zone { get; set; }
Visual C++
public:
property int Zone {
    int get ();
    void set (int value);
}
JavaScript
function get_zone();
function set_zone(value);

See Also

UtmCoordinate Structure


ZoneIdentifier Property

[image]

.NET Framework Class Library
UtmCoordinate..::..ZoneIdentifier Property
UtmCoordinate Structure See Also Send Feedback

Namespace: EGIS.ShapeFileLib
Assembly: EGIS.ShapeFileLib (in EGIS.ShapeFileLib.dll)

Syntax

Visual Basic
Public Property ZoneIdentifier As Char
    Get
    Set
C#
public char ZoneIdentifier { get; set; }
Visual C++
public:
property wchar_t ZoneIdentifier {
    wchar_t get ();
    void set (wchar_t value);
}
JavaScript
function get_zoneIdentifier();
function set_zoneIdentifier(value);

See Also

UtmCoordinate Structure


EGIS.Web.Controls Namespace

[image]

.NET Framework Class Library
EGIS.Web.Controls Namespace
Send Feedback

Classes

 | Class | Description
Public class | MapPanControl | Web Control which provides pan and zoom control for a map
Public class | MapProject |
Public class | QuantileCustomRenderSettings | QuantileCustomRenderSettings implements the ICustomRenderSettings interface and is used to provide dynamic render settings.
Public class | SFMap | ASP .NET Mapping Control which loads and displays an Easy GIS .NET map project in a web page.
Public class | TiledMapHandler | Generic IHttpHandler for handling TiledMap requests
Public class | TiledSFMap | ASP .NET Mapping Control which loads and displays an Easy GIS .NET map project in a web page using map tile images.
Public class | TooltipHeaderFieldNamePair | Simple Header / FieldName Pair class used to provide custom ToolTips in the QuantileCustomRenderSettings

Interfaces

 | Interface | Description
Public interface | ISFMap | Interface defining methods needed by MapPanControl to interact with SFMap and TiledSFMap classes.


ISFMap Interface

[image]

.NET Framework Class Library
ISFMap Interface
Members See Also Send Feedback

Interface defining methods needed by MapPanControl to interact with SFMap and TiledSFMap classes.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Interface ISFMap
C#
public interface ISFMap
Visual C++
public interface class ISFMap
JavaScript
EGIS.Web.Controls.ISFMap = function();
EGIS.Web.Controls.ISFMap.createInterface('EGIS.Web.Controls.ISFMap');

See Also

ISFMap Members
EGIS.Web.Controls Namespace


ISFMap Members

[image] [image]

.NET Framework Class Library
ISFMap Members
ISFMap Interface Properties See Also Send Feedback

The ISFMap type exposes the following members.

Properties

 | Name | Description
Public property | ClientJSResouceName | the name of the Javascript resource used by the ISFMap, which is different depending on whether a TiledSfMap or simple SFMap is used
Public property | ControlId | the Id of the MapControl
Public property | GisImageClientId | The client Id of the Map's GIS Image

See Also

ISFMap Interface
EGIS.Web.Controls Namespace


ISFMap Properties

[image] [image]

.NET Framework Class Library
ISFMap Properties
ISFMap Interface See Also Send Feedback

The ISFMap type exposes the following members.

Properties

 | Name | Description
Public property | ClientJSResouceName | the name of the Javascript resource used by the ISFMap, which is different depending on whether a TiledSfMap or simple SFMap is used
Public property | ControlId | the Id of the MapControl
Public property | GisImageClientId | The client Id of the Map's GIS Image

See Also

ISFMap Interface
EGIS.Web.Controls Namespace


ClientJSResouceName Property

[image]

.NET Framework Class Library
ISFMap..::..ClientJSResouceName Property
ISFMap Interface See Also Send Feedback

the name of the Javascript resource used by the ISFMap, which is different depending on whether a TiledSfMap or simple SFMap is used

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
ReadOnly Property ClientJSResouceName As String
    Get
C#
string ClientJSResouceName { get; }
Visual C++
property String^ ClientJSResouceName {
    String^ get ();
}
JavaScript
function get_clientJSResouceName();

See Also

ISFMap Interface
EGIS.Web.Controls Namespace


ControlId Property

[image]

.NET Framework Class Library
ISFMap..::..ControlId Property
ISFMap Interface See Also Send Feedback

the Id of the MapControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
ReadOnly Property ControlId As String
    Get
C#
string ControlId { get; }
Visual C++
property String^ ControlId {
    String^ get ();
}
JavaScript
function get_controlId();

See Also

ISFMap Interface
EGIS.Web.Controls Namespace


GisImageClientId Property

[image]

.NET Framework Class Library
ISFMap..::..GisImageClientId Property
ISFMap Interface See Also Send Feedback

The client Id of the Map's GIS Image

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
ReadOnly Property GisImageClientId As String
    Get
C#
string GisImageClientId { get; }
Visual C++
property String^ GisImageClientId {
    String^ get ();
}
JavaScript
function get_gisImageClientId();

See Also

ISFMap Interface
EGIS.Web.Controls Namespace


MapPanControl Class

[image]

.NET Framework Class Library
MapPanControl Class
Members See Also Send Feedback

Web Control which provides pan and zoom control for a map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class MapPanControl _
    Inherits CompositeControl
C#
public class MapPanControl : CompositeControl
Visual C++
public ref class MapPanControl : public CompositeControl
JavaScript
EGIS.Web.Controls.MapPanControl = function();

Type.createClass(
    'EGIS.Web.Controls.MapPanControl',
    CompositeControl);

Remarks

The MapPanControl control is a composite control that provides 4 pan buttons (left, right, up, down), a zoom-in and a zoom-out button.

The control can be customized by specifying a new Image Url for each of the pan or zoom buttons.

Each button is rendered as an "input" HTML element. To specify the CSS style of the buttons specify a class for the control and supply a style for the .class input, as shown below

Copy image Copy Code
            <style type="text/css"> .mpc input {padding:2px;} </style>
            ..
            <cc1:MapPanControl class="mpc" ID="MapPanControl1" runat="server" />

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
System.Web.UI.WebControls..::..CompositeControl
EGIS.Web.Controls..::..MapPanControl

See Also

MapPanControl Members
EGIS.Web.Controls Namespace


MapPanControl Members

[image] [image]

.NET Framework Class Library
MapPanControl Members
MapPanControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The MapPanControl type exposes the following members.

Constructors

 | Name | Description
Public method | MapPanControl | MapPanControl constructor

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client. (Inherited from CompositeControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | overrides RenderChildren in CompositeControl (Overrides Control..::..RenderChildren(HtmlTextWriter).)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetMap | Sets a reference to the SFMap Web Control that the MapPanControl will interact with
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MapReferenceId | gets/sets the ID of the ISFMap that the pan control will interact with
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Protected property | PanDownClientJS | returns the javascript code in order to pan the map down
Public property | PanDownImageUrl | Gets or sets the Url of an image to use for the "Pan Down" button
Protected property | PanLeftClientJS | returns the javascript code in order to pan the map left
Public property | PanLeftImageUrl | Gets or sets the Url of an image to use for the "Pan Left" button
Protected property | PanRightClientJS | returns the javascript code in order to pan the map right
Public property | PanRightImageUrl | Gets or sets the Url of an image to use for the "Pan Right" button
Protected property | PanUpClientJS | returns the javascript code in order to pan the map up
Public property | PanUpImageUrl | Gets or sets the Url of an image to use for the "Pan Up" button
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides TagKey in WebControl. returns div tag (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Protected property | ZoomInClientJS | returns the javascript code in order to zoom in to the map (X2)
Public property | ZoomInImageUrl | Gets or sets the Url of an image to use for the "Zoom In" button
Protected property | ZoomOutClientJS | returns the javascript code in order to zoom out of the map (X2)
Public property | ZoomOutImageUrl | Gets or sets the Url of an image to use for the "Zoom Out" button

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


MapPanControl Constructor

[image]

.NET Framework Class Library
MapPanControl Constructor
MapPanControl Class See Also Send Feedback

MapPanControl constructor

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public MapPanControl()
Visual C++
public:
MapPanControl()
JavaScript
EGIS.Web.Controls.MapPanControl = function();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


MapPanControl Methods

[image] [image]

.NET Framework Class Library
MapPanControl Methods
MapPanControl Class See Also Send Feedback

The MapPanControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client. (Inherited from CompositeControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | overrides RenderChildren in CompositeControl (Overrides Control..::..RenderChildren(HtmlTextWriter).)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetMap | Sets a reference to the SFMap Web Control that the MapPanControl will interact with
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


CreateChildControls Method

[image]

.NET Framework Class Library
MapPanControl..::..CreateChildControls Method
MapPanControl Class See Also Send Feedback

overrides CreateChildControls in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub CreateChildControls
C#
protected override void CreateChildControls()
Visual C++
protected:
virtual void CreateChildControls() override
JavaScript
function createChildControls();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


DataBind Method

[image] [image]

.NET Framework Class Library
MapPanControl..::..DataBind Method
MapPanControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

MapPanControl Class
MapPanControl Members
EGIS.Web.Controls Namespace


FindControl Method

[image] [image]

.NET Framework Class Library
MapPanControl..::..FindControl Method
MapPanControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

MapPanControl Class
MapPanControl Members
EGIS.Web.Controls Namespace


GetRouteUrl Method

[image] [image]

.NET Framework Class Library
MapPanControl..::..GetRouteUrl Method
MapPanControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)

See Also

MapPanControl Class
MapPanControl Members
EGIS.Web.Controls Namespace


OnPreRender Method

[image]

.NET Framework Class Library
MapPanControl..::..OnPreRender Method
MapPanControl Class See Also Send Feedback

overrides OnPreRender in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)
C#
protected override void OnPreRender(
    EventArgs e
)
Visual C++
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
JavaScript
function onPreRender(e);

Parameters

e
Type: System..::..EventArgs

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


RenderChildren Method

[image]

.NET Framework Class Library
MapPanControl..::..RenderChildren Method
MapPanControl Class See Also Send Feedback

overrides RenderChildren in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub RenderChildren ( _
    writer As HtmlTextWriter _
)
C#
protected override void RenderChildren(
    HtmlTextWriter writer
)
Visual C++
protected:
virtual void RenderChildren(
    HtmlTextWriter^ writer
) override
JavaScript
function renderChildren(writer);

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


RenderControl Method

[image] [image]

.NET Framework Class Library
MapPanControl..::..RenderControl Method
MapPanControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

MapPanControl Class
MapPanControl Members
EGIS.Web.Controls Namespace


SetMap Method

[image]

.NET Framework Class Library
MapPanControl..::..SetMap Method
MapPanControl Class See Also Send Feedback

Sets a reference to the SFMap Web Control that the MapPanControl will interact with

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub SetMap ( _
    map As ISFMap _
)
C#
public void SetMap(
    ISFMap map
)
Visual C++
public:
void SetMap(
    ISFMap^ map
)
JavaScript
function setMap(map);

Parameters

map
Type: EGIS.Web.Controls..::..ISFMap
the SFMap control

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


SetTraceData Method

[image] [image]

.NET Framework Class Library
MapPanControl..::..SetTraceData Method
MapPanControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)

See Also

MapPanControl Class
MapPanControl Members
EGIS.Web.Controls Namespace


MapPanControl Properties

[image] [image]

.NET Framework Class Library
MapPanControl Properties
MapPanControl Class See Also Send Feedback

The MapPanControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MapReferenceId | gets/sets the ID of the ISFMap that the pan control will interact with
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Protected property | PanDownClientJS | returns the javascript code in order to pan the map down
Public property | PanDownImageUrl | Gets or sets the Url of an image to use for the "Pan Down" button
Protected property | PanLeftClientJS | returns the javascript code in order to pan the map left
Public property | PanLeftImageUrl | Gets or sets the Url of an image to use for the "Pan Left" button
Protected property | PanRightClientJS | returns the javascript code in order to pan the map right
Public property | PanRightImageUrl | Gets or sets the Url of an image to use for the "Pan Right" button
Protected property | PanUpClientJS | returns the javascript code in order to pan the map up
Public property | PanUpImageUrl | Gets or sets the Url of an image to use for the "Pan Up" button
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides TagKey in WebControl. returns div tag (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Protected property | ZoomInClientJS | returns the javascript code in order to zoom in to the map (X2)
Public property | ZoomInImageUrl | Gets or sets the Url of an image to use for the "Zoom In" button
Protected property | ZoomOutClientJS | returns the javascript code in order to zoom out of the map (X2)
Public property | ZoomOutImageUrl | Gets or sets the Url of an image to use for the "Zoom Out" button

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


MapReferenceId Property

[image]

.NET Framework Class Library
MapPanControl..::..MapReferenceId Property
MapPanControl Class See Also Send Feedback

gets/sets the ID of the ISFMap that the pan control will interact with

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property MapReferenceId As String
    Get
    Set
C#
[BindableAttribute(true)]
public string MapReferenceId { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ MapReferenceId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mapReferenceId();
function set_mapReferenceId(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanDownClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..PanDownClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to pan the map down

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property PanDownClientJS As String
    Get
C#
protected string PanDownClientJS { get; }
Visual C++
protected:
property String^ PanDownClientJS {
    String^ get ();
}
JavaScript
function get_panDownClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanDownImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..PanDownImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Pan Down" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property PanDownImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string PanDownImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ PanDownImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_panDownImageUrl();
function set_panDownImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanLeftClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..PanLeftClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to pan the map left

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property PanLeftClientJS As String
    Get
C#
protected string PanLeftClientJS { get; }
Visual C++
protected:
property String^ PanLeftClientJS {
    String^ get ();
}
JavaScript
function get_panLeftClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanLeftImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..PanLeftImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Pan Left" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property PanLeftImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string PanLeftImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ PanLeftImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_panLeftImageUrl();
function set_panLeftImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanRightClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..PanRightClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to pan the map right

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property PanRightClientJS As String
    Get
C#
protected string PanRightClientJS { get; }
Visual C++
protected:
property String^ PanRightClientJS {
    String^ get ();
}
JavaScript
function get_panRightClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanRightImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..PanRightImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Pan Right" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property PanRightImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string PanRightImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ PanRightImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_panRightImageUrl();
function set_panRightImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanUpClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..PanUpClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to pan the map up

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property PanUpClientJS As String
    Get
C#
protected string PanUpClientJS { get; }
Visual C++
protected:
property String^ PanUpClientJS {
    String^ get ();
}
JavaScript
function get_panUpClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


PanUpImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..PanUpImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Pan Up" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property PanUpImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string PanUpImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ PanUpImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_panUpImageUrl();
function set_panUpImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


TagKey Property

[image]

.NET Framework Class Library
MapPanControl..::..TagKey Property
MapPanControl Class See Also Send Feedback

overrides TagKey in WebControl. returns div tag

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
C#
protected override HtmlTextWriterTag TagKey { get; }
Visual C++
protected:
virtual property HtmlTextWriterTag TagKey {
    HtmlTextWriterTag get () override;
}
JavaScript
function get_tagKey();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


ZoomInClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..ZoomInClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to zoom in to the map (X2)

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property ZoomInClientJS As String
    Get
C#
protected string ZoomInClientJS { get; }
Visual C++
protected:
property String^ ZoomInClientJS {
    String^ get ();
}
JavaScript
function get_zoomInClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


ZoomInImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..ZoomInImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Zoom In" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ZoomInImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string ZoomInImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ ZoomInImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zoomInImageUrl();
function set_zoomInImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


ZoomOutClientJS Property

[image]

.NET Framework Class Library
MapPanControl..::..ZoomOutClientJS Property
MapPanControl Class See Also Send Feedback

returns the javascript code in order to zoom out of the map (X2)

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property ZoomOutClientJS As String
    Get
C#
protected string ZoomOutClientJS { get; }
Visual C++
protected:
property String^ ZoomOutClientJS {
    String^ get ();
}
JavaScript
function get_zoomOutClientJS();

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


ZoomOutImageUrl Property

[image]

.NET Framework Class Library
MapPanControl..::..ZoomOutImageUrl Property
MapPanControl Class See Also Send Feedback

Gets or sets the Url of an image to use for the "Zoom Out" button

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ZoomOutImageUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string ZoomOutImageUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ ZoomOutImageUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zoomOutImageUrl();
function set_zoomOutImageUrl(value);

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


MapPanControl Events

[image] [image]

.NET Framework Class Library
MapPanControl Events
MapPanControl Class See Also Send Feedback

The MapPanControl type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

MapPanControl Class
EGIS.Web.Controls Namespace


MapProject Class

[image]

.NET Framework Class Library
MapProject Class
Members See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class MapProject
C#
public class MapProject
Visual C++
public ref class MapProject
JavaScript
EGIS.Web.Controls.MapProject = function();

Type.createClass(
    'EGIS.Web.Controls.MapProject');

Inheritance Hierarchy

System..::..Object
EGIS.Web.Controls..::..MapProject

See Also

MapProject Members
EGIS.Web.Controls Namespace


MapProject Members

[image] [image]

.NET Framework Class Library
MapProject Members
MapProject Class Constructors Methods Fields See Also Send Feedback

The MapProject type exposes the following members.

Constructors

 | Name | Description
Public method | MapProject |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | BackgroundColor |
Public field | Layers |

See Also

MapProject Class
EGIS.Web.Controls Namespace


MapProject Constructor

[image]

.NET Framework Class Library
MapProject Constructor
MapProject Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public MapProject()
Visual C++
public:
MapProject()
JavaScript
EGIS.Web.Controls.MapProject = function();

See Also

MapProject Class
EGIS.Web.Controls Namespace


MapProject Fields

[image] [image]

.NET Framework Class Library
MapProject Fields
MapProject Class See Also Send Feedback

The MapProject type exposes the following members.

Fields

 | Name | Description
Public field | BackgroundColor |
Public field | Layers |

See Also

MapProject Class
EGIS.Web.Controls Namespace


BackgroundColor Field

[image]

.NET Framework Class Library
MapProject..::..BackgroundColor Field
MapProject Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public BackgroundColor As Color
C#
public Color BackgroundColor
Visual C++
public:
Color BackgroundColor
JavaScript
backgroundColor

See Also

MapProject Class
EGIS.Web.Controls Namespace


Layers Field

[image]

.NET Framework Class Library
MapProject..::..Layers Field
MapProject Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Layers As List(Of ShapeFile)
C#
public List<ShapeFile> Layers
Visual C++
public:
List<ShapeFile^>^ Layers
JavaScript
layers

See Also

MapProject Class
EGIS.Web.Controls Namespace


MapProject Methods

[image] [image]

.NET Framework Class Library
MapProject Methods
MapProject Class See Also Send Feedback

The MapProject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapProject Class
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Class

[image]

.NET Framework Class Library
QuantileCustomRenderSettings Class
Members See Also Send Feedback

QuantileCustomRenderSettings implements the ICustomRenderSettings interface and is used to provide dynamic render settings.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class QuantileCustomRenderSettings _
    Implements ICustomRenderSettings
C#
public class QuantileCustomRenderSettings : ICustomRenderSettings
Visual C++
public ref class QuantileCustomRenderSettings : ICustomRenderSettings
JavaScript
EGIS.Web.Controls.QuantileCustomRenderSettings = function();

Type.createClass(
    'EGIS.Web.Controls.QuantileCustomRenderSettings',
    null,
    EGIS.ShapeFileLib.ICustomRenderSettings);

Remarks

QuantileCustomRenderSettings is used to render individual shape colors in a shapefile layer according to a specified range of values. For example, the color of the rendered shape could be green if field1 is between 0 and 100, yellow if field 1 is between 100 and 200, or red if it is greater than 200.

The class also provides the ability to join an external DataTable on a shapefile's DBF data file

Inheritance Hierarchy

System..::..Object
EGIS.Web.Controls..::..QuantileCustomRenderSettings

See Also

QuantileCustomRenderSettings Members
EGIS.Web.Controls Namespace
EGIS.ShapeFileLib..::..ICustomRenderSettings


QuantileCustomRenderSettings Members

[image] [image]

.NET Framework Class Library
QuantileCustomRenderSettings Members
QuantileCustomRenderSettings Class Constructors Methods Properties See Also Send Feedback

The QuantileCustomRenderSettings type exposes the following members.

Constructors

 | Name | Description
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, List<(Of <<'(TooltipHeaderFieldNamePair>)>>)) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String, List<(Of <<'(TooltipHeaderFieldNamePair>)>>)) | Constructs a new QuantileCustomRenderSettings instance

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecordFillColor | Implementation of the ICustomRenderSettings GetRecordFillColor member
Public method | GetRecordFontColor |
Public method | GetRecordImageSymbol |
Public method | GetRecordOutlineColor |
Public method | GetRecordToolTip | Implementation of the ICustomRenderSettings GetRecordToolTip member
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderShape | Implementation of the ICustomRenderSettings RenderShape member
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UseCustomImageSymbols |
Public property | UseCustomTooltips | Implementation of the ICustomRenderSettings UseCustomTooltips member

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Constructor

[image] [image]

.NET Framework Class Library
QuantileCustomRenderSettings Constructor
QuantileCustomRenderSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, List<(Of <<'(TooltipHeaderFieldNamePair>)>>)) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String) | Constructs a new QuantileCustomRenderSettings instance
Public method | QuantileCustomRenderSettings(RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String, List<(Of <<'(TooltipHeaderFieldNamePair>)>>)) | Constructs a new QuantileCustomRenderSettings instance

See Also

QuantileCustomRenderSettings Class
QuantileCustomRenderSettings Members
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Constructor (RenderSettings, Color[], Double[], String)

[image]

.NET Framework Class Library
QuantileCustomRenderSettings Constructor (RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String)
QuantileCustomRenderSettings Class See Also Send Feedback

Constructs a new QuantileCustomRenderSettings instance

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    renderSettings As RenderSettings, _
    quantileColors As Color(), _
    quantiles As Double(), _
    shapeFieldName As String _
)
C#
public QuantileCustomRenderSettings(
    RenderSettings renderSettings,
    Color[] quantileColors,
    double[] quantiles,
    string shapeFieldName
)
Visual C++
public:
QuantileCustomRenderSettings(
    RenderSettings^ renderSettings,
    array<Color>^ quantileColors,
    array<double>^ quantiles,
    String^ shapeFieldName
)
JavaScript
EGIS.Web.Controls.QuantileCustomRenderSettings = function(renderSettings, quantileColors, quantiles, shapeFieldName);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
Reference to a ShapeFile RenderSettings
quantileColors
Type: array< System.Drawing..::..Color >[]()[][]
Array of Colors to use. The number of Color elements should be 1 more than the number of quantile elements
quantiles
Type: array< System..::..Double >[]()[][]
Array of quantile values. Each successive element must be greater than the previous element. Example - {10, 50, 75}
shapeFieldName
Type: System..::..String
The name of the shapefile dbf field used to determine what color to render a shape

See Also

QuantileCustomRenderSettings Class
QuantileCustomRenderSettings Overload
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Constructor (RenderSettings, Color[], Double[], String, List(TooltipHeaderFieldNamePair))

[image]

.NET Framework Class Library
QuantileCustomRenderSettings Constructor (RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, List<(Of <(<'TooltipHeaderFieldNamePair>)>)>)
QuantileCustomRenderSettings Class See Also Send Feedback

Constructs a new QuantileCustomRenderSettings instance

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    renderSettings As RenderSettings, _
    quantileColors As Color(), _
    quantiles As Double(), _
    shapeFieldName As String, _
    tooltipHeaderFieldList As List(Of TooltipHeaderFieldNamePair) _
)
C#
public QuantileCustomRenderSettings(
    RenderSettings renderSettings,
    Color[] quantileColors,
    double[] quantiles,
    string shapeFieldName,
    List<TooltipHeaderFieldNamePair> tooltipHeaderFieldList
)
Visual C++
public:
QuantileCustomRenderSettings(
    RenderSettings^ renderSettings,
    array<Color>^ quantileColors,
    array<double>^ quantiles,
    String^ shapeFieldName,
    List<TooltipHeaderFieldNamePair^>^ tooltipHeaderFieldList
)
JavaScript
EGIS.Web.Controls.QuantileCustomRenderSettings = function(renderSettings, quantileColors, quantiles, shapeFieldName, tooltipHeaderFieldList);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
Reference to a ShapeFile RenderSettings
quantileColors
Type: array< System.Drawing..::..Color >[]()[][]
Array of Colors to use. The number of Color elements should be 1 more than the number of quantile elements
quantiles
Type: array< System..::..Double >[]()[][]
Array of quantile values. Each successive element must be greater than the previous element. Example - {10, 50, 75}
shapeFieldName
Type: System..::..String
The name of the shapefile dbf field used to determine what color to render a shape
tooltipHeaderFieldList
Type: System.Collections.Generic..::..List <(Of <(<' TooltipHeaderFieldNamePair >)>)>
List of TooltipHeaderFieldNamePair objects used to create a custom tooltip

See Also

QuantileCustomRenderSettings Class
QuantileCustomRenderSettings Overload
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Constructor (RenderSettings, Color[], Double[], String, DataTable, String, String)

[image]

.NET Framework Class Library
QuantileCustomRenderSettings Constructor (RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String)
QuantileCustomRenderSettings Class See Also Send Feedback

Constructs a new QuantileCustomRenderSettings instance

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    renderSettings As RenderSettings, _
    quantileColors As Color(), _
    quantiles As Double(), _
    quantileKey As String, _
    importData As DataTable, _
    shapeJoinKey As String, _
    importJoinKey As String _
)
C#
public QuantileCustomRenderSettings(
    RenderSettings renderSettings,
    Color[] quantileColors,
    double[] quantiles,
    string quantileKey,
    DataTable importData,
    string shapeJoinKey,
    string importJoinKey
)
Visual C++
public:
QuantileCustomRenderSettings(
    RenderSettings^ renderSettings,
    array<Color>^ quantileColors,
    array<double>^ quantiles,
    String^ quantileKey,
    DataTable^ importData,
    String^ shapeJoinKey,
    String^ importJoinKey
)
JavaScript
EGIS.Web.Controls.QuantileCustomRenderSettings = function(renderSettings, quantileColors, quantiles, quantileKey, importData, shapeJoinKey, importJoinKey);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
Reference to a ShapeFile RenderSettings
quantileColors
Type: array< System.Drawing..::..Color >[]()[][]
Array of Colors to use. The number of Color elements should be 1 more than the number of quantile elements
quantiles
Type: array< System..::..Double >[]()[][]
Array of quantile values. Each successive element must be greater than the previous element. Example - {10, 50, 75}
quantileKey
Type: System..::..String
The name of the column in the imported data used to determine what color to render a shape
importData
Type: System.Data..::..DataTable
Data to join on the shapefile layer.
shapeJoinKey
Type: System..::..String
The column in the shapefile layer's dbf file used to join to importData
importJoinKey
Type: System..::..String
The column in importData used to join on the shapefile layer

See Also

QuantileCustomRenderSettings Class
QuantileCustomRenderSettings Overload
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Constructor (RenderSettings, Color[], Double[], String, DataTable, String, String, List(TooltipHeaderFieldNamePair))

[image]

.NET Framework Class Library
QuantileCustomRenderSettings Constructor (RenderSettings, array<Color>[]()[][], array<Double>[]()[][], String, DataTable, String, String, List<(Of <(<'TooltipHeaderFieldNamePair>)>)>)
QuantileCustomRenderSettings Class See Also Send Feedback

Constructs a new QuantileCustomRenderSettings instance

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    renderSettings As RenderSettings, _
    quantileColors As Color(), _
    quantiles As Double(), _
    quantileKey As String, _
    importData As DataTable, _
    shapeJoinKey As String, _
    importJoinKey As String, _
    tooltipHeaderFieldList As List(Of TooltipHeaderFieldNamePair) _
)
C#
public QuantileCustomRenderSettings(
    RenderSettings renderSettings,
    Color[] quantileColors,
    double[] quantiles,
    string quantileKey,
    DataTable importData,
    string shapeJoinKey,
    string importJoinKey,
    List<TooltipHeaderFieldNamePair> tooltipHeaderFieldList
)
Visual C++
public:
QuantileCustomRenderSettings(
    RenderSettings^ renderSettings,
    array<Color>^ quantileColors,
    array<double>^ quantiles,
    String^ quantileKey,
    DataTable^ importData,
    String^ shapeJoinKey,
    String^ importJoinKey,
    List<TooltipHeaderFieldNamePair^>^ tooltipHeaderFieldList
)
JavaScript
EGIS.Web.Controls.QuantileCustomRenderSettings = function(renderSettings, quantileColors, quantiles, quantileKey, importData, shapeJoinKey, importJoinKey, tooltipHeaderFieldList);

Parameters

renderSettings
Type: EGIS.ShapeFileLib..::..RenderSettings
Reference to a ShapeFile RenderSettings
quantileColors
Type: array< System.Drawing..::..Color >[]()[][]
Array of Colors to use. The number of Color elements should be 1 more than the number of quantile elements
quantiles
Type: array< System..::..Double >[]()[][]
Array of quantile values. Each successive element must be greater than the previous element. Example - {10, 50, 75}
quantileKey
Type: System..::..String
The name of the column in the imported data used to determine what color to render a shape
importData
Type: System.Data..::..DataTable
Data to join on the shapefile layer.
shapeJoinKey
Type: System..::..String
The column in the shapefile layer's dbf file used to join to importData
importJoinKey
Type: System..::..String
The column in importData used to join on the shapefile layer
tooltipHeaderFieldList
Type: System.Collections.Generic..::..List <(Of <(<' TooltipHeaderFieldNamePair >)>)>
List of TooltipHeaderFieldNamePair objects used to create a custom tooltip

See Also

QuantileCustomRenderSettings Class
QuantileCustomRenderSettings Overload
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Methods

[image] [image]

.NET Framework Class Library
QuantileCustomRenderSettings Methods
QuantileCustomRenderSettings Class See Also Send Feedback

The QuantileCustomRenderSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRecordFillColor | Implementation of the ICustomRenderSettings GetRecordFillColor member
Public method | GetRecordFontColor |
Public method | GetRecordImageSymbol |
Public method | GetRecordOutlineColor |
Public method | GetRecordToolTip | Implementation of the ICustomRenderSettings GetRecordToolTip member
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderShape | Implementation of the ICustomRenderSettings RenderShape member
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


GetRecordFillColor Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..GetRecordFillColor Method
QuantileCustomRenderSettings Class See Also Send Feedback

Implementation of the ICustomRenderSettings GetRecordFillColor member

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetRecordFillColor ( _
    recordNumber As Integer _
) As Color
C#
public Color GetRecordFillColor(
    int recordNumber
)
Visual C++
public:
virtual Color GetRecordFillColor(
    int recordNumber
) sealed
JavaScript
function getRecordFillColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

Return Value

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


GetRecordFontColor Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..GetRecordFontColor Method
QuantileCustomRenderSettings Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetRecordFontColor ( _
    recordNumber As Integer _
) As Color
C#
public Color GetRecordFontColor(
    int recordNumber
)
Visual C++
public:
virtual Color GetRecordFontColor(
    int recordNumber
) sealed
JavaScript
function getRecordFontColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


GetRecordImageSymbol Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..GetRecordImageSymbol Method
QuantileCustomRenderSettings Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetRecordImageSymbol ( _
    recordNumber As Integer _
) As Image
C#
public Image GetRecordImageSymbol(
    int recordNumber
)
Visual C++
public:
virtual Image^ GetRecordImageSymbol(
    int recordNumber
) sealed
JavaScript
function getRecordImageSymbol(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


GetRecordOutlineColor Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..GetRecordOutlineColor Method
QuantileCustomRenderSettings Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetRecordOutlineColor ( _
    recordNumber As Integer _
) As Color
C#
public Color GetRecordOutlineColor(
    int recordNumber
)
Visual C++
public:
virtual Color GetRecordOutlineColor(
    int recordNumber
) sealed
JavaScript
function getRecordOutlineColor(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


GetRecordToolTip Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..GetRecordToolTip Method
QuantileCustomRenderSettings Class See Also Send Feedback

Implementation of the ICustomRenderSettings GetRecordToolTip member

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetRecordToolTip ( _
    recordNumber As Integer _
) As String
C#
public string GetRecordToolTip(
    int recordNumber
)
Visual C++
public:
virtual String^ GetRecordToolTip(
    int recordNumber
) sealed
JavaScript
function getRecordToolTip(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

Return Value

Implements

ICustomRenderSettings..::..GetRecordToolTip(Int32)

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


RenderShape Method

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..RenderShape Method
QuantileCustomRenderSettings Class See Also Send Feedback

Implementation of the ICustomRenderSettings RenderShape member

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function RenderShape ( _
    recordNumber As Integer _
) As Boolean
C#
public bool RenderShape(
    int recordNumber
)
Visual C++
public:
virtual bool RenderShape(
    int recordNumber
) sealed
JavaScript
function renderShape(recordNumber);

Parameters

recordNumber
Type: System..::..Int32

Return Value

Implements

ICustomRenderSettings..::..RenderShape(Int32)

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


QuantileCustomRenderSettings Properties

[image] [image]

.NET Framework Class Library
QuantileCustomRenderSettings Properties
QuantileCustomRenderSettings Class See Also Send Feedback

The QuantileCustomRenderSettings type exposes the following members.

Properties

 | Name | Description
Public property | UseCustomImageSymbols |
Public property | UseCustomTooltips | Implementation of the ICustomRenderSettings UseCustomTooltips member

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


UseCustomImageSymbols Property

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..UseCustomImageSymbols Property
QuantileCustomRenderSettings Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property UseCustomImageSymbols As Boolean
    Get
C#
public bool UseCustomImageSymbols { get; }
Visual C++
public:
virtual property bool UseCustomImageSymbols {
    bool get () sealed;
}
JavaScript
function get_useCustomImageSymbols();

Implements

ICustomRenderSettings..::..UseCustomImageSymbols

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


UseCustomTooltips Property

[image]

.NET Framework Class Library
QuantileCustomRenderSettings..::..UseCustomTooltips Property
QuantileCustomRenderSettings Class See Also Send Feedback

Implementation of the ICustomRenderSettings UseCustomTooltips member

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property UseCustomTooltips As Boolean
    Get
C#
public bool UseCustomTooltips { get; }
Visual C++
public:
virtual property bool UseCustomTooltips {
    bool get () sealed;
}
JavaScript
function get_useCustomTooltips();

Implements

ICustomRenderSettings..::..UseCustomTooltips

See Also

QuantileCustomRenderSettings Class
EGIS.Web.Controls Namespace


SFMap Class

[image]

.NET Framework Class Library
SFMap Class
Members See Also Send Feedback

ASP .NET Mapping Control which loads and displays an Easy GIS .NET map project in a web page.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class SFMap _
    Inherits CompositeControl _
    Implements ISFMap
C#
public class SFMap : CompositeControl, ISFMap
Visual C++
public ref class SFMap : public CompositeControl,
    ISFMap
JavaScript
EGIS.Web.Controls.SFMap = function();

Type.createClass(
    'EGIS.Web.Controls.SFMap',
    CompositeControl,
    EGIS.Web.Controls.ISFMap);

Remarks

This is the main control in the EGIS.Web.Controls namespace. The SFMap control is a composite control that looks and behaves the same as the Desktop EGIS.Controls.SFMap Control and is used to display and interact with a map in a web page.

An Easy GIS .NET project is composed of a number of Shapefiles and can be designed using the Desktop Edition of Easy GIS .NET. The project should be exported and copied to the web server hosting the page where the SFMap Web Control will be used. For more information on how to export a project ready to load in a web page see Easy GIS .NET Developers page

The SFMap Control generates all map images on the hosting web server using an IHttpHandler. All requests are performed automatically on the client's web browser using JavaScript and AJAX, resulting in a map that can be panned and zoomed in or out without refreshing the web page for each request.

NOTE: In order for the server to render maps an entry in the httpHandlers section of the web.config file must be made. If the SFMap Control is added to a page using the design view in Visual Studio an entry is added to the web.config file automatically, however if the Control is manually added to a page it will be neccessary to add the following section to the config file.

Copy image Copy Code
            <httpHandlers>
                   <add path="egismap.axd" verb="*" type="EGIS.Web.Controls.SFMapImageProvider, EGIS.Web.Controls, Version=2.3.0.0, Culture=neutral, PublicKeyToken=05b98c869b5ffe6a"
                       validate="true" />
               </httpHandlers>

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
System.Web.UI.WebControls..::..CompositeControl
EGIS.Web.Controls..::..SFMap

See Also

SFMap Members
EGIS.Web.Controls Namespace


SFMap Members

[image] [image]

.NET Framework Class Library
SFMap Members
SFMap Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The SFMap type exposes the following members.

Constructors

 | Name | Description
Public method | SFMap | Constructor

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | ClearCustomRenderSettings | Clears any ICustomRenderSettings previously set on the layers of the map
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateMap | Reads the EGIS shapefile project and creates the map
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLayer | Method to get a ShapeFile layer at the specified index
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | overrides LoadViewState in WebControl (Overrides WebControl..::..LoadViewState(Object).)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | overrides OnInit in CompositeControl (Overrides Control..::..OnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadEGPProject | static method to read a .egp project file
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Public method | RegisterHandlerInConfiguration | Registers the Http Handler in configuration.
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides CompositeControl..::..Render(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderDesignTime | Renders the control at design time.
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderMap | convenience method to render the currently loaded map to a bitmap
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetCustomRenderSettings | Applies custom render settings to the specified layer
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | CacheOnClient | Gets or sets whether to use client-side caching of any generated map image.
Public property | CenterPoint | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientJSResouceName | returns the name of the client javascript resource used to control the map.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ControlId | returns the client id of the map
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | GisImageClientId | returns the Client id of the internal GIS Image. This is used by controls only
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | HttpHandlerName | Gets the name of the http handler used to render the map on the server.
Public property | HttpHandlerType | Gets the type of the http handler used to render the map on the server.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | ImageSource | Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LayerCount | returns the number of layers in the SFMap Control
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaxZoomLevel | Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.
Public property | MinZoomLevel | Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | OnClientBoundsChanged | Gets or sets the client-side script that executes when the map Bounds are changed
Public property | OnClientZoomChanged | Gets or sets the client-side script that executes when the map ZoomLevel changes
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | ProjectName | Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides the TagKey property. Returns a Div Tag. (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | Zoom | Gets or sets the current ZoomLevel of the SFMap

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

SFMap Class
EGIS.Web.Controls Namespace


SFMap Constructor

[image]

.NET Framework Class Library
SFMap Constructor
SFMap Class See Also Send Feedback

Constructor

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public SFMap()
Visual C++
public:
SFMap()
JavaScript
EGIS.Web.Controls.SFMap = function();

See Also

SFMap Class
EGIS.Web.Controls Namespace


SFMap Methods

[image] [image]

.NET Framework Class Library
SFMap Methods
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | ClearCustomRenderSettings | Clears any ICustomRenderSettings previously set on the layers of the map
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateMap | Reads the EGIS shapefile project and creates the map
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLayer | Method to get a ShapeFile layer at the specified index
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | overrides LoadViewState in WebControl (Overrides WebControl..::..LoadViewState(Object).)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | overrides OnInit in CompositeControl (Overrides Control..::..OnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadEGPProject | static method to read a .egp project file
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Public method | RegisterHandlerInConfiguration | Registers the Http Handler in configuration.
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides CompositeControl..::..Render(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderDesignTime | Renders the control at design time.
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderMap | convenience method to render the currently loaded map to a bitmap
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetCustomRenderSettings | Applies custom render settings to the specified layer
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)

See Also

SFMap Class
EGIS.Web.Controls Namespace


ClearCustomRenderSettings Method

[image]

.NET Framework Class Library
SFMap..::..ClearCustomRenderSettings Method
SFMap Class See Also Send Feedback

Clears any ICustomRenderSettings previously set on the layers of the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub ClearCustomRenderSettings
C#
public void ClearCustomRenderSettings()
Visual C++
public:
void ClearCustomRenderSettings()
JavaScript
function clearCustomRenderSettings();

See Also

SFMap Class
EGIS.Web.Controls Namespace


CreateChildControls Method

[image]

.NET Framework Class Library
SFMap..::..CreateChildControls Method
SFMap Class See Also Send Feedback

overrides CreateChildControls in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub CreateChildControls
C#
protected override void CreateChildControls()
Visual C++
protected:
virtual void CreateChildControls() override
JavaScript
function createChildControls();

See Also

SFMap Class
EGIS.Web.Controls Namespace


CreateMap Method

[image]

.NET Framework Class Library
SFMap..::..CreateMap Method
SFMap Class See Also Send Feedback

Reads the EGIS shapefile project and creates the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Sub CreateMap
C#
protected void CreateMap()
Visual C++
protected:
void CreateMap()
JavaScript
function createMap();

See Also

SFMap Class
EGIS.Web.Controls Namespace


DataBind Method

[image] [image]

.NET Framework Class Library
SFMap..::..DataBind Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Web.Controls Namespace


FindControl Method

[image] [image]

.NET Framework Class Library
SFMap..::..FindControl Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Web.Controls Namespace


GetLayer Method

[image]

.NET Framework Class Library
SFMap..::..GetLayer Method
SFMap Class See Also Send Feedback

Method to get a ShapeFile layer at the specified index

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetLayer ( _
    index As Integer _
) As ShapeFile
C#
public ShapeFile GetLayer(
    int index
)
Visual C++
public:
ShapeFile^ GetLayer(
    int index
)
JavaScript
function getLayer(index);

Parameters

index
Type: System..::..Int32
zero-based index of layer to return

Return Value

The requested ShapeFile layer

See Also

SFMap Class
EGIS.Web.Controls Namespace


GetRouteUrl Method

[image] [image]

.NET Framework Class Library
SFMap..::..GetRouteUrl Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Web.Controls Namespace


LoadViewState Method

[image]

.NET Framework Class Library
SFMap..::..LoadViewState Method
SFMap Class See Also Send Feedback

overrides LoadViewState in WebControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)
C#
protected override void LoadViewState(
    Object savedState
)
Visual C++
protected:
virtual void LoadViewState(
    Object^ savedState
) override
JavaScript
function loadViewState(savedState);

Parameters

savedState
Type: System..::..Object

See Also

SFMap Class
EGIS.Web.Controls Namespace


OnInit Method

[image]

.NET Framework Class Library
SFMap..::..OnInit Method
SFMap Class See Also Send Feedback

overrides OnInit in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
C#
protected override void OnInit(
    EventArgs e
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override
JavaScript
function onInit(e);

Parameters

e
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Web.Controls Namespace


OnPreRender Method

[image]

.NET Framework Class Library
SFMap..::..OnPreRender Method
SFMap Class See Also Send Feedback

overrides OnPreRender in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)
C#
protected override void OnPreRender(
    EventArgs e
)
Visual C++
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
JavaScript
function onPreRender(e);

Parameters

e
Type: System..::..EventArgs

See Also

SFMap Class
EGIS.Web.Controls Namespace


ReadEGPProject Method

[image]

.NET Framework Class Library
SFMap..::..ReadEGPProject Method
SFMap Class See Also Send Feedback

static method to read a .egp project file

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Shared Function ReadEGPProject ( _
    absPath As String _
) As MapProject
C#
public static MapProject ReadEGPProject(
    string absPath
)
Visual C++
public:
static MapProject^ ReadEGPProject(
    String^ absPath
)
JavaScript
EGIS.Web.Controls.SFMap.readEGPProject = function(absPath);

Parameters

absPath
Type: System..::..String
Absolute path of the .egp file

Return Value

A MapProject object containing the project layers and map background color

Remarks

This method provides an easy means of creating a List of ShapeFiles to be used in a MapHandler

See Also

SFMap Class
EGIS.Web.Controls Namespace


RegisterHandlerInConfiguration Method

[image]

.NET Framework Class Library
SFMap..::..RegisterHandlerInConfiguration Method
SFMap Class See Also Send Feedback

Registers the Http Handler in configuration.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Overridable Sub RegisterHandlerInConfiguration
C#
public virtual void RegisterHandlerInConfiguration()
Visual C++
public:
virtual void RegisterHandlerInConfiguration()
JavaScript
function registerHandlerInConfiguration();

See Also

SFMap Class
EGIS.Web.Controls Namespace


Render Method

[image]

.NET Framework Class Library
SFMap..::..Render Method
SFMap Class See Also Send Feedback

Renders the control to the specified HTML writer.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub Render ( _
    writer As HtmlTextWriter _
)
C#
protected override void Render(
    HtmlTextWriter writer
)
Visual C++
protected:
virtual void Render(
    HtmlTextWriter^ writer
) override
JavaScript
function render(writer);

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter
The HtmlTextWriter object that receives the control content.

See Also

SFMap Class
EGIS.Web.Controls Namespace


RenderControl Method

[image] [image]

.NET Framework Class Library
SFMap..::..RenderControl Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Web.Controls Namespace


RenderDesignTime Method

[image]

.NET Framework Class Library
SFMap..::..RenderDesignTime Method
SFMap Class See Also Send Feedback

Renders the control at design time.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub RenderDesignTime ( _
    writer As HtmlTextWriter _
)
C#
protected virtual void RenderDesignTime(
    HtmlTextWriter writer
)
Visual C++
protected:
virtual void RenderDesignTime(
    HtmlTextWriter^ writer
)
JavaScript
function renderDesignTime(writer);

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter
The html writer.

See Also

SFMap Class
EGIS.Web.Controls Namespace


RenderMap Method

[image]

.NET Framework Class Library
SFMap..::..RenderMap Method
SFMap Class See Also Send Feedback

convenience method to render the currently loaded map to a bitmap

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub RenderMap ( _
    bitmap As Image, _
    context As HttpContext _
)
C#
public void RenderMap(
    Image bitmap,
    HttpContext context
)
Visual C++
public:
void RenderMap(
    Image^ bitmap,
    HttpContext^ context
)
JavaScript
function renderMap(bitmap, context);

Parameters

bitmap
Type: System.Drawing..::..Image
context
Type: System.Web..::..HttpContext

See Also

SFMap Class
EGIS.Web.Controls Namespace


SetCustomRenderSettings Method

[image]

.NET Framework Class Library
SFMap..::..SetCustomRenderSettings Method
SFMap Class See Also Send Feedback

Applies custom render settings to the specified layer

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub SetCustomRenderSettings ( _
    layerIndex As Integer, _
    settings As ICustomRenderSettings _
)
C#
public void SetCustomRenderSettings(
    int layerIndex,
    ICustomRenderSettings settings
)
Visual C++
public:
void SetCustomRenderSettings(
    int layerIndex,
    ICustomRenderSettings^ settings
)
JavaScript
function setCustomRenderSettings(layerIndex, settings);

Parameters

layerIndex
Type: System..::..Int32
The zero-based index of the layer to apply the custom render settings
settings
Type: EGIS.ShapeFileLib..::..ICustomRenderSettings
An ICustomRenderSettings object to set on the specified shapefile

Remarks

The ICustomRenderSettings object is stored in the session settings, meaning that the custom render settings are applied per user's session.

If Custom Render Settings are used then it is usualy neccessary to set CacheOnClient to False

See Also

SFMap Class
EGIS.Web.Controls Namespace
EGIS.ShapeFileLib..::..ICustomRenderSettings
EGIS.Web.Controls..::..QuantileCustomRenderSettings
SFMap..::..CacheOnClient


SetTraceData Method

[image] [image]

.NET Framework Class Library
SFMap..::..SetTraceData Method
SFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)

See Also

SFMap Class
SFMap Members
EGIS.Web.Controls Namespace


SFMap Properties

[image] [image]

.NET Framework Class Library
SFMap Properties
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | CacheOnClient | Gets or sets whether to use client-side caching of any generated map image.
Public property | CenterPoint | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientJSResouceName | returns the name of the client javascript resource used to control the map.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ControlId | returns the client id of the map
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | GisImageClientId | returns the Client id of the internal GIS Image. This is used by controls only
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | HttpHandlerName | Gets the name of the http handler used to render the map on the server.
Public property | HttpHandlerType | Gets the type of the http handler used to render the map on the server.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | ImageSource | Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LayerCount | returns the number of layers in the SFMap Control
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaxZoomLevel | Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.
Public property | MinZoomLevel | Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | OnClientBoundsChanged | Gets or sets the client-side script that executes when the map Bounds are changed
Public property | OnClientZoomChanged | Gets or sets the client-side script that executes when the map ZoomLevel changes
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | ProjectName | Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides the TagKey property. Returns a Div Tag. (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | Zoom | Gets or sets the current ZoomLevel of the SFMap

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

SFMap Class
EGIS.Web.Controls Namespace


CacheOnClient Property

[image]

.NET Framework Class Library
SFMap..::..CacheOnClient Property
SFMap Class See Also Send Feedback

Gets or sets whether to use client-side caching of any generated map image.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property CacheOnClient As Boolean
    Get
    Set
C#
[BindableAttribute(true)]
public bool CacheOnClient { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property bool CacheOnClient {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cacheOnClient();
function set_cacheOnClient(value);

Remarks

By default CacheOnClient will be set to true. This means that cache-specific HTTP headers will be set on generated map images. This will generally improve map performance as successive map images are cached by client web-browsers, however in some cases this is not desirable.

If you are using CustomRenderSettings then it may be neccessary to set CacheOnClient ot False

See Also

SFMap Class
EGIS.Web.Controls Namespace


CenterPoint Property

[image]

.NET Framework Class Library
SFMap..::..CenterPoint Property
SFMap Class See Also Send Feedback

Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Overridable Property CenterPoint As PointD
    Get
    Set
C#
[BindableAttribute(true)]
public virtual PointD CenterPoint { get; set; }
Visual C++
[BindableAttribute(true)]
public:
virtual property PointD CenterPoint {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_centerPoint();
function set_centerPoint(value);

Remarks

Changing the CenterPoint can be used to center the map on a new location without changing the map scale

The ZoomLevel, CenterPoint, Width and Height of the SFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CenterPoint and scaled according to the ZoomLevel.

See Also

SFMap Class
EGIS.Web.Controls Namespace
SFMap..::..Zoom


ClientJSResouceName Property

[image]

.NET Framework Class Library
SFMap..::..ClientJSResouceName Property
SFMap Class See Also Send Feedback

returns the name of the client javascript resource used to control the map.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ClientJSResouceName As String
    Get
C#
public string ClientJSResouceName { get; }
Visual C++
public:
virtual property String^ ClientJSResouceName {
    String^ get () sealed;
}
JavaScript
function get_clientJSResouceName();

Implements

ISFMap..::..ClientJSResouceName

Remarks

this method implements the ClientJSResouceName method of ISFMap interface

See Also

SFMap Class
EGIS.Web.Controls Namespace


ControlId Property

[image]

.NET Framework Class Library
SFMap..::..ControlId Property
SFMap Class See Also Send Feedback

returns the client id of the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ControlId As String
    Get
C#
public string ControlId { get; }
Visual C++
public:
virtual property String^ ControlId {
    String^ get () sealed;
}
JavaScript
function get_controlId();

Implements

ISFMap..::..ControlId

Remarks

this method implements the ClientJSResouceName method of ISFMap interface

See Also

SFMap Class
EGIS.Web.Controls Namespace


Extent Property

[image]

.NET Framework Class Library
SFMap..::..Extent Property
SFMap Class See Also Send Feedback

Gets the rectangular extent of the entire map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property Extent As RectangleF
    Get
C#
public RectangleF Extent { get; }
Visual C++
public:
property RectangleF Extent {
    RectangleF get ();
}
JavaScript
function get_extent();

Remarks

Extent is the rectangular extent of the ENTIRE map, regardless of the current ZoomLevel or CentrePoint.

See Also

SFMap Class
EGIS.Web.Controls Namespace


GisImageClientId Property

[image]

.NET Framework Class Library
SFMap..::..GisImageClientId Property
SFMap Class See Also Send Feedback

returns the Client id of the internal GIS Image. This is used by controls only

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property GisImageClientId As String
    Get
C#
public string GisImageClientId { get; }
Visual C++
public:
virtual property String^ GisImageClientId {
    String^ get () sealed;
}
JavaScript
function get_gisImageClientId();

Implements

ISFMap..::..GisImageClientId

See Also

SFMap Class
EGIS.Web.Controls Namespace


HttpHandlerName Property

[image]

.NET Framework Class Library
SFMap..::..HttpHandlerName Property
SFMap Class See Also Send Feedback

Gets the name of the http handler used to render the map on the server.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property HttpHandlerName As String
    Get
C#
public string HttpHandlerName { get; }
Visual C++
public:
property String^ HttpHandlerName {
    String^ get ();
}
JavaScript
function get_httpHandlerName();

See Also

SFMap Class
EGIS.Web.Controls Namespace


HttpHandlerType Property

[image]

.NET Framework Class Library
SFMap..::..HttpHandlerType Property
SFMap Class See Also Send Feedback

Gets the type of the http handler used to render the map on the server.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Overridable ReadOnly Property HttpHandlerType As Type
    Get
C#
public virtual Type HttpHandlerType { get; }
Visual C++
public:
virtual property Type^ HttpHandlerType {
    Type^ get ();
}
JavaScript
function get_httpHandlerType();

See Also

SFMap Class
EGIS.Web.Controls Namespace


ImageSource Property

[image]

.NET Framework Class Library
SFMap..::..ImageSource Property
SFMap Class See Also Send Feedback

Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property ImageSource As String
    Get
C#
protected string ImageSource { get; }
Visual C++
protected:
property String^ ImageSource {
    String^ get ();
}
JavaScript
function get_imageSource();

Field Value

The image src.

See Also

SFMap Class
EGIS.Web.Controls Namespace


LayerCount Property

[image]

.NET Framework Class Library
SFMap..::..LayerCount Property
SFMap Class See Also Send Feedback

returns the number of layers in the SFMap Control

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property LayerCount As Integer
    Get
C#
public int LayerCount { get; }
Visual C++
public:
property int LayerCount {
    int get ();
}
JavaScript
function get_layerCount();

See Also

SFMap Class
EGIS.Web.Controls Namespace


MaxZoomLevel Property

[image]

.NET Framework Class Library
SFMap..::..MaxZoomLevel Property
SFMap Class See Also Send Feedback

Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property MaxZoomLevel As Single
    Get
    Set
C#
[BindableAttribute(true)]
public float MaxZoomLevel { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property float MaxZoomLevel {
    float get ();
    void set (float value);
}
JavaScript
function get_maxZoomLevel();
function set_maxZoomLevel(value);

See Also

SFMap Class
EGIS.Web.Controls Namespace
SFMap..::..MinZoomLevel


MinZoomLevel Property

[image]

.NET Framework Class Library
SFMap..::..MinZoomLevel Property
SFMap Class See Also Send Feedback

Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property MinZoomLevel As Single
    Get
    Set
C#
[BindableAttribute(true)]
public float MinZoomLevel { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property float MinZoomLevel {
    float get ();
    void set (float value);
}
JavaScript
function get_minZoomLevel();
function set_minZoomLevel(value);

See Also

SFMap Class
EGIS.Web.Controls Namespace
SFMap..::..MaxZoomLevel


OnClientBoundsChanged Property

[image]

.NET Framework Class Library
SFMap..::..OnClientBoundsChanged Property
SFMap Class See Also Send Feedback

Gets or sets the client-side script that executes when the map Bounds are changed

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property OnClientBoundsChanged As String
    Get
    Set
C#
[BindableAttribute(true)]
public string OnClientBoundsChanged { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ OnClientBoundsChanged {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_onClientBoundsChanged();
function set_onClientBoundsChanged(value);

Remarks

When the map bounds change a client-side javascript event will be fired with the the following 3 parameters
  • typeThe event type (="BoundsChanged"). This can be ignored
  • argsThe new map bounds. args[0] contains MinX, args[1] contains MaxY, args[2] contains MaxX, args[3] contains MaxY
  • objThe object generating the event. This can be ignored.

Examples

Copy image Copy Code

            function MapBoundsChanged(type, args, obj)
            {
               var debugPanel = document.getElementById('debugpanel');
               debugPanel.innerHTML = '[' + obj.toString() + ',' + type + ']Current Bounds: ' + args[0] + ',' + args[1] +  ',' + args[2] + ',' + args[3] + '
' + debugPanel.innerHTML ;
            }
             ..
             <div id = "debugpanel" ..
In this example OnClientBoundsChanged would be set to "MapBoundsChanged"

See Also

SFMap Class
EGIS.Web.Controls Namespace


OnClientZoomChanged Property

[image]

.NET Framework Class Library
SFMap..::..OnClientZoomChanged Property
SFMap Class See Also Send Feedback

Gets or sets the client-side script that executes when the map ZoomLevel changes

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property OnClientZoomChanged As String
    Get
    Set
C#
[BindableAttribute(true)]
public string OnClientZoomChanged { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ OnClientZoomChanged {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_onClientZoomChanged();
function set_onClientZoomChanged(value);

Remarks

When the zoom level changes a client-side javascript event will be fired with the the following 3 parameters
  • typeThe event type (="ZoomChanged"). This can be ignored
  • argsargs[0] contains the current zoom level
  • objThe object generating the event. This can be ignored.

Examples

Copy image Copy Code

             function MapZoomChanged(type, args, obj)
            {
                var debugpanel = document.getElementById('debugpanel');
                debugpanel.innerHTML = '[' + obj.toString() + ',' + type + ']Current Zoom: ' + args[0] + '<br/>' + debugpanel.innerHTML;
            }
             ..
             <div id = "debugpanel" ..
In this example OnClientZoomChanged would be set to "MapZoomChanged"

See Also

SFMap Class
EGIS.Web.Controls Namespace


ProjectName Property

[image]

.NET Framework Class Library
SFMap..::..ProjectName Property
SFMap Class See Also Send Feedback

Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ProjectName As String
    Get
    Set
C#
[BindableAttribute(true)]
public string ProjectName { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_projectName();
function set_projectName(value);

See Also

SFMap Class
EGIS.Web.Controls Namespace


TagKey Property

[image]

.NET Framework Class Library
SFMap..::..TagKey Property
SFMap Class See Also Send Feedback

overrides the TagKey property. Returns a Div Tag.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
C#
protected override HtmlTextWriterTag TagKey { get; }
Visual C++
protected:
virtual property HtmlTextWriterTag TagKey {
    HtmlTextWriterTag get () override;
}
JavaScript
function get_tagKey();

See Also

SFMap Class
EGIS.Web.Controls Namespace


Zoom Property

[image]

.NET Framework Class Library
SFMap..::..Zoom Property
SFMap Class See Also Send Feedback

Gets or sets the current ZoomLevel of the SFMap

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property Zoom As Single
    Get
    Set
C#
[BindableAttribute(true)]
public float Zoom { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property float Zoom {
    float get ();
    void set (float value);
}
JavaScript
function get_zoom();
function set_zoom(value);

Remarks

Changing the ZoomLevel will zoom into or out of the map. Increasing the ZoomLevel will zoom into the map, while decreasing the ZoomLevel will zoom out of the map

The ZoomLevel, CenterPoint, Width and Height of the SFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CenterPoint and scaled according to the ZoomLevel.

Exceptions

Exception | Condition
System..::..ArgumentException | if ZoomLevel less than or equal to zero

See Also

SFMap Class
EGIS.Web.Controls Namespace
SFMap..::..CenterPoint


SFMap Events

[image] [image]

.NET Framework Class Library
SFMap Events
SFMap Class See Also Send Feedback

The SFMap type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

SFMap Class
EGIS.Web.Controls Namespace


TiledMapHandler Class

[image]

.NET Framework Class Library
TiledMapHandler Class
Members See Also Send Feedback

Generic IHttpHandler for handling TiledMap requests

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public MustInherit Class TiledMapHandler _
    Implements IHttpHandler
C#
public abstract class TiledMapHandler : IHttpHandler
Visual C++
public ref class TiledMapHandler abstract : IHttpHandler
JavaScript
EGIS.Web.Controls.TiledMapHandler = function();

Type.createClass(
    'EGIS.Web.Controls.TiledMapHandler',
    null,
    IHttpHandler);

Inheritance Hierarchy

System..::..Object
EGIS.Web.Controls..::..TiledMapHandler

See Also

TiledMapHandler Members
EGIS.Web.Controls Namespace


TiledMapHandler Members

[image] [image]

.NET Framework Class Library
TiledMapHandler Members
TiledMapHandler Class Constructors Methods Properties See Also Send Feedback

The TiledMapHandler type exposes the following members.

Constructors

 | Name | Description
Protected method | TiledMapHandler |

Methods

 | Name | Description
Protected method | CreateCachePath |
Protected method | CreateMapLayers | Abstract method to create the Map layers for the request
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCustomTooltipText |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginRequest |
Protected method | OnEndRequest |
Protected method | ProcessGetShapeRequest |
Public method | ProcessRequest |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | CacheDirectory | Name of the directory (relative to the handler) used to store cached images
Protected property | CacheOnServer | Whether or not to cache requested image requests on the server
Public property | IsReusable |
Protected property | MapBackgroundColor | Color used to render the background of map tile images

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


TiledMapHandler Constructor

[image]

.NET Framework Class Library
TiledMapHandler Constructor
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Sub New
C#
protected TiledMapHandler()
Visual C++
protected:
TiledMapHandler()
JavaScript
EGIS.Web.Controls.TiledMapHandler = function();

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


TiledMapHandler Methods

[image] [image]

.NET Framework Class Library
TiledMapHandler Methods
TiledMapHandler Class See Also Send Feedback

The TiledMapHandler type exposes the following members.

Methods

 | Name | Description
Protected method | CreateCachePath |
Protected method | CreateMapLayers | Abstract method to create the Map layers for the request
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCustomTooltipText |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginRequest |
Protected method | OnEndRequest |
Protected method | ProcessGetShapeRequest |
Public method | ProcessRequest |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


CreateCachePath Method

[image]

.NET Framework Class Library
TiledMapHandler..::..CreateCachePath Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Function CreateCachePath ( _
    context As HttpContext, _
    tileX As Integer, _
    tileY As Integer, _
    zoom As Integer _
) As String
C#
protected virtual string CreateCachePath(
    HttpContext context,
    int tileX,
    int tileY,
    int zoom
)
Visual C++
protected:
virtual String^ CreateCachePath(
    HttpContext^ context,
    int tileX,
    int tileY,
    int zoom
)
JavaScript
function createCachePath(context, tileX, tileY, zoom);

Parameters

context
Type: System.Web..::..HttpContext
tileX
Type: System..::..Int32
tileY
Type: System..::..Int32
zoom
Type: System..::..Int32

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


CreateMapLayers Method

[image]

.NET Framework Class Library
TiledMapHandler..::..CreateMapLayers Method
TiledMapHandler Class See Also Send Feedback

Abstract method to create the Map layers for the request

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected MustOverride Function CreateMapLayers ( _
    context As HttpContext _
) As List(Of ShapeFile)
C#
protected abstract List<ShapeFile> CreateMapLayers(
    HttpContext context
)
Visual C++
protected:
virtual List<ShapeFile^>^ CreateMapLayers(
    HttpContext^ context
) abstract
JavaScript
function createMapLayers(context);

Parameters

context
Type: System.Web..::..HttpContext

Return Value

Remarks

Derived classes must implement the CreateMapLayers method

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


GetCustomTooltipText Method

[image]

.NET Framework Class Library
TiledMapHandler..::..GetCustomTooltipText Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub GetCustomTooltipText ( _
    context As HttpContext, _
    layer As ShapeFile, _
    recordIndex As Integer, _
    ByRef tooltipText As String _
)
C#
protected virtual void GetCustomTooltipText(
    HttpContext context,
    ShapeFile layer,
    int recordIndex,
    ref string tooltipText
)
Visual C++
protected:
virtual void GetCustomTooltipText(
    HttpContext^ context,
    ShapeFile^ layer,
    int recordIndex,
    String^% tooltipText
)
JavaScript
function getCustomTooltipText(context, layer, recordIndex, tooltipText);

Parameters

context
Type: System.Web..::..HttpContext
layer
Type: EGIS.ShapeFileLib..::..ShapeFile
recordIndex
Type: System..::..Int32
tooltipText
Type: System..::..String %

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


OnBeginRequest Method

[image]

.NET Framework Class Library
TiledMapHandler..::..OnBeginRequest Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub OnBeginRequest ( _
    context As HttpContext _
)
C#
protected virtual void OnBeginRequest(
    HttpContext context
)
Visual C++
protected:
virtual void OnBeginRequest(
    HttpContext^ context
)
JavaScript
function onBeginRequest(context);

Parameters

context
Type: System.Web..::..HttpContext

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


OnEndRequest Method

[image]

.NET Framework Class Library
TiledMapHandler..::..OnEndRequest Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub OnEndRequest ( _
    context As HttpContext _
)
C#
protected virtual void OnEndRequest(
    HttpContext context
)
Visual C++
protected:
virtual void OnEndRequest(
    HttpContext^ context
)
JavaScript
function onEndRequest(context);

Parameters

context
Type: System.Web..::..HttpContext

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


ProcessGetShapeRequest Method

[image]

.NET Framework Class Library
TiledMapHandler..::..ProcessGetShapeRequest Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub ProcessGetShapeRequest ( _
    context As HttpContext _
)
C#
protected virtual void ProcessGetShapeRequest(
    HttpContext context
)
Visual C++
protected:
virtual void ProcessGetShapeRequest(
    HttpContext^ context
)
JavaScript
function processGetShapeRequest(context);

Parameters

context
Type: System.Web..::..HttpContext

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


ProcessRequest Method

[image]

.NET Framework Class Library
TiledMapHandler..::..ProcessRequest Method
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub ProcessRequest ( _
    context As HttpContext _
)
C#
public void ProcessRequest(
    HttpContext context
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed
JavaScript
function processRequest(context);

Parameters

context
Type: System.Web..::..HttpContext

Implements

IHttpHandler..::..ProcessRequest(HttpContext)

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


TiledMapHandler Properties

[image] [image]

.NET Framework Class Library
TiledMapHandler Properties
TiledMapHandler Class See Also Send Feedback

The TiledMapHandler type exposes the following members.

Properties

 | Name | Description
Protected property | CacheDirectory | Name of the directory (relative to the handler) used to store cached images
Protected property | CacheOnServer | Whether or not to cache requested image requests on the server
Public property | IsReusable |
Protected property | MapBackgroundColor | Color used to render the background of map tile images

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


CacheDirectory Property

[image]

.NET Framework Class Library
TiledMapHandler..::..CacheDirectory Property
TiledMapHandler Class See Also Send Feedback

Name of the directory (relative to the handler) used to store cached images

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable ReadOnly Property CacheDirectory As String
    Get
C#
protected virtual string CacheDirectory { get; }
Visual C++
protected:
virtual property String^ CacheDirectory {
    String^ get ();
}
JavaScript
function get_cacheDirectory();

Remarks

Default value is "tilecache". Derived classes should override if a different directory is required.

Note it may be neccessary to grant write permissions on the directory

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


CacheOnServer Property

[image]

.NET Framework Class Library
TiledMapHandler..::..CacheOnServer Property
TiledMapHandler Class See Also Send Feedback

Whether or not to cache requested image requests on the server

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable ReadOnly Property CacheOnServer As Boolean
    Get
C#
protected virtual bool CacheOnServer { get; }
Visual C++
protected:
virtual property bool CacheOnServer {
    bool get ();
}
JavaScript
function get_cacheOnServer();

Remarks

Default value is true. Derived classes should override if neccessary

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


IsReusable Property

[image]

.NET Framework Class Library
TiledMapHandler..::..IsReusable Property
TiledMapHandler Class See Also Send Feedback

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Overridable ReadOnly Property IsReusable As Boolean
    Get
C#
public virtual bool IsReusable { get; }
Visual C++
public:
virtual property bool IsReusable {
    bool get ();
}
JavaScript
function get_isReusable();

Implements

IHttpHandler..::..IsReusable

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


MapBackgroundColor Property

[image]

.NET Framework Class Library
TiledMapHandler..::..MapBackgroundColor Property
TiledMapHandler Class See Also Send Feedback

Color used to render the background of map tile images

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable ReadOnly Property MapBackgroundColor As Color
    Get
C#
protected virtual Color MapBackgroundColor { get; }
Visual C++
protected:
virtual property Color MapBackgroundColor {
    Color get ();
}
JavaScript
function get_mapBackgroundColor();

See Also

TiledMapHandler Class
EGIS.Web.Controls Namespace


TiledSFMap Class

[image]

.NET Framework Class Library
TiledSFMap Class
Members See Also Send Feedback

ASP .NET Mapping Control which loads and displays an Easy GIS .NET map project in a web page using map tile images.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class TiledSFMap _
    Inherits CompositeControl _
    Implements ISFMap
C#
public class TiledSFMap : CompositeControl, ISFMap
Visual C++
public ref class TiledSFMap : public CompositeControl,
    ISFMap
JavaScript
EGIS.Web.Controls.TiledSFMap = function();

Type.createClass(
    'EGIS.Web.Controls.TiledSFMap',
    CompositeControl,
    EGIS.Web.Controls.ISFMap);

Remarks

This control is similar to the SFMap Control, but it uses a tile approach to take advantage of caching on client's web-browsers to provide much faster map interaction.

Note that in order to use the SFMap the displayed project must be using lat long degree coordinates as the map will use a Mercator Projection

Tiles are organised in a manner similar to the approach used by google maps and bing maps. Each tiles dimension is 256x256 pixels. A tile request is made up of a zoom-level between 0 and 16(inclusive), tile x-ccord and a tile y-ccord. At zoom-level 0 the entire world (-180 lon -> +180 lon) is scaled to fit in 1 tile. At level 1 the world will fit in 2 tiles x 2 tiles, at level 2 the world will fit into 4 tiles x 4 tiles, .. etc.

Tiles are numbered from zero in the upper left corner to (NumTiles at zoom-level)-1 as below:

Copy image Copy Code
            (0,0) (1,0) (2,0) ..
            (0,1) (1,1) (2,1) ..
            (0,2) (1,2) (2,2) ..
            ..

An Easy GIS .NET project is composed of a number of Shapefiles and can be designed using the Desktop Edition of Easy GIS .NET. The project should be exported and copied to the web server hosting the page where the TiledSFMap Web Control will be used. For more information on how to export a project ready to load in a web page see Easy GIS .NET Developers page The TiledSFMap Control generates all map images on the hosting web server using an IHttpHandler. All requests are performed automatically on the client's web browser using JavaScript and AJAX, resulting in a map that can be panned and zoomed in or out without refreshing the web page for each request.

NOTE: In order for the server to render maps an entry in the httpHandlers section of the web.config file must be made. If the TiledSFMap Control is added to a page using the design view in Visual Studio an entry is added to the web.config file automatically, however if the Control is manually added to a page it will be neccessary to add the following section to the config file.

Copy image Copy Code
            <httpHandlers>
                   <add path="egismaptiled.axd" verb="*" type="EGIS.Web.Controls.SFMapImageProvider, EGIS.Web.Controls, Version=2.3.0.0, Culture=neutral, PublicKeyToken=05b98c869b5ffe6a"
                       validate="true" />
               </httpHandlers>

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
System.Web.UI.WebControls..::..CompositeControl
EGIS.Web.Controls..::..TiledSFMap

See Also

TiledSFMap Members
EGIS.Web.Controls Namespace


TiledSFMap Members

[image] [image]

.NET Framework Class Library
TiledSFMap Members
TiledSFMap Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The TiledSFMap type exposes the following members.

Constructors

 | Name | Description
Public method | TiledSFMap | Constructor

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | ClearCustomRenderSettings | Clears any ICustomRenderSettings previously set on the layers of the map
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateMap | Reads the EGIS shapefile project and creates the map
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLayer | Method to get a ShapeFile layer at the specified index
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Overrides LoadViewState method in WebControl (Overrides WebControl..::..LoadViewState(Object).)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | overrides OnInit in WebControl (Overrides Control..::..OnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Public method | RegisterHandlerInConfiguration | Registers the Http Handler in configuration.
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides CompositeControl..::..Render(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderDesignTime | Renders the control at design time.
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderMap | Convenience method to render the current map to a bitmap
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetCustomRenderSettings | Applies custom render settings to the specified layer
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | CacheOnClient | Gets or sets whether to use client-side caching of any generated map image.
Public property | CacheOnServer | Gets or sets whether to use server-side caching of any generated map tile image.
Public property | CenterPoint | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientJSResouceName | returns the name of the client javascript resource used to control the map.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ControlId | returns the client id of the map
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | GisImageClientId | returns the Client id of the internal GIS Image. This is used by controls only
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | HttpHandlerName | Gets the name of the http handler used to render the map on the server.
Public property | HttpHandlerType | Gets the type of the http handler used to render the map on the server.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | ImageSource | Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LayerCount | returns the number of layers in the TiledSFMap Control
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaxZoomLevel | Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.
Public property | MinZoomLevel | Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | OnClientBoundsChanged | Gets or sets the client-side script that executes when the map Bounds are changed
Public property | OnClientZoomChanged | Gets or sets the client-side script that executes when the map ZoomLevel changes
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | ProjectName | Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | ServerCacheDirectoryUrl | The Url of the directory where image tiles will be cached on the server if CacheOnServer is set to true
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides the TagKey property. Returns a Div Tag. (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | ZoomLevel | Gets or sets the current ZoomLevel of the TiledSFMap

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


TiledSFMap Constructor

[image]

.NET Framework Class Library
TiledSFMap Constructor
TiledSFMap Class See Also Send Feedback

Constructor

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New
C#
public TiledSFMap()
Visual C++
public:
TiledSFMap()
JavaScript
EGIS.Web.Controls.TiledSFMap = function();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


TiledSFMap Methods

[image] [image]

.NET Framework Class Library
TiledSFMap Methods
TiledSFMap Class See Also Send Feedback

The TiledSFMap type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | ClearCustomRenderSettings | Clears any ICustomRenderSettings previously set on the layers of the map
Protected method | ClearEffectiveClientIDMode | (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | overrides CreateChildControls in CompositeControl (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateMap | Reads the EGIS shapefile project and creates the map
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLayer | Method to get a ShapeFile layer at the specified index
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Overrides LoadViewState method in WebControl (Overrides WebControl..::..LoadViewState(Object).)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | overrides OnInit in WebControl (Overrides Control..::..OnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | overrides OnPreRender in CompositeControl (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RecreateChildControls | Recreates the child controls n a control derived from CompositeControl. (Inherited from CompositeControl.)
Public method | RegisterHandlerInConfiguration | Registers the Http Handler in configuration.
Protected method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides CompositeControl..::..Render(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderDesignTime | Renders the control at design time.
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderMap | Convenience method to render the current map to a bitmap
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetCustomRenderSettings | Applies custom render settings to the specified layer
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::..AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IAttributeAccessor..::..GetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | ICompositeControlDesignerAccessor..::..RecreateChildControls | (Inherited from CompositeControl.)
Explicit interface implemetation | IAttributeAccessor..::..SetAttribute | (Inherited from WebControl.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..SetOwnerControl | (Inherited from Control.)

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ClearCustomRenderSettings Method

[image]

.NET Framework Class Library
TiledSFMap..::..ClearCustomRenderSettings Method
TiledSFMap Class See Also Send Feedback

Clears any ICustomRenderSettings previously set on the layers of the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub ClearCustomRenderSettings
C#
public void ClearCustomRenderSettings()
Visual C++
public:
void ClearCustomRenderSettings()
JavaScript
function clearCustomRenderSettings();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


CreateChildControls Method

[image]

.NET Framework Class Library
TiledSFMap..::..CreateChildControls Method
TiledSFMap Class See Also Send Feedback

overrides CreateChildControls in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub CreateChildControls
C#
protected override void CreateChildControls()
Visual C++
protected:
virtual void CreateChildControls() override
JavaScript
function createChildControls();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


CreateMap Method

[image]

.NET Framework Class Library
TiledSFMap..::..CreateMap Method
TiledSFMap Class See Also Send Feedback

Reads the EGIS shapefile project and creates the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Sub CreateMap
C#
protected void CreateMap()
Visual C++
protected:
void CreateMap()
JavaScript
function createMap();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


DataBind Method

[image] [image]

.NET Framework Class Library
TiledSFMap..::..DataBind Method
TiledSFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

TiledSFMap Class
TiledSFMap Members
EGIS.Web.Controls Namespace


FindControl Method

[image] [image]

.NET Framework Class Library
TiledSFMap..::..FindControl Method
TiledSFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

TiledSFMap Class
TiledSFMap Members
EGIS.Web.Controls Namespace


GetLayer Method

[image]

.NET Framework Class Library
TiledSFMap..::..GetLayer Method
TiledSFMap Class See Also Send Feedback

Method to get a ShapeFile layer at the specified index

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Function GetLayer ( _
    index As Integer _
) As ShapeFile
C#
public ShapeFile GetLayer(
    int index
)
Visual C++
public:
ShapeFile^ GetLayer(
    int index
)
JavaScript
function getLayer(index);

Parameters

index
Type: System..::..Int32
zero-based index of layer to return

Return Value

The requested ShapeFile layer

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


GetRouteUrl Method

[image] [image]

.NET Framework Class Library
TiledSFMap..::..GetRouteUrl Method
TiledSFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRouteUrl(Object) | (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)

See Also

TiledSFMap Class
TiledSFMap Members
EGIS.Web.Controls Namespace


LoadViewState Method

[image]

.NET Framework Class Library
TiledSFMap..::..LoadViewState Method
TiledSFMap Class See Also Send Feedback

Overrides LoadViewState method in WebControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)
C#
protected override void LoadViewState(
    Object savedState
)
Visual C++
protected:
virtual void LoadViewState(
    Object^ savedState
) override
JavaScript
function loadViewState(savedState);

Parameters

savedState
Type: System..::..Object

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


OnInit Method

[image]

.NET Framework Class Library
TiledSFMap..::..OnInit Method
TiledSFMap Class See Also Send Feedback

overrides OnInit in WebControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
C#
protected override void OnInit(
    EventArgs e
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override
JavaScript
function onInit(e);

Parameters

e
Type: System..::..EventArgs

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


OnPreRender Method

[image]

.NET Framework Class Library
TiledSFMap..::..OnPreRender Method
TiledSFMap Class See Also Send Feedback

overrides OnPreRender in CompositeControl

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)
C#
protected override void OnPreRender(
    EventArgs e
)
Visual C++
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
JavaScript
function onPreRender(e);

Parameters

e
Type: System..::..EventArgs

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


RegisterHandlerInConfiguration Method

[image]

.NET Framework Class Library
TiledSFMap..::..RegisterHandlerInConfiguration Method
TiledSFMap Class See Also Send Feedback

Registers the Http Handler in configuration.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Overridable Sub RegisterHandlerInConfiguration
C#
public virtual void RegisterHandlerInConfiguration()
Visual C++
public:
virtual void RegisterHandlerInConfiguration()
JavaScript
function registerHandlerInConfiguration();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


Render Method

[image]

.NET Framework Class Library
TiledSFMap..::..Render Method
TiledSFMap Class See Also Send Feedback

Renders the control to the specified HTML writer.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides Sub Render ( _
    writer As HtmlTextWriter _
)
C#
protected override void Render(
    HtmlTextWriter writer
)
Visual C++
protected:
virtual void Render(
    HtmlTextWriter^ writer
) override
JavaScript
function render(writer);

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter
The HtmlTextWriter object that receives the control content.

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


RenderControl Method

[image] [image]

.NET Framework Class Library
TiledSFMap..::..RenderControl Method
TiledSFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

TiledSFMap Class
TiledSFMap Members
EGIS.Web.Controls Namespace


RenderDesignTime Method

[image]

.NET Framework Class Library
TiledSFMap..::..RenderDesignTime Method
TiledSFMap Class See Also Send Feedback

Renders the control at design time.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overridable Sub RenderDesignTime ( _
    writer As HtmlTextWriter _
)
C#
protected virtual void RenderDesignTime(
    HtmlTextWriter writer
)
Visual C++
protected:
virtual void RenderDesignTime(
    HtmlTextWriter^ writer
)
JavaScript
function renderDesignTime(writer);

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter
The html writer.

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


RenderMap Method

[image]

.NET Framework Class Library
TiledSFMap..::..RenderMap Method
TiledSFMap Class See Also Send Feedback

Convenience method to render the current map to a bitmap

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub RenderMap ( _
    bitmap As Image, _
    context As HttpContext _
)
C#
public void RenderMap(
    Image bitmap,
    HttpContext context
)
Visual C++
public:
void RenderMap(
    Image^ bitmap,
    HttpContext^ context
)
JavaScript
function renderMap(bitmap, context);

Parameters

bitmap
Type: System.Drawing..::..Image
context
Type: System.Web..::..HttpContext

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


SetCustomRenderSettings Method

[image]

.NET Framework Class Library
TiledSFMap..::..SetCustomRenderSettings Method
TiledSFMap Class See Also Send Feedback

Applies custom render settings to the specified layer

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub SetCustomRenderSettings ( _
    layerIndex As Integer, _
    settings As ICustomRenderSettings _
)
C#
public void SetCustomRenderSettings(
    int layerIndex,
    ICustomRenderSettings settings
)
Visual C++
public:
void SetCustomRenderSettings(
    int layerIndex,
    ICustomRenderSettings^ settings
)
JavaScript
function setCustomRenderSettings(layerIndex, settings);

Parameters

layerIndex
Type: System..::..Int32
The zero-based index of the layer to apply the custom render settings
settings
Type: EGIS.ShapeFileLib..::..ICustomRenderSettings
An ICustomRenderSettings object to set on the specified shapefile

Remarks

The ICustomRenderSettings object is stored in the session settings, meaning that the custom render settings are applied per user's session.

If Custom Render Settings are used then it is usualy neccessary to set CacheOnClient to False

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace
EGIS.ShapeFileLib..::..ICustomRenderSettings
EGIS.Web.Controls..::..QuantileCustomRenderSettings
TiledSFMap..::..CacheOnClient


SetTraceData Method

[image] [image]

.NET Framework Class Library
TiledSFMap..::..SetTraceData Method
TiledSFMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTraceData(Object, Object) | (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | (Inherited from Control.)

See Also

TiledSFMap Class
TiledSFMap Members
EGIS.Web.Controls Namespace


TiledSFMap Properties

[image] [image]

.NET Framework Class Library
TiledSFMap Properties
TiledSFMap Class See Also Send Feedback

The TiledSFMap type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | CacheOnClient | Gets or sets whether to use client-side caching of any generated map image.
Public property | CacheOnServer | Gets or sets whether to use server-side caching of any generated map tile image.
Public property | CenterPoint | Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientJSResouceName | returns the name of the client javascript resource used to control the map.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ControlId | returns the client id of the map
Public property | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | DataItemContainer | (Inherited from Control.)
Public property | DataKeysContainer | (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Extent | Gets the rectangular extent of the entire map
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | GisImageClientId | returns the Client id of the internal GIS Image. This is used by controls only
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | HttpHandlerName | Gets the name of the http handler used to render the map on the server.
Public property | HttpHandlerType | Gets the type of the http handler used to render the map on the server.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | ImageSource | Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LayerCount | returns the number of layers in the TiledSFMap Control
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaxZoomLevel | Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.
Public property | MinZoomLevel | Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | OnClientBoundsChanged | Gets or sets the client-side script that executes when the map Bounds are changed
Public property | OnClientZoomChanged | Gets or sets the client-side script that executes when the map ZoomLevel changes
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | ProjectName | Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.
Public property | RenderingCompatibility | (Inherited from Control.)
Public property | ServerCacheDirectoryUrl | The Url of the directory where image tiles will be cached on the server if CacheOnServer is set to true
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | (Inherited from CompositeControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | overrides the TagKey property. Returns a Div Tag. (Overrides WebControl..::..TagKey.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | ZoomLevel | Gets or sets the current ZoomLevel of the TiledSFMap

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::..ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::..HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::..HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::..UserData | (Inherited from Control.)

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


CacheOnClient Property

[image]

.NET Framework Class Library
TiledSFMap..::..CacheOnClient Property
TiledSFMap Class See Also Send Feedback

Gets or sets whether to use client-side caching of any generated map image.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property CacheOnClient As Boolean
    Get
    Set
C#
[BindableAttribute(true)]
public bool CacheOnClient { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property bool CacheOnClient {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cacheOnClient();
function set_cacheOnClient(value);

Remarks

By default CacheOnClient will be set to true. This means that cache-specific HTTP headers will be set on generated map images. This will generally improve map performance as successive map images are cached by client web-browsers, however in some cases this is not desirable.

If you are using CustomRenderSettings then it may be neccessary to set CacheOnClient ot False

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


CacheOnServer Property

[image]

.NET Framework Class Library
TiledSFMap..::..CacheOnServer Property
TiledSFMap Class See Also Send Feedback

Gets or sets whether to use server-side caching of any generated map tile image.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property CacheOnServer As Boolean
    Get
    Set
C#
[BindableAttribute(true)]
public bool CacheOnServer { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property bool CacheOnServer {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cacheOnServer();
function set_cacheOnServer(value);

Remarks

By default CacheOnServer will be set to false. If this property is set to true then ServerCacheDirectoryUrl must be set to a directory with appropriate write permissions. If images are cached on server then the processing overhead of rendering map image requests will not be required on the server, but there must be sufficient space on the server to store images.

If you are using CustomRenderSettings then it may be neccessary to set CacheOnServer to False

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


CenterPoint Property

[image]

.NET Framework Class Library
TiledSFMap..::..CenterPoint Property
TiledSFMap Class See Also Send Feedback

Gets or sets the center point of the map in mapping coordinates (as used by the shapefiles)

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Overridable Property CenterPoint As PointD
    Get
    Set
C#
[BindableAttribute(true)]
public virtual PointD CenterPoint { get; set; }
Visual C++
[BindableAttribute(true)]
public:
virtual property PointD CenterPoint {
    PointD get ();
    void set (PointD value);
}
JavaScript
function get_centerPoint();
function set_centerPoint(value);

Remarks

Changing the CenterPoint can be used to center the map on a new location without changing the map scale

The ZoomLevel, CenterPoint, Width and Height of the TiledSFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CenterPoint and scaled according to the ZoomLevel.

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace
[!:Zoom]


ClientJSResouceName Property

[image]

.NET Framework Class Library
TiledSFMap..::..ClientJSResouceName Property
TiledSFMap Class See Also Send Feedback

returns the name of the client javascript resource used to control the map.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ClientJSResouceName As String
    Get
C#
public string ClientJSResouceName { get; }
Visual C++
public:
virtual property String^ ClientJSResouceName {
    String^ get () sealed;
}
JavaScript
function get_clientJSResouceName();

Implements

ISFMap..::..ClientJSResouceName

Remarks

this method implements the ClientJSResouceName method of ISFMap interface

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ControlId Property

[image]

.NET Framework Class Library
TiledSFMap..::..ControlId Property
TiledSFMap Class See Also Send Feedback

returns the client id of the map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property ControlId As String
    Get
C#
public string ControlId { get; }
Visual C++
public:
virtual property String^ ControlId {
    String^ get () sealed;
}
JavaScript
function get_controlId();

Implements

ISFMap..::..ControlId

Remarks

this method implements the ClientJSResouceName method of ISFMap interface

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


Extent Property

[image]

.NET Framework Class Library
TiledSFMap..::..Extent Property
TiledSFMap Class See Also Send Feedback

Gets the rectangular extent of the entire map

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property Extent As RectangleF
    Get
C#
public RectangleF Extent { get; }
Visual C++
public:
property RectangleF Extent {
    RectangleF get ();
}
JavaScript
function get_extent();

Remarks

Extent is the rectangular extent of the ENTIRE map, regardless of the current ZoomLevel or CentrePoint.

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


GisImageClientId Property

[image]

.NET Framework Class Library
TiledSFMap..::..GisImageClientId Property
TiledSFMap Class See Also Send Feedback

returns the Client id of the internal GIS Image. This is used by controls only

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property GisImageClientId As String
    Get
C#
public string GisImageClientId { get; }
Visual C++
public:
virtual property String^ GisImageClientId {
    String^ get () sealed;
}
JavaScript
function get_gisImageClientId();

Implements

ISFMap..::..GisImageClientId

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


HttpHandlerName Property

[image]

.NET Framework Class Library
TiledSFMap..::..HttpHandlerName Property
TiledSFMap Class See Also Send Feedback

Gets the name of the http handler used to render the map on the server.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Property HttpHandlerName As String
    Get
    Set
C#
public string HttpHandlerName { get; set; }
Visual C++
public:
property String^ HttpHandlerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpHandlerName();
function set_httpHandlerName(value);

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


HttpHandlerType Property

[image]

.NET Framework Class Library
TiledSFMap..::..HttpHandlerType Property
TiledSFMap Class See Also Send Feedback

Gets the type of the http handler used to render the map on the server.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Overridable ReadOnly Property HttpHandlerType As Type
    Get
C#
public virtual Type HttpHandlerType { get; }
Visual C++
public:
virtual property Type^ HttpHandlerType {
    Type^ get ();
}
JavaScript
function get_httpHandlerType();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ImageSource Property

[image]

.NET Framework Class Library
TiledSFMap..::..ImageSource Property
TiledSFMap Class See Also Send Feedback

Gets the image real src that points to the http handler. It is used as a key for the server cache so shoud be overriden with caution.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected ReadOnly Property ImageSource As String
    Get
C#
protected string ImageSource { get; }
Visual C++
protected:
property String^ ImageSource {
    String^ get ();
}
JavaScript
function get_imageSource();

Field Value

The image src.

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


LayerCount Property

[image]

.NET Framework Class Library
TiledSFMap..::..LayerCount Property
TiledSFMap Class See Also Send Feedback

returns the number of layers in the TiledSFMap Control

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public ReadOnly Property LayerCount As Integer
    Get
C#
public int LayerCount { get; }
Visual C++
public:
property int LayerCount {
    int get ();
}
JavaScript
function get_layerCount();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


MaxZoomLevel Property

[image]

.NET Framework Class Library
TiledSFMap..::..MaxZoomLevel Property
TiledSFMap Class See Also Send Feedback

Gets or Sets the Maximum Allowed ZoomLevel. This is the maximum ZoomLevel that can be set before the map can no longer be zoomed in.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property MaxZoomLevel As Integer
    Get
    Set
C#
[BindableAttribute(true)]
public int MaxZoomLevel { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property int MaxZoomLevel {
    int get ();
    void set (int value);
}
JavaScript
function get_maxZoomLevel();
function set_maxZoomLevel(value);

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace
TiledSFMap..::..MinZoomLevel


MinZoomLevel Property

[image]

.NET Framework Class Library
TiledSFMap..::..MinZoomLevel Property
TiledSFMap Class See Also Send Feedback

Gets or Sets the Minimum Allowed ZoomLevel. This is the minimum ZoomLevel that can be set before the map can no longer be zoomed out.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property MinZoomLevel As Integer
    Get
    Set
C#
[BindableAttribute(true)]
public int MinZoomLevel { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property int MinZoomLevel {
    int get ();
    void set (int value);
}
JavaScript
function get_minZoomLevel();
function set_minZoomLevel(value);

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace
TiledSFMap..::..MaxZoomLevel


OnClientBoundsChanged Property

[image]

.NET Framework Class Library
TiledSFMap..::..OnClientBoundsChanged Property
TiledSFMap Class See Also Send Feedback

Gets or sets the client-side script that executes when the map Bounds are changed

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property OnClientBoundsChanged As String
    Get
    Set
C#
[BindableAttribute(true)]
public string OnClientBoundsChanged { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ OnClientBoundsChanged {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_onClientBoundsChanged();
function set_onClientBoundsChanged(value);

Remarks

When the map bounds change a client-side javascript event will be fired with the the following 3 parameters
  • typeThe event type (="BoundsChanged"). This can be ignored
  • argsThe new map bounds. args[0] contains MinX, args[1] contains MaxY, args[2] contains MaxX, args[3] contains MaxY
  • objThe object generating the event. This can be ignored.

Examples

Copy image Copy Code

            function MapBoundsChanged(type, args, obj)
            {
               var debugPanel = document.getElementById('debugpanel');
               debugPanel.innerHTML = '[' + obj.toString() + ',' + type + ']Current Bounds: ' + args[0] + ',' + args[1] +  ',' + args[2] + ',' + args[3] + '
' + debugPanel.innerHTML ;
            }
             ..
             <div id = "debugpanel" ..
In this example OnClientBoundsChanged would be set to "MapBoundsChanged"

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


OnClientZoomChanged Property

[image]

.NET Framework Class Library
TiledSFMap..::..OnClientZoomChanged Property
TiledSFMap Class See Also Send Feedback

Gets or sets the client-side script that executes when the map ZoomLevel changes

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property OnClientZoomChanged As String
    Get
    Set
C#
[BindableAttribute(true)]
public string OnClientZoomChanged { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ OnClientZoomChanged {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_onClientZoomChanged();
function set_onClientZoomChanged(value);

Remarks

When the zoom level changes a client-side javascript event will be fired with the the following 3 parameters
  • typeThe event type (="ZoomChanged"). This can be ignored
  • argsargs[0] contains the current zoom level
  • objThe object generating the event. This can be ignored.

Examples

Copy image Copy Code

             function MapZoomChanged(type, args, obj)
            {
                var debugpanel = document.getElementById('debugpanel');
                debugpanel.innerHTML = '[' + obj.toString() + ',' + type + ']Current Zoom: ' + args[0] + '<br/>' + debugpanel.innerHTML;
            }
             ..
             <div id = "debugpanel" ..
In this example OnClientZoomChanged would be set to "MapZoomChanged"

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ProjectName Property

[image]

.NET Framework Class Library
TiledSFMap..::..ProjectName Property
TiledSFMap Class See Also Send Feedback

Gets or sets the name of the Easy GIS .NET (.egp) project to load in the map.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ProjectName As String
    Get
    Set
C#
[BindableAttribute(true)]
public string ProjectName { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_projectName();
function set_projectName(value);

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ServerCacheDirectoryUrl Property

[image]

.NET Framework Class Library
TiledSFMap..::..ServerCacheDirectoryUrl Property
TiledSFMap Class See Also Send Feedback

The Url of the directory where image tiles will be cached on the server if CacheOnServer is set to true

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ServerCacheDirectoryUrl As String
    Get
    Set
C#
[BindableAttribute(true)]
public string ServerCacheDirectoryUrl { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property String^ ServerCacheDirectoryUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_serverCacheDirectoryUrl();
function set_serverCacheDirectoryUrl(value);

Remarks

Note that it may be neccessary to give appropriate write permissions to the ASP user account on the specified directory

If CacheOnServer is false then this parameter will be ignored

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


TagKey Property

[image]

.NET Framework Class Library
TiledSFMap..::..TagKey Property
TiledSFMap Class See Also Send Feedback

overrides the TagKey property. Returns a Div Tag.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
C#
protected override HtmlTextWriterTag TagKey { get; }
Visual C++
protected:
virtual property HtmlTextWriterTag TagKey {
    HtmlTextWriterTag get () override;
}
JavaScript
function get_tagKey();

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


ZoomLevel Property

[image]

.NET Framework Class Library
TiledSFMap..::..ZoomLevel Property
TiledSFMap Class See Also Send Feedback

Gets or sets the current ZoomLevel of the TiledSFMap

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
<BindableAttribute(True)> _
Public Property ZoomLevel As Integer
    Get
    Set
C#
[BindableAttribute(true)]
public int ZoomLevel { get; set; }
Visual C++
[BindableAttribute(true)]
public:
property int ZoomLevel {
    int get ();
    void set (int value);
}
JavaScript
function get_zoomLevel();
function set_zoomLevel(value);

Remarks

Changing the ZoomLevel will zoom into or out of the map. Increasing the ZoomLevel will zoom into the map, while decreasing the ZoomLevel will zoom out of the map

The ZoomLevel, CenterPoint, Width and Height of the TiledSFMap determine the location and visible area of the rendered map. The map will be rendered centered at the CenterPoint and scaled according to the ZoomLevel.

Exceptions

Exception | Condition
System..::..ArgumentException | if ZoomLevel less than or equal to zero

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace
TiledSFMap..::..CenterPoint


TiledSFMap Events

[image] [image]

.NET Framework Class Library
TiledSFMap Events
TiledSFMap Class See Also Send Feedback

The TiledSFMap type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

TiledSFMap Class
EGIS.Web.Controls Namespace


TooltipHeaderFieldNamePair Class

[image]

.NET Framework Class Library
TooltipHeaderFieldNamePair Class
Members See Also Send Feedback

Simple Header / FieldName Pair class used to provide custom ToolTips in the QuantileCustomRenderSettings

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Class TooltipHeaderFieldNamePair
C#
public class TooltipHeaderFieldNamePair
Visual C++
public ref class TooltipHeaderFieldNamePair
JavaScript
EGIS.Web.Controls.TooltipHeaderFieldNamePair = function();

Type.createClass(
    'EGIS.Web.Controls.TooltipHeaderFieldNamePair');

Remarks

Each TooltipHeaderFieldNamePair object represents a single line that is displayed in a tooltip.

Inheritance Hierarchy

System..::..Object
EGIS.Web.Controls..::..TooltipHeaderFieldNamePair

See Also

TooltipHeaderFieldNamePair Members
EGIS.Web.Controls Namespace
EGIS.Web.Controls..::..QuantileCustomRenderSettings


TooltipHeaderFieldNamePair Members

[image] [image]

.NET Framework Class Library
TooltipHeaderFieldNamePair Members
TooltipHeaderFieldNamePair Class Constructors Methods Properties See Also Send Feedback

The TooltipHeaderFieldNamePair type exposes the following members.

Constructors

 | Name | Description
Public method | TooltipHeaderFieldNamePair | Constructs a new TooltipHeaderFieldNamePair object

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldName | Gets or sets the name of the DBF field (or column in joined table) to get the tooltip data from.
Public property | HeaderText | Gets or sets the text to appear as the header of a line in a tooltip

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace


TooltipHeaderFieldNamePair Constructor

[image]

.NET Framework Class Library
TooltipHeaderFieldNamePair Constructor
TooltipHeaderFieldNamePair Class See Also Send Feedback

Constructs a new TooltipHeaderFieldNamePair object

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Sub New ( _
    headerText As String, _
    fieldName As String _
)
C#
public TooltipHeaderFieldNamePair(
    string headerText,
    string fieldName
)
Visual C++
public:
TooltipHeaderFieldNamePair(
    String^ headerText,
    String^ fieldName
)
JavaScript
EGIS.Web.Controls.TooltipHeaderFieldNamePair = function(headerText, fieldName);

Parameters

headerText
Type: System..::..String
The text to appear as the header of a line in a tooltip
fieldName
Type: System..::..String
The name of the DBF field (or column in joined table) to get the tooltip data from

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace


TooltipHeaderFieldNamePair Methods

[image] [image]

.NET Framework Class Library
TooltipHeaderFieldNamePair Methods
TooltipHeaderFieldNamePair Class See Also Send Feedback

The TooltipHeaderFieldNamePair type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace


TooltipHeaderFieldNamePair Properties

[image] [image]

.NET Framework Class Library
TooltipHeaderFieldNamePair Properties
TooltipHeaderFieldNamePair Class See Also Send Feedback

The TooltipHeaderFieldNamePair type exposes the following members.

Properties

 | Name | Description
Public property | FieldName | Gets or sets the name of the DBF field (or column in joined table) to get the tooltip data from.
Public property | HeaderText | Gets or sets the text to appear as the header of a line in a tooltip

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace


FieldName Property

[image]

.NET Framework Class Library
TooltipHeaderFieldNamePair..::..FieldName Property
TooltipHeaderFieldNamePair Class See Also Send Feedback

Gets or sets the name of the DBF field (or column in joined table) to get the tooltip data from.

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Property FieldName As String
    Get
    Set
C#
public string FieldName { get; set; }
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fieldName();
function set_fieldName(value);

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace


HeaderText Property

[image]

.NET Framework Class Library
TooltipHeaderFieldNamePair..::..HeaderText Property
TooltipHeaderFieldNamePair Class See Also Send Feedback

Gets or sets the text to appear as the header of a line in a tooltip

Namespace: EGIS.Web.Controls
Assembly: EGIS.Web.Controls (in EGIS.Web.Controls.dll)

Syntax

Visual Basic
Public Property HeaderText As String
    Get
    Set
C#
public string HeaderText { get; set; }
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_headerText();
function set_headerText(value);

See Also

TooltipHeaderFieldNamePair Class
EGIS.Web.Controls Namespace